Subject: Re: [IPP] Stable draft of IPP Finishings 2.1 posted for review

From: "Kennedy, Smith (Wireless Architect)" <[email-masked]>
Date: Mon, 19 Sep 2016 18:15:49 +0000

Hello,

HP has the following feedback on Finishings 2.1:

RFC 3806 <https://tools.ietf.org/html/rfc3806> defines on page 19 the "maximumSheets" OID thus:

      maximumSheets(8),                  Integer32 (-2..32767)
         INTEGER:  Defines the maximum number of media sheets that a
           finisher device is able to process.

This RFC is a bit hard to parse, but it seems that maximumSheets is an "attribute" that is conveyed in a finDeviceAttributeEntry
sequence from finDeviceAttributeTable. There is no IPP equivalent to finDeviceAttributeTable currently defined, nor is there an equivalent IPP attribute defined to indicate this limit. (The "job-pages-per-set-supported" might have conveyed this information but it is defined as a boolean so a new IPP attribute would need to be defined to convey this limit.) An IPP Client that supports Finishings 2.0 / 2.1 would benefit from this information.

HP proposes the definition of a new IPP attribute "job-maximum-sheets-per-set-supported":

job-maximum-sheets-per-set-supported (integer)

The "job-maximum-sheets-per-set-supported" Printer Attribute specifies the maximum number of sheets per set that the Printer is able to process. It is semantically identical to the "maximumSheets" Finisher MIB attribute [RFC3806]. This attribute MUST be supported if the "job-pages-per-set" attribute is supported.

We can discuss this at a future IPP WG meeting if there are objections / questions.

Smith

/**
    Smith Kennedy
    Wireless Architect - Client Software - IPG-PPS
    Standards - IEEE ISTO PWG / Bluetooth SIG / Wi-Fi Alliance / NFC Forum / USB IF
    Chair, IEEE ISTO Printer Working Group
    HP Inc.
*/

> On 2016-08-15, at 2:08 PM, Kennedy, Smith (Wireless Architect) <[email-masked]> wrote:
> 
> Greetings,
> 
> Following the 2 weeks that the Prototype draft of Finishings 2.1 has been available, there have been no comments on it.  I have just posted a stable draft to the PWG FTP site in advance of next week's PWG F2F in Camas.  The stable draft is available here:
> 
> http://ftp.pwg.org/pub/pwg/ipp/wd/wd-ippfinishings21-20160815.pdf <http://ftp.pwg.org/pub/pwg/ipp/wd/wd-ippfinishings21-20160815.pdf> 
> http://ftp.pwg.org/pub/pwg/ipp/wd/wd-ippfinishings21-20160815.docx <http://ftp.pwg.org/pub/pwg/ipp/wd/wd-ippfinishings21-20160815.docx> 
> http://ftp.pwg.org/pub/pwg/ipp/wd/wd-ippfinishings21-20160815-rev.pdf <http://ftp.pwg.org/pub/pwg/ipp/wd/wd-ippfinishings21-20160815-rev.pdf> 
> http://ftp.pwg.org/pub/pwg/ipp/wd/wd-ippfinishings21-20160815-rev.docx <http://ftp.pwg.org/pub/pwg/ipp/wd/wd-ippfinishings21-20160815-rev.docx> 
> 
> This draft should be suitable for an IPP WG  Working Group Last Call.
> 
> Smith
> 
> /**
>     Smith Kennedy
>     Wireless Architect - Client Software - IPG-PPS
>     Standards - IEEE ISTO PWG / Bluetooth SIG / Wi-Fi Alliance / NFC Forum / USB IF
>     Chair, IEEE ISTO Printer Working Group
>     HP Inc.
> */
> 
> 
> 
> _______________________________________________
> ipp mailing list
> [email-masked]
> https://www.pwg.org/mailman/listinfo/ipp

_______________________________________________
ipp mailing list
[email-masked]
https://www.pwg.org/mailman/listinfo/ipp

---

From: Michael Sweet <[email-masked]>
Date: Wed, 21 Sep 2016 10:36:07 -0400

Smith,

Sorry for the long delay in looking at this...

> On Aug 26, 2016, at 5:33 PM, Kennedy, Smith (Wireless Architect) <[email-masked]> wrote:
> 
> Greetings,
> 
> In some discussions I have had within HP, I wanted to get some certainty about the orientation of "Portrait" in a long-edge feed scenario.  Figure 3 of the draft below shows the leading edge to be on the left side of the page. But when I went back to look at my earlier presentations where we were looking at Finishings 2.1 and feed orientation, the way that the pages were being shown would have had the leading edge be on the right edge of the page.
> 
> I posted a slide deck to the PWG FTP site:
> 
> http://ftp.pwg.org/pub/pwg/ipp/wd/Finishings-2.1-Page-Orientation-and-Page-Leading-Edge-2016-08-26.pdf
> 
> to try to illustrate the issue.  The basic question is: does a long-edge feed document get printed so that the right edge of the page is the leading edge, or does Finishings 2.1 define the left edge of the page to be the leading edge?

The leading edge can be the left or right side of the portrait page.  The orientation of the media is reported in the media-col-{database,ready}.media-source-properties.media-feed-orientation member attribute and is highly printer-specific.

If the Client requests finishings=staple-top-left, then the expectation is that the Printer will place the staple in the top-left corner of the portrait page.  The following ASCII art shows the location of the staple for various media-feed-orientation values:

media-feed-orientation=portrait

 +-------+
 |/      |
 |       |
 |       |
 |       |
 |       |
 +-------+

media-feed-orientation=landscape

 +----------+
 |          |
 |          |
 |\         |
 +----------+

media-feed-orientation=reverse-landscape

 +----------+
 |         \|
 |          |
 |          |
 +----------+

media-feed-orientation=reverse-portrait

 +-------+
 |       |
 |       |
 |       |
 |       |
 |      /|
 +-------+

_________________________________________________________
Michael Sweet, Senior Printing System Engineer