Subject: Re: [IPP] [IANA #923474] General Request for Assignment (ipp-registrations)

From: "Kennedy, Smith (Wireless Architect)" <[email-masked]>
Date: Wed, 7 Sep 2016 16:03:42 +0000

Greetings,

As I mentioned at the August F2F, I found a couple of issues when I downloaded the latest .csv files from the IANA registry page. I forgot I had started writing them up and found this in my drafts box.  In the "Attributes" section, the value from the "Reference" column is also appended to the value in the "Syntax" column:

- "folding-offset-supported"
- "job-account-type-supported"
- "punching-locations-supported"
- "retry-time-out-default"

I thought I found some other errors but didn't record them. If I find them again I'll let you know.

Cheers,

Smith

/**
    Smith Kennedy
    Wireless Architect - Client Software - IPG-PPS
    Standards - IEEE ISTO PWG / Bluetooth SIG / Wi-Fi Alliance / NFC Forum / USB IF
    Chair, IEEE ISTO Printer Working Group
    HP Inc.
*/

> On 2016-08-18, at 10:11 AM, Michael Sweet <[email-masked]> wrote:
> 
> Looks good!
> 
> 
>> On Aug 17, 2016, at 6:06 PM, Ira McDonald <[email-masked] <mailto:[email-masked]>> wrote:
>> 
>> Hi,
>> 
>> Amanda Baber at IANA has surpassed herself - 20 hours to complete
>> IANA IPP Registrations updates!
>> 
>> Mike - please double-check.
>> 
>> Cheers,
>> - Ira
>> 
>> Ira McDonald (Musician / Software Architect)
>> Co-Chair - TCG Trusted Mobility Solutions WG
>> Chair - Linux Foundation Open Printing WG
>> Secretary - IEEE-ISTO Printer Working Group
>> Co-Chair - IEEE-ISTO PWG Internet Printing Protocol WG
>> IETF Designated Expert - IPP & Printer MIB
>> Blue Roof Music / High North Inc
>> http://sites.google.com/site/blueroofmusic <http://sites.google.com/site/blueroofmusic>
>> http://sites.google.com/site/highnorthinc <http://sites.google.com/site/highnorthinc>
>> mailto: [email-masked] <mailto:[email-masked]>
>> Jan-April: 579 Park Place  Saline, MI  48176  734-944-0094
>> May-Dec: PO Box 221  Grand Marais, MI 49839  906-494-2434
>> 
>> 
>> ---------- Forwarded message ----------
>> From: Amanda Baber via RT <[email-masked] <mailto:[email-masked]>>
>> Date: Wed, Aug 17, 2016 at 5:17 PM
>> Subject: [IANA #923474] General Request for Assignment (ipp-registrations)
>> To: [email-masked] <mailto:[email-masked]>
>> 
>> 
>> Hi Ira,
>> 
>> These changes are complete. Please see
>> 
>> http://www.iana.org/assignments/ipp-registrations <http://www.iana.org/assignments/ipp-registrations>
>> 
>> Best regards,
>> 
>> Amanda Baber
>> IANA Lead Specialist
>> ICANN
>> 
>> On Tue Aug 16 23:38:24 2016, [email-masked] <mailto:[email-masked]> wrote:
>> >
>> > Contact Name:
>> > Ira McDonald
>> >
>> > Contact Email:
>> > [email-masked] <mailto:[email-masked]>
>> >
>> > Type of Assignment:
>> > Permanent registration updates in IPP Registry
>> >
>> > Copy of revised IANA XML registry is at:
>> > http://ftp.pwg.org/pub/pwg/ipp/IANA-IPP-registrations/ <http://ftp.pwg.org/pub/pwg/ipp/IANA-IPP-registrations/>
>> > in the file ipp-registrations-20160816.xml
>> >
>> > Changes:
>> > - move all of the "-actual" attributes to the corresponding Status
>> > group, along with a couple "-supplied" attributes that were also
>> > incorrectly in the Description group
>> >
>> > Registry:
>> > IANA IPP Registry
>> > http://www.iana.org/assignments/ipp-registrations/ipp- <http://www.iana.org/assignments/ipp-registrations/ipp->
>> > registrations.xml
>> >
>> > Description:
>> > Description:
>> > Proposed: Mike Sweet (Apple)
>> > Reviewed: By IETF Designated Experts for IPP Registry
>> > Approved: 16 August 2016
>> > By: Ira McDonald (IETF Designated Expert for IPP Registry)
>> >
>> > Additional Info:
>> >  Brings IANA IPP Registry (from RFC 2911) up-to-date for recent
>> > PWG IPP attribute registrations
>> 
>> 
>> 
>> 
> 
> _________________________________________________________
> Michael Sweet, Senior Printing System Engineer
> 
> _______________________________________________
> ipp mailing list
> [email-masked] <mailto:[email-masked]>
> https://www.pwg.org/mailman/listinfo/ipp <https://www.pwg.org/mailman/listinfo/ipp>
_______________________________________________
ipp mailing list
[email-masked]
https://www.pwg.org/mailman/listinfo/ipp

---

From: "Kennedy, Smith (Wireless Architect)" <[email-masked]>
Date: Thu, 8 Sep 2016 20:35:24 +0000

Found another one:

media-col.media-size is listed as a "collection" but its children (x-dimension, y-dimension) are not listed in the registry.

Smith

> On 2016-09-07, at 10:03 AM, Kennedy, Smith (Wireless Architect) <[email-masked]> wrote:
> 
> Greetings,
> 
>> On 2016-08-18, at 10:11 AM, Michael Sweet <[email-masked] <mailto:[email-masked]>> wrote:
>> 
>> Looks good!
>> 
>>

---

From: Michael Sweet <[email-masked]>
Date: Fri, 09 Sep 2016 06:51:25 -0400

Smith,

Thanks for these.  I'll hold onto them until the IPP/1.1 RFCs are published (that will cause some IANA registry changes) and then send the corrections in...

> On Sep 8, 2016, at 4:35 PM, Kennedy, Smith (Wireless Architect) <[email-masked]> wrote:
> 
> Found another one:
> 
>>>> On Aug 17, 2016, at 6:06 PM, Ira McDonald <[email-masked]> wrote:
>>>> 
>>>> Hi,
>>>> 
>>>> http://sites.google.com/site/blueroofmusic
>>>> http://sites.google.com/site/highnorthinc
>>>> mailto: [email-masked]
>>>> From: Amanda Baber via RT <[email-masked]>
>>>> To: [email-masked]
>>>> 
>>>> 
>>>> Hi Ira,
>>>> 
>>>> http://www.iana.org/assignments/ipp-registrations
>>>> 
>>>> Best regards,
>>>> 
>>>> Amanda Baber
>>>> IANA Lead Specialist
>>>> ICANN
>>>> 
>>>> On Tue Aug 16 23:38:24 2016, [email-masked] wrote:
>>>> >
>>>> > Contact Name:
>>>> > Ira McDonald
>>>> >
>>>> > Contact Email:
>>>> > [email-masked]
>>>> >
>>>> > Type of Assignment:
>>>> > http://ftp.pwg.org/pub/pwg/ipp/IANA-IPP-registrations/
>>>> > http://www.iana.org/assignments/ipp-registrations/ipp-
>>>> > registrations.xml
>>>> >
>>>> > Description:
>>>> > Description: