Subject: [IPP] Requesting information pertaining to the project - Enhancements for ipptool

From: Lakshay Bandlish <[email-masked]>
Date: Thu, 22 Mar 2018 22:54:41 +0530

Hi everyone,

I wish to work for The Linux Foundation in this year's Google Summer of
Code. I am applying for the project - Enhancements for ipptool.

IPP Everywhere's self-certification program's software uses ipptool to
allow printer manufacturers to test if their printers satisfy IPP
standards. Currently, ipptool doesn't provide support for testing all
attributes and operations required by IPP Everywhere, and this project
involves writing scripts to enable ipptool to test printers for these. It
also involves writing more scripts for other ipp specifications.

I want to know more about this project. It would be great if you can help
me here.

Thank you,
Lakshay Bandlish.
_______________________________________________
ipp mailing list
[email-masked]
https://www.pwg.org/mailman/listinfo/ipp

---

From: Ira McDonald <[email-masked]>
Date: Thu, 22 Mar 2018 13:37:44 -0400

Hi Lakshay,

Thank your very much for your interest in the GSoC ipptool enhancements
project!

Smith Kennedy and Mike Sweet have already discussed this one and will send
you
more details soon, hopefully.

I'm forwarding your request to Aveek Basu and Till Kamppeter, who are
coordinating
all of the Open Printing GSoC 2018 projects.

I will volunteer as one of the mentors for this project.

Cheers,
- Ira (co-chair of IEEE-ISTO IPP WG)

Ira McDonald (Musician / Software Architect)
Co-Chair - TCG Trusted Mobility Solutions WG
Chair - Linux Foundation Open Printing WG
Secretary - IEEE-ISTO Printer Working Group
Co-Chair - IEEE-ISTO PWG Internet Printing Protocol WG
IETF Designated Expert - IPP & Printer MIB
Blue Roof Music / High North Inc
http://sites.google.com/site/blueroofmusic
http://sites.google.com/site/highnorthinc
mailto: [email-masked]
Jan-April: 579 Park Place  Saline, MI  48176  734-944-0094
May-Dec: PO Box 221  Grand Marais, MI 49839  906-494-2434

---

From: Michael Sweet <[email-masked]>
Date: Thu, 22 Mar 2018 14:04:53 -0400

Hi Lakshay,

I've setup a Github project for the ippsample repository that covers all of the potential work:

    https://github.com/istopwg/ippsample/projects/4

Most of the issues in the project involve writing ipptool test files, but I've also included an "ippfuzz" test generator (for fuzz-testing printers) and changes to ipptool to support running subsets of a test file.

Please let me know if you have any questions!

> On Mar 22, 2018, at 1:24 PM, Lakshay Bandlish <[email-masked]> wrote:
> 
> Hi everyone,
> 
> 
> I wish to work for The Linux Foundation in this year's Google Summer of Code. I am applying for the project - Enhancements for ipptool.
> 
> IPP Everywhere's self-certification program's software uses ipptool to allow printer manufacturers to test if their printers satisfy IPP standards. Currently, ipptool doesn't provide support for testing all attributes and operations required by IPP Everywhere, and this project involves writing scripts to enable ipptool to test printers for these. It also involves writing more scripts for other ipp specifications.
> 
> I want to know more about this project. It would be great if you can help me here.
> 
> 
> Thank you,
> Lakshay Bandlish.

_________________________________________________________
Michael Sweet, Senior Printing System Engineer