Subject: [IPP] Erratum on RFC 8011 : 'document-attributes-group' not mentioned in Send-Document, etc.

From: "Kennedy, Smith (Wireless & Standards Architec)" <[email-masked]>
Date: Fri, 9 Mar 2018 21:37:24 +0000

Hi there,

I've been fielding a few questions about Send-Document, and everybody is reading RFC 8011 (after I ask them to move to that from 2911). I just dealt with a question having to do with the 'document-attributes-tag' and Send-Document. I was surprised to find that in 8011 we didn't include mention of the 'document-attributes-tag' even though there are references to PWG 5100.5. 

Is there a conscious reason why we didn't add that? Or was it an oversight and hence worthy of an erratum report against 8011? Cross-references such as this would help close the loop especially if it was listed as optional in 8011, which wouldn't change the normative requirements for IPP/1.1 IMO.

Smith

/**
    Smith Kennedy
    Wireless & Standards Architect - IPG-PPS
    Standards - IEEE ISTO PWG / Bluetooth SIG / Wi-Fi Alliance / NFC Forum / USB-IF
    Chair, IEEE ISTO Printer Working Group
    HP Inc.
*/

_______________________________________________
ipp mailing list
[email-masked]
https://www.pwg.org/mailman/listinfo/ipp

---

From: Michael Sweet <[email-masked]>
Date: Fri, 09 Mar 2018 16:54:53 -0500

Smith,

PWG 5100.5 is an extension to IPP/1.1 that defines the Document object, the document-attributes-tag (group) value, and the amended semantics for the Send-Document and Send-URI operations.  None of that was part of the core IPP/1.1 (which is what RFC 8011 defines) and we've historically been conservative about requiring support for the Document object extension - right now only IPP/2.2 and IPP INFRA require it and most implementations only support a single document per job anyways...

> On Mar 9, 2018, at 4:37 PM, Kennedy, Smith (Wireless & Standards Architec) <[email-masked]> wrote:
> 
> Hi there,
> 

_________________________________________________________
Michael Sweet, Senior Printing System Engineer

---

From: "Kennedy, Smith (Wireless & Standards Architec)" <[email-masked]>
Date: Mon, 12 Mar 2018 17:16:47 +0000

> On Mar 9, 2018, at 2:54 PM, Michael Sweet <[email-masked]> wrote:
> 
> Smith,
> 

I understand that we cannot add additional normative requirements. I was just thinking that, if the "document group" were mentioned even in passing as an optional group in 8011, with a reference to PWG 5100.5, that would help with the "cross referencing" thing.

---

From: Michael Sweet <[email-masked]>
Date: Mon, 12 Mar 2018 13:51:14 -0400

Smith,

> On Mar 12, 2018, at 1:16 PM, Kennedy, Smith (Wireless & Standards Architec) <[email-masked]> wrote:
> 
> 
> 

We also have the Subscription object and its associated attribute group that can be included in Job Creation operations but which we don't say anything about (beyond a reference in the introduction)...

I think the last thing we want to do is One Spec to Rule Them All™.  And honestly I don't think that mentioning other attribute groups without providing any details will be all that useful, especially for something as complicated as the Document object extension.

---

From: Ira McDonald <[email-masked]>
Date: Mon, 12 Mar 2018 14:24:57 -0400

Hi,

I agree with Mike.  Document object has the complexity of the Job object
plus bells and whistles.
Subscription object covering multiple targets (System, Printer, Job,
Document) is complex.

Even IPP/2.0 (w/ 2.1 and 2.2) is just brief lists of required attributes
and operations for three levels
of IPP Printer capabilities (and no longer even close to all inclusive).

RFCs 8010/8011 are meant to be strictly cleanups of RFCs 2910/2911 - the
universe of IPP (over
30 IETF and PWG specs) is too broad to cover in one spec, without major
omissions.

Cheers,
- Ira

Ira McDonald (Musician / Software Architect)
Co-Chair - TCG Trusted Mobility Solutions WG
Chair - Linux Foundation Open Printing WG
Secretary - IEEE-ISTO Printer Working Group
Co-Chair - IEEE-ISTO PWG Internet Printing Protocol WG
IETF Designated Expert - IPP & Printer MIB
Blue Roof Music / High North Inc
http://sites.google.com/site/blueroofmusic
http://sites.google.com/site/highnorthinc
mailto: [email-masked]
Jan-April: 579 Park Place  Saline, MI  48176  734-944-0094
May-Dec: PO Box 221  Grand Marais, MI 49839  906-494-2434

On Mon, Mar 12, 2018 at 1:51 PM, Michael Sweet <[email-masked]> wrote:

> >> PWG 5100.5 is an extension to IPP/1.1 that defines the Document object,
> the document-attributes-tag (group) value, and the amended semantics for
> the Send-Document and Send-URI operations.  None of that was part of the
> core IPP/1.1 (which is what RFC 8011 defines) and we've historically been
> conservative about requiring support for the Document object extension -
> right now only IPP/2.2 and IPP INFRA require it and most implementations
> only support a single document per job anyways...
> >
> > I understand that we cannot add additional normative requirements. I was
> just thinking that, if the "document group" were mentioned even in passing
> as an optional group in 8011, with a reference to PWG 5100.5, that would
> help with the "cross referencing" thing.
>
> We also have the Subscription object and its associated attribute group
> that can be included in Job Creation operations but which we don't say
> anything about (beyond a reference in the introduction)...
>
> I think the last thing we want to do is One Spec to Rule Them All™.  And
> honestly I don't think that mentioning other attribute groups without
> providing any details will be all that useful, especially for something as
> complicated as the Document object extension.
>

---

From: Paul Tykodi <[email-masked]>
Date: Mon, 12 Mar 2018 17:54:16 -0400

Hi Ira,

Do you think the document object might be a good topic to cover in the IPP book we have been discussing?

Thanks.

Best Regards,

/Paul

Sent from my iPhone

> On Mar 12, 2018, at 2:24 PM, Ira McDonald <[email-masked]> wrote:
> 
> Hi,
> 
> I agree with Mike.  Document object has the complexity of the Job object plus bells and whistles.
> Subscription object covering multiple targets (System, Printer, Job, Document) is complex.
> 
> Even IPP/2.0 (w/ 2.1 and 2.2) is just brief lists of required attributes and operations for three levels
> RFCs 8010/8011 are meant to be strictly cleanups of RFCs 2910/2911 - the universe of IPP (over
> 30 IETF and PWG specs) is too broad to cover in one spec, without major omissions.
> 
> Cheers,
> - Ira
> 
>

---

From: Michael Sweet <[email-masked]>
Date: Mon, 12 Mar 2018 18:38:08 -0400

Paul,

No, the purpose of the IPP book is to document the basics that can be used on most/all printers.  The document object extension does not meet that criteria...

> On Mar 12, 2018, at 5:54 PM, Paul Tykodi <[email-masked]> wrote:
> 
> Hi Ira,
> 
> On Mar 12, 2018, at 2:24 PM, Ira McDonald <[email-masked] <mailto:[email-masked]>> wrote:
> 
>> Hi,
>> 
>> http://sites.google.com/site/blueroofmusic <http://sites.google.com/site/blueroofmusic>
>> http://sites.google.com/site/highnorthinc <http://sites.google.com/site/highnorthinc>
>> mailto: [email-masked] <mailto:[email-masked]>
>> On Mon, Mar 12, 2018 at 1:51 PM, Michael Sweet <[email-masked] <mailto:[email-masked]>> wrote:
>> Smith,
>> 
>> > On Mar 12, 2018, at 1:16 PM, Kennedy, Smith (Wireless & Standards Architec) <[email-masked] <mailto:[email-masked]>> wrote:
>> >
>> >
>> >
>> >> On Mar 9, 2018, at 2:54 PM, Michael Sweet <[email-masked] <mailto:[email-masked]>> wrote:
>> >>
>> >> Smith,
>> >>
>> [email-masked] <mailto:[email-masked]>
>> https://www.pwg.org/mailman/listinfo/ipp <https://www.pwg.org/mailman/listinfo/ipp>
>> 
>> [email-masked] <mailto:[email-masked]>
>> https://www.pwg.org/mailman/listinfo/ipp <https://www.pwg.org/mailman/listinfo/ipp>