Subject: [IPP] Questioning IPP Everywhere requiring "print-rendering-intent" for all printers

From: "Kennedy, Smith (Wireless & Standards Architec)" <[email-masked]>
Date: Tue, 10 Apr 2018 21:05:57 +0000

Greetings,

In IPP Everywhere™ 1.0, "print-rendering-intent" support is mandatory for all printers. However, in JPS3 (PWG 5100.13), "print-rendering-intent" support is required only for printers that support "printer-icc-profiles" and ICC color matching. Is there any functional reason to continue to require "print-rendering-intent" for printers that don't support "printer-icc-profiles"? If there is no compelling reason, I propose we soften the IPP Everywhere™ requirement for "print-rendering-intent" in v1.1.

Thoughts? Objections?

Cheers,
Smith

/**
    Smith Kennedy
    Wireless & Standards Architect - IPG-PPS
    Standards - IEEE ISTO PWG / Bluetooth SIG / Wi-Fi Alliance / NFC Forum / USB-IF
    Chair, IEEE ISTO Printer Working Group
    HP Inc.
*/

_______________________________________________
ipp mailing list
[email-masked]
https://www.pwg.org/mailman/listinfo/ipp

---

From: Michael Sweet <[email-masked]>
Date: Tue, 10 Apr 2018 17:11:27 -0400

+1, make it conditionally required based on ICC support, like JPS3 does...

> On Apr 10, 2018, at 5:05 PM, Kennedy, Smith (Wireless & Standards Architec) <[email-masked]> wrote:
> 
> Greetings,
> 

_________________________________________________________
Michael Sweet, Senior Printing System Engineer