Subject: [IPP] Updated interim draft of IPP Everywhere v1.1 posted

From: Michael Sweet <[email-masked]>
Date: Tue, 03 Apr 2018 17:25:19 -0400

All,

I have posted an updated interim draft of the IPP Everywhere v1.1 specification to:

	https://ftp.pwg.org/pub/pwg/ipp/wd/wd-ippeve11-20180403.docx
	https://ftp.pwg.org/pub/pwg/ipp/wd/wd-ippeve11-20180403.pdf
	https://ftp.pwg.org/pub/pwg/ipp/wd/wd-ippeve11-20180403-rev.pdf

The only change since the last draft is to make JPEG conditionally required for color printers.
(previously it was required for all printers)

_________________________________________________________
Michael Sweet, Senior Printing System Engineer

_______________________________________________
ipp mailing list
[email-masked]
https://www.pwg.org/mailman/listinfo/ipp

---

From: "Kennedy, Smith (Wireless & Standards Architec)" <[email-masked]>
Date: Wed, 4 Apr 2018 16:53:49 +0000

Hi Mike,

Reviewing wd-ippeve11-20180403.pdf - line numbers are from that document.

Line 1423 / 1424 say: "Now recommend using a resource path of /ipp/print or /ipp/print/name in Printer URIs" but I'm not finding any such recommendation. The only mention of "/ipp/print" in this revision seems to be in the examples showing absolute vs. relative URIs on line 1001-1002. I want to make sure that that is recommended in this IPP Everywhere 1.1 update.

Smith

/**
    Smith Kennedy
    Wireless & Standards Architect - IPG-PPS
    Standards - IEEE ISTO PWG / Bluetooth SIG / Wi-Fi Alliance / NFC Forum / USB-IF
    Chair, IEEE ISTO Printer Working Group
    HP Inc.
*/

> On Apr 3, 2018, at 3:25 PM, Michael Sweet <[email-masked]> wrote:
> 
> All,
>

---

From: Michael Sweet <[email-masked]>
Date: Wed, 04 Apr 2018 13:00:43 -0400

Smith,

The recommendation is in section 5.4.1 on lines 887-889:

The REQUIRED "printer-uri-supported" Printer attribute provides 'ipp' and 'ipps' URIs that can be used to access the Printer. Printers SHOULD advertise URIs with a resource path of the form "/ipp/print" or "/ipp/print/queuename".

> On Apr 4, 2018, at 12:53 PM, Kennedy, Smith (Wireless & Standards Architec) <[email-masked]> wrote:
> 
> Hi Mike,
>

---

From: "Kennedy, Smith (Wireless & Standards Architec)" <[email-masked]>
Date: Wed, 4 Apr 2018 17:05:41 +0000

Indeed it is! (I was using the search function in Apple Preview to look for "/ipp/print" (including double-quotes) and it failed to find that instance.)

Smith

> On Apr 4, 2018, at 11:00 AM, Michael Sweet <[email-masked]> wrote:
> 
> Smith,
> 
>> On Apr 4, 2018, at 12:53 PM, Kennedy, Smith (Wireless & Standards Architec) <[email-masked] <mailto:[email-masked]>> wrote:
>> 
>> Hi Mike,
>> 
>>> On Apr 3, 2018, at 3:25 PM, Michael Sweet <[email-masked] <mailto:[email-masked]>> wrote:
>>> 
>>> All,
>>> 
>>> 	https://ftp.pwg.org/pub/pwg/ipp/wd/wd-ippeve11-20180403.docx <https://ftp.pwg.org/pub/pwg/ipp/wd/wd-ippeve11-20180403.docx>