Subject: [IPP] RFC: Drop 1284 device ID requirements from IPP Everywhere 1.1

From: Michael Sweet <[email-masked]>
Date: Mon, 16 Apr 2018 21:46:47 -0400

All,

As 1284 device IDs are only needed for printer driver selection, I'd like remove all of the 1284 device ID requirements from IPP Everywhere 1.1.

Thoughts?

_________________________________________________________
Michael Sweet, Senior Printing System Engineer

_______________________________________________
ipp mailing list
[email-masked]
https://www.pwg.org/mailman/listinfo/ipp

---

From: "Kennedy, Smith (Wireless & Standards Architec)" <[email-masked]>
Date: Tue, 17 Apr 2018 02:38:24 +0000

I approve and second this!

Smith

/**
    Smith Kennedy
    Wireless & Standards Architect - IPG-PPS
    Standards - IEEE ISTO PWG / Bluetooth SIG / Wi-Fi Alliance / NFC Forum / USB-IF
    Chair, IEEE ISTO Printer Working Group
    HP Inc.
*/

> On Apr 16, 2018, at 7:46 PM, Michael Sweet <[email-masked]> wrote:
> 
> All,
>

---

From: "Paul Tykodi" <[email-masked]>
Date: Tue, 17 Apr 2018 05:14:34 -0400

Hi Mike,

Where I believe some vendors use them to send pre and post job processing
device specific commands, I don't believe we should fully retire support for
the 1284 device ID's at this time.

Are you planning to make them an OPTIONAL requirement?

Thanks.

Best Regards,

/Paul

--

Paul Tykodi
Principal Consultant
TCS - Tykodi Consulting Services LLC

Tel/Fax: 603-343-1820
Mobile:  603-866-0712
E-mail:  [email-masked] <mailto:[email-masked]> 
WWW:   <http://www.tykodi.com/> http://www.tykodi.com

This e-mail reply and any attachments are confidential and may be
privileged.

If you are not the intended recipient, please notify Tykodi Consulting
Services LLC 

immediately by replying to this message and destroying all copies of this
message 

and any attachments. Thank you

From: ipp <[email-masked]> On Behalf Of Kennedy, Smith (Wireless &
Standards Architec)
Sent: Monday, April 16, 2018 10:38 PM
To: Michael Sweet <[email-masked]>
Cc: PWG IPP WG Reflector <[email-masked]>
Subject: Re: [IPP] RFC: Drop 1284 device ID requirements from IPP Everywhere
1.1

Smith

/**
    Smith Kennedy
    Wireless & Standards Architect - IPG-PPS
    Standards - IEEE ISTO PWG / Bluetooth SIG / Wi-Fi Alliance / NFC Forum /
USB-IF
    Chair, IEEE ISTO Printer Working Group
    HP Inc.
*/

On Apr 16, 2018, at 7:46 PM, Michael Sweet <[email-masked]
<mailto:[email-masked]> > wrote:

All,

As 1284 device IDs are only needed for printer driver selection, I'd like
remove all of the 1284 device ID requirements from IPP Everywhere 1.1.

Thoughts?

_______________________________________________
ipp mailing list
[email-masked] <mailto:[email-masked]> 
https://www.pwg.org/mailman/listinfo/ipp

---

From: Ira McDonald <[email-masked]>
Date: Tue, 17 Apr 2018 06:35:39 -0400

Hi,

Paul - you can't submit a 1284 Device ID as a command in IPP - it's a
declarative
property only.

Mike and Smith - certainly we should drop 1284 Device ID from IPP
Everywhere,
which is about driverless printing.

Cheers,
- Ira

Ira McDonald (Musician / Software Architect)
Co-Chair - TCG Trusted Mobility Solutions WG
Chair - Linux Foundation Open Printing WG
Secretary - IEEE-ISTO Printer Working Group
Co-Chair - IEEE-ISTO PWG Internet Printing Protocol WG
IETF Designated Expert - IPP & Printer MIB
Blue Roof Music / High North Inc
http://sites.google.com/site/blueroofmusic
http://sites.google.com/site/highnorthinc
mailto: [email-masked]
Jan-April: 579 Park Place  Saline, MI  48176  734-944-0094
May-Dec: PO Box 221  Grand Marais, MI 49839  906-494-2434

On Tue, Apr 17, 2018 at 5:14 AM, Paul Tykodi <[email-masked]> wrote:

> device specific commands, I don’t believe we should fully retire support
> for the 1284 device ID’s at this time.
>
>
>
> E-mail:  [email-masked]
> WWW:  http://www.tykodi.com
>
>
>
> *From:* ipp <[email-masked]> *On Behalf Of *Kennedy, Smith (Wireless
> & Standards Architec)
> *Sent:* Monday, April 16, 2018 10:38 PM
> *To:* Michael Sweet <[email-masked]>
> *Cc:* PWG IPP WG Reflector <[email-masked]>
> *Subject:* Re: [IPP] RFC: Drop 1284 device ID requirements from IPP
> Everywhere 1.1
>
>
>

---

From: Michael Sweet <[email-masked]>
Date: Tue, 17 Apr 2018 08:13:02 -0400

Paul,

> On Apr 17, 2018, at 5:14 AM, Paul Tykodi <[email-masked]> wrote:
> 
> Hi Mike,
>  
> Where I believe some vendors use them to send pre and post job processing device specific commands, I don’t believe we should fully retire support for the 1284 device ID’s at this time.

While I acknowledge this may be true for general IPP printing, the device ID is not needed for IPP Everywhere since we have higher-level PDLs that respect Job Template attributes.  And in the case of PWG Raster, the pwg-raster-document-xxx attributes are used by a Client to produce a compatible raster stream, *not* the 1284 device ID.
 
> Are you planning to make them an OPTIONAL requirement?

Basically, although I'd like to just remove the references in the IPP Everywhere specification and let the original definition in PWG 5107.2 stand for vendors that want to support the attribute.

---

From: Paul Tykodi <[email-masked]>
Date: Tue, 17 Apr 2018 08:17:17 -0400

Hi Ira,

My thought is that some vendor developed IPP Everywhere implementations may tweak PDF or JPEG processing on the client (i.e. sender) side for certain 1284 device ID’s.

If we make retiring them a two step process, we probably would give any developers that have done this time to adjust their code.

I am Ok with removing them from IPP Everywhere but am just asking about best way to implement change so that developers have time to react.

Best Regards,

/Paul

Sent from my iPhone

> On Apr 17, 2018, at 6:35 AM, Ira McDonald <[email-masked]> wrote:
> 
> Hi,
> 
> Paul - you can't submit a 1284 Device ID as a command in IPP - it's a declarative
> property only.
> 
> Mike and Smith - certainly we should drop 1284 Device ID from IPP Everywhere,
>> This e-mail reply and any attachments are confidential and may be privileged.
>> 
>> If you are not the intended recipient, please notify Tykodi Consulting Services LLC
>> 
>> immediately by replying to this message and destroying all copies of this message
>> 
>> From: ipp <[email-masked]> On Behalf Of Kennedy, Smith (Wireless & Standards Architec)
>> Subject: Re: [IPP] RFC: Drop 1284 device ID requirements from IPP Everywhere 1.1
>> 
>>  
>>

---

From: Michael Sweet <[email-masked]>
Date: Tue, 17 Apr 2018 09:15:46 -0400

Paul,

I'm not aware of any IPP Everywhere client that does this - CUPS certainly doesn't.

> On Apr 17, 2018, at 8:17 AM, Paul Tykodi <[email-masked]> wrote:
> 
> Hi Ira,
> 
> On Apr 17, 2018, at 6:35 AM, Ira McDonald <[email-masked] <mailto:[email-masked]>> wrote:
> 
>> Hi,
>> 
>> http://sites.google.com/site/blueroofmusic <http://sites.google.com/site/blueroofmusic>
>> http://sites.google.com/site/highnorthinc <http://sites.google.com/site/highnorthinc>
>> mailto: [email-masked] <mailto:[email-masked]>
>> On Tue, Apr 17, 2018 at 5:14 AM, Paul Tykodi <[email-masked] <mailto:[email-masked]>> wrote:
>> Hi Mike,
>> 
>>  
>> 
>> WWW:  http://www.tykodi.com <http://www.tykodi.com/>
>>  
>> 
>> From: ipp <[email-masked] <mailto:[email-masked]>> On Behalf Of Kennedy, Smith (Wireless & Standards Architec)
>> To: Michael Sweet <[email-masked] <mailto:[email-masked]>>
>> Cc: PWG IPP WG Reflector <[email-masked] <mailto:[email-masked]>>
>> On Apr 16, 2018, at 7:46 PM, Michael Sweet <[email-masked] <mailto:[email-masked]>> wrote:
>> 
>>  
>> 
>> All,
>> 
>> https://www.pwg.org/mailman/listinfo/ipp <https://www.pwg.org/mailman/listinfo/ipp>
>>  
>> 
>> 
>> https://www.pwg.org/mailman/listinfo/ipp <https://www.pwg.org/mailman/listinfo/ipp>
>> 
>>

---

From: Ira McDonald <[email-masked]>
Date: Tue, 17 Apr 2018 09:34:11 -0400

Hi Paul,

As Mike pointed out, using IEEE 1284 Device ID to do PDL-stream tweaks in
IPP Everywhere was
never a legitimate implementation.  Vendors who honored IEEE 1284 Device ID
info over the much
more authoritative IPP Printer status attributes have broken
implementations anyway.

I agree with Mike - delete all mention of IEEE 1284 Device ID from IPP
Everywhere (with which it
is incompatible).

Cheers,
- Ira

On Tue, Apr 17, 2018 at 8:17 AM, Paul Tykodi <[email-masked]> wrote:

> Hi Ira,
>
> My thought is that some vendor developed IPP Everywhere implementations
> may tweak PDF or JPEG processing on the client (i.e. sender) side for
> certain 1284 device ID’s.
>
> If we make retiring them a two step process, we probably would give any
> developers that have done this time to adjust their code.
>
> I am Ok with removing them from IPP Everywhere but am just asking about
> best way to implement change so that developers have time to react.
>
> Best Regards,
>
> /Paul
>
> Sent from my iPhone
>
> Jan-April: 579 Park Place
> <https://maps.google.com/?q=579+Park+Place+Saline,+MI+48176+734&entry=gmail&source=g>
> Saline, MI
> <https://maps.google.com/?q=579+Park+Place+Saline,+MI+48176+734&entry=gmail&source=g>
> 48176
> <https://maps.google.com/?q=579+Park+Place+Saline,+MI+48176+734&entry=gmail&source=g>
> 734
> <https://maps.google.com/?q=579+Park+Place+Saline,+MI+48176+734&entry=gmail&source=g>
> -944-0094
>> *From:* ipp <[email-masked]> *On Behalf Of *Kennedy, Smith
>> (Wireless & Standards Architec)

---

From: Paul Tykodi <[email-masked]>
Date: Tue, 17 Apr 2018 09:44:58 -0400

Hi Ira,

If we remove the 1284 device ID requirements from IPP Everywhere 1.1 and subsequently an IPP Everywhere 1.1 conforming client queries an IPP Everywhere 1.0 conforming device, which returns a 1284 device ID, should the client just ignore the 1284 device ID response?

Thanks.

Best Regards,

/Paul

Sent from my iPhone

> On Apr 17, 2018, at 9:34 AM, Ira McDonald <[email-masked]> wrote:
> 
> Hi Paul,
> 
> As Mike pointed out, using IEEE 1284 Device ID to do PDL-stream tweaks in IPP Everywhere was
> never a legitimate implementation.  Vendors who honored IEEE 1284 Device ID info over the much
> more authoritative IPP Printer status attributes have broken implementations anyway.
> 
> I agree with Mike - delete all mention of IEEE 1284 Device ID from IPP Everywhere (with which it
> is incompatible).
> 
> Cheers,
> - Ira
> 
> 
>

---

From: Michael Sweet <[email-masked]>
Date: Tue, 17 Apr 2018 09:50:30 -0400

Paul,

Yes, absolutely it ignores it, just as it will ignore any other attribute it doesn't care about.

An IPP Everywhere client looks at the document-format-supported, media-xxx, and pwg-raster-document-xxx attributes to know what to send, *not* printer-device-id.

> On Apr 17, 2018, at 9:44 AM, Paul Tykodi <[email-masked]> wrote:
> 
> Hi Ira,
> 
> On Apr 17, 2018, at 9:34 AM, Ira McDonald <[email-masked] <mailto:[email-masked]>> wrote:
> 
>> Hi Paul,
>> 
>> On Tue, Apr 17, 2018 at 8:17 AM, Paul Tykodi <[email-masked] <mailto:[email-masked]>> wrote:
>> Hi Ira,
>> 
>>> Jan-April: 579 Park Place <https://maps.google.com/?q=579+Park+Place+Saline,+MI+48176+734&entry=gmail&source=g>  Saline, MI <https://maps.google.com/?q=579+Park+Place+Saline,+MI+48176+734&entry=gmail&source=g>  48176 <https://maps.google.com/?q=579+Park+Place+Saline,+MI+48176+734&entry=gmail&source=g>  734 <https://maps.google.com/?q=579+Park+Place+Saline,+MI+48176+734&entry=gmail&source=g>-944-0094

---

From: Ira McDonald <[email-masked]>
Date: Tue, 17 Apr 2018 09:51:19 -0400

Hi Paul,

ANY optional attribute can be returned by an IPP Printer from ANY IETF or
PWG IPP spec.
IPP Everywhere is a *profile* of IPP, not a *version*.

If an IPP Client is so out-of-date to parse and use the PDL identifiers in
an IEEE 1284
Device ID string, then it's a poor implementation anyway.

Cheers,
- Ira

On Tue, Apr 17, 2018 at 9:44 AM, Paul Tykodi <[email-masked]> wrote:

> Hi Ira,
>
> If we remove the 1284 device ID requirements from IPP Everywhere 1.1 and
> subsequently an IPP Everywhere 1.1 conforming client queries an IPP
> Everywhere 1.0 conforming device, which returns a 1284 device ID, should
> the client just ignore the 1284 device ID response?
>
> Thanks.
>
> Best Regards,
>
> /Paul
>
> Sent from my iPhone
>
>>> Where I believe some vendors use them to send pre and post job
>>> processing device specific commands, I don’t believe we should fully retire
>>> support for the 1284 device ID’s at this time.
>>>
>>>
>>>
>>> As 1284 device IDs are only needed for printer driver selection, I'd
>>> like remove all of the 1284 device ID requirements from IPP Everywhere 1.1.
>>>
>>> Thoughts?
>>>