Subject: [IPP] Why is JPEG JFIF document format support required for monochrome IPP Everywhere printers?

From: "Kennedy, Smith (Wireless & Standards Architec)" <[email-masked]>
Date: Mon, 2 Apr 2018 16:11:04 +0000

Hello,

Why is it that JPEG JFIF document format support is mandatory for all IPP Everywhere printers? We have some monochrome products that support PWG Raster, but don't support JPEG JFIF. That makes it impossible for us to certify these products as IPP Everywhere, since in IPP Everywhere JPEG support is mandatory (5100.14 section 6 page 45).

I propose to the IPP WG that it should consider softening the JPEG JFIF requirement in 5100.14 for monochrome printers. I am fine with it remaining required for color printers.

Thoughts?

Cheers,

Smith

/**
    Smith Kennedy
    Wireless & Standards Architect - IPG-PPS
    Standards - IEEE ISTO PWG / Bluetooth SIG / Wi-Fi Alliance / NFC Forum / USB-IF
    Chair, IEEE ISTO Printer Working Group
    HP Inc.
*/

_______________________________________________
ipp mailing list
[email-masked]
https://www.pwg.org/mailman/listinfo/ipp

---

From: Michael Sweet <[email-masked]>
Date: Mon, 02 Apr 2018 15:14:36 -0400

Smith,

This sounds OK to me, as JPEG printing is primarily for photos - most B&W-only printers are not photo printers (and those that are will likely support JPEG...)

>From a client-perspective, all CUPS-based implementations will handle this just fine and convert a local JPEG to PWG Raster as needed.

> On Apr 2, 2018, at 12:11 PM, Kennedy, Smith (Wireless & Standards Architec) <[email-masked]> wrote:
> 
> Hello,
> 

_________________________________________________________
Michael Sweet, Senior Printing System Engineer

---

From: Ira McDonald <[email-masked]>
Date: Mon, 2 Apr 2018 16:00:51 -0400

Hi,

I agree w/ removing JPEG for monochrome printer conformance.

Another fix for IPP Everywhere/1.1.

Cheers,
- Ira

Ira McDonald (Musician / Software Architect)
Co-Chair - TCG Trusted Mobility Solutions WG
Chair - Linux Foundation Open Printing WG
Secretary - IEEE-ISTO Printer Working Group
Co-Chair - IEEE-ISTO PWG Internet Printing Protocol WG
IETF Designated Expert - IPP & Printer MIB
Blue Roof Music / High North Inc
http://sites.google.com/site/blueroofmusic
http://sites.google.com/site/highnorthinc
mailto: [email-masked]
Jan-April: 579 Park Place  Saline, MI  48176  734-944-0094
May-Dec: PO Box 221  Grand Marais, MI 49839  906-494-2434

On Mon, Apr 2, 2018 at 3:14 PM, Michael Sweet <[email-masked]> wrote:

> Smith,
>
> This sounds OK to me, as JPEG printing is primarily for photos - most
> B&W-only printers are not photo printers (and those that are will likely
> support JPEG...)
>
> From a client-perspective, all CUPS-based implementations will handle this
> just fine and convert a local JPEG to PWG Raster as needed.
>
>
> > Why is it that JPEG JFIF document format support is mandatory for all
> IPP Everywhere printers? We have some monochrome products that support PWG
> Raster, but don't support JPEG JFIF. That makes it impossible for us to
> certify these products as IPP Everywhere, since in IPP Everywhere JPEG
> support is mandatory (5100.14 section 6 page 45).
> >
> > I propose to the IPP WG that it should consider softening the JPEG JFIF
> requirement in 5100.14 for monochrome printers. I am fine with it remaining
> required for color printers.
> >
> > Thoughts?
> >
> > Cheers,
> >
> > Smith
> >
> > /**
> >    Smith Kennedy