Subject: [IPP] IPP WG Last Call of IPP Privacy Attributes v1.0 (PRIVACY) (Ends April 12, 2018)

From: Michael Sweet <[email-masked]>
Date: Tue, 03 Apr 2018 15:12:23 -0400

All,

This message initiates an IPP workgroup last call of the IPP Privacy Attributes v1.0 (PRIVACY) registration document, which can be found here:

	https://ftp.pwg.org/pub/pwg/ipp/wd/wd-ippprivacy10-20180403.pdf

This registration defines attributes for specifying the privacy policies of Document, Job, Printer, and Subscription objects.  The "ippsample" project contains a prototype implementation of these attributes:

	https://github.com/istopwg/ippsample

Please review this document and respond to the IPP mailing list (reply-all to this message is fine) with any feedback you have for the proposed registration.

This last call ends on April 12, 2018 (the next IPP workgroup conference call).

_________________________________________________________
Michael Sweet, Senior Printing System Engineer

_______________________________________________
ipp mailing list
[email-masked]
https://www.pwg.org/mailman/listinfo/ipp

---

From: "Kennedy, Smith (Wireless & Standards Architec)" <[email-masked]>
Date: Tue, 10 Apr 2018 21:16:42 +0000

Hi Mike,

Sorry for not getting this feedback to you sooner. One minor quibble:

Lines 161 / 180 / 209: "This value MUST appear by itself." might be better expressed by adding the normative statement "If the 'none' keyword is specified by this attribute, it MUST be the only keyword specified." to the paragraph above it (lines 153-155, lines 173-174, lines 201-203).

I'm fine if we leave the document as is, too.

Smith

/**
    Smith Kennedy
    Wireless & Standards Architect - IPG-PPS
    Standards - IEEE ISTO PWG / Bluetooth SIG / Wi-Fi Alliance / NFC Forum / USB-IF
    Chair, IEEE ISTO Printer Working Group
    HP Inc.
*/

> On Apr 3, 2018, at 1:12 PM, Michael Sweet <[email-masked]> wrote:
> 
> All,
>

---

From: Michael Sweet <[email-masked]>
Date: Tue, 10 Apr 2018 17:18:43 -0400

Smith,

No worries, comments are fine during last call.  I can make the changes before publication in the "registrations" directory (assuming there are no hard objections before the end of the last call...)

> On Apr 10, 2018, at 5:16 PM, Kennedy, Smith (Wireless & Standards Architec) <[email-masked]> wrote:
> 
> Hi Mike,
>