Subject: Re: [IPP] 5100.11 "job-password-encryption-supported" - what SHA version does 'sha' keyword indicate?

From: "Kennedy, Smith (Wireless & Standards Architect)" <[email-masked]>
Date: Mon, 27 Aug 2018 21:18:13 +0000

Greetings,

Resurrecting an old thread: although not listed below, the 'sha2-512_224' keyword was also registered.

Smith

/**
    Smith Kennedy
    Wireless & Standards Architect - IPG-PPS
    Standards - IEEE ISTO PWG / Bluetooth SIG / Wi-Fi Alliance / NFC Forum / USB-IF
    Chair, IEEE ISTO Printer Working Group
    HP Inc.
*/

> On Jun 16, 2014, at 2:56 PM, Michael Sweet <[email-masked]> wrote:
> 
> OK, the consensus at today's concall is that "sha" refers to SHA-1.  We will register the following values for SHA2:
> 
>   sha2-224
>   sha2-256
>   sha2-384
>   sha2-512
>   sha2-512_256
> 
> The latter is the 512-bit SHA-2 hash truncated to 256 bits as used in the upcoming HTTP Digest authentication update.
> 
> Once a non-draft US NIST (or other) specification is released, we will also register the following new values for SHA-3 and Shake:
> 
>   sha3-224
>   sha3-256
>   sha3-384
>   sha3-512
>   sha3-512_256
>   shake-128
>   shake-256
> 
> 
> The IANA registration information for the SHA-2 registrations is:
> 
> Attributes (attribute syntax)
>   Keyword Attribute Value                       Reference
>   -----------------------                       ---------
> job-password-encryption (type2 keyword)		[PWG5100.11]
>   sha2-224
>   sha2-256
>   sha2-384
>   sha2-512
>   sha2-512_256
> 
> 
> On Jun 12, 2014, at 4:52 PM, Kennedy, Smith (Wireless Architect) <[email-masked] <mailto:[email-masked]>> wrote:
> 
>> Greetings,
>> 
>> PWG 5100.11 (JPS2) defines the “job-password-encryption-supported” attribute.  One of the keywords defined in JPS2 is ’sha’.  Neither the keyword nor the description is clear as to which SHA generation is being used.  Is this SHA-0 or SHA-1?  Do we need to define additional keywords to bring this up-to-date?
>> 
>> Smith
>> 
>> /**
>>     Smith Kennedy
>>     ATB Wireless Architect - PPS
>>     Hewlett-Packard Co.
>> */
>> 
>> 
>> 
>> _______________________________________________
>> ipp mailing list
>> [email-masked] <mailto:[email-masked]>
>> https://www.pwg.org/mailman/listinfo/ipp
> 
> _________________________________________________________
> Michael Sweet, Senior Printing System Engineer, PWG Chair
> 

_______________________________________________
ipp mailing list
[email-masked]
https://www.pwg.org/mailman/listinfo/ipp

---

From: "Kennedy, Smith (Wireless & Standards Architect)" <[email-masked]>
Date: Mon, 27 Aug 2018 21:22:18 +0000

Actually, found that they were registered here:

http://www.pwg.org/pipermail/ipp/2015/018630.html

Mike or Ira, can you update the link for the 'sha2-512_224' and 'sha3-512_224' keyword registrations in the IANA registry? 

Smith

> On Aug 27, 2018, at 3:18 PM, Kennedy, Smith (Wireless & Standards Architect) <[email-masked]> wrote:
> 
> Greetings,
> 
>> On Jun 12, 2014, at 4:52 PM, Kennedy, Smith (Wireless Architect) <[email-masked]> wrote:
>> 
>>> Greetings,
>>>

---

From: Michael Sweet <[email-masked]>
Date: Mon, 27 Aug 2018 17:27:14 -0400

Smith,

I've added this to my TODO list for the next registry update.

> On Aug 27, 2018, at 5:22 PM, Kennedy, Smith (Wireless & Standards Architect) <[email-masked]> wrote:
> 

_________________________________________________________
Michael Sweet, Senior Printing System Engineer