Subject: Re: [IPP] Updated IPP Everywhere v1.1 drafts posted

From: "Kennedy, Smith (Wireless & Standards Architect)" <[email-masked]>
Date: Wed, 15 Aug 2018 17:21:23 +0000

Just resurrecting this thread because the August F2F didn't review an update that included any of my points of feedback, etc.

Smith

> On Jul 19, 2018, at 6:51 PM, Kennedy, Smith (Wireless & Standards Architect) <[email-masked]> wrote:
> 
> 
> 
>> On Jul 19, 2018, at 6:04 PM, Michael Sweet <[email-masked] <mailto:[email-masked]>> wrote:
>> 
>> 
>> 
>>> On Jul 19, 2018, at 6:31 PM, Kennedy, Smith (Wireless & Standards Architect) <[email-masked] <mailto:[email-masked]>> wrote:
>>> 
>>> 
>>> 
>>>> On Jul 18, 2018, at 8:35 AM, Michael Sweet <[email-masked] <mailto:[email-masked]>> wrote:
>>>> 
>>>>> 
>>>>> Page 22, Table 3: Should we be defining a new "ippe" key that specifies the version of IPP Everywhere™ supported? Or one that duplicates "ipp-features-supported" since that attribute's value contains arguably valuable values for filtering?
>>>> 
>>>> Given that we are still on the same major version and the limited space available for TXT record keys, I'd argue that an "ippe" key is not yet necessary (maybe if we ever get to v2).
>>>> 
>>>> As for "ipp-features-supported", what features were you thinking of as valuable for filtering?
>>> 
>>> Basically sub-filtering at discovery time for a particular generation of IPP Everywhere™.
>> 
>> ... in order to do what?
> 
> Ummmm.....not sure.
> 
>> 
>> Unless there is a compelling need (and I'm not aware of any IPP protocol-level features that would qualify), I really can't support it.  We have keys for specific kinds of printer features, PDL support, etc., but at the protocol level we are entirely generic so that any client can send print jobs to any printer.
>> 
>> And even for those printer features the only printing UI I am aware of that shipped support for filtering was my old ESP Print Pro software and the original Qt print dialog - both are long gone now...
> 
> Upon more reflection, I don't see any substantive value and so I withdraw the feedback / comment / change request.
> _______________________________________________
> ipp mailing list
> [email-masked] <mailto:[email-masked]>
> https://www.pwg.org/mailman/listinfo/ipp <https://www.pwg.org/mailman/listinfo/ipp>
_______________________________________________
ipp mailing list
[email-masked]
https://www.pwg.org/mailman/listinfo/ipp

---

From: Michael Sweet <[email-masked]>
Date: Thu, 23 Aug 2018 18:43:43 -0400

OK, I've added all of our discussions to my editing TODO list for the spec, and collected a list of items to discuss at our next conference call:

- Should we add recommended attributes? "job-password-repertoire", "jpeg-features-supported", "jpeg-k-octets-supported", "jpeg-x-dimension-supported", "jpeg-y-dimension-supported", "pdf-features-supported", "pdf-k-octets-supported", and "pdf-versions-supported"
- Should we add an 'ipp-everywhere-1.1' value for "ipp-features-supported"?
- Should we address/update paid/managed printing (use of Get-User-Printer-Attributes, attributes/values needed for paid/managed printing)

> On Aug 15, 2018, at 1:21 PM, Kennedy, Smith (Wireless & Standards Architect) <[email-masked]> wrote:
> 
>>> On Jul 19, 2018, at 6:04 PM, Michael Sweet <[email-masked]> wrote:
>>> 
>>> 
>>> 
>>>> On Jul 19, 2018, at 6:31 PM, Kennedy, Smith (Wireless & Standards Architect) <[email-masked]> wrote:
>>>> 
>>>> 
>>>> 
>>>>> On Jul 18, 2018, at 8:35 AM, Michael Sweet <[email-masked]> wrote:
>>>>> 
>>>>>> 

_________________________________________________________
Michael Sweet, Senior Printing System Engineer