Subject: [IPP] MSN2 Table 3: Why is there a "Localized Name" column?

From: "Kennedy, Smith (Wireless & Standards Architect)" <[email-masked]>
Date: Wed, 29 Aug 2018 20:44:41 +0000

Hi there,

Why did we include the "Localized Name" column in Table 3 of PWG 5101.1 MSN2? How is a reader expected to use this information?

Smith

/**
    Smith Kennedy
    Wireless & Standards Architect - IPG-PPS
    Standards - IEEE ISTO PWG / Bluetooth SIG / Wi-Fi Alliance / NFC Forum / USB-IF
    Chair, IEEE ISTO Printer Working Group
    HP Inc.
*/

_______________________________________________
ipp mailing list
[email-masked]
https://www.pwg.org/mailman/listinfo/ipp

---

From: Michael Sweet <[email-masked]>
Date: Wed, 29 Aug 2018 16:50:30 -0400

Smith,

It is intended to show suggested text for a user interface, e.g., "US Letter" instead of 'na_letter_8.5x11in'.  From an implementor's standpoint it can be used as a starting point for localization, and in fact I use these strings as part of the example ipp.strings file:

    https://ftp.pwg.org/pub/pwg/ipp/examples/ipp.strings

> On Aug 29, 2018, at 4:44 PM, Kennedy, Smith (Wireless & Standards Architect) <[email-masked]> wrote:
> 
> Hi there,
> 

_________________________________________________________
Michael Sweet, Senior Printing System Engineer

---

From: "Kennedy, Smith (Wireless & Standards Architect)" <[email-masked]>
Date: Wed, 29 Aug 2018 20:59:30 +0000

OK, that makes sense, and that is what I assumed. I got a query from one of my cohorts and wanted to confirm that MSN2 isn't being prescriptive in the sense that it is suggesting that all clients SHOULD use these strings.

Smith

> On Aug 29, 2018, at 2:50 PM, Michael Sweet <[email-masked]> wrote:
> 
> Smith,
>