Subject: [IPP] New "Initial Draft" of IPP Job and Printer Extensions Set 2 v2 (JPS2v2) posted

From: "Kennedy, Smith (Wireless & Standards Architect)" <[email-masked]>
Date: Tue, 28 Aug 2018 12:06:56 +0000

Greetings,

I have posted a new "Initial Draft" of IPP Job and Printer Extensions Set 2 v2 (JPS2v2). This was created using the published final PDF draft to ensure a start from the wording that was finalized. I have made a number of editorial changes that are all preserved in the -rev version in case there are objections. The primary set of changes involved moving all the Printer Description attributes out of sub-sections of the "Job Template" section to the "Printer Description Attributes" section.

   https://ftp.pwg.org/pub/pwg/ipp/wd/wd-ippjobprinterext20-20180828.docx
   https://ftp.pwg.org/pub/pwg/ipp/wd/wd-ippjobprinterext20-20180828.pdf
   https://ftp.pwg.org/pub/pwg/ipp/wd/wd-ippjobprinterext20-20180828-rev.docx
   https://ftp.pwg.org/pub/pwg/ipp/wd/wd-ippjobprinterext20-20180828-rev.pdf

I propose using this as our starting point, but please chime in if you don't like how this was produced. I will separately post slides to facilitate discussion about the changes HP would like to see in JPS2v2.

Cheers,
Smith

/**
    Smith Kennedy
    Wireless & Standards Architect - IPG-PPS
    Standards - IEEE ISTO PWG / Bluetooth SIG / Wi-Fi Alliance / NFC Forum / USB-IF
    Chair, IEEE ISTO Printer Working Group
    HP Inc.
*/

_______________________________________________
ipp mailing list
[email-masked]
https://www.pwg.org/mailman/listinfo/ipp

---

From: Michael Sweet <[email-masked]>
Date: Tue, 28 Aug 2018 09:33:11 -0400

Smith,

I really appreciate you tackling this update!  Apologies in advance for the length of this editorial feedback (going through the same thing myself with the 5100.5 update):

- Filename should be wd-ippjobprinterext2v20-yyyymmdd.ext
- Title should be "IPP Job and Printer Extensions - Set 2 v2.0 (JPS2)
- Abstract appears to be truncated and probably needs some editorial love.
- The IPP workgroup boilerplate on page 4 should be removed (not in current template)
- Global: Change all "type3 keyword" to "type2 keyword"
- Global: Change "The 'foo' Something Something attribute" in the attribute descriptions to just "This attribute"
- Section 4 appears to have the "4." in the title twice
- Section 5 (REQUIRED OPERATIONS) should be moved after the attributes and renamed "New Operations" (for consistency with our current spec template)
- Sections 6, 7, 9, and 10 should be brought under a new section 5 "New Attributes"
  - Section 5.1 Operation Attributes
  - Section 5.2 Job Description Attributes (or Job Status Attributes since job-save-printer-make-and-model appears to be set by the Printer during processing and thus should be READ ONLY)
  - Section 5.3 Job Template Attributes
  - Section 5.4 Printer Description Attributes
- Section 8 (Additional Semantics) should come after Section 11 (Additional Values)
- Add new Section 8.1: Get-Jobs: which-jobs to talk about new which-jobs values
- Section 8.1: make section 8.2 Hold-Job: job-hold-until-time
- Section 8.2: make section 8.3 Set-Job-Attributes: job-delay-output-until, job-delay-output-until-time, job-hold-until-time
- Section 10.11 should be made a subsection of job-delay-output-until-time
- Section 10.13 should be made a subsection of job-hold-until-time
- Section 10.35 should be made a subsection of save-info
- Section 10.40 should be made a subsection of save-name
- Section 11: New Values for Existing Attributes (drop semantics here)
- Section 11.1: Drop "Printer Description attribute" from title
- Section 11.2: Just "which-jobs (type2 keyword)" - which-jobs-supported inherits everything from which-jobs
- Section 11.3: Drop "Job Description attribute" from title
- Section 11.3.x: Move to corresponding Job Template attribute definitions
- Section 11.4: Delete (part of MSN2)
- Section 11.5: Move to section 5.3 Job Template attributes under a new "media-col (collection) Extension" section.
- Section 12: Just "IANA Considerations", we don't need the Semantic Model registration stuff anymore
- Section 12: Should come after section 14 (Security Considerations)
- Section 12.1: Attribute Registrations
- Bring back the "Conformance Requirements" section (missing!) - it should go before the Internationalization Considerations section
- Section 13: Drop UTR20 (not needed for IPP and no longer being maintained by the Unicode Consortium...) and make sure you don't lose the advisory text from the current WD template - UTR17, UTR23, and UTR33 are informational (non-normative) so the SHOULD is not appropriate.
- Section 14: Use the standard boilerplate text for now.  We'll probably want to add more once we settle on the final content.
- Add an "Overview of Changes" section before the Change History section with an "IPP Job and Printer Extensions - Set 2 v2.0" subsection to provide a high-level list the changes in the v2.0 update.
- Add a "Deprecated Attributes" section after the "New Values for Existing Attributes" section (empty for now)

Once we get closer to prototype I'll work with you on the registration templates - they'll need a significant amount of work... :/

> On Aug 28, 2018, at 8:06 AM, Kennedy, Smith (Wireless & Standards Architect) <[email-masked]> wrote:
> 
> Greetings,
> 

_________________________________________________________
Michael Sweet, Senior Printing System Engineer

---

From: Ira McDonald <[email-masked]>
Date: Tue, 28 Aug 2018 15:54:34 -0400

Hi Smith,

In the interests of sanity, I suggest that you do the "furniture moving"
that Mike
recommended with change tracking OFF and then we proceed forward from
there.

Cheers,
- Ira

Ira McDonald (Musician / Software Architect)
Co-Chair - TCG Trusted Mobility Solutions WG
Chair - Linux Foundation Open Printing WG
Secretary - IEEE-ISTO Printer Working Group
Co-Chair - IEEE-ISTO PWG Internet Printing Protocol WG
IETF Designated Expert - IPP & Printer MIB
Blue Roof Music / High North Inc
http://sites.google.com/site/blueroofmusic
http://sites.google.com/site/highnorthinc
mailto: [email-masked]
Jan-April: 579 Park Place  Saline, MI  48176  734-944-0094
May-Dec: PO Box 221  Grand Marais, MI 49839  906-494-2434

On Tue, Aug 28, 2018 at 9:35 AM Michael Sweet <[email-masked]> wrote:

> Smith,
>
> I really appreciate you tackling this update!  Apologies in advance for
> the length of this editorial feedback (going through the same thing myself
> with the 5100.5 update):
>
> - Global: Change "The 'foo' Something Something attribute" in the
> attribute descriptions to just "This attribute"
> - Section 5 (REQUIRED OPERATIONS) should be moved after the attributes and
> renamed "New Operations" (for consistency with our current spec template)
>   - Section 5.2 Job Description Attributes (or Job Status Attributes since
> job-save-printer-make-and-model appears to be set by the Printer during
> processing and thus should be READ ONLY)
> - Section 8.2: make section 8.3 Set-Job-Attributes:
> job-delay-output-until, job-delay-output-until-time, job-hold-until-time
> - Section 11.5: Move to section 5.3 Job Template attributes under a new
> "media-col (collection) Extension" section.
> - Bring back the "Conformance Requirements" section (missing!) - it should
> go before the Internationalization Considerations section
> - Section 13: Drop UTR20 (not needed for IPP and no longer being
> maintained by the Unicode Consortium...) and make sure you don't lose the
> advisory text from the current WD template - UTR17, UTR23, and UTR33 are
> informational (non-normative) so the SHOULD is not appropriate.
> - Section 14: Use the standard boilerplate text for now.  We'll probably
> want to add more once we settle on the final content.
> - Add an "Overview of Changes" section before the Change History section
> with an "IPP Job and Printer Extensions - Set 2 v2.0" subsection to provide
> a high-level list the changes in the v2.0 update.
> Once we get closer to prototype I'll work with you on the registration
> templates - they'll need a significant amount of work... :/
>
>
>
> > I have posted a new "Initial Draft" of IPP Job and Printer Extensions
> Set 2 v2 (JPS2v2). This was created using the published final PDF draft to
> ensure a start from the wording that was finalized. I have made a number of
> editorial changes that are all preserved in the -rev version in case there
> are objections. The primary set of changes involved moving all the Printer
> Description attributes out of sub-sections of the "Job Template" section to
> the "Printer Description Attributes" section.
> >
> > I propose using this as our starting point, but please chime in if you
> don't like how this was produced. I will separately post slides to
> facilitate discussion about the changes HP would like to see in JPS2v2.
> >
> > Cheers,
> > Smith
> >
> > /**
> >    Smith Kennedy

---

From: "Kennedy, Smith (Wireless & Standards Architect)" <[email-masked]>
Date: Tue, 28 Aug 2018 20:48:38 +0000

Sounds good. An "even newer initial draft" with all of Mike's suggested changes is coming soon to an FTP site near you...

Smith

> On Aug 28, 2018, at 1:54 PM, Ira McDonald <[email-masked]> wrote:
> 
> Hi Smith,
> 
> In the interests of sanity, I suggest that you do the "furniture moving" that Mike
> http://sites.google.com/site/blueroofmusic <https://protect-us.mimecast.com/s/AjeJC2kr5rfkPgN9FnBIt7?domain=sites.google.com>
> http://sites.google.com/site/highnorthinc <https://protect-us.mimecast.com/s/LLEjC31v5vim6O5EIqLitA?domain=sites.google.com>
> mailto: [email-masked] <mailto:[email-masked]>
> On Tue, Aug 28, 2018 at 9:35 AM Michael Sweet <[email-masked] <mailto:[email-masked]>> wrote:
> Smith,
> 
> > On Aug 28, 2018, at 8:06 AM, Kennedy, Smith (Wireless & Standards Architect) <[email-masked] <mailto:[email-masked]>> wrote:
> > 
> > Greetings,
> > 
> >   https://ftp.pwg.org/pub/pwg/ipp/wd/wd-ippjobprinterext20-20180828.docx <https://protect-us.mimecast.com/s/6KekC4xw7wuJMqpviBg-cA?domain=ftp.pwg.org>
> >   https://ftp.pwg.org/pub/pwg/ipp/wd/wd-ippjobprinterext20-20180828.pdf <https://protect-us.mimecast.com/s/GMmTC5yx5xs052VDs24Grc?domain=ftp.pwg.org>
> >   https://ftp.pwg.org/pub/pwg/ipp/wd/wd-ippjobprinterext20-20180828-rev.docx <https://protect-us.mimecast.com/s/a2XdC68y5yIojqnBsxw5LI?domain=ftp.pwg.org>
> >   https://ftp.pwg.org/pub/pwg/ipp/wd/wd-ippjobprinterext20-20180828-rev.pdf <https://protect-us.mimecast.com/s/6uxyC73z5zum4wOJIRN4g1?domain=ftp.pwg.org>
> > 
> > [email-masked] <mailto:[email-masked]>
> > https://www.pwg.org/mailman/listinfo/ipp <https://protect-us.mimecast.com/s/JqGMC82A5AhjDE7KuzlBpA?domain=pwg.org>
> 
> [email-masked] <mailto:[email-masked]>
> https://www.pwg.org/mailman/listinfo/ipp <https://protect-us.mimecast.com/s/JqGMC82A5AhjDE7KuzlBpA?domain=pwg.org>

---

From: "Kennedy, Smith (Wireless & Standards Architect)" <[email-masked]>
Date: Thu, 30 Aug 2018 03:58:43 +0000

Thanks for the detailed feedback! A few questions below - all that don't have questions have been resolved in my new local copy.

> On Aug 28, 2018, at 7:33 AM, Michael Sweet <[email-masked]> wrote:
> 
> Smith,
> 

I think it would read better if it was "8.2 Hold-Job operation" and then the 8.2.1 heading listing the name of "job-hold-until-time"

> - Section 8.2: make section 8.3 Set-Job-Attributes: job-delay-output-until, job-delay-output-until-time, job-hold-until-time

I think it would read better if it was "8.3 Set-Job-Attributes operation" and then the 8.3.x headings listing the names of the various attributes.

> - Section 10.40 should be made a subsection of save-name

I think the reader would be more likely to look for these in the Printer Description attributes section, but I moved them to where you recommended.

> - Section 11.3.x: Move to corresponding Job Template attribute definitions

I am not clear on what you are recommending that I do about these...

> - Bring back the "Conformance Requirements" section (missing!) - it should go before the Internationalization Considerations section

How did I drop that one?  :p

> - Section 13: Drop UTR20 (not needed for IPP and no longer being maintained by the Unicode Consortium...) and make sure you don't lose the advisory text from the current WD template - UTR17, UTR23,…

I copied over what is in the template

> - Section 14: Use the standard boilerplate text for now. We'll probably want to add more once we settle on the final content.

I copied in what is in the template. (BTW, the template has an indented "Implementations of this specification..." paragraph that should be outdented.

> > https://ftp.pwg.org/pub/pwg/ipp/wd/wd-ippjobprinterext20-20180828.docx <https://protect-us.mimecast.com/s/0a51CPNlvlc4zKYDSran-x?domain=ftp.pwg.org>
> > https://ftp.pwg.org/pub/pwg/ipp/wd/wd-ippjobprinterext20-20180828.pdf <https://protect-us.mimecast.com/s/18NACQWmwmF6vkGDu9I6wS?domain=ftp.pwg.org>
> > https://ftp.pwg.org/pub/pwg/ipp/wd/wd-ippjobprinterext20-20180828-rev.docx <https://protect-us.mimecast.com/s/RgqbCR6nxnhr4v9KH06cDS?domain=ftp.pwg.org>
> > https://ftp.pwg.org/pub/pwg/ipp/wd/wd-ippjobprinterext20-20180828-rev.pdf <https://protect-us.mimecast.com/s/8J2SCVOrBrclqxr4Cr5Lsb?domain=ftp.pwg.org>
> > 
> > https://www.pwg.org/mailman/listinfo/ipp <https://protect-us.mimecast.com/s/U5NECW6vDvhjr57pIBG2yf?domain=pwg.org>
>

---

From: Michael Sweet <[email-masked]>
Date: Thu, 30 Aug 2018 14:47:13 -0400

Smith,

Responses are inline below...

> On Aug 29, 2018, at 11:58 PM, Kennedy, Smith (Wireless & Standards Architect) <[email-masked]> wrote:
> 
> ...

Generally we've been using the format "Operation-Name: attribute[, ..., attribute" in recent specs.  All of the 8.x subsections are operations so I don't think we need to say "operation" specifically.

> I think it would read better if it was "8.3 Set-Job-Attributes operation" and then the 8.3.x headings listing the names of the various attributes.

Again, that's not how we've done it before, mainly because the separate third-level headings just make the spec wordier as you repeat everything N times.  Alternately maybe break this into two 8.x sections:

    8.3 Set-Job-Attributes: job-delay-output-until, job-delay-output-until-time

    ...

    8.4 Set-Job-Attributes: job-hold-until-time

since job-hold-until[-time] and job-delay-output-until[-time] have different semantics???

> I think the reader would be more likely to look for these in the Printer Description attributes section, but I moved them to where you recommended.

It just seems strange to have a heading "why there is no xxx-default attribute" rather than just omitting it from the list and adding a note or two where "xxx" is defined.

In other specs we have included a table of Job Template attributes with the corresponding default and supported values attributes - if we include that then we can add a note there stating there is no default value because it doesn't make sense.

> I am not clear on what you are recommending that I do about these...

For the definition of job-hold-until-time, note that Printer MUST add the 'job-hold-until-specified' keyword to "job-state-reasons" when the "job-hold-until-time" is specified.

Similarly, for "job-save-disposition", the discussion of state keywords belongs in the definition of that attribute.

In short, the "new values" section is just for listing new values and their meanings, not for defining or amending semantics for their use with other operations/attributes.

> I copied over what is in the template

OK, maybe you copied before I had updated the template?

> I copied in what is in the template. (BTW, the template has an indented "Implementations of this specification..." paragraph that should be outdented.

Yeah, I noticed that while I was reviewing the differences between the two. :)