Subject: [IPP] IPP WG Agenda 3:00-4:30pm US Eastern (30 August 2018)

From: Ira McDonald <[email-masked]>
Date: Wed, 29 Aug 2018 17:13:53 -0400

Hi,

Our next IPP WG call will be Thursday 30 August 2018 at
12:00-1:30pm US Pacific / 3:00pm-4:30pm US Eastern

NOTE: Please USE the *new* WebEx and Audio Bridge below

-------------------------------------------------------
Meeting information
-------------------------------------------------------
Topic: IPP WG
Every 2 weeks on Thursday, from Thursday, May 11, 2017, to no end date
3:00 pm  |  Eastern Standard Time (New York, GMT-05:00)  |  1 hr 30 mins

-------------------------------------------------------
WebEx online meeting (join first, before audio bridge)
-------------------------------------------------------
1. Go to
https://ieee-isto.webex.com/ieee-isto/j.php?MTID=m0359478143ca01e059a570ada91f3573
2. If requested, enter your name and email address.
3. If a password is required, enter the meeting password: Printing123
4. Click "Join".

-------------------------------------------------------
Audio Bridge (join second w/ unique access code from WebEx)
-------------------------------------------------------
Call-in toll-free number (US/Canada): +1 866 469-3239 <%28866%29%20469-3239>
Call-in toll number (US/Canada): +1 650 429-3300 <%28650%29%20429-3300>
Call-in toll number (US/Canada): +1 408 856-9570 <%28408%29%20856-9570>

Global toll-free call in numbers and other audio options ("Call Me Back" or
VoIP) are listed once you join the WebEx meeting.

Unique attendee access code:  Displayed in the WebEx meeting

Agenda:
(1) PWG IP Policy, Minute Taker, Roll Call, and Agenda Review
- Mike as minute taker?

(2) Approve IPP minutes from previous meetings
- http://ftp.pwg.org/pub/pwg/ipp/minutes/ippv2-concall-minutes-20180809.pdf
-- IPP WG call on 08/09/18 (delayed from previous week)
- https://ftp.pwg.org/pub/pwg/ipp/minutes/ippv2-f2f-minutes-20180815.pdf
-- IPP WG sessions at PWG Virtual F2F (08/15/18 to 08/16/18)

(3) Status/Review of various IPP mailing list notes
- http://www.pwg.org/archives/ipp/2018/019705.html
-- [PWG5100.11] "save-job-disposition" -> "job-save-disposition"
- http://www.pwg.org/archives/ipp/2018/019708.html
-- IESG draft to deprecate TLS/1.0 *and* TLS/1.1
- http://www.pwg.org/archives/ipp/2018/019727.html
-- RFC: Recommend same port/origin policy for resources in IPP Everywhere
v1.1
- h <http://www.pwg.org/archives/ipp/2018/019734.html>
ttp://www.pwg.org/archives/ipp/2018/019734.html
-- Recommended text for referencing STD 92: Internet Printing Protocol/1.1
- http://www.pwg.org/archives/ipp/2018/019741.html
-- "job-password-encryption-supported" - what SHA version does 'sha'
keyword indicate?
- http://www.pwg.org/archives/ipp/2018/019746.html
-- Registration request for attributes from "Wi-Fi Peer-to-Peer Services
Print (P2Ps-Print) Technical Specification v1.1" for PCLm

(4) Status of Open Printing WG GSoC 2018 (Ira)
-
https://ftp.pwg.org/pub/pwg/liaison/openprinting/presentations/TheLinuxFoundationGSoC-2018.pdf
-- success on all OP projects!
-- DONE - 14 May - GSoC coding begins
-- DONE - 11-15 June - GSoc Phase 1 evaluations by Mentors and Students
-- DONE - 9-13 July - GSoc Phase 2 evaluations by Mentors and Students
-- DONE - 6-14 August - GSoC final week!
-- DONE - 14-21 August - Mentors submit final Student evaluations
-- DONE - 22 August - GSoC announces final results

(5) Status of AMSC and ISO liaisons w/ PWG (Paul)
- https://ftp.pwg.org/pub/pwg/general/sc/pwg-sc-call-minutes-20180827.htm
-- see PWG SC minutes from 27 August 2018

(6) Status of Safe G-Code (Mike)
- https://ftp.pwg.org/pub/pwg/ipp/wd/wd-pwgsafegcode10-20180704-rev.pdf
<http://www.pwg.org/archives/ipp/2018/019661.html>
-- Prototype draft - PWG F2F review in August 2018
-- Schedule - IPP WG Last Call Q4 2018

(7) Status of IPP 3D Printing Extensions v1.1 (Mike)
- https://ftp.pwg.org/pub/pwg/ipp/wd/wd-ipp3d11-20180704-rev.pdf
-- Prototype draft - PWG F2F review in August 2018
-- Schedule - PWG Last Call Q4 2018

(8) Status of How to Print Using the IPP (Mike)
- https://ftp.pwg.org/pub/pwg/ipp/wd/wd-ippguide-20180430.html
- https://github.com/istopwg/pwg-books
-- PWG F2F review in May 2018
-- Current HTML draft available in Github repository
-- Schedule - TBD

(9) Status of IPP HTTP Authentication whitepaper (Smith)
- http://ftp.pwg.org/pub/pwg/ipp/whitepaper/tb-ippauth-20180629.pdf
-- Interim draft - PWG F2F review in August 2018
-- Instead publish as PWG Best Practice
-- Schedule - TBD

(10) Status of IPP Encrypted Jobs and Documents (Mike)
- https://ftp.pwg.org/pub/pwg/ipp/wd/wd-ipptrustnoone10-20180328-rev.pdf
-- Interim draft - PWG F2F review in May 2018
-- good news - PGP-based path forward on 06/04/18!
-- Schedule - Mike to work on updated draft w/ just PGP this fall

(11) Status of IPP System Service (Ira/Mike)
- https://ftp.pwg.org/pub/pwg/ipp/wd/wd-ippsystem10-20180701-rev.pdf
<http://www.pwg.org/archives/ipp/2018/019657.html>-- Prototype draft - PWG
F2F review in August 2018
-- Prototyping tasks being tracked as a Github project
-- Schedule - prototype in "ippserver" - Stable draft in Q3/Q4 2018

(12) Status of IPP Reprint Password (Smith)
- https://ftp.pwg.org/pub/pwg/ipp/wd/wd-ippreprintpwd-20180620-rev.pdf
-
https://ftp.pwg.org/pub/pwg/ipp/slides/IPP%20Job%20Print%20Password%20Use%20Cases%202018-08-14.pdf
- http://www.pwg.org/archives/ipp/2018/019744.html
-- PWG F2F review in August 2018
-- Instead fold into PWG 5100.11 (JPS2) v2 major update
-- Schedule - TBD

(13) Status of IPP Everywhere Printer Self-Certification 1.0 Update 3?
- http://ftp.pwg.org/pub/pwg/ipp/minutes/ippv2-f2f-minutes-20180515.pdf
-- Goals, ipptool and ippfind updates
-- Now have code signing certificate!
-- Schedule - Mike to release beta of update 3 for testing soon

(14) Status of IPP Everywhere 1.1 (Mike)
- https://ftp.pwg.org/pub/pwg/ipp/wd/wd-ippeve11-20180704-rev.pdf
-- Prototype draft  - PWG F2F review in August 2018
-- Schedule - Q3/Q4 2018

(15) Status of IPP Everywhere 1.1 Self-Certification Manual 1.1 (Mike)
- https://ftp.pwg.org/pub/pwg/ipp/wd/wd-ippeveselfcert11-20180704-rev.pdf
-- Prototype draft - PWG F2F review in August 2018
-- Schedule - Q3/Q4 2018

(16) Status/Review of PWG Printer MIB and IPP MFD Alerts 1.1 (Ira)
- http://ftp.pwg.org/pub/pwg/ipp/wd/wd-pmpmfdalerts10-20180813-rev.pdf
-- Interim draft - for IPP WG review
-- Schedule - Prototype draft Q4 2018

(17) Next steps

- IPP WG call on Thu 13 September 2018 at 3:00-4:30pm US Eastern
-- TLS/1.3 slides (Ira) and regular topics

- IPP WG call on Thu 27 September 2018 at 3:00-4:30pm US Eastern
-- regular topics

Cheers,
- Ira

Ira McDonald (Musician / Software Architect)
Co-Chair - TCG Trusted Mobility Solutions WG
Chair - Linux Foundation Open Printing WG
Secretary - IEEE-ISTO Printer Working Group
Co-Chair - IEEE-ISTO PWG Internet Printing Protocol WG
IETF Designated Expert - IPP & Printer MIB
Blue Roof Music / High North Inc
http://sites.google.com/site/blueroofmusic
http://sites.google.com/site/highnorthinc
mailto: [email-masked]
Jan-April: 579 Park Place  Saline, MI  48176  734-944-0094
May-Dec: PO Box 221  Grand Marais, MI 49839  906-494-2434
_______________________________________________
ipp mailing list
[email-masked]
https://www.pwg.org/mailman/listinfo/ipp

---

From: Ira McDonald <[email-masked]>
Date: Thu, 30 Aug 2018 14:58:29 -0400

Hi,

Sorry, but the IPP WebEx meeting appears to be cancelled (huh?).
Smith, Mike, or I will send a note shortly with a new working link...

Cheers,
- Ira

On Wed, Aug 29, 2018 at 5:13 PM Ira McDonald <[email-masked]>
wrote:

> Global toll-free call in numbers and other audio options ("Call Me Back"
> or VoIP) are listed once you join the WebEx meeting.
>
> http://ftp.pwg.org/pub/pwg/ipp/minutes/ippv2-concall-minutes-20180809.pdf

---

From: "Kennedy, Smith (Wireless & Standards Architect)" <[email-masked]>
Date: Thu, 30 Aug 2018 19:04:17 +0000

See if this meeting works:

https://ieee-isto.webex.com/ieee-isto/e.php?MTID=m38712b4c20ce0406e73ff05ad42d194b <https://ieee-isto.webex.com/ieee-isto/e.php?MTID=m38712b4c20ce0406e73ff05ad42d194b>

Smith

/**
    Smith Kennedy
    Wireless & Standards Architect - IPG-PPS
    Standards - IEEE ISTO PWG / Bluetooth SIG / Wi-Fi Alliance / NFC Forum / USB-IF
    Chair, IEEE ISTO Printer Working Group
    HP Inc.
*/

> On Aug 30, 2018, at 12:58 PM, Ira McDonald <[email-masked]> wrote:
> 
> Hi,
> 
> http://sites.google.com/site/blueroofmusic <https://protect-us.mimecast.com/s/LCh4CVOrBrc2Pl8NTzIjyz?domain=sites.google.com>
> http://sites.google.com/site/highnorthinc <https://protect-us.mimecast.com/s/3Zf7CW6vDvh6yj8RSKDgZG?domain=sites.google.com>
> mailto: [email-masked] <mailto:[email-masked]>
> On Wed, Aug 29, 2018 at 5:13 PM Ira McDonald <[email-masked] <mailto:[email-masked]>> wrote:
> Hi,
> 
> 1. Go to https://ieee-isto.webex.com/ieee-isto/j.php?MTID=m0359478143ca01e059a570ada91f3573 <https://protect-us.mimecast.com/s/zfg7CXDwEwT4MnZVukeBTk?domain=ieee-isto.webex.com>
> Call-in toll-free number (US/Canada): +1 866 469-3239 <tel:%28866%29%20469-3239>
> Call-in toll number (US/Canada): +1 650 429-3300 <tel:%28650%29%20429-3300>
> Call-in toll number (US/Canada): +1 408 856-9570 <tel:%28408%29%20856-9570>
> 
> Global toll-free call in numbers and other audio options ("Call Me Back" or VoIP) are listed once you join the WebEx meeting.
> 
> - http://ftp.pwg.org/pub/pwg/ipp/minutes/ippv2-concall-minutes-20180809.pdf <https://protect-us.mimecast.com/s/OChYCYExGxuD63XEtMZlfT?domain=ftp.pwg.org>
> - https://ftp.pwg.org/pub/pwg/ipp/minutes/ippv2-f2f-minutes-20180815.pdf <https://protect-us.mimecast.com/s/FE7uCZ6yJyh7oMYrsPvx8N?domain=ftp.pwg.org> 
> - http://www.pwg.org/archives/ipp/2018/019705.html <https://protect-us.mimecast.com/s/NjSWC1wq8qi6EpX2SyggIL?domain=pwg.org>
> - http://www.pwg.org/archives/ipp/2018/019708.html <https://protect-us.mimecast.com/s/2Z-nC2kr5rfVEkQPS0MOEF?domain=pwg.org>
> - http://www.pwg.org/archives/ipp/2018/019727.html <https://protect-us.mimecast.com/s/CrQ9C31v5viXRmv6UOAVDv?domain=pwg.org>
> -- RFC: Recommend same port/origin policy for resources in IPP Everywhere v1.1
> - h <https://protect-us.mimecast.com/s/5AG_C4xw7wuz7JxMsXxnVg?domain=pwg.org>https://protect-us.mimecast.com/s/DyVxC5yx5xsMW015sj8Z87 <>
> - http://www.pwg.org/archives/ipp/2018/019741.html <https://protect-us.mimecast.com/s/0SgyC68y5yIPGoJjSlVVqt?domain=pwg.org>
> -- "job-password-encryption-supported" - what SHA version does 'sha' keyword indicate?
> - http://www.pwg.org/archives/ipp/2018/019746.html <https://protect-us.mimecast.com/s/ufE8C73z5zuzWmY4sE7u3H?domain=pwg.org>
> -- Registration request for attributes from "Wi-Fi Peer-to-Peer Services Print (P2Ps-Print) Technical Specification v1.1" for PCLm
> 
> - https://ftp.pwg.org/pub/pwg/liaison/openprinting/presentations/TheLinuxFoundationGSoC-2018.pdf <https://protect-us.mimecast.com/s/e0y6C82A5AhXwjgDUg3nxd?domain=ftp.pwg.org>
> - https://ftp.pwg.org/pub/pwg/general/sc/pwg-sc-call-minutes-20180827.htm <https://protect-us.mimecast.com/s/NvgvC9rB5BFzYmjLsKGb2C?domain=ftp.pwg.org>
> - https://ftp.pwg.org/pub/pwg/ipp/wd/wd-pwgsafegcode10-20180704-rev.pdf <https://protect-us.mimecast.com/s/rf2VC0Rp6pskr2zqTR89vt?domain=ftp.pwg.org> <https://protect-us.mimecast.com/s/hjUlCgJKgKTqYlJOTYkFOL?domain=pwg.org>
> - https://ftp.pwg.org/pub/pwg/ipp/wd/wd-ipp3d11-20180704-rev.pdf <https://protect-us.mimecast.com/s/OiJrCjRMlMsYyj0Ks4OMpn?domain=ftp.pwg.org>
> - https://ftp.pwg.org/pub/pwg/ipp/wd/wd-ippguide-20180430.html <https://protect-us.mimecast.com/s/vlUKCkRKmKskqnv8Txj6De?domain=ftp.pwg.org>
> - https://github.com/istopwg/pwg-books  <https://protect-us.mimecast.com/s/sJgsClYLnLi1zol0cm7FSX?domain=github.com>
> - http://ftp.pwg.org/pub/pwg/ipp/whitepaper/tb-ippauth-20180629.pdf <https://protect-us.mimecast.com/s/WQ6NCmZ6o6hpR5qBsP7BYV?domain=ftp.pwg.org>
> - https://ftp.pwg.org/pub/pwg/ipp/wd/wd-ipptrustnoone10-20180328-rev.pdf <https://protect-us.mimecast.com/s/FcmFCn5XpXTX6GVAU581zM?domain=ftp.pwg.org> 
> - https://ftp.pwg.org/pub/pwg/ipp/wd/wd-ippsystem10-20180701-rev.pdf <https://protect-us.mimecast.com/s/QTYGCo2KqKhDKXmjt808Fr?domain=ftp.pwg.org>
>  <https://protect-us.mimecast.com/s/GDFTCpYK0Ki9xzZ1TEkT0P?domain=pwg.org>-- Prototype draft - PWG F2F review in August 2018
> - https://ftp.pwg.org/pub/pwg/ipp/wd/wd-ippreprintpwd-20180620-rev.pdf <https://protect-us.mimecast.com/s/wuU9Cqx5v5u17OvKcwU8zZ?domain=ftp.pwg.org> 
> - https://ftp.pwg.org/pub/pwg/ipp/slides/IPP%20Job%20Print%20Password%20Use%20Cases%202018-08-14.pdf <https://protect-us.mimecast.com/s/159cCADo5oTZ195LsWZsKQ?domain=ftp.pwg.org>
> - http://www.pwg.org/archives/ipp/2018/019744.html <https://protect-us.mimecast.com/s/5tn7Cv25A5hEyWZpsNv4zd?domain=pwg.org>
> - http://ftp.pwg.org/pub/pwg/ipp/minutes/ippv2-f2f-minutes-20180515.pdf <https://protect-us.mimecast.com/s/3XN1Cwp5B5IvRLnJsnqckA?domain=ftp.pwg.org>
> - https://ftp.pwg.org/pub/pwg/ipp/wd/wd-ippeve11-20180704-rev.pdf <https://protect-us.mimecast.com/s/7vgECxk5D5fLQJjnS69ozC?domain=ftp.pwg.org>
> - https://ftp.pwg.org/pub/pwg/ipp/wd/wd-ippeveselfcert11-20180704-rev.pdf <https://protect-us.mimecast.com/s/3IqaCyP5E5u7yN3qsmMhTT?domain=ftp.pwg.org>
> - http://ftp.pwg.org/pub/pwg/ipp/wd/wd-pmpmfdalerts10-20180813-rev.pdf <https://protect-us.mimecast.com/s/0PoTCzp5G5IGmRzQsLevam?domain=ftp.pwg.org>
> http://sites.google.com/site/blueroofmusic <https://protect-us.mimecast.com/s/LCh4CVOrBrc2Pl8NTzIjyz?domain=sites.google.com>
> http://sites.google.com/site/highnorthinc <https://protect-us.mimecast.com/s/3Zf7CW6vDvh6yj8RSKDgZG?domain=sites.google.com>
> mailto: [email-masked] <mailto:[email-masked]>
> https://protect-us.mimecast.com/s/z-QQCR6nxnhGgrXjs9MKK-?domain=pwg.org

---

From: <[email-masked]>
Date: Thu, 30 Aug 2018 15:08:44 -0400

Started to load, but then said meeting ended!
Bill W.

From: Kennedy, Smith (Wireless & Standards Architect)
Sent: Thursday, August 30, 2018 3:06 PM
To: Ira McDonald
Cc: [email-masked]
Subject: Re: [IPP] [Broken WebEx link] IPP WG Agenda 3:00-4:30pm US Eastern(30 August 2018)

https://ieee-isto.webex.com/ieee-isto/e.php?MTID=m38712b4c20ce0406e73ff05ad42d194b

Smith

/**
    Smith Kennedy

Hi,

Cheers,
- Ira

On Wed, Aug 29, 2018 at 5:13 PM Ira McDonald <[email-masked]> wrote:
Hi,

1. Go to https://ieee-isto.webex.com/ieee-isto/j.php?MTID=m0359478143ca01e059a570ada91f3573

-------------------------------------------------------
Audio Bridge (join second w/ unique access code from WebEx)
-------------------------------------------------------
Call-in toll-free number (US/Canada): +1 866 469-3239
Call-in toll number (US/Canada): +1 650 429-3300
Call-in toll number (US/Canada): +1 408 856-9570

- hhttps://protect-us.mimecast.com/s/DyVxC5yx5xsMW015sj8Z87

- https://ftp.pwg.org/pub/pwg/liaison/openprinting/presentations/TheLinuxFoundationGSoC-2018.pdf

- https://ftp.pwg.org/pub/pwg/ipp/slides/IPP%20Job%20Print%20Password%20Use%20Cases%202018-08-14.pdf

(17) Next steps

Cheers,
- Ira

---

From: "Kennedy, Smith (Wireless & Standards Architect)" <[email-masked]>
Date: Thu, 30 Aug 2018 19:08:49 +0000

Sorry, that one had no audio. 😞

This one has audio: https://ieee-isto.webex.com/ieee-isto/e.php?MTID=mf763f00f2d69bd7778b5f17e9ae8fd2d <https://ieee-isto.webex.com/ieee-isto/e.php?MTID=mf763f00f2d69bd7778b5f17e9ae8fd2d>

> On Aug 30, 2018, at 1:04 PM, Kennedy, Smith (Wireless & Standards Architect) <[email-masked]> wrote:
> 
>> On Aug 30, 2018, at 12:58 PM, Ira McDonald <[email-masked] <mailto:[email-masked]>> wrote:
>> 
>> Hi,
>> 
>> [email-masked] <mailto:[email-masked]>

---

From: <[email-masked]>
Date: Thu, 30 Aug 2018 15:12:10 -0400

Now is saying that meeting is not started.
Bill W.

From: [email-masked]
Sent: Thursday, August 30, 2018 3:08 PM
To: Kennedy, Smith (Wireless & Standards Architect); Ira McDonald
Cc: [email-masked]
Subject: Re: [IPP] [Broken WebEx link] IPP WG Agenda 3:00-4:30pm USEastern(30 August 2018)

Smith

/**
    Smith Kennedy

Hi,

Cheers,
- Ira

(17) Next steps

Cheers,
- Ira