Subject: [IPP] Updated IPP Everywhere v1.1 draft posted

From: Michael Sweet <[email-masked]>
Date: Fri, 24 Aug 2018 10:06:18 -0400

All,

I have posted an updated prototype draft of the IPP Everywhere v1.1 specification to:

	https://ftp.pwg.org/pub/pwg/ipp/wd/wd-ippeve11-20180824.docx
	https://ftp.pwg.org/pub/pwg/ipp/wd/wd-ippeve11-20180824.pdf
	https://ftp.pwg.org/pub/pwg/ipp/wd/wd-ippeve11-20180824-rev.pdf

As noted in a prior email, we have a few outstanding issues to discuss:

- Should we add recommended attributes? "job-password-repertoire", "jpeg-features-supported", "jpeg-k-octets-supported", "jpeg-x-dimension-supported", "jpeg-y-dimension-supported", "pdf-features-supported", "pdf-k-octets-supported", and "pdf-versions-supported"
- Should we add an 'ipp-everywhere-1.1' value for "ipp-features-supported"?
- Should we address/update paid/managed printing (use of Get-User-Printer-Attributes, attributes/values needed for paid/managed printing)

_________________________________________________________
Michael Sweet, Senior Printing System Engineer

_______________________________________________
ipp mailing list
[email-masked]
https://www.pwg.org/mailman/listinfo/ipp

---

From: "Kennedy, Smith (Wireless & Standards Architect)" <[email-masked]>
Date: Fri, 24 Aug 2018 16:58:47 +0000

> On Aug 24, 2018, at 8:06 AM, Michael Sweet <[email-masked]> wrote:
> 
> All,
> 
> https://ftp.pwg.org/pub/pwg/ipp/wd/wd-ippeve11-20180824.docx <https://protect-us.mimecast.com/s/VXaWCG6xjxhJJxPWSkdlrE?domain=ftp.pwg.org>
> https://ftp.pwg.org/pub/pwg/ipp/wd/wd-ippeve11-20180824.pdf <https://protect-us.mimecast.com/s/_B6iCJ6AmAh88G2pUOOpmj?domain=ftp.pwg.org>
> https://ftp.pwg.org/pub/pwg/ipp/wd/wd-ippeve11-20180824-rev.pdf <https://protect-us.mimecast.com/s/XOcsCKrBnBFqqgY8coF33X?domain=ftp.pwg.org>
> 
> - Should we add recommended attributes?

In general, yes.

> "job-password-repertoire"

I'd vote "No" to this one since we might be revisiting job passwords in JPS2v2.

> , "jpeg-features-supported", "jpeg-k-octets-supported", "jpeg-x-dimension-supported", "jpeg-y-dimension-supported", "pdf-features-supported", "pdf-k-octets-supported", and "pdf-versions-supported"

I'd vote "Yes" to all of these.

> - Should we add an 'ipp-everywhere-1.1' value for "ipp-features-supported"?

I'd vote "Yes".

> - Should we address/update paid/managed printing (use of Get-User-Printer-Attributes, attributes/values needed for paid/managed printing)

I'd vote "Yes" for these updates too.

> https://www.pwg.org/mailman/listinfo/ipp <https://protect-us.mimecast.com/s/F72kCL9DoDCPPxgNHKIxl7?domain=pwg.org>

---

From: Ira McDonald <[email-masked]>
Date: Fri, 24 Aug 2018 13:23:20 -0400

Hi,

I agree with all of Smith's recommendations.

I agree that we should leave out "job-password-repertoire" for now in IPP
EW v1.1
(and probably forever, because I'm not comfortable with its usefulness for
Clients).

Cheers,
- Ira

Ira McDonald (Musician / Software Architect)
Co-Chair - TCG Trusted Mobility Solutions WG
Chair - Linux Foundation Open Printing WG
Secretary - IEEE-ISTO Printer Working Group
Co-Chair - IEEE-ISTO PWG Internet Printing Protocol WG
IETF Designated Expert - IPP & Printer MIB
Blue Roof Music / High North Inc
http://sites.google.com/site/blueroofmusic
http://sites.google.com/site/highnorthinc
mailto: [email-masked]
Jan-April: 579 Park Place  Saline, MI  48176  734-944-0094
May-Dec: PO Box 221  Grand Marais, MI 49839  906-494-2434

On Fri, Aug 24, 2018 at 12:59 PM Kennedy, Smith (Wireless & Standards
Architect) <[email-masked]> wrote:

> <https://protect-us.mimecast.com/s/VXaWCG6xjxhJJxPWSkdlrE?domain=ftp.pwg.org>
> <https://protect-us.mimecast.com/s/_B6iCJ6AmAh88G2pUOOpmj?domain=ftp.pwg.org>
> <https://protect-us.mimecast.com/s/XOcsCKrBnBFqqgY8coF33X?domain=ftp.pwg.org>
>
> , "jpeg-features-supported", "jpeg-k-octets-supported",
> "jpeg-x-dimension-supported", "jpeg-y-dimension-supported",
> "pdf-features-supported", "pdf-k-octets-supported", and
> "pdf-versions-supported"
>
>
> - Should we address/update paid/managed printing (use of
> Get-User-Printer-Attributes, attributes/values needed for paid/managed
> printing)
>
>
> <https://protect-us.mimecast.com/s/F72kCL9DoDCPPxgNHKIxl7?domain=pwg.org>
>
>

---

From: Michael Sweet <[email-masked]>
Date: Sat, 25 Aug 2018 07:10:44 -0400

Smith/Ira,

If we *do* add a ‘ipp-everywhere-1.1’ value, what will it mean? It’s not like the conformance requirements are getting higher...

Sent from my iPhone

> On Aug 24, 2018, at 1:23 PM, Ira McDonald <[email-masked]> wrote:
> 
> Hi,
> 
> I agree that we should leave out "job-password-repertoire" for now in IPP EW v1.1
> (and probably forever, because I'm not comfortable with its usefulness for Clients).
> 
> Cheers,
> - Ira
> 
>> On Fri, Aug 24, 2018 at 12:59 PM Kennedy, Smith (Wireless & Standards Architect) <[email-masked]> wrote:
>> 
>>

---

From: Ira McDonald <[email-masked]>
Date: Sat, 25 Aug 2018 11:25:49 -0400

Hi Mike,

A good question.

Because it's a minor version release, we're not adding any new REQUIRED
stuff.  We're actually removing some stuff and adding new RECOMMENDED
stuff.

On reflection, I don't think the new feature keyword is appropriate.

Cheers,
- Ira

On Sat, Aug 25, 2018 at 7:10 AM Michael Sweet <[email-masked]> wrote:

> Smith/Ira,
>
> If we *do* add a ‘ipp-everywhere-1.1’ value, what will it mean? It’s not
> like the conformance requirements are getting higher...
>
> Sent from my iPhone
>