Subject: [IPP] IPP Everywhere PWG-Raster AND PDF Requirement

From: Sean Kau via ipp <[email-masked]>
Date: Mon, 4 Mar 2019 12:26:43 -0800

Question about the IPP Everywhere specification:

Why do we require that printers support PWG-Raster if it can accept PDF?
Is this to improve compatibility with clients?  I tried to look through the
archives and couldn't find any commentary.

-- 
Sean Kau
_______________________________________________
ipp mailing list
[email-masked]
https://www.pwg.org/mailman/listinfo/ipp

---

From: "Kennedy, Smith \(Wireless & Standards Architect\) via ipp" <[email-masked]>
Date: Mon, 4 Mar 2019 20:51:01 +0000

Good question, Sean. The reason for this is to set a baseline for interoperability. Some clients may not support PDF. So all Clients and Printers are required to support PWG Raster as a bare minimum. That way, there will always be some common document format that both can fall back to.

Smith

> On Mar 4, 2019, at 1:26 PM, Sean Kau via ipp <[email-masked]> wrote:
> 
> Why do we require that printers support PWG-Raster if it can accept PDF?  Is this to improve compatibility with clients?  I tried to look through the archives and couldn't find any commentary.
> 
> --
> Sean Kau
> https://protect-us.mimecast.com/s/OLVKCXDwEwTKJv3Bh6nyay?domain=pwg.org

---

From: Sean Kau via ipp <[email-masked]>
Date: Mon, 4 Mar 2019 13:34:46 -0800

That's sensible behavior for the standard as applicable to printers.  Is
there a recommendation for client behavior?  It seems like clients should
prefer PDF since that should be smaller on the wire,

On Mon, Mar 4, 2019 at 12:51 PM Kennedy, Smith (Wireless & Standards
Architect) <[email-masked]> wrote:

> Good question, Sean. The reason for this is to set a baseline for
> interoperability. Some clients may not support PDF. So all Clients and
> Printers are required to support PWG Raster as a bare minimum. That way,
> there will always be some common document format that both can fall back to.
>
> Smith
>
>
>
> > Why do we require that printers support PWG-Raster if it can accept
> PDF?  Is this to improve compatibility with clients?  I tried to look
> through the archives and couldn't find any commentary.
> >
> > --
> > Sean Kau

---

From: Michael Sweet via ipp <[email-masked]>
Date: Mon, 04 Mar 2019 19:30:01 -0500

Sean,

> On Mar 4, 2019, at 4:34 PM, Sean Kau via ipp <[email-masked]> wrote:
> 
> That's sensible behavior for the standard as applicable to printers.  Is there a recommendation for client behavior?  It seems like clients should prefer PDF since that should be smaller on the wire,

Generally speaking, if the Client can produce PDF then it should use it.  However, if the Client is printing a JPEG image (without special layout) and the Printer accepts JPEG, it should send the JPEG and not try wrapping it in a PDF or rendering as PWG Raster.

That said, a Client should also handle the document-unprintable-error case and retry as raster if the PDF (or JPEG) fails.  You can see this behavior in the CUPS ipp backend (where it tells cupsd to retry the job and use raster...)

> 
> On Mon, Mar 4, 2019 at 12:51 PM Kennedy, Smith (Wireless & Standards Architect) <[email-masked] <mailto:[email-masked]>> wrote:
> > On Mar 4, 2019, at 1:26 PM, Sean Kau via ipp <[email-masked] <mailto:[email-masked]>> wrote:
> > 
> > [email-masked] <mailto:[email-masked]>
> > https://protect-us.mimecast.com/s/OLVKCXDwEwTKJv3Bh6nyay?domain=pwg.org <https://protect-us.mimecast.com/s/OLVKCXDwEwTKJv3Bh6nyay?domain=pwg.org>
> 
> 
> 
> -- 
> Sean Kau
> [email-masked] <mailto:[email-masked]>
> https://www.pwg.org/mailman/listinfo/ipp <https://www.pwg.org/mailman/listinfo/ipp>
_________________________________________________________
Michael Sweet, Senior Printing System Engineer