Subject: [IPP] Minutes from yesterday's concall posted

From: Michael Sweet via ipp <[email-masked]>
Date: Fri, 15 Mar 2019 09:21:49 -0400

All,

I have posted the minutes from yesterday's IPP workgroup conference call to:

	https://ftp.pwg.org/pub/pwg/ipp/minutes/ippv2-concall-minutes-20190314.pdf

Our next conference call is on March 28, 2019 at 3pm ET.

Many thanks to Smith for taking the minutes this week!

_________________________________________________________
Michael Sweet, Senior Printing System Engineer

_______________________________________________
ipp mailing list
[email-masked]
https://www.pwg.org/mailman/listinfo/ipp

---

From: Ira McDonald via ipp <[email-masked]>
Date: Fri, 15 Mar 2019 14:20:09 -0400

Hi,

As already noted in a later thread by Smith, there is a significant typo in
these minutes:

• consensus was to keep "job-retain-until" (type2 keyword) and
"job-retain-until-time" (integer) and NOT implement "job-retain-until-date"
(dateTime)

There was a strong consensus against "job-xxx-until-date" attributes -
they're clumsy
and hard to use in a user friendly Client UI.

Cheers,
- Ira

Ira McDonald (Musician / Software Architect)
Co-Chair - TCG Trusted Mobility Solutions WG
Co-Chair - TCG Metadata Access Protocol SG
Chair - Linux Foundation Open Printing WG
Secretary - IEEE-ISTO Printer Working Group
Co-Chair - IEEE-ISTO PWG Internet Printing Protocol WG
IETF Designated Expert - IPP & Printer MIB
Blue Roof Music / High North Inc
http://sites.google.com/site/blueroofmusic
http://sites.google.com/site/highnorthinc
mailto: [email-masked]
PO Box 221  Grand Marais, MI 49839  906-494-2434

---

From: Michael Sweet via ipp <[email-masked]>
Date: Fri, 15 Mar 2019 20:33:31 -0400

Ira,

I've posted updated minutes with the correction.

Also, the three attributes were "job-retain-until (type2 keyword | name(MAX)", "job-retain-until-interval (integer(0:MAX))", and "job-retain-until-time (dateTime)".

The -time suffix matches what we have for job-hold-until-time, job-delay-output-until-time, printer-current-time, etc. dateTime attributes, although we also have time-at-xxx and notify-lease-expiration-time which are (integer) printer-up-time values and date-time-at-xxx (dateTime) values...

The -interval suffix matches what is used when an attribute represents a time interval (e.g. document-data-get-interval, notify-get-interval, notify-time-interval, retry-interval, restart-interval) although we could also use -duration (e.g. notify-lease-duration).

> On Mar 15, 2019, at 2:20 PM, Ira McDonald via ipp <[email-masked]> wrote:
> 
> Hi,
> 
> As already noted in a later thread by Smith, there is a significant typo in these minutes:
> 
> • consensus was to keep "job-retain-until" (type2 keyword) and "job-retain-until-time" (integer) and NOT implement "job-retain-until-date" (dateTime)
> 
> There was a strong consensus against "job-xxx-until-date" attributes - they're clumsy