Subject: [IPP] RFC: IPP Document Object update version

From: Michael Sweet via ipp <[email-masked]>
Date: Fri, 15 Mar 2019 09:56:56 -0400

All,

In reviewing the minutes from yesterday's IPP concall I saw the following comments regarding the IPP Document Object v1.1 errata update:

• Prototyping going on

  I believe this is actually complete in ippserver, and there are of course a LOT of IPP (PDF) printers with document object support already, so I think any prototyping requirement has been met. (not that there is one for an errata update)

• Need to add "Deprecated" and "Obsolete" definitions

  These will be included in the next (stable) update, per our prior discussions.

• Will be PWG Call for Objections because it is a 1.1 (errata update) but should it be a 2.0?

  Given that there is NOTHING NEW in this spec, just a general cleanup and a relaxation of the multiple document support requirement, I see no reason to make this 2.0. Any 1.0 compliant implementation is also 1.1 compliant.

_________________________________________________________
Michael Sweet, Senior Printing System Engineer

_______________________________________________
ipp mailing list
[email-masked]
https://www.pwg.org/mailman/listinfo/ipp

---

From: Ira McDonald via ipp <[email-masked]>
Date: Fri, 15 Mar 2019 10:41:25 -0400

Hi Mike,

I agree with your rationale that Document Object should be v1.1 (no new
content).

For Job Extensions (because of adding three operations, especially), I
think and
the folks yesterday on IPP WG call agreed that v2.0 was preferable.

Cheers,
- Ira

Ira McDonald (Musician / Software Architect)
Co-Chair - TCG Trusted Mobility Solutions WG
Co-Chair - TCG Metadata Access Protocol SG
Chair - Linux Foundation Open Printing WG
Secretary - IEEE-ISTO Printer Working Group
Co-Chair - IEEE-ISTO PWG Internet Printing Protocol WG
IETF Designated Expert - IPP & Printer MIB
Blue Roof Music / High North Inc
http://sites.google.com/site/blueroofmusic
http://sites.google.com/site/highnorthinc
mailto: [email-masked]
PO Box 221  Grand Marais, MI 49839  906-494-2434

On Fri, Mar 15, 2019 at 9:57 AM Michael Sweet via ipp <[email-masked]> wrote:

> All,
>
> In reviewing the minutes from yesterday's IPP concall I saw the following
> comments regarding the IPP Document Object v1.1 errata update:
>
> • Prototyping going on
>
>   I believe this is actually complete in ippserver, and there are of
> course a LOT of IPP (PDF) printers with document object support already, so
> I think any prototyping requirement has been met. (not that there is one
> for an errata update)
>
>   Given that there is NOTHING NEW in this spec, just a general cleanup and
> a relaxation of the multiple document support requirement, I see no reason
> to make this 2.0. Any 1.0 compliant implementation is also 1.1 compliant.
>

---

From: Michael Sweet via ipp <[email-masked]>
Date: Fri, 15 Mar 2019 11:01:23 -0400

Ira,

> On Mar 15, 2019, at 10:41 AM, Ira McDonald via ipp <[email-masked]> wrote:
> 
> Hi Mike,
> 
> I agree with your rationale that Document Object should be v1.1 (no new content).
> 
> For Job Extensions (because of adding three operations, especially), I think and

I'm in the process of posting JOBEXT 2.0 now; will summarize the conformance changes from 1.0...

> http://sites.google.com/site/blueroofmusic <http://sites.google.com/site/blueroofmusic>
> http://sites.google.com/site/highnorthinc <http://sites.google.com/site/highnorthinc>
> mailto: [email-masked] <mailto:[email-masked]>
> On Fri, Mar 15, 2019 at 9:57 AM Michael Sweet via ipp <[email-masked] <mailto:[email-masked]>> wrote:
> All,
> 
> [email-masked] <mailto:[email-masked]>
> https://www.pwg.org/mailman/listinfo/ipp <https://www.pwg.org/mailman/listinfo/ipp>