Subject: [IPP] RFC: job-history-interval-configured/-supported Printer Description attributes

From: Michael Sweet via ipp <[email-masked]>
Date: Thu, 07 Mar 2019 12:06:33 -0500

All,

For your consideration, the following two Printer Description attributes would allow a Client to discover (and potentially the administrator to configure since the values are settable) how long a Job will stay in the history phase.

(I also considered "job-history-xxx" and "job-history-time-xxx" for the names; "interval" seemed the most consistent with other existing attributes, particularly with notifications)

--------

job-history-interval-configured (integer(0:MAX))

This Printer Description attribute specifies the minimum number of seconds that a Job will remain in the history phase of its lifecycle [STD92]. Printers SHOULD have a default configured value of at least 60 seconds to allow Clients to discover the disposition of any Jobs that have reached a terminating state.

This attribute MUST be supported if the "job-history-interval-supported" (section N.M.P) attribute is supported.

job-history-interval-supported (rangeOfInteger(0:MAX))

This Printer Description attribute specifies the range of values that are supported for the "job-history-interval-configured" Printer Description attribute.

This attribute MUST be supported if the "job-history-interval-configured" (section N.M.P) attribute is supported.

_________________________________________________________
Michael Sweet, Senior Printing System Engineer

_______________________________________________
ipp mailing list
[email-masked]
https://www.pwg.org/mailman/listinfo/ipp

---

From: Michael Sweet via ipp <[email-masked]>
Date: Thu, 07 Mar 2019 12:20:43 -0500

Oh, and as I was writing this up I thought of maybe the following as well (since IPP/1.1 is vague about what the history contains):

job-history-attributes-configured (1setOf keyword)

This Printer Description attribute lists the Job attributes that will be retained in the history phase of each Job. IPP/1.1 [STD92] specifies that at least the "job-id", "job-printer-uri", "job-state", and "job-state-reasons" attributes MUST be retained in the history phase.

This attribute MUST be supported if the "job-history-attributes-supported" (section N.M.P) attribute is supported.

job-history-attributes-supported (1setOf keyword)

This Printer Description attribute lists the Job attributes that can be retained in the history phase of each Job.

This attribute MUST be supported if the "job-history-attributes-configured" (section N.M.P) attribute is supported.

> On Mar 7, 2019, at 12:06 PM, Michael Sweet <[email-masked]> wrote:
> 
> All,
>

---

From: Ira McDonald via ipp <[email-masked]>
Date: Thu, 7 Mar 2019 12:23:35 -0500

Hi Mike,

Yes, to all three of these proposed attributes.

Cheers,
- Ira

Ira McDonald (Musician / Software Architect)
Co-Chair - TCG Trusted Mobility Solutions WG
Co-Chair - TCG Metadata Access Protocol SG
Chair - Linux Foundation Open Printing WG
Secretary - IEEE-ISTO Printer Working Group
Co-Chair - IEEE-ISTO PWG Internet Printing Protocol WG
IETF Designated Expert - IPP & Printer MIB
Blue Roof Music / High North Inc
http://sites.google.com/site/blueroofmusic
http://sites.google.com/site/highnorthinc
mailto: [email-masked]
PO Box 221  Grand Marais, MI 49839  906-494-2434

On Thu, Mar 7, 2019 at 12:21 PM Michael Sweet via ipp <[email-masked]> wrote:

> Oh, and as I was writing this up I thought of maybe the following as well
> (since IPP/1.1 is vague about what the history contains):
>
> This Printer Description attribute lists the Job attributes that will be
> retained in the history phase of each Job. IPP/1.1 [STD92] specifies that
> at least the "job-id", "job-printer-uri", "job-state", and
> "job-state-reasons" attributes MUST be retained in the history phase.
>
> This Printer Description attribute lists the Job attributes that can be
> retained in the history phase of each Job.
>
> This attribute MUST be supported if the
> "job-history-attributes-configured" (section N.M.P) attribute is supported.
>
>
> For your consideration, the following two Printer Description attributes
> would allow a Client to discover (and potentially the administrator to
> configure since the values are settable) how long a Job will stay in the
> history phase.
>
> (I also considered "job-history-xxx" and "job-history-time-xxx" for the
> names; "interval" seemed the most consistent with other existing
> attributes, particularly with notifications)
>
> --------
>
> This Printer Description attribute specifies the minimum number of seconds
> that a Job will remain in the history phase of its lifecycle [STD92].
> Printers SHOULD have a default configured value of at least 60 seconds to
> allow Clients to discover the disposition of any Jobs that have reached a
> terminating state.
>
> This Printer Description attribute specifies the range of values that are
> supported for the "job-history-interval-configured" Printer Description
> attribute.
>

---

From: "Kennedy, Smith \(Wireless & Standards Architect\) via ipp" <[email-masked]>
Date: Thu, 7 Mar 2019 17:37:30 +0000

+1 for all 3 of them.

To what spec do we want to add these? Job Extensions v1.1? Enterprise Printing Extensions? Or System Service?

> On Mar 7, 2019, at 10:23 AM, Ira McDonald via ipp <[email-masked]> wrote:
> 
> Hi Mike,
> 
> http://sites.google.com/site/blueroofmusic <https://protect-us.mimecast.com/s/N81mCn5XpXTLXommtJmdHU?domain=sites.google.com>
> http://sites.google.com/site/highnorthinc <https://protect-us.mimecast.com/s/qJHYCo2KqKhGDzvvuVMKHM?domain=sites.google.com>
> mailto: [email-masked] <mailto:[email-masked]>
> On Thu, Mar 7, 2019 at 12:21 PM Michael Sweet via ipp <[email-masked] <mailto:[email-masked]>> wrote:
>> On Mar 7, 2019, at 12:06 PM, Michael Sweet <[email-masked] <mailto:[email-masked]>> wrote:
>> 
>> All,
>> 
> [email-masked] <mailto:[email-masked]>
> https://www.pwg.org/mailman/listinfo/ipp <https://protect-us.mimecast.com/s/fxgUCmZ6o6hYpnWWIGXtnT?domain=pwg.org>
> [email-masked] <mailto:[email-masked]>
> https://protect-us.mimecast.com/s/fxgUCmZ6o6hYpnWWIGXtnT?domain=pwg.org <https://protect-us.mimecast.com/s/fxgUCmZ6o6hYpnWWIGXtnT?domain=pwg.org>

---

From: Ira McDonald via ipp <[email-masked]>
Date: Thu, 7 Mar 2019 12:39:14 -0500

Hi,

I hope Job Extensions, because I see them as filling holes in original
IPP/1.1.
All printers implement some Job History (perhaps pretty short-lived).

Cheers,
- Ira

On Thu, Mar 7, 2019 at 12:37 PM Kennedy, Smith (Wireless & Standards
Architect) <[email-masked]> wrote:

> <https://protect-us.mimecast.com/s/N81mCn5XpXTLXommtJmdHU?domain=sites.google.com>
> <https://protect-us.mimecast.com/s/qJHYCo2KqKhGDzvvuVMKHM?domain=sites.google.com>
>> "job-history-attributes-supported" (section N.M.P) attribute is supported.
>>
>>
>> This Printer Description attribute specifies the minimum number of
>> seconds that a Job will remain in the history phase of its lifecycle
>> [STD92]. Printers SHOULD have a default configured value of at least 60
>> seconds to allow Clients to discover the disposition of any Jobs that have
>> reached a terminating state.
>>
>> <https://protect-us.mimecast.com/s/fxgUCmZ6o6hYpnWWIGXtnT?domain=pwg.org>
>>
> https://protect-us.mimecast.com/s/fxgUCmZ6o6hYpnWWIGXtnT?domain=pwg.org
>
>
>

---

From: "Kennedy, Smith \(Wireless & Standards Architect\) via ipp" <[email-masked]>
Date: Thu, 7 Mar 2019 17:42:31 +0000

Defining them in Job Extensions v1.1 seems to be what Mike is recommending in the other thread about JPS2v2.

Smith

> On Mar 7, 2019, at 10:39 AM, Ira McDonald <[email-masked]> wrote:
> 
> Hi,
> 
> I hope Job Extensions, because I see them as filling holes in original IPP/1.1.
> http://sites.google.com/site/blueroofmusic <https://protect-us.mimecast.com/s/Dp6ZCM8gpgI8x06NUwZ_0u?domain=sites.google.com>
> http://sites.google.com/site/highnorthinc <https://protect-us.mimecast.com/s/VYZaCNkjqjfxVrM4t4tksB?domain=sites.google.com>
> On Thu, Mar 7, 2019 at 12:37 PM Kennedy, Smith (Wireless & Standards Architect) <[email-masked] <mailto:[email-masked]>> wrote:
> +1 for all 3 of them.
> 
>> On Mar 7, 2019, at 10:23 AM, Ira McDonald via ipp <[email-masked] <mailto:[email-masked]>> wrote:
>> 
>> Hi Mike,
>> 
>> http://sites.google.com/site/blueroofmusic <https://protect-us.mimecast.com/s/Dp6ZCM8gpgI8x06NUwZ_0u?domain=sites.google.com>
>> http://sites.google.com/site/highnorthinc <https://protect-us.mimecast.com/s/VYZaCNkjqjfxVrM4t4tksB?domain=sites.google.com>
>> https://www.pwg.org/mailman/listinfo/ipp <https://protect-us.mimecast.com/s/DAB2COYkrkiX592WHk3W0z?domain=pwg.org>
>> https://protect-us.mimecast.com/s/fxgUCmZ6o6hYpnWWIGXtnT?domain=pwg.org <https://protect-us.mimecast.com/s/DAB2COYkrkiX592WHk3W0z?domain=pwg.org>

---

From: Uli Wehner via ipp <[email-masked]>
Date: Thu, 7 Mar 2019 17:47:45 +0000

Ira

Ours do keep jobs in history until they scroll of the screen if you will. Weeks even months. However if you send hundreds of 1 pagers, they drop off quickly. 60 seconds sounds like a good default for the print controller to keep track of them

Sent from my Sprint Samsung Galaxy S9.

-------- Original message --------
From: Ira McDonald via ipp <[email-masked]>
Date: 3/7/19 12:40 (GMT-05:00)
To: "Kennedy, Smith (Wireless & Standards Architect)" <[email-masked]>, Ira McDonald <[email-masked]>
Cc: PWG IPP Workgroup <[email-masked]>
Subject: Re: [IPP] RFC: job-history-interval-configured/-supported Printer Description attributes[EXTERNAL]

Hi,

Cheers,
- Ira

Ira McDonald (Musician / Software Architect)
Co-Chair - TCG Trusted Mobility Solutions WG
Co-Chair - TCG Metadata Access Protocol SG
Chair - Linux Foundation Open Printing WG
Secretary - IEEE-ISTO Printer Working Group
Co-Chair - IEEE-ISTO PWG Internet Printing Protocol WG
IETF Designated Expert - IPP & Printer MIB
Blue Roof Music / High North Inc
http://sites.google.com/site/blueroofmusic<https://urldefense.proofpoint.com/v2/url?u=http-3A__sites.google.com_site_blueroofmusic&d=DwMFaQ&c=5hYF0Zu0Yz-C6S-kaHDItw&r=Kf2OsKTEH35gSgu0U6HqdHzbU1TrLWRQF9AyGiFJjds&m=e2tqnp3aJGDafO-1nP5OPpfwPsISxe53b0p2ecvA-Ko&s=igStktYa1Hv1zAiOP2lB05sJPaNalVV_ROXWZlWnRNQ&e=>
http://sites.google.com/site/highnorthinc<https://urldefense.proofpoint.com/v2/url?u=http-3A__sites.google.com_site_highnorthinc&d=DwMFaQ&c=5hYF0Zu0Yz-C6S-kaHDItw&r=Kf2OsKTEH35gSgu0U6HqdHzbU1TrLWRQF9AyGiFJjds&m=e2tqnp3aJGDafO-1nP5OPpfwPsISxe53b0p2ecvA-Ko&s=l2svqSYmKuL1k6HqXBlgf1i6W1bc22-N1NcKkNyfRQE&e=>
mailto: [email-masked]<mailto:[email-masked]>
PO Box 221  Grand Marais, MI 49839  906-494-2434

On Thu, Mar 7, 2019 at 12:37 PM Kennedy, Smith (Wireless & Standards Architect) <[email-masked]<mailto:[email-masked]>> wrote:
+1 for all 3 of them.

On Mar 7, 2019, at 10:23 AM, Ira McDonald via ipp <[email-masked]<mailto:[email-masked]>> wrote:

Hi Mike,

Cheers,
- Ira

Ira McDonald (Musician / Software Architect)
Co-Chair - TCG Trusted Mobility Solutions WG
Co-Chair - TCG Metadata Access Protocol SG
Chair - Linux Foundation Open Printing WG
Secretary - IEEE-ISTO Printer Working Group
Co-Chair - IEEE-ISTO PWG Internet Printing Protocol WG
IETF Designated Expert - IPP & Printer MIB
Blue Roof Music / High North Inc
http://sites.google.com/site/blueroofmusic<https://urldefense.proofpoint.com/v2/url?u=https-3A__protect-2Dus.mimecast.com_s_N81mCn5XpXTLXommtJmdHU-3Fdomain-3Dsites.google.com&d=DwMFaQ&c=5hYF0Zu0Yz-C6S-kaHDItw&r=Kf2OsKTEH35gSgu0U6HqdHzbU1TrLWRQF9AyGiFJjds&m=e2tqnp3aJGDafO-1nP5OPpfwPsISxe53b0p2ecvA-Ko&s=4Jfgc7czRtsdAdOryrimO4MIU8OEhCEWpTWv63zDr-I&e=>
http://sites.google.com/site/highnorthinc<https://urldefense.proofpoint.com/v2/url?u=https-3A__protect-2Dus.mimecast.com_s_qJHYCo2KqKhGDzvvuVMKHM-3Fdomain-3Dsites.google.com&d=DwMFaQ&c=5hYF0Zu0Yz-C6S-kaHDItw&r=Kf2OsKTEH35gSgu0U6HqdHzbU1TrLWRQF9AyGiFJjds&m=e2tqnp3aJGDafO-1nP5OPpfwPsISxe53b0p2ecvA-Ko&s=OV_LgvxrMut2Yb7nEJ_VBunzsAU_CrOqIlLente4MJc&e=>
mailto: [email-masked]<mailto:[email-masked]>
PO Box 221  Grand Marais, MI 49839  906-494-2434

On Thu, Mar 7, 2019 at 12:21 PM Michael Sweet via ipp <[email-masked]<mailto:[email-masked]>> wrote:
Oh, and as I was writing this up I thought of maybe the following as well (since IPP/1.1 is vague about what the history contains):

On Mar 7, 2019, at 12:06 PM, Michael Sweet <[email-masked]<mailto:[email-masked]>> wrote:

All,

--------

_______________________________________________
ipp mailing list
[email-masked]<mailto:[email-masked]>
https://www.pwg.org/mailman/listinfo/ipp<https://urldefense.proofpoint.com/v2/url?u=https-3A__protect-2Dus.mimecast.com_s_fxgUCmZ6o6hYpnWWIGXtnT-3Fdomain-3Dpwg.org&d=DwMFaQ&c=5hYF0Zu0Yz-C6S-kaHDItw&r=Kf2OsKTEH35gSgu0U6HqdHzbU1TrLWRQF9AyGiFJjds&m=e2tqnp3aJGDafO-1nP5OPpfwPsISxe53b0p2ecvA-Ko&s=HO0pZzrPcR6FnMxXXhGBiq7Uctp5_5LXZQVvUdidVO0&e=>
_______________________________________________
ipp mailing list
[email-masked]<mailto:[email-masked]>
https://protect-us.mimecast.com/s/fxgUCmZ6o6hYpnWWIGXtnT?domain=pwg.org<https://urldefense.proofpoint.com/v2/url?u=https-3A__protect-2Dus.mimecast.com_s_fxgUCmZ6o6hYpnWWIGXtnT-3Fdomain-3Dpwg.org&d=DwMFaQ&c=5hYF0Zu0Yz-C6S-kaHDItw&r=Kf2OsKTEH35gSgu0U6HqdHzbU1TrLWRQF9AyGiFJjds&m=e2tqnp3aJGDafO-1nP5OPpfwPsISxe53b0p2ecvA-Ko&s=HO0pZzrPcR6FnMxXXhGBiq7Uctp5_5LXZQVvUdidVO0&e=>