Subject: [IPP] W3C Approves WebAuthn

From: Michael Sweet via ipp <[email-masked]>
Date: Mon, 04 Mar 2019 12:43:42 -0500

All,

Haven't had a chance to see if this could at all be used with IPP, but WebAuthn is a new standard for authenticating without traditional passwords:

    https://www.w3.org/2019/03/pressrelease-webauthn-rec.html
    https://www.w3.org/TR/webauthn/

See also the related FIDO2 project information:

    https://fidoalliance.org/fido2/

_________________________________________________________
Michael Sweet, Senior Printing System Engineer

_______________________________________________
ipp mailing list
[email-masked]
https://www.pwg.org/mailman/listinfo/ipp

---

From: "Kennedy, Smith \(Wireless & Standards Architect\) via ipp" <[email-masked]>
Date: Thu, 14 Mar 2019 19:25:36 +0000

Hi Mike,

I've been meaning to ask about this in the context of IPP Authentication Methods. Should we update IPP Authentication Methods with this before finishing it off? Or is WebAuthn outside the scope of IPP?

Smith

> On Mar 4, 2019, at 10:43 AM, Michael Sweet via ipp <[email-masked]> wrote:
> 
> All,
> 
> https://www.w3.org/2019/03/pressrelease-webauthn-rec.html <https://protect-us.mimecast.com/s/LcjZCzp5G5IqglolToThye?domain=w3.org>
> https://www.w3.org/TR/webauthn/ <https://protect-us.mimecast.com/s/faeWCADo5oTO6yAycMq1Sq?domain=w3.org>
> 
> https://fidoalliance.org/fido2/ <https://protect-us.mimecast.com/s/CSHbCBBp5puK6Q5Quv-emT?domain=fidoalliance.org>
> 
> https://www.pwg.org/mailman/listinfo/ipp <https://protect-us.mimecast.com/s/YZPICDkr5rfAv2l2sBp-VO?domain=pwg.org>

---

From: Michael Sweet via ipp <[email-masked]>
Date: Thu, 14 Mar 2019 16:54:34 -0400

Smith,

This appears to be outside the scope, at least for now.  I could see it being combined with OAuth 2 (like SAML), but until we can see where it goes I wouldn't want to put that in a best practices document...

> On Mar 14, 2019, at 3:25 PM, Kennedy, Smith (Wireless & Standards Architect) via ipp <[email-masked]> wrote:
> 
> Hi Mike,
>

---

From: "Kennedy, Smith \(Wireless & Standards Architect\) via ipp" <[email-masked]>
Date: Thu, 14 Mar 2019 20:56:31 +0000

Good! 😊 So we can move forward instead of waiting.

Smith

> On Mar 14, 2019, at 2:54 PM, Michael Sweet <[email-masked]> wrote:
> 
> Smith,
> 
> >> https://www.w3.org/2019/03/pressrelease-webauthn-rec.html <https://protect-us.mimecast.com/s/kTdWCBBp5puk3RR2cWWyTt?domain=w3.org>
> >> https://www.w3.org/TR/webauthn/ <https://protect-us.mimecast.com/s/TzPaCDkr5rfWQJJGskokM4?domain=w3.org>
> >>
> >> https://fidoalliance.org/fido2/ <https://protect-us.mimecast.com/s/QODRCERv5vszK00XCB6KGD?domain=fidoalliance.org>
> >>
> >> https://www.pwg.org/mailman/listinfo/ipp <https://protect-us.mimecast.com/s/R8bkCG6xjxhPoOOXUYVxsq?domain=pwg.org>
> >
> > https://www.pwg.org/mailman/listinfo/ipp <https://protect-us.mimecast.com/s/R8bkCG6xjxhPoOOXUYVxsq?domain=pwg.org>
>