Subject: [IPP] RFC: DEPRECATED and OBSOLETED definitions

From: Michael Sweet via ipp <[email-masked]>
Date: Wed, 06 Mar 2019 14:27:00 -0500

All,

Here is my proposed text for deprecations and obsoletions in the conformance section of new IPP specifications:

The term DEPRECATED is used for previously defined and approved items that SHOULD NOT be used or implemented. The term OBSOLETED is used for previously defined and approved items that MUST NOT be used or implemented.

Thoughts?

_________________________________________________________
Michael Sweet, Senior Printing System Engineer

_______________________________________________
ipp mailing list
[email-masked]
https://www.pwg.org/mailman/listinfo/ipp

---

From: Ira McDonald via ipp <[email-masked]>
Date: Thu, 7 Mar 2019 16:45:12 -0500

Hi Mike,

+1.

Except that we want to be able to (and have already) marked *operations*
(and not just attributes) as DEPRECATED.

Cheers,
- Ira

Ira McDonald (Musician / Software Architect)
Co-Chair - TCG Trusted Mobility Solutions WG
Co-Chair - TCG Metadata Access Protocol SG
Chair - Linux Foundation Open Printing WG
Secretary - IEEE-ISTO Printer Working Group
Co-Chair - IEEE-ISTO PWG Internet Printing Protocol WG
IETF Designated Expert - IPP & Printer MIB
Blue Roof Music / High North Inc
http://sites.google.com/site/blueroofmusic
http://sites.google.com/site/highnorthinc
mailto: [email-masked]
PO Box 221  Grand Marais, MI 49839  906-494-2434

On Wed, Mar 6, 2019 at 2:27 PM Michael Sweet via ipp <[email-masked]> wrote:

> All,
>
> Here is my proposed text for deprecations and obsoletions in the
> conformance section of new IPP specifications:
>
> The term DEPRECATED is used for previously defined and approved
> items that SHOULD NOT be used or implemented. The term OBSOLETED is used
> for previously defined and approved items that MUST NOT be used or
> implemented.
>
>
> Thoughts?
>

---

From: Ira McDonald via ipp <[email-masked]>
Date: Thu, 7 Mar 2019 16:47:07 -0500

Hi,

That last may have been a dumb response.

But I don't like the term "items".  Should we enumerate operations,
features,
attributes, and values?

Cheers,
- Ira

---

From: Michael Sweet via ipp <[email-masked]>
Date: Thu, 07 Mar 2019 16:50:41 -0500

Ira,

> On Mar 7, 2019, at 4:47 PM, Ira McDonald via ipp <[email-masked]> wrote:
> 
> Hi,
> 
> But I don't like the term "items".  Should we enumerate operations, features, 
> attributes, and values?

I originally enumerated things (like we do in the IPP registry process document), which is "operations, attributes, attribute syntaxes, values, and status codes", but that seemed like too much so I opted to shorten things to "items" since it covers any usage.

---

From: Ira McDonald via ipp <[email-masked]>
Date: Thu, 7 Mar 2019 16:52:48 -0500

Hi Mike,

In ITU-T specs, I've seen "protocol elements" used to avoid ultimately vague
words like "items" (which sounds like the stock of a convenience store...).

Cheers,
- Ira

On Thu, Mar 7, 2019 at 4:50 PM Michael Sweet <[email-masked]> wrote:

> I originally enumerated things (like we do in the IPP registry process
> document), which is "operations, attributes, attribute syntaxes, values,
> and status codes", but that seemed like too much so I opted to shorten
> things to "items" since it covers any usage.
>