Subject: [IPP] RFC: IPP Job Extensions v1.1 or v2.0?

From: Michael Sweet via ipp <[email-masked]>
Date: Thu, 07 Mar 2019 12:51:33 -0500

All,

I mentioned this in a previous thread, but wanted to bring this up in a new thread to discuss separately.

We are in the process of updating PWG 5100.7-2003: IPP Job Extensions (JOBEXT), and based on previous discussions have decided to incorporate parts of PWG 5100.11-2010: IPP Job and Printer Extensions - Set 2 (JPS2) that have more general usefulness, with the remaining enterprise functionality going into a new IPP Enterprise Printing Extensions specification to replace 5100.11 (which will be obsoleted, like we did for the original overrides spec many years ago).

Many of the attributes coming from 5100.11 are OPTIONAL, so adding them to Job Extensions v1.1 poses no problem for our defined standards errata process - no change in conformance for the original 5100.7 so the 5100.7-2019 update will be backwards-compatible with any implementation conformaing to 5100.7-2003.

However, JPS2 also defines four new REQUIRED operations and a REQUIRED operation attribute (job-ids). Keeping these in a 5100.11 errata update would pose no problem, but PWG Process/3.0 says nothing about cross-spec errata updates.

Using a conservative interpretation of the approved process, we would need to change the major version number of the Job Extensions specification to increase the conformance requirements, and then use the "long" process (verification of prototyping, PWG Last Call, and PWG Formal Vote) instead of the "short" process (PWG Call for Objections).

An alternative is to make these operations RECOMMENDED and job-ids conditionally required - then there is no conformance increase and we can use the short process for an errata update.  Since IPP Everywhere already makes most of these operations REQUIRED already, the practical reality is that they will be required attributes.

Thoughts?

_________________________________________________________
Michael Sweet, Senior Printing System Engineer

_______________________________________________
ipp mailing list
[email-masked]
https://www.pwg.org/mailman/listinfo/ipp

---

From: Ira McDonald via ipp <[email-masked]>
Date: Thu, 7 Mar 2019 16:58:53 -0500

Hi Mike,

I actually favor v2.0, with a firm hand making attributes filling
holes in IPP/1.1 (retention, history, etc.) as REQUIRED and
as many as possible remaining attributes as RECOMMENDED.

I hope we stop using OPTIONAL in IPP specs and reserve it
for "experimental" or "narrow-use" new stuff in Registrations.

Cheers,
- Ira

Ira McDonald (Musician / Software Architect)
Co-Chair - TCG Trusted Mobility Solutions WG
Co-Chair - TCG Metadata Access Protocol SG
Chair - Linux Foundation Open Printing WG
Secretary - IEEE-ISTO Printer Working Group
Co-Chair - IEEE-ISTO PWG Internet Printing Protocol WG
IETF Designated Expert - IPP & Printer MIB
Blue Roof Music / High North Inc
http://sites.google.com/site/blueroofmusic
http://sites.google.com/site/highnorthinc
mailto: [email-masked]
PO Box 221  Grand Marais, MI 49839  906-494-2434

On Thu, Mar 7, 2019 at 12:51 PM Michael Sweet via ipp <[email-masked]> wrote:

> We are in the process of updating PWG 5100.7-2003: IPP Job Extensions
> (JOBEXT), and based on previous discussions have decided to incorporate
> parts of PWG 5100.11-2010: IPP Job and Printer Extensions - Set 2 (JPS2)
> that have more general usefulness, with the remaining enterprise
> functionality going into a new IPP Enterprise Printing Extensions
> specification to replace 5100.11 (which will be obsoleted, like we did for
> the original overrides spec many years ago).
>
> Many of the attributes coming from 5100.11 are OPTIONAL, so adding them to
> Job Extensions v1.1 poses no problem for our defined standards errata
> process - no change in conformance for the original 5100.7 so the
> 5100.7-2019 update will be backwards-compatible with any implementation
> conformaing to 5100.7-2003.
>
> However, JPS2 also defines four new REQUIRED operations and a REQUIRED
> operation attribute (job-ids). Keeping these in a 5100.11 errata update
> would pose no problem, but PWG Process/3.0 says nothing about cross-spec
> errata updates.
>
> Using a conservative interpretation of the approved process, we would need
> to change the major version number of the Job Extensions specification to
> increase the conformance requirements, and then use the "long" process
> (verification of prototyping, PWG Last Call, and PWG Formal Vote) instead
> of the "short" process (PWG Call for Objections).
>
> An alternative is to make these operations RECOMMENDED and job-ids
> conditionally required - then there is no conformance increase and we can
> use the short process for an errata update.  Since IPP Everywhere already
> makes most of these operations REQUIRED already, the practical reality is
> that they will be required attributes.
>
> Thoughts?
>