Subject: Re: [IPP] Updated PWG Message Catalog Help Extensions (HELPME) draft posted for review

From: "Kennedy, Smith \(Wireless & Standards Architect\) via ipp" <[email-masked]>
Date: Wed, 3 Jul 2019 18:41:22 +0000

Greetings,

In the review from June 27, we discussed the plusses and minuses of moving this from a "Best Practice" document to a specification. That would affect the tone and intent of the Design Requirements and the normative language. The consensus was that PWG Message Catalog Help Extensions (HELPME) ought to be a specification rather than a Best Practice document.

Any feedback for or against changing PWG Message Catalog Help Extensions (HELPME) to a specification?

Smith

/**
    Smith Kennedy
    HP Inc.
*/

> On May 28, 2019, at 3:45 PM, Kennedy, Smith (Wireless & Standards Architect) via ipp <[email-masked]> wrote:
> 
> Signed PGP part
> Greetings,
> 
> I've posted a new draft of PWG Message Catalog Help Extensions (HELPME) to the PWG FTP site here:
> 
>    https://ftp.pwg.org/pub/pwg/ipp/wd/wd-ipphelpme-20190528.docx <https://protect-us.mimecast.com/s/frI0CERv5vs3WAl4liw0TnC?domain=ftp.pwg.org>
>    https://ftp.pwg.org/pub/pwg/ipp/wd/wd-ipphelpme-20190528.pdf <https://protect-us.mimecast.com/s/cIxyCG6xjxh1JyB3BHp7cjO?domain=ftp.pwg.org>
>    https://ftp.pwg.org/pub/pwg/ipp/wd/wd-ipphelpme-20190528-rev.docx <https://protect-us.mimecast.com/s/5iujCJ6AmAhq84B9BtLCPYh?domain=ftp.pwg.org>
>    https://ftp.pwg.org/pub/pwg/ipp/wd/wd-ipphelpme-20190528-rev.pdf <https://protect-us.mimecast.com/s/elGCCKrBnBF2qAD7DTp5to9?domain=ftp.pwg.org>
> 
> I wasn't sure what to say about using "//" as the start of an absolute URL, but other than that all feedback from the April 25 review was addressed.
> 
> Cheers!
> 
> Smith
> 
> /**
>     Smith Kennedy
>     HP Inc.
> */
> 
> 
> 

_______________________________________________
ipp mailing list
[email-masked]
https://www.pwg.org/mailman/listinfo/ipp

---

From: Michael Sweet via ipp <[email-masked]>
Date: Wed, 3 Jul 2019 15:09:25 -0400

FWIW, if we are talking about including this in a spec, then let's just do an errata update of JPS3 with these extensions included.  Then we can update the other JPS3 issues and have all of our core documents for IPP Everywhere up-to-date...

> On Jul 3, 2019, at 2:41 PM, Kennedy, Smith (Wireless & Standards Architect) via ipp <[email-masked]> wrote:
> 
> Greetings,
> 
>>    https://ftp.pwg.org/pub/pwg/ipp/wd/wd-ipphelpme-20190528.docx 
>>    https://ftp.pwg.org/pub/pwg/ipp/wd/wd-ipphelpme-20190528.pdf 
>>    https://ftp.pwg.org/pub/pwg/ipp/wd/wd-ipphelpme-20190528-rev.docx
>>    https://ftp.pwg.org/pub/pwg/ipp/wd/wd-ipphelpme-20190528-rev.pdf 
>> 

________________________
Michael Sweet

---

From: "Kennedy, Smith \(Wireless & Standards Architect\) via ipp" <[email-masked]>
Date: Wed, 3 Jul 2019 21:16:43 +0000

I like that idea, Mike! As you probably noticed, I posted an update to the “help me“ white paper a few minutes ago. I can also post a 5100.13 errata draft update to review as an alternative.

Cheers,
Smith
---
Smith Kennedy
[email-masked]<mailto:[email-masked]>

On Jul 3, 2019, at 1:09 PM, Michael Sweet <[email-masked]<mailto:[email-masked]>> wrote:

> On Jul 3, 2019, at 2:41 PM, Kennedy, Smith (Wireless & Standards Architect) via ipp <[email-masked]<mailto:[email-masked]>> wrote:
>
> Greetings,
>
>> On May 28, 2019, at 3:45 PM, Kennedy, Smith (Wireless & Standards Architect) via ipp <[email-masked]<mailto:[email-masked]>> wrote:
>>
>> Signed PGP part
>> Greetings,
>>
>> https://ftp.pwg.org/pub/pwg/ipp/wd/wd-ipphelpme-20190528.docx<https://ftp.pwg.org/pub/pwg/ipp/wd/wd-ipphelpme-20190528.docx>
>> https://ftp.pwg.org/pub/pwg/ipp/wd/wd-ipphelpme-20190528.pdf<https://ftp.pwg.org/pub/pwg/ipp/wd/wd-ipphelpme-20190528.pdf>
>> https://ftp.pwg.org/pub/pwg/ipp/wd/wd-ipphelpme-20190528-rev.docx<https://ftp.pwg.org/pub/pwg/ipp/wd/wd-ipphelpme-20190528-rev.docx>
>> https://ftp.pwg.org/pub/pwg/ipp/wd/wd-ipphelpme-20190528-rev.pdf<https://ftp.pwg.org/pub/pwg/ipp/wd/wd-ipphelpme-20190528-rev.pdf>
>>
> [email-masked]<mailto:[email-masked]>
> https://www.pwg.org/mailman/listinfo/ipp<https://www.pwg.org/mailman/listinfo/ipp>

________________________
Michael Sweet

---

From: Michael Sweet via ipp <[email-masked]>
Date: Wed, 3 Jul 2019 17:24:44 -0400

Smith,

If we go the errata path, then posting an initial JPS3 draft is my preference.

> On Jul 3, 2019, at 5:16 PM, Kennedy, Smith (Wireless & Standards Architect) via ipp <[email-masked]> wrote:
> 
> [email-masked]
> On Jul 3, 2019, at 1:09 PM, Michael Sweet <[email-masked]> wrote:
> 

________________________
Michael Sweet