Subject: [IPP] Adding a section 3.5 "Design Requirements" to IPP Authentication Methods

From: "Kennedy, Smith \(Wireless & Standards Architect\) via ipp" <[email-masked]>
Date: Mon, 1 Jul 2019 19:20:00 +0000

Greetings,

From our LCRC review of IPP Authentication Methods, it was pointed out in the review that the document was lacking a "Design Requirements" subsection to section 3. We decided to post a draft here on the reflector, and once consensus was reached, to add that to the final draft to be used in the PWG Formal Vote of Approval.

3.5 Design Requirements

The design requirements for this IPP Authentication Methods Best Practice document are:

1. Illustrate how each authentication method currently defined for IPP integrates into IPP interaction flows;
2. Identify and describe points to be considered in implementing Client or Printer support for authentication in general, including factors that influence user experience as well as protocol technical concerns.

Thoughts?

Smith

/**
    Smith Kennedy
    HP Inc.
*/

_______________________________________________
ipp mailing list
[email-masked]
https://www.pwg.org/mailman/listinfo/ipp

---

From: Michael Sweet via ipp <[email-masked]>
Date: Mon, 1 Jul 2019 20:49:53 -0400

Smith,

Quick feedback:

- End initial sentence with "are to:" (add "to")?
- Item 1: "currently defined for IPP" is awkward
- Add "and" at the end of item 1.
- Item 2: "Describe implementation considerations for authentication ..." (identification has already happened, you are describing the items that were identified during the development of the document)
- Item 2: "protocol technical concerns" should read "technical protocol concerns"

That would make it:

3.5 Design Requirements

The design requirements for this IPP Authentication Methods Best Practice document are to:

1. Illustrate how each authentication method integrates into IPP interaction flows; and
2. Describe implementation considerations for authentication in general, including factors that influence user experience and technical protocol concerns.

> On Jul 1, 2019, at 3:20 PM, Kennedy, Smith (Wireless & Standards Architect) via ipp <[email-masked]> wrote:
> 
> Greetings,
> 

________________________
Michael Sweet

---

From: "Kennedy, Smith \(Wireless & Standards Architect\) via ipp" <[email-masked]>
Date: Tue, 2 Jul 2019 12:20:42 +0000

I like it!

Unless there are any other suggestions, I'm going to run with that, and post an updated document later this morning.

Smith

> On Jul 1, 2019, at 6:49 PM, Michael Sweet <[email-masked]> wrote:
> 
> Smith,
> 
> Quick feedback:
> 
>> On Jul 1, 2019, at 3:20 PM, Kennedy, Smith (Wireless & Standards Architect) via ipp <[email-masked] <mailto:[email-masked]>> wrote:
>> 
>> Greetings,
>> 
>> [email-masked] <mailto:[email-masked]>
>> https://www.pwg.org/mailman/listinfo/ipp <https://protect-us.mimecast.com/s/NaEyCmZ6o6hjkD2Y5HGAJTC?domain=pwg.org>
> 
> ________________________
> Michael Sweet

---

From: Ira McDonald via ipp <[email-masked]>
Date: Tue, 2 Jul 2019 09:38:06 -0400

Hi,

Looks fine to me with Mike's suggested edits.

Cheers,
- Ira

Ira McDonald (Musician / Software Architect)
Co-Chair - TCG Trusted Mobility Solutions WG
Co-Chair - TCG Metadata Access Protocol SG
Chair - Linux Foundation Open Printing WG
Secretary - IEEE-ISTO Printer Working Group
Co-Chair - IEEE-ISTO PWG Internet Printing Protocol WG
IETF Designated Expert - IPP & Printer MIB
Blue Roof Music / High North Inc
http://sites.google.com/site/blueroofmusic
http://sites.google.com/site/highnorthinc
mailto: [email-masked]
PO Box 221  Grand Marais, MI 49839  906-494-2434

On Tue, Jul 2, 2019 at 8:21 AM Kennedy, Smith (Wireless & Standards
Architect) via ipp <[email-masked]> wrote:

> I like it!
>
> Unless there are any other suggestions, I'm going to run with that, and
> post an updated document later this morning.
>
> Smith
>
>
>
> - Item 2: "Describe implementation considerations for authentication ..."
> (identification has already happened, you are describing the items that
> were identified during the development of the document)
> 2. Describe implementation considerations for authentication in general,
> including factors that influence user experience and technical protocol
> concerns.
>
>
> From our LCRC review of IPP Authentication Methods, it was pointed out in
> the review that the document was lacking a "Design Requirements" subsection
> to section 3. We decided to post a draft here on the reflector, and once
> consensus was reached, to add that to the final draft to be used in the PWG
> Formal Vote of Approval.
>
>
> 3.5 Design Requirements
>
> 2. Identify and describe points to be considered in implementing Client or
> Printer support for authentication in general, including factors that
> influence user experience as well as protocol technical concerns.
>
>
> Thoughts?
>
> Smith
>
> /**
>    Smith Kennedy
>    HP Inc.
> */
>
> <https://protect-us.mimecast.com/s/NaEyCmZ6o6hjkD2Y5HGAJTC?domain=pwg.org>
>
>
> ________________________
> Michael Sweet
>
>