Subject: [IPP] RFC: max-page-ranges-supported (integer(1:MAX)) Printer Description Attribute

From: Michael Sweet via ipp <[email-masked]>
Date: Thu, 11 Jul 2019 11:49:55 -0400

All,

A recent issue on the Javascript IPP project (https://github.com/williamkapke/ipp/issues/72) highlights an issue with the "page-ranges (1setOf rangeOfInteger)" Job Template attribute, namely that a Client cannot discover how many ranges a printer supports.  The existing "page-ranges-supported (boolean)" attribute only specifies whether the "page-ranges" Job Template attribute is supported and not the maximum number of values a Printer supports.  Moreover, existing Printers seem to ignore extra values without reporting this in the unsupported attributes group of the Create-Job/Print-Job/Print-URI/Validate-Job response, so from the perspective of the Client nothing has gone wrong.

For other attributes we have a "max-xxx" Printer Description attribute that tells the Client how many values can be specified, e.g., "max-stitching-locations-supported" and "max-materials-col-supported".  I therefore propose to register a new "max-page-ranges-supported (integer(1:MAX))" Printer Description attribute that a Printer can return to specify the number of page ranges the Printer supports.

Here is the registration template:

Printer Description attributes:               Reference
------------------------------                ---------
max-page-ranges-supported (integer(1:MAX))    [IPP20190711]

________________________
Michael Sweet

_______________________________________________
ipp mailing list
[email-masked]
https://www.pwg.org/mailman/listinfo/ipp

---

From: Ira McDonald via ipp <[email-masked]>
Date: Thu, 11 Jul 2019 12:01:51 -0400

Hi Mike,

YES - a good and needed addition for fidelity to the Client's intent.

Cheers,
- Ira

Ira McDonald (Musician / Software Architect)
Co-Chair - TCG Trusted Mobility Solutions WG
Co-Chair - TCG Metadata Access Protocol SG
Chair - Linux Foundation Open Printing WG
Secretary - IEEE-ISTO Printer Working Group
Co-Chair - IEEE-ISTO PWG Internet Printing Protocol WG
IETF Designated Expert - IPP & Printer MIB
Blue Roof Music / High North Inc
http://sites.google.com/site/blueroofmusic
http://sites.google.com/site/highnorthinc
mailto: [email-masked]
PO Box 221  Grand Marais, MI 49839  906-494-2434

On Thu, Jul 11, 2019 at 11:50 AM Michael Sweet via ipp <[email-masked]> wrote:

> All,
>
> A recent issue on the Javascript IPP project (
> https://github.com/williamkapke/ipp/issues/72) highlights an issue with
> the "page-ranges (1setOf rangeOfInteger)" Job Template attribute, namely
> that a Client cannot discover how many ranges a printer supports.  The
> existing "page-ranges-supported (boolean)" attribute only specifies whether
> the "page-ranges" Job Template attribute is supported and not the maximum
> number of values a Printer supports.  Moreover, existing Printers seem to
> ignore extra values without reporting this in the unsupported attributes
> group of the Create-Job/Print-Job/Print-URI/Validate-Job response, so from
> the perspective of the Client nothing has gone wrong.
>
> For other attributes we have a "max-xxx" Printer Description attribute
> that tells the Client how many values can be specified, e.g.,
> "max-stitching-locations-supported" and "max-materials-col-supported".  I
> therefore propose to register a new "max-page-ranges-supported
> (integer(1:MAX))" Printer Description attribute that a Printer can return
> to specify the number of page ranges the Printer supports.
>

---

From: "Kennedy, Smith \(Wireless & Standards Architect\) via ipp" <[email-masked]>
Date: Thu, 11 Jul 2019 16:11:25 +0000

+1 !

Smith

/**
    Smith Kennedy
    HP Inc.
*/

> On Jul 11, 2019, at 9:49 AM, Michael Sweet via ipp <[email-masked]> wrote:
> 
> All,
> 
> A recent issue on the Javascript IPP project (https://github.com/williamkapke/ipp/issues/72 <https://protect-us.mimecast.com/s/QAYgC82A5Ah69A6zBI233N3?domain=github.com>) highlights an issue with the "page-ranges (1setOf rangeOfInteger)" Job Template attribute, namely that a Client cannot discover how many ranges a printer supports. The existing "page-ranges-supported (boolean)" attribute only specifies whether the "page-ranges" Job Template attribute is supported and not the maximum number of values a Printer supports. Moreover, existing Printers seem to ignore extra values without reporting this in the unsupported attributes group of the Create-Job/Print-Job/Print-URI/Validate-Job response, so from the perspective of the Client nothing has gone wrong.
> 
> https://www.pwg.org/mailman/listinfo/ipp <https://protect-us.mimecast.com/s/N0TkC9rB5BFk86kMrcOeSX5?domain=pwg.org>