Subject: [IPP] RFC: Registration Template for printer-firmware-xxx attributes

From: Michael Sweet via ipp <[email-masked]>
Date: Wed, 24 Jul 2019 16:54:34 -0400

All,

AirPrint has long defined several Printer Status attributes providing the current firmware names, patches, and versions associated with a Printer.  These are based on the corresponding PWG Hardcopy Device Health Assessment Attributes [PWG5110.1] and require that each of these attributes have the same cardinality (number of values), for example:

    printer-firmware-name           = 'IPP Server','PDF Interpreter'
    printer-firmware-string-version = '4.2', '2.0r6'
    printer-firmware-patches        = '',''
    printer-firmware-version        = <0402>,<020006>

Apple would like to officially register these in the IANA IPP Registry.  The template is as follows:

Printer Status attributes:                            Reference
------------------------------                        ---------
printer-firmware-name (1setOf name(MAX))              [APPLE20190724]
printer-firmware-patches (1setOf text(MAX))           [APPLE20190724]
printer-firmware-string-version (1setOf text(MAX))    [APPLE20190724]
printer-firmware-version (1setOf octetString(MAX))    [APPLE20190724]

________________________
Michael Sweet

_______________________________________________
ipp mailing list
[email-masked]
https://www.pwg.org/mailman/listinfo/ipp

---

From: Ira McDonald via ipp <[email-masked]>
Date: Thu, 25 Jul 2019 07:17:40 -0400

Hi,

+1

I'm happy to see this uptake of HCD Health Assessment Attributes
members into mainstream IPP.  I'm also happy because I already
wanted to talk about these in my new HCD Security Guidelines
draft.

Cheers,
- Ira
Ira McDonald (Musician / Software Architect)
Co-Chair - TCG Trusted Mobility Solutions WG
Co-Chair - TCG Metadata Access Protocol SG
Chair - Linux Foundation Open Printing WG
Secretary - IEEE-ISTO Printer Working Group
Co-Chair - IEEE-ISTO PWG Internet Printing Protocol WG
IETF Designated Expert - IPP & Printer MIB
Blue Roof Music / High North Inc
http://sites.google.com/site/blueroofmusic
http://sites.google.com/site/highnorthinc
mailto: [email-masked]
PO Box 221  Grand Marais, MI 49839  906-494-2434

On Wed, Jul 24, 2019 at 4:54 PM Michael Sweet via ipp <[email-masked]> wrote:

> All,
>
> AirPrint has long defined several Printer Status attributes providing the
> current firmware names, patches, and versions associated with a Printer.
> These are based on the corresponding PWG Hardcopy Device Health Assessment
> Attributes [PWG5110.1] and require that each of these attributes have the
> same cardinality (number of values), for example:
>

---

From: "Kennedy, Smith \(Wireless & Standards Architect\) via ipp" <[email-masked]>
Date: Thu, 25 Jul 2019 16:36:13 +0000

Thanks Mike!

Given the current stable of open drafts, do you see value in pulling those into one of the in-flight draft specs?

> On Jul 24, 2019, at 2:54 PM, Michael Sweet via ipp <[email-masked]> wrote:
> 
> All,
> 
> https://www.pwg.org/mailman/listinfo/ipp <https://protect-us.mimecast.com/s/B_WJC68y5yIr39NZ3H6yKwb?domain=pwg.org>

---

From: Michael Sweet via ipp <[email-masked]>
Date: Thu, 25 Jul 2019 12:57:15 -0400

Smith,

Aside from maybe EPX, I'm not sure these really fit.  And given that they are pulled directly from 5110.1 (which defines the semantics, etc.) and widely implemented (probably in 800M+ printers) I don't think there is a lot of value in holding them for a spec.

> On Jul 25, 2019, at 12:36 PM, Kennedy, Smith (Wireless & Standards Architect) <[email-masked]> wrote:
> 
> Thanks Mike!
> 

________________________
Michael Sweet