Subject: [IPP] Weird coomand IPP

From: Paul Santangelo via ipp <[email-masked]>
Date: Mon, 18 Nov 2019 18:58:58 -0500

Hi All:

Trying to understand an IPP transmission capture from an AS/400.

I got most of it down except for what seems to be a transmission size, 
but it doesn't correlate to anything I can identify.

If you see the image below, there is an FCC before the print job starts 
in job A and a 594 before print job B starts.

I am trying to identify what this means.  Its not the size of the file 
being transmitted, because other print job traces has the FCC and the 
size of the transmission is different.  I'm wondering if its more of a 
binary vs. ASCII transmission, but I am uncertain and can not find any 
documentation.

Any clarification here would be greatly appreciated, thank you.

-- 

Regards,

Paul Santangelo, CCNA, CNE
Escalation System Support (ESS) Integrator
Konica Minolta Business Solutions U.S.A., Inc.
101 Williams Drive Ramsey, NJ 07446
Office: 800-825-5664 <tel:800-825-5664>
Visit us: Count on Konica Minolta <http://www.countonkonicaminolta.com/>
<http://www.facebook.com/konicaminoltaus> 
<http://www.twitter.com/konicaminoltaus> 
<https://plus.google.com/u/0/101069343240482341568/about> 
<http://www.linkedin.com/companies/4830> 
<http://www.youtube.com/user/konicaminoltaus> 
<http://www.pinterest.com/konicaminoltaus>
Disclaimer 
<http://kmbs.konicaminolta.us/signature/KMBSUS-Disclaimer%20.png>

_______________________________________________
ipp mailing list
[email-masked]
https://www.pwg.org/mailman/listinfo/ipp

---

From: Mike Sweet via ipp <[email-masked]>
Date: Mon, 18 Nov 2019 19:16:46 -0500

Paul,

Those are the chunk lengths in hexadecimal.

Sent from my iPhone

> On Nov 18, 2019, at 6:59 PM, Paul Santangelo via ipp <[email-masked]> wrote:
> 
>  Hi All:
> 
> I got most of it down except for what seems to be a transmission size, but it doesn't correlate to anything I can identify.
> 
> If you see the image below, there is an FCC before the print job starts in job A and a 594 before print job B starts.
> 
> I am trying to identify what this means.  Its not the size of the file being transmitted, because other print job traces has the FCC and the size of the transmission is different.  I'm wondering if its more of a binary vs. ASCII transmission, but I am uncertain and can not find any documentation.
> 
> PAUL SANTANGELO, CCNA, CNE
> Office: 800-825-5664
> Visit us: Count on Konica Minolta
>            
> Disclaimer 
> 
>  
>

---

From: Paul Santangelo via ipp <[email-masked]>
Date: Mon, 18 Nov 2019 19:21:09 -0500

Perfect, Thank you.

Would you be able to point me in a place that actually states that?

I read the RFC's, well glazed over them quickly, I would like to know 
more about these.

Thank you.

Regards,

On 11/18/2019 7:16 PM, Mike Sweet wrote:
>> I got most of it down except for what seems to be a transmission 
>> size, but it doesn't correlate to anything I can identify.
>>
>> If you see the image below, there is an FCC before the print job 
>> starts in job A and a 594 before print job B starts.
>>
>> I am trying to identify what this means.  Its not the size of the 
>> file being transmitted, because other print job traces has the FCC 
>> and the size of the transmission is different.  I'm wondering if its 
>> more of a binary vs. ASCII transmission, but I am uncertain and can 
>> not find any documentation.
>>

---

From: Michael Sweet via ipp <[email-masked]>
Date: Mon, 18 Nov 2019 21:49:51 -0500

Paul,

That's a part of the HTTP specifications; basically look for the Transfer-Encoding information (I think in RFC 7230 or 7231) which takes the place of Content-Length for data whose length is not known ahead of time.

> On Nov 18, 2019, at 7:21 PM, Paul Santangelo <[email-masked]> wrote:
> 
> Perfect, Thank you.
> 
> I read the RFC's, well glazed over them quickly, I would like to know more about these.
> 
> Thank you.
> 
> Regards,
> 
> 
> 

________________________
Michael Sweet

---

From: Paul Santangelo via ipp <[email-masked]>
Date: Mon, 18 Nov 2019 21:51:34 -0500

Thank you Michael. 

Sent from my iPhone

> On Nov 18, 2019, at 9:49 PM, Michael Sweet <[email-masked]> wrote:
> 
> Paul,
>