Subject: Re: [IPP] RFC: Rename JPS3?

From: "Kennedy, Smith \(Wireless & IPP Standards\) via ipp" <[email-masked]>
Date: Mon, 4 Nov 2019 04:40:49 +0000

So if it is now named "IPP Driverless Printing Extensions (NODRIVER)", what version number, since it is a renamed / rebranded JPS3?

> On Oct 19, 2019, at 9:48 AM, Kennedy, Smith (Wireless & Standards Architect) via ipp <[email-masked]> wrote:
> 
> Signed PGP part
> +1. Will go with that.
> 
> Smith
> 
> /**
>     Smith Kennedy
>     HP Inc.
> */
> 
>> On Oct 19, 2019, at 1:18 AM, Michael Sweet <[email-masked] <mailto:[email-masked]>> wrote:
>> 
>> Ira,
>> 
>> NODRIVER works for me as well.
>> 
>> ____________________
>> Michael Sweet
>> 
>>> On Oct 18, 2019, at 4:52 PM, Ira McDonald <[email-masked] <mailto:[email-masked]>> wrote:
>>> 
>>> 
>>> Hi Mike,
>>> 
>>> See my reply to Uli just now.
>>> 
>>> For simplicity, how about "nodriver"?
>>> 
>>> I never visually parse things like "DRVR" and I doubt others do.
>>> 
>>> Cheers,
>>> - Ira
>>> 
>>> Ira McDonald (Musician / Software Architect)
>>> Co-Chair - TCG Trusted Mobility Solutions WG
>>> Co-Chair - TCG Metadata Access Protocol SG
>>> Chair - Linux Foundation Open Printing WG
>>> Secretary - IEEE-ISTO Printer Working Group
>>> Co-Chair - IEEE-ISTO PWG Internet Printing Protocol WG
>>> IETF Designated Expert - IPP & Printer MIB
>>> Blue Roof Music / High North Inc
>>> http://sites.google.com/site/blueroofmusic <http://sites.google.com/site/blueroofmusic>
>>> http://sites.google.com/site/highnorthinc <http://sites.google.com/site/highnorthinc>
>>> mailto: [email-masked] <mailto:[email-masked]>
>>> PO Box 221  Grand Marais, MI 49839  906-494-2434
>>> 
>>> 
>>> 
>>> On Fri, Oct 18, 2019 at 3:29 PM Michael Sweet <[email-masked] <mailto:[email-masked]>> wrote:
>>> Ira,
>>> 
>>> It doesn't roll off the tongue quite as easily as "NODRVR", and I think the "ipp" that comes before it should hint at the focus on printing, but I don't have a strong objection to it.
>>> 
>>> 
>>> > On Oct 18, 2019, at 2:47 PM, Ira McDonald <[email-masked] <mailto:[email-masked]>> wrote:
>>> >
>>> > Hi Mike,
>>> >
>>> > I hadn't thought about "DLP".
>>> >
>>> > How about "nodprt" (No Driver Printing) to preserve the printing aspect.
>>> >
>>> > Cheers,
>>> > - Ira
>>> >
>>> > Ira McDonald (Musician / Software Architect)
>>> > Co-Chair - TCG Trusted Mobility Solutions WG
>>> > Co-Chair - TCG Metadata Access Protocol SG
>>> > Chair - Linux Foundation Open Printing WG
>>> > Secretary - IEEE-ISTO Printer Working Group
>>> > Co-Chair - IEEE-ISTO PWG Internet Printing Protocol WG
>>> > IETF Designated Expert - IPP & Printer MIB
>>> > Blue Roof Music / High North Inc
>>> > http://sites.google.com/site/blueroofmusic <http://sites.google.com/site/blueroofmusic>
>>> > http://sites.google.com/site/highnorthinc <http://sites.google.com/site/highnorthinc>
>>> > mailto: [email-masked] <mailto:[email-masked]>
>>> > PO Box 221  Grand Marais, MI 49839  906-494-2434
>>> >
>>> >
>>> >
>>> > On Fri, Oct 18, 2019 at 1:22 PM Michael Sweet <[email-masked] <mailto:[email-masked]>> wrote:
>>> > Ira,
>>> >
>>> > How about "DRVRLS" or "NODRVR" as the acronym?  DLPX makes me think of a super version of DLP projectors... :)
>>> >
>>> >
>>> > > On Oct 18, 2019, at 10:52 AM, Ira McDonald <[email-masked] <mailto:[email-masked]>> wrote:
>>> > >
>>> > > Hi,
>>> > >
>>> > > To avoid the growing collection of three-letter acronyms ending in 'x',
>>> > > I suggest 'ippdlpx' (DLPX) to emphasize that it's about *not* needing
>>> > > special drivers.
>>> > >
>>> > > Cheers,
>>> > > - Ira
>>> > >
>>> > > Ira McDonald (Musician / Software Architect)
>>> > > Co-Chair - TCG Trusted Mobility Solutions WG
>>> > > Co-Chair - TCG Metadata Access Protocol SG
>>> > > Chair - Linux Foundation Open Printing WG
>>> > > Secretary - IEEE-ISTO Printer Working Group
>>> > > Co-Chair - IEEE-ISTO PWG Internet Printing Protocol WG
>>> > > IETF Designated Expert - IPP & Printer MIB
>>> > > Blue Roof Music / High North Inc
>>> > > http://sites.google.com/site/blueroofmusic <http://sites.google.com/site/blueroofmusic>
>>> > > http://sites.google.com/site/highnorthinc <http://sites.google.com/site/highnorthinc>
>>> > > mailto: [email-masked] <mailto:[email-masked]>
>>> > > PO Box 221  Grand Marais, MI 49839  906-494-2434
>>> > >
>>> > >
>>> > >
>>> > > On Fri, Oct 18, 2019 at 9:12 AM Kennedy, Smith (Wireless & Standards Architect) <[email-masked] <mailto:[email-masked]>> wrote:
>>> > > I'm fine with renaming it to be "Driverless Printing Extensions" - will change it in the next draft once the current one has been reviewed.
>>> > >
>>> > > Smith
>>> > >
>>> > > /**
>>> > >     Smith Kennedy
>>> > >     HP Inc.
>>> > > */
>>> > >
>>> > >> On Oct 15, 2019, at 8:18 AM, Ira McDonald via ipp <[email-masked] <mailto:[email-masked]>> wrote:
>>> > >>
>>> > >> Hi Mike,
>>> > >>
>>> > >> Thank you!
>>> > >>
>>> > >> +1
>>> > >>
>>> > >> I like "IPP Driverless Printing Extensions" best of your suggestions
>>> > >> (because "Mobile" is too narrow and "Universal" is too ambiguous).
>>> > >>
>>> > >> JPS3 is a meaningless name.
>>> > >>
>>> > >> Cheers,
>>> > >> - Ira
>>> > >>
>>> > >> Ira McDonald (Musician / Software Architect)
>>> > >> Co-Chair - TCG Trusted Mobility Solutions WG
>>> > >> Co-Chair - TCG Metadata Access Protocol SG
>>> > >> Chair - Linux Foundation Open Printing WG
>>> > >> Secretary - IEEE-ISTO Printer Working Group
>>> > >> Co-Chair - IEEE-ISTO PWG Internet Printing Protocol WG
>>> > >> IETF Designated Expert - IPP & Printer MIB
>>> > >> Blue Roof Music / High North Inc
>>> > >> http://sites.google.com/site/blueroofmusic <http://sites.google.com/site/blueroofmusic>
>>> > >> http://sites.google.com/site/highnorthinc <http://sites.google.com/site/highnorthinc>
>>> > >> mailto: [email-masked] <mailto:[email-masked]>
>>> > >> PO Box 221  Grand Marais, MI 49839  906-494-2434
>>> > >>
>>> > >>
>>> > >>
>>> > >> On Tue, Oct 15, 2019 at 1:53 PM Michael Sweet via ipp <[email-masked] <mailto:[email-masked]>> wrote:
>>> > >> All,
>>> > >>
>>> > >> As I start to prepare the slides for the November F2F, it occurs to me that we have made some useful name changes to historical specifications:
>>> > >>
>>> > >> - PWG 5100.3 ("IPP Production Printing Attributes - Set 1") renamed to "IPP Production Printing Extensions"
>>> > >> - PWG 5100.11 ("IPP Job and Printer Extensions - Set 2") renamed to "IPP Enterprise Printing Extensions"
>>> > >>
>>> > >> That just leaves PWG 5100.13 ("IPP Job and Printer Extensions - Set 3"), which has a strong focus on "driverless" printing.  I suggest we rename JPS3 to something that indicates its focus, for example:
>>> > >>
>>> > >>     "IPP Driverless Printing Extensions"
>>> > >>
>>> > >>     "IPP Driver Equivalence Extensions"
>>> > >>
>>> > >>     "IPP Mobile Printing Extensions"
>>> > >>
>>> > >>     "IPP Universal Printing Extensions"
>>> > >>
>>> > >> Thoughts?
>>> > >>
>>> > >> ________________________
>>> > >> Michael Sweet
>>> > >>
>>> > >>
>>> > >>
>>> > >> _______________________________________________
>>> > >> ipp mailing list
>>> > >> [email-masked] <mailto:[email-masked]>
>>> > >> https://www.pwg.org/mailman/listinfo/ipp <https://www.pwg.org/mailman/listinfo/ipp>
>>> > >> _______________________________________________
>>> > >> ipp mailing list
>>> > >> [email-masked] <mailto:[email-masked]>
>>> > >> https://www.pwg.org/mailman/listinfo/ipp <https://www.pwg.org/mailman/listinfo/ipp>
>>> > >
>>> >
>>> > ________________________
>>> > Michael Sweet
>>> >
>>> >
>>> >
>>> 
>>> ________________________
>>> Michael Sweet
>>> 
>>> 
>>> 
> 
> 

_______________________________________________
ipp mailing list
[email-masked]
https://www.pwg.org/mailman/listinfo/ipp

---

From: Michael Sweet via ipp <[email-masked]>
Date: Mon, 04 Nov 2019 07:46:32 -0500

Smith,

Still 2.0 - we'll keep the same standard number since the content is mostly unchanged.

> On Nov 3, 2019, at 11:40 PM, Kennedy, Smith (Wireless & IPP Standards) via ipp <[email-masked]> wrote:
> 
>>> On Oct 19, 2019, at 1:18 AM, Michael Sweet <[email-masked]> wrote:
>>> 
>>> Ira,
>>> 
>>>> On Oct 18, 2019, at 4:52 PM, Ira McDonald <[email-masked]> wrote:
>>>> 
>>>> 
>>>> Hi Mike,
>>>> 
>>>> http://sites.google.com/site/blueroofmusic
>>>> http://sites.google.com/site/highnorthinc
>>>> mailto: [email-masked]
>>>> On Fri, Oct 18, 2019 at 3:29 PM Michael Sweet <[email-masked]> wrote:
>>>> Ira,
>>>> 
>>>> > On Oct 18, 2019, at 2:47 PM, Ira McDonald <[email-masked]> wrote:
>>>> > 
>>>> > Hi Mike,
>>>> > 
>>>> > http://sites.google.com/site/blueroofmusic
>>>> > http://sites.google.com/site/highnorthinc
>>>> > mailto: [email-masked]
>>>> > On Fri, Oct 18, 2019 at 1:22 PM Michael Sweet <[email-masked]> wrote:
>>>> > Ira,
>>>> > 
>>>> > > On Oct 18, 2019, at 10:52 AM, Ira McDonald <[email-masked]> wrote:
>>>> > > 
>>>> > > Hi,
>>>> > > 
>>>> > > http://sites.google.com/site/blueroofmusic
>>>> > > http://sites.google.com/site/highnorthinc
>>>> > > mailto: [email-masked]
>>>> > > On Fri, Oct 18, 2019 at 9:12 AM Kennedy, Smith (Wireless & Standards Architect) <[email-masked]> wrote:
>>>> > >> On Oct 15, 2019, at 8:18 AM, Ira McDonald via ipp <[email-masked]> wrote:
>>>> > >> 
>>>> > >> Hi Mike,
>>>> > >> 
>>>> > >> Thank you!
>>>> > >> 
>>>> > >> +1
>>>> > >> 
>>>> > >> http://sites.google.com/site/blueroofmusic
>>>> > >> http://sites.google.com/site/highnorthinc
>>>> > >> mailto: [email-masked]
>>>> > >> On Tue, Oct 15, 2019 at 1:53 PM Michael Sweet via ipp <[email-masked]> wrote:
>>>> > >> All,
>>>> > >> 

_________________________________________________________
Michael Sweet, Senior Printing System Engineer

---

From: Ira McDonald via ipp <[email-masked]>
Date: Mon, 4 Nov 2019 09:36:08 -0500

Hi Smith,

If the revised/renamed document adds conformance
requirements (it does - all of this cluster of revisions
do so), then I suggest it should be v2.0 (truth-in-
advertising) because the same IPP attributes now
have new conformance and usage constraints.

Mike - WDYT?

Cheers,
- Ira

On Sun, Nov 3, 2019 at 11:40 PM Kennedy, Smith (Wireless & IPP Standards) <
[email-masked]> wrote:

> So if it is now named "IPP Driverless Printing Extensions (NODRIVER)",
> what version number, since it is a renamed / rebranded JPS3?
>
>
>> It doesn't roll off the tongue quite as easily as "NODRVR", and I think
>> the "ipp" that comes before it should hint at the focus on printing, but I
>> don't have a strong objection to it.
>>
>>
>> > > I'm fine with renaming it to be "Driverless Printing Extensions" -
>> will change it in the next draft once the current one has been reviewed.
>> > >
>> > > Smith
>> > >
>> > > /**
>> > >     Smith Kennedy
>> > >     HP Inc.
>> > > */
>> > >
>> > >> As I start to prepare the slides for the November F2F, it occurs to
>> me that we have made some useful name changes to historical specifications:
>> > >>
>> > >> That just leaves PWG 5100.13 ("IPP Job and Printer Extensions - Set
>> 3"), which has a strong focus on "driverless" printing.  I suggest we
>> rename JPS3 to something that indicates its focus, for example:
>> > >>

---

From: Ira McDonald via ipp <[email-masked]>
Date: Mon, 4 Nov 2019 09:37:30 -0500

Hi Smith and Mike,

Never mind - Mike had already agreed with 2.0.

Cheers,
- Ira