Subject: [IPP] Typo in IANA registration for print-content-optimize

From: Sean Kau via ipp <[email-masked]>
Date: Fri, 13 Dec 2019 16:28:34 -0800

PWG 5100.7-2019 – IPP Job Extensions v2.0 lists the following options for
print-content-optimize:

'graphics': Graphs and line drawings.
'photo': Photographs.
'text': Text.
'text-and-graphics': Text and graphics.

The IANA registration at
https://www.iana.org/assignments/ipp-registrations/ipp-registrations.xhtml
lists
the following:

auto
graphic
photo
text-and-graphic

There is a discrepancy between 'graphic' and 'graphics' and
'text-and-graphic' vs 'text-and-graphics'.  Either the IANA registration or
the PWG document is incorrect.

-- 
Sean Kau
_______________________________________________
ipp mailing list
[email-masked]
https://www.pwg.org/mailman/listinfo/ipp

---

From: "Kennedy, Smith \(Wireless & IPP Standards\) via ipp" <[email-masked]>
Date: Sat, 14 Dec 2019 01:14:32 +0000

Thanks Sean!

Cheers,
Smith
---
Smith Kennedy
[email-masked]

On Dec 13, 2019, at 5:29 PM, Sean Kau via ipp <[email-masked]> wrote:

PWG 5100.7-2019 – IPP Job Extensions v2.0 lists the following options for print-content-optimize:

The IANA registration at https://www.iana.org/assignments/ipp-registrations/ipp-registrations.xhtml<https://www.iana.org/assignments/ipp-registrations/ipp-registrations.xhtml> lists the following:

auto
graphic
photo
text-and-graphic

There is a discrepancy between 'graphic' and 'graphics' and 'text-and-graphic' vs 'text-and-graphics'.  Either the IANA registration or the PWG document is incorrect.

---

From: Michael Sweet via ipp <[email-masked]>
Date: Fri, 13 Dec 2019 21:21:40 -0500

Sean,

Those are typos in the new specification - the original PWG 5100.11 values were 'graphic' and 'text-and-graphic', which was preserved in the final registration.

I've logged this issue on the PWG web site:

    https://www.pwg.org/dynamo/issues.php?L+Z67

> On Dec 13, 2019, at 7:28 PM, Sean Kau via ipp <[email-masked]> wrote:
> 
> The IANA registration at https://www.iana.org/assignments/ipp-registrations/ipp-registrations.xhtml lists the following:
> 
> auto
> graphic
> photo
> text-and-graphic
> 

________________________
Michael Sweet