Subject: [IPP] IPP Enterprise Printing Extensions: Feature Names and Job Types

From: "Kennedy, Smith \(Wireless & IPP Standards\) via ipp" <[email-masked]>
Date: Wed, 18 Dec 2019 17:12:11 +0000

Hi there,

I'm in the process of producing a new draft of IPP Enterprise Printing Extensions v2.0 (EPX) and I'm trying to nail down the "feature names" and "job types" for the several features defined therein.

What I have thus far is this:

Job Password
	• Feature: Password Job Protection
	• Job Type: Password Protected Job
	• Use Case: Protecting a Job with a Password

Job Storage
	• Feature: Job Storage
	• Job Type: Stored Job
	• Use Case: Storing a Job for Later Reprinting, Reprinting a Stored Job

Proof Print
	• Feature: Proof Print
	• Job Type: Proof Job
	• Use Case: Proof Printing

Authenticated Release
	• Feature: Authenticated Release? Credential Job Protection?
	• Job Type: User Credential Protected Job?
	• Use Case: Protecting a Job with User Authentication Credentials

Any feedback on any of these labels? Thanks for any help!

Smith

/**
    Smith Kennedy
    HP Inc.
*/

_______________________________________________
ipp mailing list
[email-masked]
https://www.pwg.org/mailman/listinfo/ipp

---

From: Michael Sweet via ipp <[email-masked]>
Date: Wed, 18 Dec 2019 13:52:50 -0500

Smith,

Most of these look fine to me.  One comment at the end...

> On Dec 18, 2019, at 12:12 PM, Kennedy, Smith (Wireless & IPP Standards) via ipp <[email-masked]> wrote:
> 
> Hi there,
> 

I've been calling this Release Printing in the Job Accounting document - the kind of authentication varies widely but functionally it is Print then Release at the printer.  Some vendors call their implementation Follow Me or Pull Printing, although those have the additional wrinkle of releasing from any of several output devices, vs. from a single output device associated with the Printer.

I've avoided using Follow Me since it is a trademarked term.  Pull Printing seems to be safe, and I'd have no objection to using it here (even for a single output device).  Whatever we settle on, I'll update the Job Accounting document accordingly...

________________________
Michael Sweet

---

From: Ira McDonald via ipp <[email-masked]>
Date: Wed, 18 Dec 2019 14:37:03 -0500

Hi,

Two comments:

(1) I definitely prefer "Release Printing" (and not saying anything about
Authentication in the title).

(2) The actual keyword names of all these features of course have to be
all lowercase and use hyphens (but not underscores or spaces).

Cheers,
- Ira

Ira McDonald (Musician / Software Architect)
Co-Chair - TCG Trusted Mobility Solutions WG
Co-Chair - TCG Metadata Access Protocol SG
Chair - Linux Foundation Open Printing WG
Secretary - IEEE-ISTO Printer Working Group
Co-Chair - IEEE-ISTO PWG Internet Printing Protocol WG
IETF Designated Expert - IPP & Printer MIB
Blue Roof Music / High North Inc
http://sites.google.com/site/blueroofmusic
http://sites.google.com/site/highnorthinc
mailto: [email-masked]
PO Box 221  Grand Marais, MI 49839  906-494-2434

On Wed, Dec 18, 2019 at 1:53 PM Michael Sweet via ipp <[email-masked]> wrote:

> > I'm in the process of producing a new draft of IPP Enterprise Printing
> Extensions v2.0 (EPX) and I'm trying to nail down the "feature names" and
> "job types" for the several features defined therein.
> >
> I've been calling this Release Printing in the Job Accounting document -
> the kind of authentication varies widely but functionally it is Print then
> Release at the printer.  Some vendors call their implementation Follow Me
> or Pull Printing, although those have the additional wrinkle of releasing
> from any of several output devices, vs. from a single output device
> associated with the Printer.
>
> I've avoided using Follow Me since it is a trademarked term.  Pull
> Printing seems to be safe, and I'd have no objection to using it here (even
> for a single output device).  Whatever we settle on, I'll update the Job
> Accounting document accordingly...
>
> ________________________
> Michael Sweet
>
>
>