Subject: [IPP] IPP Everywhere ipp-tests.sh printer-alert

From: "Rizzo, Christopher via ipp" <[email-masked]>
Date: Sun, 22 Mar 2020 03:37:03 +0000

Mike,

I get a failure for printer-alert when running ipp-tests.sh because there are no alerts present in the printer and IPP printer-alert attribute is blank.  Is it not supposed to be blank?  I can't find in specs an explicit statement of what the value of printer-alert should be when there are no alerts present.

Thanks,
Chris

Christopher Rizzo
Xerox Corporation
GDG/Discovery/Advance Technology
26600 SW Parkway Ave.
Wilsonville, OR 97070-9251
Phone: (585) 314-6936
Email: [email-masked]

"The realization came over me with full force that a good part of the remainder of my life was going to be spent in finding errors in my own programs."
-Maurice Wilkes, Memoirs of a Computer Pioneer
_______________________________________________
ipp mailing list
[email-masked]
https://www.pwg.org/mailman/listinfo/ipp

---

From: Michael Sweet via ipp <[email-masked]>
Date: Sun, 22 Mar 2020 13:01:22 -0400

Chris,

Generally you omit an attribute when it has no values, but for "printer-alert" I have also seen "code=other" being returned when there are no issues to report.  The Printer MIB is similarly silent on the best practice here, so I think we should probably clarify this in an errata update.

Please bring this up on the IPP mailing list so we can discuss it at the next concall.  

> On Mar 21, 2020, at 11:37 PM, Rizzo, Christopher <[email-masked]> wrote:
> 
> Mike,
>  

________________________
Michael Sweet

---

From: "Rizzo, Christopher via ipp" <[email-masked]>
Date: Sun, 22 Mar 2020 19:14:03 +0000

Hi Mike,

I copied IPP Workgroup on this email, is there a more formal way of adding an issue to the mailing list?  Or did I use the wrong mailing list?

Thanks,
Chris

Christopher Rizzo
Xerox Corporation

From: Michael Sweet <[email-masked]>
Date: Sunday, March 22, 2020 at 10:02 AM
To: Christopher Rizzo <[email-masked]>
Cc: PWG Workgroup <[email-masked]>
Subject: Re: IPP Everywhere ipp-tests.sh printer-alert

Chris,

On Mar 21, 2020, at 11:37 PM, Rizzo, Christopher <[email-masked]<mailto:[email-masked]>> wrote:
Mike,

Thanks,
Chris

Christopher Rizzo
Xerox Corporation
GDG/Discovery/Advance Technology
26600 SW Parkway Ave.
Wilsonville, OR 97070-9251
Phone: (585) 314-6936
Email: [email-masked]<mailto:[email-masked]>

________________________
Michael Sweet

---

From: Ira McDonald via ipp <[email-masked]>
Date: Sun, 22 Mar 2020 20:44:50 -0400

Hi Chris,

Nope - you used the right mailing list in your original note.

Thanks,
- Ira

Ira McDonald (Musician / Software Architect)
Co-Chair - TCG Trusted Mobility Solutions WG
Co-Chair - TCG Metadata Access Protocol SG
Chair - Linux Foundation Open Printing WG
Secretary - IEEE-ISTO Printer Working Group
Co-Chair - IEEE-ISTO PWG Internet Printing Protocol WG
IETF Designated Expert - IPP & Printer MIB
Blue Roof Music / High North Inc
http://sites.google.com/site/blueroofmusic
http://sites.google.com/site/highnorthinc
mailto: [email-masked]
(permanent) PO Box 221  Grand Marais, MI 49839  906-494-2434
(to 30 April 2020) 203 W Oak St  Ellettsville, IN 47429  812-876-9970

On Sun, Mar 22, 2020 at 3:14 PM Rizzo, Christopher via ipp <[email-masked]>
wrote:

> Hi Mike,
>
>
>
> I copied IPP Workgroup on this email, is there a more formal way of adding
> an issue to the mailing list?  Or did I use the wrong mailing list?
>
>
>
> Thanks,
>
> Chris
>
>
>
> Christopher Rizzo
>
> Xerox Corporation
>
> "The realization came over me with full force that a good part of the
> remainder of my life was going to be spent in finding errors in my own
> programs."
>
> -Maurice Wilkes, * Memoirs of a Computer Pioneer*
>
>
>
> *From: *Michael Sweet <[email-masked]>
> *Date: *Sunday, March 22, 2020 at 10:02 AM
> *To: *Christopher Rizzo <[email-masked]>
> *Cc: *PWG Workgroup <[email-masked]>
> *Subject: *Re: IPP Everywhere ipp-tests.sh printer-alert
>
>
>
> Chris,
>
>
>
> Generally you omit an attribute when it has no values, but for
> "printer-alert" I have also seen "code=other" being returned when there are
> no issues to report.  The Printer MIB is similarly silent on the best
> practice here, so I think we should probably clarify this in an errata
> update.
>
>
>
> I get a failure for printer-alert when running ipp-tests.sh because there
> are no alerts present in the printer and IPP printer-alert attribute is
> blank.  Is it not supposed to be blank?  I can't find in specs an explicit
> statement of what the value of printer-alert should be when there are no
> alerts present.
>
>
>
> Thanks,
>
> Chris
>
>
>
> Christopher Rizzo
>
> Xerox Corporation
>
> "The realization came over me with full force that a good part of the
> remainder of my life was going to be spent in finding errors in my own
> programs."
>

---

From: Michael Sweet via ipp <[email-masked]>
Date: Thu, 26 Mar 2020 17:43:44 -0400

To close the loop on this, during today's IPP conference call we decided to file an errata on 5100.9 to note that "printer-alert" and "printer-alert-description" SHOULD NOT be reported when the prtAlertTable is empty.

I have also included this in the latest IPP Everywhere v1.1 draft along with a note concerning existing implementations that choose to report '' or 'code=other' for an empty table.  IPP Everywhere 1.1 also now makes this attribute RECOMMENDED for physical printers and OPTIONAL for print servers.

The IPP Everywhere self-certification tools will also be updated to a) not require printer-alert or printer-alert-description and b) allow printer-alert to be the empty string.

________________________
Michael Sweet