Subject: [IPP] IPP Everywhere v1.1 Printer Self-Certification Tools: Second release candidate posted

From: Michael Sweet via ipp <[email-masked]>
Date: Thu, 21 May 2020 17:33:56 -0400

All,

I have posted a second release candidate of the IPP Everywhere v1.1 Printer Self-Certifications Tools to:

	https://ftp.pwg.org/pub/pwg/ipp/wd/sw-ippeveselfcert11-macos.zip
	https://ftp.pwg.org/pub/pwg/ipp/wd/sw-ippeveselfcert11-rhel.tar.gz
	https://ftp.pwg.org/pub/pwg/ipp/wd/sw-ippeveselfcert11-ubuntu.tar.gz
	https://ftp.pwg.org/pub/pwg/ipp/wd/sw-ippeveselfcert11-windows.msi

These release candidates fix the following issues:

- Issue #47: Test for finishings support should define HAVE_FINISHINGS if "finishings-supported" has value other than 3 (none)
- Issue #48: HAVE_IDENTIFY_PRINTER isn't defined prior to test I-9 that uses it
- Issue #50: Relax Get-Printer-Attributes tests
- Issue #51: Add "strict" mode for Get-Printer-Attributes tests

Please test these tools prior to the next IPP workgroup meeting on June 4, 2020 at 3pm ET so that we can approve both the tools and the new specifications.

Thank you!

________________________
Michael Sweet

_______________________________________________
ipp mailing list
[email-masked]
https://www.pwg.org/mailman/listinfo/ipp

---

From: Michael Sweet via ipp <[email-masked]>
Date: Mon, 25 May 2020 22:10:40 -0400

All,

Sorry for the broken links.  I also posted another update for the Windows MSI installer package on Friday and now have confirmation that the Windows tools now install and run correctly.  Here are the corrected links:

	https://ftp.pwg.org/pub/pwg/ipp/wd/sw-ippeveselfcert11-20200521-macos.zip
	https://ftp.pwg.org/pub/pwg/ipp/wd/sw-ippeveselfcert11-20200521-rhel.tar.gz
	https://ftp.pwg.org/pub/pwg/ipp/wd/sw-ippeveselfcert11-20200521-ubuntu.tar.gz
	https://ftp.pwg.org/pub/pwg/ipp/wd/sw-ippeveselfcert11-20200522-windows.msi

> On May 21, 2020, at 5:33 PM, Michael Sweet via ippeveselfcert <[email-masked]> wrote:
> 
> All,
> 
> ippeveselfcert mailing list
> [email-masked]
> https://www.pwg.org/mailman/listinfo/ippeveselfcert
> 

________________________
Michael Sweet

---

From: "Rizzo, Christopher via ipp" <[email-masked]>
Date: Tue, 26 May 2020 14:46:58 +0000

Mike,

What is the argument provided to ipp-tests.sh to control whether strict mode or not is being used?  I have a feeling it is a bash trick being used, but not being a guru with bash, I cannot tell.   Somehow there has to be a way to pass -d STRICT=1 to ipptool inside of ipp-tests.sh, correct?

Thanks,
Chris

Christopher Rizzo
Xerox Corporation
GDG/Discovery/Advance Technology
26600 SW Parkway Ave.
Wilsonville, OR 97070-9251
Phone: (585) 314-6936
Email: [email-masked]

"The realization came over me with full force that a good part of the remainder of my life was going to be spent in finding errors in my own programs."
-Maurice Wilkes, Memoirs of a Computer Pioneer

From: ipp <[email-masked]> on behalf of PWG Workgroup <[email-masked]>
Reply-To: Michael Sweet <[email-masked]>
Date: Monday, May 25, 2020 at 7:12 PM
To: Michael Sweet <[email-masked]>, PWG Self-Certification <[email-masked]>
Cc: PWG Workgroup <[email-masked]>
Subject: Re: [IPP] [IPP Everywhere Self-Certification] IPP Everywhere v1.1 Printer Self-Certification Tools: Second release candidate posted

All,

On May 21, 2020, at 5:33 PM, Michael Sweet via ippeveselfcert <[email-masked]<mailto:[email-masked]>> wrote:

All,

Thank you!

________________________
Michael Sweet

_______________________________________________
ippeveselfcert mailing list
[email-masked]<mailto:[email-masked]>
https://www.pwg.org/mailman/listinfo/ippeveselfcert

________________________
Michael Sweet

_______________________________________________
ipp mailing list
[email-masked]<mailto:[email-masked]>
https://www.pwg.org/mailman/listinfo/ipp

---

From: Michael Sweet via ipp <[email-masked]>
Date: Tue, 26 May 2020 10:55:37 -0400

Chris,

Right now you just run ipptool with the ipp-tests.test file directly, e.g.:

    ipptool -d STRICT=1 -tI PRINTER-URI ipp-tests.test

for the interactive output and:

    ipptool -d STRICT=1 -P FILENAME.plist -I PRINTER-URI ipp-tests.test

to also create the plist file.

I can look into ways of supporting this with a command-line option, but doing it in Windows .BAT files would be a challenge due to their limited capabilities...

> On May 26, 2020, at 10:46 AM, Rizzo, Christopher <[email-masked]> wrote:
> 
> Mike,
>  

________________________
Michael Sweet

---

From: "Rizzo, Christopher via ipp" <[email-masked]>
Date: Thu, 28 May 2020 20:59:20 +0000

Trying to determine the cause of these failures without much luck.  I tried to create my own printer-supply test to isolate each of the regex's, but still getting the failure:

        EXPECTED: printer-alert WITH-ALL-VALUES /^code=[A-Za-z]+(;index=[0-9]+|;severity=[A-Za-z]+|;training=[A-Za-z]+|;group=[A-Za-z]+|;groupindex=[0-9]+|;location=[0-9]+|;time=[0-9]+){0,};?$/

        GOT: printer-alert="code=tonerLow;index=2;severity=warningBinaryChangeEvent;training=trained;group=markerSupplies;groupindex=2;location=956700;time=1590695059"

        GOT: printer-alert="code=subunitPowerSaver;index=3;severity=warningBinaryChangeEvent;training=noInterventionRequired;group=generalPrinter;groupindex=-1;location=155100;time=1590698660"

        EXPECTED: printer-supply WITH-ALL-VALUES /^(type=[A-Za-z]+;|maxcapacity=-{0,1}[0-9]+;|level=-{0,1}[0-9]+;|index=[0-9]+;|markerindex=[0-9]+;|class=[A-Za-z]+;|unit=[A-Za-z]+;|colorantindex=[0-9]+;|colorantrole=[A-Za-z]+;|colorantname=[-_.A-Za-z0-9]+;|coloranttonality=[0-9]+;){0,}$/

        GOT: printer-supply="type=toner;maxcapacity=5300;level=4717;class=supplyThatIsConsumed;unit=tenthsOfGrams;colorantindex=4;colorantrole=process;colorantname=black;coloranttonality=256"

        GOT: printer-supply="type=toner;maxcapacity=3000;level=480;class=supplyThatIsConsumed;unit=tenthsOfGrams;colorantindex=1;colorantrole=process;colorantname=cyan;coloranttonality=256"

        GOT: printer-supply="type=toner;maxcapacity=3000;level=2730;class=supplyThatIsConsumed;unit=tenthsOfGrams;colorantindex=2;colorantrole=process;colorantname=magenta;coloranttonality=256"

        GOT: printer-supply="type=toner;maxcapacity=3050;level=671;class=supplyThatIsConsumed;unit=tenthsOfGrams;colorantindex=3;colorantrole=process;colorantname=yellow;coloranttonality=256"

        GOT: printer-supply="type=opc;maxcapacity=100;level=74;class=supplyThatIsConsumed;unit=percent;colorantindex=4;colorantrole=process;colorantname=black;coloranttonality=256"

        GOT: printer-supply="type=opc;maxcapacity=100;level=79;class=supplyThatIsConsumed;unit=percent;colorantindex=1;colorantrole=process;colorantname=cyan;coloranttonality=256"

        GOT: printer-supply="type=opc;maxcapacity=100;level=79;class=supplyThatIsConsumed;unit=percent;colorantindex=2;colorantrole=process;colorantname=magenta;coloranttonality=256"

        GOT: printer-supply="type=opc;maxcapacity=100;level=77;class=supplyThatIsConsumed;unit=percent;colorantindex=3;colorantrole=process;colorantname=yellow;coloranttonality=256"

        GOT: printer-supply="type=fuser;maxcapacity=100;level=96;class=supplyThatIsConsumed;unit=percent"

        GOT: printer-supply="type=wasteToner;maxcapacity=100;level=100;class=receptacleThatIsFilled;unit=percent"

        GOT: printer-supply="type=transferUnit;maxcapacity=100;level=85;class=supplyThatIsConsumed;unit=percent"

        GOT: printer-supply="type=transferUnit;maxcapacity=100;level=88;class=supplyThatIsConsumed;unit=percent"

Trying to isolate regex's example: printer-supply.test copied from ipptests.test, removed all tests except I-10. Get-Printer-Attributes Operation (default) and used a "type" only specific regex still failed ('+' means 0 or more, '{0,}' means 0 or more of entries within parenthesis that comes before correct?):

crizzo@ChrisMacBook15:~/OneDrive - Xerox/pwg/ipp/everywhere/sw-ippeveselfcert11-20200521[42] ./ippfind --literal-name "Xerox AltaLink C8035" -x ./ipptool -P "Xerox AltaLink C8035 IPP Results.plist" -I '{}' printer-supply.test \;

"printer-supply.test":

    I-10. Get-Printer-Attributes Operation (default)                     [FAIL]

        RECEIVED: 1785 bytes in response

        status-code = successful-ok (successful-ok)

        EXPECTED: printer-supply WITH-ALL-VALUES /^(type=[A-Za-z]+){0,}$/

        GOT: printer-supply="type=toner;maxcapacity=5300;level=4717;class=supplyThatIsConsumed;unit=tenthsOfGrams;colorantindex=4;colorantrole=process;colorantname=black;coloranttonality=256"

        GOT: printer-supply="type=toner;maxcapacity=3000;level=480;class=supplyThatIsConsumed;unit=tenthsOfGrams;colorantindex=1;colorantrole=process;colorantname=cyan;coloranttonality=256"

        GOT: printer-supply="type=toner;maxcapacity=3000;level=2730;class=supplyThatIsConsumed;unit=tenthsOfGrams;colorantindex=2;colorantrole=process;colorantname=magenta;coloranttonality=256"

        GOT: printer-supply="type=toner;maxcapacity=3050;level=671;class=supplyThatIsConsumed;unit=tenthsOfGrams;colorantindex=3;colorantrole=process;colorantname=yellow;coloranttonality=256"

        GOT: printer-supply="type=opc;maxcapacity=100;level=74;class=supplyThatIsConsumed;unit=percent;colorantindex=4;colorantrole=process;colorantname=black;coloranttonality=256"

        GOT: printer-supply="type=opc;maxcapacity=100;level=79;class=supplyThatIsConsumed;unit=percent;colorantindex=1;colorantrole=process;colorantname=cyan;coloranttonality=256"

        GOT: printer-supply="type=opc;maxcapacity=100;level=79;class=supplyThatIsConsumed;unit=percent;colorantindex=2;colorantrole=process;colorantname=magenta;coloranttonality=256"

        GOT: printer-supply="type=opc;maxcapacity=100;level=77;class=supplyThatIsConsumed;unit=percent;colorantindex=3;colorantrole=process;colorantname=yellow;coloranttonality=256"

        GOT: printer-supply="type=fuser;maxcapacity=100;level=96;class=supplyThatIsConsumed;unit=percent"

        GOT: printer-supply="type=wasteToner;maxcapacity=100;level=100;class=receptacleThatIsFilled;unit=percent"

        GOT: printer-supply="type=transferUnit;maxcapacity=100;level=85;class=supplyThatIsConsumed;unit=percent"

        GOT: printer-supply="type=transferUnit;maxcapacity=100;level=88;class=supplyThatIsConsumed;unit=percent"

Chris

Christopher Rizzo
Xerox Corporation

From: Michael Sweet <[email-masked]>
Date: Tuesday, May 26, 2020 at 7:57 AM
To: Christopher Rizzo <[email-masked]>
Cc: PWG Self-Certification <[email-masked]>, PWG Workgroup <[email-masked]>
Subject: Re: [IPP] [IPP Everywhere Self-Certification] IPP Everywhere v1.1 Printer Self-Certification Tools: Second release candidate posted

Chris,

On May 26, 2020, at 10:46 AM, Rizzo, Christopher <[email-masked]<mailto:[email-masked]>> wrote:

Mike,

Thanks,
Chris

Christopher Rizzo
Xerox Corporation
GDG/Discovery/Advance Technology
26600 SW Parkway Ave.
Wilsonville, OR 97070-9251
Phone: (585) 314-6936
Email: [email-masked]<mailto:[email-masked]>

From: ipp <[email-masked]<mailto:[email-masked]>> on behalf of PWG Workgroup <[email-masked]<mailto:[email-masked]>>
Reply-To: Michael Sweet <[email-masked]<mailto:[email-masked]>>
Date: Monday, May 25, 2020 at 7:12 PM
To: Michael Sweet <[email-masked]<mailto:[email-masked]>>, PWG Self-Certification <[email-masked]<mailto:[email-masked]>>
Cc: PWG Workgroup <[email-masked]<mailto:[email-masked]>>
Subject: Re: [IPP] [IPP Everywhere Self-Certification] IPP Everywhere v1.1 Printer Self-Certification Tools: Second release candidate posted

All,

All,

Thank you!

________________________
Michael Sweet

________________________
Michael Sweet

________________________
Michael Sweet

---

From: "Rizzo, Christopher via ipp" <[email-masked]>
Date: Thu, 28 May 2020 21:06:55 +0000

Ahhh...  Looks like the problem may be the double $ at the end of SUPPLY_REGEX definition in ipptests.test file...

Chris

Christopher Rizzo
Xerox Corporation

From: Christopher Rizzo <[email-masked]>
Date: Thursday, May 28, 2020 at 1:59 PM
To: Michael Sweet <[email-masked]>
Cc: PWG Self-Certification <[email-masked]>, PWG Workgroup <[email-masked]>
Subject: Re: [IPP] [IPP Everywhere Self-Certification] IPP Everywhere v1.1 Printer Self-Certification Tools: Second release candidate posted

"printer-supply.test":

Chris

Christopher Rizzo
Xerox Corporation

Chris,

Mike,

Thanks,
Chris

Christopher Rizzo
Xerox Corporation

All,

All,

Thank you!

________________________
Michael Sweet

________________________
Michael Sweet

________________________
Michael Sweet

---

From: Michael Sweet via ipp <[email-masked]>
Date: Thu, 28 May 2020 17:32:40 -0400

Chris,

> On May 28, 2020, at 4:59 PM, Rizzo, Christopher <[email-masked]> wrote:
> 

There is no trailing semicolon...

>         GOT: printer-supply="type=toner;maxcapacity=5300;level=4717;class=supplyThatIsConsumed;unit=tenthsOfGrams;colorantindex=4;colorantrole=process;colorantname=black;coloranttonality=256"

Ditto...

________________________
Michael Sweet

---

From: Michael Sweet via ipp <[email-masked]>
Date: Thu, 28 May 2020 17:33:33 -0400

Chris,

The double $ is necessary because $ is used for variable substitution.  $$ inserts a single $...

> On May 28, 2020, at 5:06 PM, Rizzo, Christopher <[email-masked]> wrote:
> 

________________________
Michael Sweet

---

From: "Rizzo, Christopher via ipp" <[email-masked]>
Date: Thu, 28 May 2020 22:37:16 +0000

Thanks Mike,

I thought for sure I tried adding the semi-colon on the end, apparently in all the tests I ran I did not.

Chris

Christopher Rizzo
Xerox Corporation

Date: Thursday, May 28, 2020 at 2:34 PM

Chris,

On May 28, 2020, at 4:59 PM, Rizzo, Christopher <[email-masked]<mailto:[email-masked]>> wrote:

Ditto...

________________________
Michael Sweet