Subject: [IPP] IPP Everywhere tests

From: "Rizzo, Christopher via ipp" <[email-masked]>
Date: Fri, 1 May 2020 17:35:44 +0000

Mike,

Apologies for not raising this sooner, I have not been able to get to running all these tests because of other work, and because I need to make fixes for failed tests where needed.  I am continuing to run IPP everywhere tests, but while doing so I am modifying code to get the failing tests to pass, so testing for me is not just testing alone...  As I continue to get the code written to pass the tests, I could run into other issues.

1. document-password-supported  IPP Everywhere test fails:

    I-10. Get-Printer-Attributes Operation (default)                     [FAIL]

        RECEIVED: 15326 bytes in response

        status-code = successful-ok (successful-ok)

        EXPECTED: document-password-supported

PWG 5100.13 document-password or document-password-supported are OPTIONAL.  Test should not fail based on EXPECT document-password-supported.  Correct?

2. job-ids-supported - PWG-5100.11, Section 10.2 - 1st sentence should be "... the Printer supports the "job-ids" attribute for the following Operations: Purge-Jobs and Get-Jobs.", the 1st sentence implies that "job-ids" is an operation?  Section 6.5 2nd sentence implies job-ids is an operation, but I believe it is just an attribute to an operation.

3. Should the following be job-preferred-attributes-supported?  IPP everywhere spec table 6 lists job-preferred-attributes-supported, but PWG 5100.13 5.6.19 lists preferrred-attributes-supported, and section 6.12 paragraph 2 refers to job-preferred-attributes-supported.  Are preferred-attributes-supported and job-preferred-attributes-supported different attributes?

    I-10. Get-Printer-Attributes Operation (default)                     [FAIL]

        RECEIVED: 15349 bytes in response

        status-code = successful-ok (successful-ok)

        EXPECTED: preferred-attributes-supported

Chris

Christopher Rizzo
Xerox Corporation
GDG/Discovery/Advance Technology
26600 SW Parkway Ave.
Wilsonville, OR 97070-9251
Phone: (585) 314-6936
Email: [email-masked]

"The realization came over me with full force that a good part of the remainder of my life was going to be spent in finding errors in my own programs."
-Maurice Wilkes, Memoirs of a Computer Pioneer
_______________________________________________
ipp mailing list
[email-masked]
https://www.pwg.org/mailman/listinfo/ipp

---

From: Michael Sweet via ipp <[email-masked]>
Date: Fri, 1 May 2020 15:00:20 -0400

Chris,

> On May 1, 2020, at 1:35 PM, Rizzo, Christopher via ipp <[email-masked]> wrote:
> 
> Mike,
>  

IPP Everywhere makes it CONDITIONALLY REQUIRED for printers that support PDF files (which can have passwords to decrypt the contents...)

> 2. job-ids-supported - PWG-5100.11, Section 10.2 - 1st sentence should be "... the Printer supports the "job-ids" attribute for the following Operations: Purge-Jobs and Get-Jobs.", the 1st sentence…

Look to PWG 5100.7 for that now - from 5100.7-2019:

5.5.20 job-ids-supported (boolean)

This REQUIRED attribute specifies whether the "job-ids" operation attribute (section 5.1.3) is supported.

>         EXPECTED: preferred-attributes-supported

It should be "preferred-attributes-supported", which is what the current draft of IPP Everywhere 1.1 lists... :)

https://ftp.pwg.org/pub/pwg/ipp/wd/wd-ippeve11-20200417.pdf <https://ftp.pwg.org/pub/pwg/ipp/wd/wd-ippeve11-20200417.pdf>

________________________
Michael Sweet