Subject: [IPP] IPP WG Agenda 3:00-4:30pm US Eastern (21 May 2020)

From: Ira McDonald via ipp <[email-masked]>
Date: Wed, 20 May 2020 15:37:01 -0400

Hi,

Our next IPP WG call will be regular Thursday 21 May 2020 at
12:00-13:30pm US Pacific / 3:00-4:30pm US Eastern

NOTE: Please USE the *new* WebEx and Audio Bridge below

-------------------------------------------------------
Meeting information
-------------------------------------------------------
Topic: IPP WG
Every 2 weeks on Thursday 3:00-4:30 pm US Eastern

-------------------------------------------------------
WebEx online meeting (join WebEx first, before audio bridge)
-------------------------------------------------------
1. Go to
https://ieee-isto.webex.com/ieee-isto/j.php?MTID=m8952a7e2500bbe43a428c15193736ec0
2. If requested, enter your name and email address.
3. If a password is required, enter the meeting password: Printing123
4. Click "Join".

-------------------------------------------------------
Audio Bridge (join audio second w/ unique access code from WebEx)
-------------------------------------------------------
Call-in toll-free number (US/Canada): +1 866 469-3239 <%28866%29%20469-3239>
Call-in toll number (US/Canada): +1 650 429-3300 <%28650%29%20429-3300>
Call-in toll number (US/Canada): +1 408 856-9570 <%28408%29%20856-9570>

Global toll-free call in numbers and other audio options ("Call Me Back" or
VoIP) are listed once you join the WebEx meeting.

Unique attendee access code:  Displayed in the WebEx meeting

Agenda:
(1) PWG IP Policy, Minute Taker, Roll Call, and Agenda Review
- Volunteer as minute taker?
- Volunteer as moderator? - Ira in ISO 24089 review meeting
-- Status of all IPP documents in progress up-to-date below

(2) Approve IPP minutes from previous meetings
- https://ftp.pwg.org/pub/pwg/ipp/minutes/ippv2-concall-minutes-20200423.pdf
<https://ftp.pwg.org/pub/pwg/ipp/minutes/ippv2-concall-minutes-20200409.pdf>
-- IPP WG regular call on 04/09/20
- https://ftp.pwg.org/pub/pwg/ipp/minutes/ippv2-f2f-minutes-20200506.pdf
-- IPP sessions at Joint PWG/OP Virtual F2F on 05/06/20 to 05/08/20

(3) Status/Review of various IPP mailing list notes
** FIX ME **
- http://www.pwg.org/archives/ipp/2020/020538.html
-- IPP Everywhere Self Certification Process (Bill, Mike)
- http://www.pwg.org/archives/ipp/2020/020547.html
-- Clarification of Best Practice Conformance Terminolgy - MUST is allowed

<http://www.pwg.org/archives/ipp/2019/019948.html>
(4) Status of AMSC and ISO liaisons w/ PWG (Paul)
- http://ftp.pwg.org/pub/pwg/general/sc/pwg-sc-call-minutes-20200323.htm
- http://ftp.pwg.org/pub/pwg/general/sc/pwg-sc-call-minutes-20200406.htm
- http://ftp.pwg.org/pub/pwg/general/sc/pwg-sc-call-minutes-20200420.htm
-- see PWG Steering Committee minutes from 03/23/20, 04/06/20, 04/20/20

(5) Status of PWG and IPP WG Formal Approvals and Last Calls (All)
* IPP Everywhere v1.1 (Mike)
- https://ftp.pwg.org/pub/pwg/ipp/wd/wd-ippeve11-20200417.pdf
-- Stable draft - for a Candidate Standard errata update
-- IPP WG review on 9 April 2020
-- PWG Call for Objections ended 15 May 2020
-- Schedule -  PWG Candidate Standard Q2 2020

* IPP Everywhere Self-Certification Manual v1.1 (Mike)
- https://ftp.pwg.org/pub/pwg/ipp/wd/wd-ippeveselfcert11-20200312.pdf
-- Stable draft - for a Candidate Standard errata update
-- IPP WG Last Call ended on 12 March 2020
-- IPP WG discussion on 9 April 2020
-- PWG Call for Objections ended 15 May 2020
-- Schedule -  PWG Candidate Standard Q2 2020

* PWG IPP Registry Policy (Smith)
-
https://ftp.pwg.org/pub/pwg/general/process/ipp-registry-policy-20200518.txt
-- IPP WG final review started 10 April 2020 ended 20 April 2020
-- PWG Steering Committee review and approval 18 May 2020
-- Schedule - PWG announcement Q2 2020

(6) Review of IPP System Service Discovery (Mike)
- https://ftp.pwg.org/pub/pwg/ipp/wd/wd-ippsysdisc10-20200427-rev.pdf
- http://www.pwg.org/archives/ipp/2020/020523.html
-- Stable draft for an IPP Registration on 27 April 2020
-- Prototyped in PAPPL project / planned to be added to "ippserver"
-- PWG Discussion at PWG/OP Virtual F2F on 05/07/20
-- Schedule - IPP WG Approval for IANA Registration in Q2 2020

(7) Encoding of "printer-supply" (Chris Rizzo)
- http://www.pwg.org/archives/ipp/2020/020533.html
-- PWG Discussion at PWG/OP Virtual F2F on 05/07/20
-- Schedule - Resolution in Q2 2020 (possible errata issue)

(8) Updates to IPP System Service and IPP INFRA (Cihan, Mike)
- http://www.pwg.org/archives/ipp/2020/020540.html
- https://ftp.pwg.org/pub/pwg/ipp/minutes/ippv2-f2f-minutes-20200506.pdf
-- see section 9 of IPP F2F minutes
-- PWG Discussion at PWG/OP Virtual F2F on 05/08/20
-- Schedule - IPP Registration in Q2/Q3 2020

(9) Simplified "print-quality-col" for IPP Driverless (Smith, Mike)
- https://github.com/istopwg/ippsample/wiki/IPP-Print-Quality-Discussion
- https://ftp.pwg.org/pub/pwg/ipp/minutes/ippv2-f2f-minutes-20200506.pdf
-- see section 7 of IPP F2F minutes
-- PWG Discussion at PWG/OP Virtual F2F on 05/08/20
-- Schedule - Resolution in Q2 2020

(10) Status of IPP Everywhere v1.1 Printer Self-Certification Tools
(Smith/Mike)
- http://www.pwg.org/archives/ipp/2020/020499.html
-- IPP WG Last Call ended 12 March 2020
-- PWG Discussion at PWG/OP Virtual F2F on 05/06/20
-- Schedule - Approval w/ IPP Everywhere v1.1 in Q2 2020

(11) Recent IPP Wiki Pages (Mike)
-
https://github.com/istopwg/ippsample/wiki/How-to-Support-TLS-Before-the-Date-and-Time-Is-Set
-- How to Support TLS Before the Date and Time Is Set
- https://github.com/istopwg/ippsample/wiki/IPP-Print-Quality-Discussion
-- IPP Print Quality Discussion
-
https://github.com/istopwg/ippsample/wiki/IPP-Everywhere-Value-Proposition-Discussion-Points
-- IPP Everywhere Value Proposition Discussion Points
-
https://github.com/istopwg/ippsample/wiki/Roll-Feed-Printing-Extensions:-eliminate-margins
-- Roll Feed Printing Extensions: eliminate margins

(12) Status of various IPP documents (All)
* IPP Driverless Printing Extensions v2.0 (Smith)
- https://ftp.pwg.org/pub/pwg/ipp/wd-ippnodriver20-20200204-rev.pdf
-- Interim draft - for a Candidate Standard
-- PWG Review at PWG/OP Virtual F2F on 05/08/20
-- Schedule - Prototype draft in Q2/Q3 2020

* IPP Encrypted Jobs and Documents v1.0 (Mike/Smith)
- https://ftp.pwg.org/pub/pwg/ipp/wd/wd-ipptrustnoone10-20200218-rev.pdf
-- Prototype draft - for a Candidate Standard
-- PWG F2F review on 6 February 2020
-- Schedule - Stable draft in Q2/Q3 2020

* Job Accounting for IPP v1.0 (Mike)
- https://ftp.pwg.org/pub/pwg/ipp/wd/wd-ippaccounting10-20200427-rev.pdf
-- Interim draft - for a Best Practice
-- PWG Review at PWG/OP Virtual F2F on 05/06/20
-- Schedule - Prototype draft in Q2/Q3 2020

* IPP Production Printing Ext v2.0 (Mike)
- https://ftp.pwg.org/pub/pwg/ipp/wd/wd-ippppx20-20200429-rev.pdf
-- Prototype draft - for a Candidate Standard
-- PWG Review at PWG/OP Virtual F2F on 05/08/20
-- Just waiting on prototyping in ippsample
-- Schedule - Stable draft in Q2/Q3 2020

* IPP Enterprise Printing Ext v2.0 (Smith)
- https://ftp.pwg.org/pub/pwg/ipp/wd/wd-ippepx20-20200504-rev.pdf
- http://www.pwg.org/archives/ipp/2020/020532.html
-- Interim draft - for a Candidate Standard
-- PWG Review at PWG/OP Virtual F2F on 05/07/20
-- Schedule - Prototype draft in Q2/Q3 2020

(13) Open Printing update (Ira)
- https://openprinting.github.io
- https://developers.google.com/open-source/gsoc
-- OP website is now live w/ IPP Everywhere logo and GSoC 2019/2020 info
-- OP monthly calls on 03/17/20, 04/07/20 and upcoming 05/12/20
- GSoC 2020 Timeline (*updated)
-- DONE - 30 April* - Student Project selections due from Org Admins
-- DONE - 4 May* - Accepted student projects announced
-- 1 June* Coding officially begins!
-- 29 June* - Mentors and students can begin submitting Phase 1 evaluations
-- 3 July* - Phase 1 Evaluation deadline
-- 27 July* - Mentors and students can begin submitting Phase 2 evaluations
-- 31 July* - Phase 2 Evaluation deadline
-- 24-31 August* - Final week: Students submit final work and mentor
evaluations
-- 31 August to 7 September* - Mentors submit final student evaluations
-- 8 September* - Final results of Google Summer of Code 2020 announced

(14) Next IPP Meetings
- IPP WG call on Thu 4 June 2020 at 3:00-4:30pm US Eastern
-- regular call

- IPP WG call on Thu 18 June 2020 at 3:00-4:30pm US Eastern
-- regular call

- IPP WG call on Thu 2 July 2020 at 3:00-4:30pm US Eastern
-- CANCEL due to US July 4th Holiday?

Cheers,
- Ira

Ira McDonald (Musician / Software Architect)
Co-Chair - TCG Trusted Mobility Solutions WG
Co-Chair - TCG Metadata Access Protocol SG
Chair - Linux Foundation Open Printing WG
Secretary - IEEE-ISTO Printer Working Group
Co-Chair - IEEE-ISTO PWG Internet Printing Protocol WG
IETF Designated Expert - IPP & Printer MIB
Blue Roof Music / High North Inc
http://sites.google.com/site/blueroofmusic
http://sites.google.com/site/highnorthinc
mailto: [email-masked]
(permanent) PO Box 221  Grand Marais, MI 49839  906-494-2434
_______________________________________________
ipp mailing list
[email-masked]
https://www.pwg.org/mailman/listinfo/ipp

---

From: wamwagner--- via ipp <[email-masked]>
Date: Thu, 21 May 2020 15:03:58 -0400

Has this webex started, or is webex just giving me trouble?

Sent from Mail for Windows 10

From: Ira McDonald via ipp
Sent: Wednesday, May 20, 2020 3:37 PM
To: [email-masked]; Ira McDonald
Subject: [IPP] IPP WG Agenda 3:00-4:30pm US Eastern (21 May 2020)

Hi,

1. Go to https://ieee-isto.webex.com/ieee-isto/j.php?MTID=m8952a7e2500bbe43a428c15193736ec0

-------------------------------------------------------
Audio Bridge (join audio second w/ unique access code from WebEx)
-------------------------------------------------------
Call-in toll-free number (US/Canada): +1 866 469-3239
Call-in toll number (US/Canada): +1 650 429-3300
Call-in toll number (US/Canada): +1 408 856-9570

Global toll-free call in numbers and other audio options ("Call Me Back" or VoIP) are listed once you join the WebEx meeting.

- https://ftp.pwg.org/pub/pwg/general/process/ipp-registry-policy-20200518.txt 

(10) Status of IPP Everywhere v1.1 Printer Self-Certification Tools (Smith/Mike)

(11) Recent IPP Wiki Pages (Mike)
- https://github.com/istopwg/ippsample/wiki/How-to-Support-TLS-Before-the-Date-and-Time-Is-Set
-- How to Support TLS Before the Date and Time Is Set
- https://github.com/istopwg/ippsample/wiki/IPP-Print-Quality-Discussion
-- IPP Print Quality Discussion
- https://github.com/istopwg/ippsample/wiki/IPP-Everywhere-Value-Proposition-Discussion-Points
-- IPP Everywhere Value Proposition Discussion Points
- https://github.com/istopwg/ippsample/wiki/Roll-Feed-Printing-Extensions:-eliminate-margins
-- Roll Feed Printing Extensions: eliminate margins

-- 24-31 August* - Final week: Students submit final work and mentor evaluations

Cheers,
- Ira