Subject: [IPP] IPP Everywhere Self Certification Process

From: wamwagner--- via ipp <[email-masked]>
Date: Wed, 13 May 2020 16:30:25 -0400

Sorry, I am a little confused.
a. The IPP F2F slides  say “New JSON-based portal is online: • https://www.pwg.org/printers”, but this just appears to be a list of certified printers
b. The IPP Everywhere™ Printer Self-Certification Manual v1.1 says to submit the "Printer Name.json" file  through https://www.pwg.org/ippeveselfcert
c. https://www.pwg.org/ippeveselfcert has a series of instructions on how to generate the "Printer Name.json" file  with different computer OS, but the file is to be submitted by attaching it to an email message sent to [email-masked] (or attaching it to a newly created issue on Github.)

1. Am I missing something on https://www.pwg.org/printers”,?
2. I assume that the manual points to the web page to allow easy submission process update  without having to update the manual. But “submit the "Printer Name.json" file  through” the web page suggests that this is an active process, rather than an instruction to attach it to an email.
3. “attaching it to a newly created issue on Github” sounds like a good idea, but  it may not be clear what issue page. Is it https://github.com/istopwg/ippeveselfcert/issues?
Thanks, 
Bill Wagner

_______________________________________________
ipp mailing list
[email-masked]
https://www.pwg.org/mailman/listinfo/ipp

---

From: Michael Sweet via ipp <[email-masked]>
Date: Wed, 13 May 2020 16:51:34 -0400

Bill,

> On May 13, 2020, at 4:30 PM, wamwagner--- via ipp <[email-masked]> wrote:
> 
> 	• The IPP F2F slides  say “New JSON-based portal is online: • https://www.pwg.org/printers”, but this just appears to be a list of certified printers

Right, that's the public-facing page listing the submitted printers, which are backed by a JSON file that the page loads.

> 	• The IPP Everywhere™ Printer Self-Certification Manual v1.1 says to submit the "Printer Name.json" file  through https://www.pwg.org/ippeveselfcert
> 	• https://www.pwg.org/ippeveselfcert has a series of instructions on how to generate the "Printer Name.json" file  with different computer OS, but the file is to be submitted by attaching it to an email message sent to [email-masked] (or attaching it to a newly created issue on Github.)

That's how we approached the migration from the original 1.0 self-cert manual (submit directly through the web site at that address) to the new email/issue tracker method.  So if you want to do a submission, you go to the ippeveselfcert page, download the tools and files you need, run them, and then send the results via an email or a Github issue.
 
> 		• Am I missing something on https://www.pwg.org/printers”,?
> 		• I assume that the manual points to the web page to allow easy submission process update  without having to update the manual. But “submit the "Printer Name.json" file  through” the web page suggests that this is an active process, rather than an instruction to attach it to an email.
> 		• “attaching it to a newly created issue on Github” sounds like a good idea, but  it may not be clear what issue page. Is it https://github.com/istopwg/ippeveselfcert/issues?

The "file an issue" text is a hyperlink to the issue tracker.

Maybe it would be less confusing if I added linked/buttons at the top of the page?

________________________
Michael Sweet