Subject: Re: [IPP] RFC: Registration Template for printer-firmware-xxx attributes

From: "Kennedy, Smith \(Wireless & IPP Standards\) via ipp" <[email-masked]>
Date: Tue, 26 May 2020 20:53:10 +0000

Hi Mike,

I'm not finding these in the IANA registry. Did these ever get published?

Smith

/**
    Smith Kennedy
    HP Inc.
*/

> On Jul 24, 2019, at 2:54 PM, Michael Sweet via ipp <[email-masked]> wrote:
> 
> All,
> 
> AirPrint has long defined several Printer Status attributes providing the current firmware names, patches, and versions associated with a Printer. These are based on the corresponding PWG Hardcopy Device Health Assessment Attributes [PWG5110.1] and require that each of these attributes have the same cardinality (number of values), for example:
> 
> printer-firmware-name = 'IPP Server','PDF Interpreter'
> printer-firmware-string-version = '4.2', '2.0r6'
> printer-firmware-patches = '',''
> printer-firmware-version = <0402>,<020006>
> 
> Apple would like to officially register these in the IANA IPP Registry. The template is as follows:
> 
> Printer Status attributes: Reference
> ------------------------------ ---------
> printer-firmware-name (1setOf name(MAX)) [APPLE20190724]
> printer-firmware-patches (1setOf text(MAX)) [APPLE20190724]
> printer-firmware-string-version (1setOf text(MAX)) [APPLE20190724]
> printer-firmware-version (1setOf octetString(MAX)) [APPLE20190724]
> 
> 
> ________________________
> Michael Sweet
> 
> 
> 
> _______________________________________________
> ipp mailing list
> [email-masked]
> https://www.pwg.org/mailman/listinfo/ipp <https://www.pwg.org/mailman/listinfo/ipp>

_______________________________________________
ipp mailing list
[email-masked]
https://www.pwg.org/mailman/listinfo/ipp

---

From: Michael Sweet via ipp <[email-masked]>
Date: Tue, 26 May 2020 16:54:19 -0400

Hmm, I'll see where they disappeared to...

> On May 26, 2020, at 4:53 PM, Kennedy, Smith (Wireless & IPP Standards) <[email-masked]> wrote:
> 
> Hi Mike,
> 

________________________
Michael Sweet

---

From: Michael Sweet via ipp <[email-masked]>
Date: Tue, 26 May 2020 17:19:00 -0400

OK, they are back up on the PWG page, and I'll include them in the next IANA drop (with the System Discovery registration).

> On May 26, 2020, at 4:54 PM, Michael Sweet via ipp <[email-masked]> wrote:
> 

________________________
Michael Sweet

---

From: "Kennedy, Smith \(Wireless & IPP Standards\) via ipp" <[email-masked]>
Date: Tue, 26 May 2020 21:55:34 +0000

Thank you!

Smith

/**
    Smith Kennedy
    HP Inc.
*/

> On May 26, 2020, at 3:19 PM, Michael Sweet <[email-masked]> wrote:
>