Subject: [IPP] PWG 5100.13 - IPP document-password-supported value of 0

From: "Rizzo, Christopher via ipp" <[email-masked]>
Date: Tue, 28 Jul 2020 15:05:16 +0000

This might seem totally off the wall, but IPP Everywhere tests have led me down this path:

PWG 5100.13 section 5.1.2 document-password (octetString(1023)) states "this attribute MUST be supported if the printer also supports the "document-password-supported" attribute."

But section 5.6.4 document-password-supported (integer(0:1023)) states "The value of 0 indicates that the attribute is not supported".

It seems it does not make sense that document-password MUST be supported when the value of document-password-supported = 0.

Thanks,
Chris

Christopher Rizzo
Xerox Corporation
GDG/Discovery/Advance Technology
26600 SW Parkway Ave.
Wilsonville, OR 97070-9251
Phone: (585) 314-6936
Email: [email-masked]

"The realization came over me with full force that a good part of the remainder of my life was going to be spent in finding errors in my own programs."
-Maurice Wilkes, Memoirs of a Computer Pioneer
_______________________________________________
ipp mailing list
[email-masked]
https://www.pwg.org/mailman/listinfo/ipp

---

From: Michael Sweet via ipp <[email-masked]>
Date: Tue, 28 Jul 2020 11:17:32 -0400

Chris,

> On Jul 28, 2020, at 11:05 AM, Rizzo, Christopher via ipp <[email-masked]> wrote:
> 

🤪

Let's make sure the NODRIVER (the successor to JPS3) fixes this nonsense.  I seem to remember some discussion of this back when I authored JPS3 ("how do I know that document-password is supported...") but it looks like the final text wasn't properly cleaned up.

It should, of course, tie "document-password-supported" to "document-password", and not vice-versa.

________________________
Michael Sweet

---

From: "Kennedy, Smith \(Wireless & IPP Standards\) via ipp" <[email-masked]>
Date: Tue, 28 Jul 2020 15:22:24 +0000

I’ll resolve this in the next revision of NODRIVER.

Cheers,
Smith
---
Smith Kennedy
[email-masked]

On Jul 28, 2020, at 9:17 AM, Michael Sweet via ipp <[email-masked]> wrote:

 Chris,

🤪

________________________
Michael Sweet

_______________________________________________
ipp mailing list
[email-masked]
https://www.pwg.org/mailman/listinfo/ipp<https://www.pwg.org/mailman/listinfo/ipp>
_______________________________________________
ipp mailing list
[email-masked]
https://www.pwg.org/mailman/listinfo/ipp