Subject: [IPP] IPP Everywhere v1.1 ipp-tests.sh test I-10.3 Get-Printer-Attributes with requested-attributes = 'none'

From: "Rizzo, Christopher via ipp" <[email-masked]>
Date: Fri, 7 Aug 2020 00:12:08 +0000

Trying to find in what IPP spec a requested-attributes value of 'none' is documented.

Also wondering what is the purpose of a Get-Printer-Attributes request whose requested-attributes value = 'none'?

Thanks,
Chris

Christopher Rizzo
Xerox Corporation
GDG/Discovery/Advance Technology
26600 SW Parkway Ave.
Wilsonville, OR 97070-9251
Phone: (585) 314-6936
Email: [email-masked]

"The realization came over me with full force that a good part of the remainder of my life was going to be spent in finding errors in my own programs."
-Maurice Wilkes, Memoirs of a Computer Pioneer
_______________________________________________
ipp mailing list
[email-masked]
https://www.pwg.org/mailman/listinfo/ipp

---

From: Ira McDonald via ipp <[email-masked]>
Date: Thu, 6 Aug 2020 20:23:33 -0400

Hi Chris,

Mike will no doubt have a more useful reply, but...

The short answer is that, according to the IANA IPP Registry, the value of
'none' has
never been registered in any IETF or PWG IPP spec as a valid keyword value
for the
"requested-attributes" operation attribute.  Hm...

Wondering,
- Ira

*Ira McDonald (Musician / Software Architect)Co-Chair - TCG Trusted
Mobility Solutions WG*

*Co-Chair - TCG Metadata Access Protocol SG*

*Chair - Linux Foundation Open Printing WGSecretary - IEEE-ISTO Printer
Working GroupCo-Chair - IEEE-ISTO PWG Internet Printing Protocol WGIETF
Designated Expert - IPP & Printer MIBBlue Roof Music / High North
Inchttp://sites.google.com/site/blueroofmusic
<http://sites.google.com/site/blueroofmusic>http://sites.google.com/site/highnorthinc
<http://sites.google.com/site/highnorthinc>mailto: [email-masked]
<[email-masked]>(permanent) PO Box 221  Grand Marais, MI 49839
906-494-2434*

On Thu, Aug 6, 2020 at 8:12 PM Rizzo, Christopher via ipp <[email-masked]>
wrote:

> Also wondering what is the purpose of a Get-Printer-Attributes request
> whose requested-attributes value = 'none'?
>
>
>
> Thanks,
>
> Chris
>
>
>
> Christopher Rizzo
>
> Xerox Corporation
>
> "The realization came over me with full force that a good part of the
> remainder of my life was going to be spent in finding errors in my own
> programs."
>
> -Maurice Wilkes, * Memoirs of a Computer Pioneer*

---

From: Michael Sweet via ipp <[email-masked]>
Date: Fri, 7 Aug 2020 09:41:59 -0400

Chris,

> On Aug 6, 2020, at 8:12 PM, Rizzo, Christopher via ipp <[email-masked]> wrote:
> 

Sadly, it is not explicitly documented.

However, as it is not one of the registered group names, 'none' literally represents an attribute named 'none', since it is quite likely that nobody will have implemented an attribute named 'none'. :)
 
> Also wondering what is the purpose of a Get-Printer-Attributes request whose requested-attributes value = 'none'?

The point is more to ensure that an implementation actually supports attribute filtering using the "requested-attributes" operation attribute.  Too many printers incorrectly support it, particularly in respect to the registered attribute group names, and this has caused years of interoperability issues as CUPS and other clients have tried to implement driverless printing.

________________________
Michael Sweet

---

From: "Rizzo, Christopher via ipp" <[email-masked]>
Date: Fri, 7 Aug 2020 14:25:04 +0000

Mike,

So our device is returning 'successful-ok-ignored-or-substituted-attributes', and not 'successful-ok', since 'none' is not an attribute that it supports.

Why is this a failure?

Chris

Christopher Rizzo
Xerox Corporation

From: Michael Sweet <[email-masked]>
Date: Friday, August 7, 2020 at 6:43 AM
To: Christopher Rizzo <[email-masked]>
Cc: PWG Workgroup <[email-masked]>
Subject: Re: [IPP] IPP Everywhere v1.1 ipp-tests.sh test I-10.3 Get-Printer-Attributes with requested-attributes = 'none'

Chris,

On Aug 6, 2020, at 8:12 PM, Rizzo, Christopher via ipp <[email-masked]<mailto:[email-masked]>> wrote:

________________________
Michael Sweet

---

From: "Rizzo, Christopher via ipp" <[email-masked]>
Date: Fri, 7 Aug 2020 14:30:59 +0000

Could the failure be due to 'none (unsupported)' being in the unsupported-attributes group, when it should be 'requested-attributes'?

Christopher Rizzo
Xerox Corporation

From: Christopher Rizzo <[email-masked]>
Date: Friday, August 7, 2020 at 7:25 AM
To: Michael Sweet <[email-masked]>
Cc: PWG Workgroup <[email-masked]>
Subject: Re: [IPP] IPP Everywhere v1.1 ipp-tests.sh test I-10.3 Get-Printer-Attributes with requested-attributes = 'none'

Mike,

Why is this a failure?

Chris

Christopher Rizzo
Xerox Corporation

Chris,

________________________
Michael Sweet