Subject: [IPP] Fwd: IPP 5100.9 issue on "printer-alert" and "printer-alert-table"

From: Ira McDonald via ipp <[email-masked]>
Date: Thu, 13 Aug 2020 15:20:37 -0400

---------- Forwarded message ---------
From: Michael Sweet via ipp <[email-masked]>
Date: Thu, Mar 26, 2020 at 5:44 PM
Subject: Re: [IPP] IPP Everywhere ipp-tests.sh printer-alert
To: Rizzo, Christopher <[email-masked]>
Cc: PWG IPP Workgroup <[email-masked]>

To close the loop on this, during today's IPP conference call we decided to
file an errata on 5100.9 to note that "printer-alert" and
"printer-alert-description" SHOULD NOT be reported when the prtAlertTable
is empty.

I have also included this in the latest IPP Everywhere v1.1 draft along
with a note concerning existing implementations that choose to report '' or
'code=other' for an empty table.  IPP Everywhere 1.1 also now makes this
attribute RECOMMENDED for physical printers and OPTIONAL for print servers.

The IPP Everywhere self-certification tools will also be updated to a) not
require printer-alert or printer-alert-description and b) allow
printer-alert to be the empty string.

> On Mar 21, 2020, at 11:37 PM, Rizzo, Christopher <
[email-masked]> wrote:
>
> Mike,
>
> I get a failure for printer-alert when running ipp-tests.sh because there
are no alerts present in the printer and IPP printer-alert attribute is
blank.  Is it not supposed to be blank?  I can't find in specs an explicit
statement of what the value of printer-alert should be when there are no
alerts present.
>
> Thanks,
> Chris
>
> Christopher Rizzo
> Xerox Corporation
> GDG/Discovery/Advance Technology
> 26600 SW Parkway Ave.
> Wilsonville, OR 97070-9251
> Phone: (585) 314-6936
> Email: [email-masked]
>
> "The realization came over me with full force that a good part of the
remainder of my life was going to be spent in finding errors in my own
programs."
> -Maurice Wilkes, Memoirs of a Computer Pioneer

________________________
Michael Sweet

_______________________________________________
ipp mailing list
[email-masked]
https://www.pwg.org/mailman/listinfo/ipp
_______________________________________________
ipp mailing list
[email-masked]
https://www.pwg.org/mailman/listinfo/ipp

---

From: "Rizzo, Christopher via ipp" <[email-masked]>
Date: Thu, 13 Aug 2020 21:30:14 +0000

Per action item from today's meeting.

I added the issue for PWG 5100.9 for printer-alert and printer-alert-description.  Hope I did it correctly.

Also added a Github issue for IPP Everywhere v1.1 test fix to address this.

Thanks,
Chris

Christopher Rizzo
Xerox Corporation

"The realization came over me with full force that a good part of the remainder of my life was going to be spent in finding errors in my own programs."
-Maurice Wilkes, Memoirs of a Computer Pioneer

From: Ira McDonald <[email-masked]>
Date: Thursday, August 13, 2020 at 12:21 PM
To: PWG Workgroup <[email-masked]>, Michael Sweet <[email-masked]>, "Kennedy, Smith (Wireless Architect)" <[email-masked]>, Ira McDonald <[email-masked]>, Christopher Rizzo <[email-masked]>
Subject: Fwd: [IPP] IPP 5100.9 issue on "printer-alert" and "printer-alert-table"

---------- Forwarded message ---------
From: Michael Sweet via ipp <[email-masked]<mailto:[email-masked]>>
Date: Thu, Mar 26, 2020 at 5:44 PM
Subject: Re: [IPP] IPP Everywhere ipp-tests.sh printer-alert
To: Rizzo, Christopher <[email-masked]<mailto:[email-masked]>>
Cc: PWG IPP Workgroup <[email-masked]<mailto:[email-masked]>>

To close the loop on this, during today's IPP conference call we decided to file an errata on 5100.9 to note that "printer-alert" and "printer-alert-description" SHOULD NOT be reported when the prtAlertTable is empty.

I have also included this in the latest IPP Everywhere v1.1 draft along with a note concerning existing implementations that choose to report '' or 'code=other' for an empty table.  IPP Everywhere 1.1 also now makes this attribute RECOMMENDED for physical printers and OPTIONAL for print servers.

The IPP Everywhere self-certification tools will also be updated to a) not require printer-alert or printer-alert-description and b) allow printer-alert to be the empty string.

> On Mar 21, 2020, at 11:37 PM, Rizzo, Christopher <[email-masked]<mailto:[email-masked]>> wrote:
>
> Mike,
>
> I get a failure for printer-alert when running ipp-tests.sh because there are no alerts present in the printer and IPP printer-alert attribute is blank.  Is it not supposed to be blank?  I can't find in specs an explicit statement of what the value of printer-alert should be when there are no alerts present.
>
> Thanks,
> Chris
>
> Christopher Rizzo
> Xerox Corporation
> Email: [email-masked]<mailto:[email-masked]>
>
> "The realization came over me with full force that a good part of the remainder of my life was going to be spent in finding errors in my own programs."

________________________
Michael Sweet

_______________________________________________
ipp mailing list
[email-masked]<mailto:[email-masked]>
https://www.pwg.org/mailman/listinfo/ipp
_______________________________________________
ipp mailing list
[email-masked]
https://www.pwg.org/mailman/listinfo/ipp