Subject: [IPP] Updated draft of IPP Enterprise Printing Extensions v2.0 posted for review

From: "Kennedy, Smith \(Wireless & IPP Standards\) via ipp" <[email-masked]>
Date: Sat, 15 Aug 2020 13:39:20 +0000

Greetings,

I have posted an updated draft of IPP Enterprise Printing Extensions v2.0 for review next week:

https://ftp.pwg.org/pub/pwg/ipp/wd/wd-ippepx20-20200813.pdf <https://ftp.pwg.org/pub/pwg/ipp/wd/wd-ippepx20-20200813.pdf>
https://ftp.pwg.org/pub/pwg/ipp/wd/wd-ippepx20-20200813.docx <https://ftp.pwg.org/pub/pwg/ipp/wd/wd-ippepx20-20200813.docx>
https://ftp.pwg.org/pub/pwg/ipp/wd/wd-ippepx20-20200813-rev.pdf <https://ftp.pwg.org/pub/pwg/ipp/wd/wd-ippepx20-20200813-rev.pdf>
https://ftp.pwg.org/pub/pwg/ipp/wd/wd-ippepx20-20200813-rev.docx <https://ftp.pwg.org/pub/pwg/ipp/wd/wd-ippepx20-20200813-rev.docx>

Changes include:
Renamed and simplified the "proof-and-hold" collection to become "proof-copies" (integer(1:MAX));
Refactored sections 4.4 and 4.5 to now be sub-sections of a new 4.4 "Proof Printing". Also renamed "Proof and Hold" to be "Job Proof and Suspend" and restored "Job Proof Print" as the feature name from the original 5100.11-2010.
Removed the "Feature Interoperability" sub-section of section 4 and instead distributed the points to other relevant areas of the document;
Updated language for "parent-job-id" and "parent-job-uuid" as per minutes. Also added a new subsection in section 7 to state that a Printer implementing the Resubmit-Job operation is required to add these attributes to the new copy of the Job;
Moved the tables listing the standard keywords to the section defining the Job Template attribute or operation attribute, not the Printer Description attribute ("xxx- supported") and added a note in the new PWG document style policy draft;
Added definitions for Control Console and End User and simplified the definition of Password Release Job;
Clarified and expanded the definition of the Job Release feature;
Extensively rewrote the definition of the Job Storage feature;
Added minor clarifications to the Get-User-Printer-Attributes operation definition;
Moved the portions of the "job-password" and "job-password-encryption" definitions concerning printer processing to new Job Status attribute definitions, since that is really where such discussion belongs;
Clarified the definition of the "job-cancel-after" attribute;
Fixed the table formatting for the "job-password-encryption-supported" keyword listing;
Updated keywords for "ipp-features-supported" to specify keywords for all conceptual features defined in this draft;
Updated Conformance Requirements and IANA Considerations; and
Fixed many instances of passive voice and other issues once the grammar checker had additional checking criteria enabled.
Cheers,

Smith

/**
    Smith Kennedy
    HP Inc.
*/

_______________________________________________
ipp mailing list
[email-masked]
https://www.pwg.org/mailman/listinfo/ipp

---

From: "Kennedy, Smith \(Wireless & IPP Standards\) via ipp" <[email-masked]>
Date: Mon, 17 Aug 2020 17:28:43 +0000

Sorry, the URLs were wrong:

https://ftp.pwg.org/pub/pwg/ipp/wd/wd-ippepx20-20200815.pdf <https://ftp.pwg.org/pub/pwg/ipp/wd/wd-ippepx20-20200815.pdf>
https://ftp.pwg.org/pub/pwg/ipp/wd/wd-ippepx20-20200815.docx <https://ftp.pwg.org/pub/pwg/ipp/wd/wd-ippepx20-20200815.docx>
https://ftp.pwg.org/pub/pwg/ipp/wd/wd-ippepx20-20200815-rev.pdf <https://ftp.pwg.org/pub/pwg/ipp/wd/wd-ippepx20-20200815-rev.pdf>
https://ftp.pwg.org/pub/pwg/ipp/wd/wd-ippepx20-20200815-rev.docx <https://ftp.pwg.org/pub/pwg/ipp/wd/wd-ippepx20-20200815-rev.docx>

Smith

/**
    Smith Kennedy
    HP Inc.
*/

> On Aug 15, 2020, at 7:39 AM, Kennedy, Smith (Wireless & IPP Standards) via ipp <[email-masked]> wrote:
> 
> Signed PGP part
> Greetings,
>