Subject: [IPP] Updated draft of IPP Enterprise Printing Extensions v2.0 posted for review

From: "Kennedy, Smith \(Wireless & IPP Standards\) via ipp" <[email-masked]>
Date: Wed, 26 Aug 2020 13:29:19 +0000

Greetings,

Following the review at the recent F2F of the IPP Enterprise Printing Extensions v2.0 draft posted August 15, 2020, which revealed some critical flaws, I have I believe corrected those flaws and posted a new draft, available here:

https://ftp.pwg.org/pub/pwg/ipp/wd/wd-ippepx20-20200826.docx
https://ftp.pwg.org/pub/pwg/ipp/wd/wd-ippepx20-20200826.pdf
https://ftp.pwg.org/pub/pwg/ipp/wd/wd-ippepx20-20200826-rev.docx
https://ftp.pwg.org/pub/pwg/ipp/wd/wd-ippepx20-20200826-rev.pdf
https://ftp.pwg.org/pub/pwg/ipp/wd/wd-ippepx20-20200826-rev-20200815.docx
https://ftp.pwg.org/pub/pwg/ipp/wd/wd-ippepx20-20200826-rev-20200815.pdf

I have included two "-rev" versions: the "-rev" are comparing this latest draft with the last fully reviewed draft published June 30, and the "-rev-20200815" are comparing this latest draft with the most recent August 15 draft. Here is a list of changes:

August 26, 2020:
Changed wording at the start of each subsection of section 4 describing a conceptual feature, because the wording in the previous draft was inappropriate given the PWG model and its actors capable of activity;
Restored the definition of "job-password" and removed the added Job Status definitions of "job-password" and "job-password-encryption" because the internal Printer / Job values are not to be defined as "hidden Job Status attributes";
Changed all uses of the word "deprecated" to "DEPRECATED" other than those uses in the IANA Considerations section;
Fixed the IANA Considerations to reflect the state of the rest of the document; and
Restructured and updated the definition of "proof-copies".

August 15, 2020:
Renamed and simplified the "proof-and-hold" collection to become "proof-copies" (integer(1:MAX));
Refactored sections 4.4 and 4.5 to now be sub-sections of a new 4.4 "Proof Printing". Also renamed "Proof and Hold" to be "Job Proof and Suspend" and restored "Job Proof Print" as the feature name from the original 5100.11-2010.
Removed the "Feature Interoperability" sub-section of section 4 and instead distributed the points to other relevant areas of the document;
Updated language for "parent-job-id" and "parent-job-uuid" as per minutes. Also added a new subsection in section 7 to state that a Printer implementing the Resubmit-Job operation is required to add these attributes to the new copy of the Job;
Moved the tables listing the standard keywords to the section defining the Job Template attribute or operation attribute, not the Printer Description attribute ("xxx-supported") and added a note in the new PWG document style policy draft;
Added definitions for Control Console and End User and simplified the definition of Password Release Job;
Clarified and expanded the definition of the Job Release feature;
Extensively rewrote the definition of the Job Storage feature;
Added minor clarifications to the Get-User-Printer-Attributes operation definition;
Moved the portions of the "job-password" and "job-password-encryption" definitions concerning printer processing to new Job Status attribute definitions, since that is really where such discussion belongs;
Clarified the definition of the "job-cancel-after" attribute;
Fixed the table formatting for the "job-password-encryption-supported" keyword listing;
Updated keywords for "ipp-features-supported" to specify keywords for all conceptual features defined in this draft;
Updated Conformance Requirements and IANA Considerations; and
Fixed many instances of passive voice and other issues once the grammar checker had additional checking criteria enabled.

Thanks to all for  your patience and assistance in helping to review this important specification!

Cheers,
Smith

/**
    Smith Kennedy
    HP Inc.
*/

_______________________________________________
ipp mailing list
[email-masked]
https://www.pwg.org/mailman/listinfo/ipp

---

From: Ira McDonald via ipp <[email-masked]>
Date: Wed, 26 Aug 2020 09:36:56 -0400

Hi Smith,

Text of URIs is correct, but the links (check the blue) are mostly wrong.

Cheers,
- Ira

*Ira McDonald (Musician / Software Architect)Co-Chair - TCG Trusted
Mobility Solutions WG*

*Co-Chair - TCG Metadata Access Protocol SG*

*Chair - Linux Foundation Open Printing WGSecretary - IEEE-ISTO Printer
Working GroupCo-Chair - IEEE-ISTO PWG Internet Printing Protocol WGIETF
Designated Expert - IPP & Printer MIBBlue Roof Music / High North
Inchttp://sites.google.com/site/blueroofmusic
<http://sites.google.com/site/blueroofmusic>http://sites.google.com/site/highnorthinc
<http://sites.google.com/site/highnorthinc>mailto: [email-masked]
<[email-masked]>(permanent) PO Box 221  Grand Marais, MI 49839
906-494-2434*

On Wed, Aug 26, 2020 at 9:29 AM Kennedy, Smith (Wireless & IPP Standards)
via ipp <[email-masked]> wrote:

> Greetings,
>
> Following the review at the recent F2F of the IPP Enterprise Printing
> Extensions v2.0 draft posted August 15, 2020, which revealed some critical
> flaws, I have I believe corrected those flaws and posted a new draft,
> available here:
>
> I have included two "-rev" versions: the "-rev" are comparing this latest
> draft with the last fully reviewed draft published June 30, and the
> "-rev-20200815" are comparing this latest draft with the most recent August
> 15 draft. Here is a list of changes:
>
> August 26, 2020:
>
>    - Changed wording at the start of each subsection of section 4
>    describing a conceptual feature, because the wording in the previous draft
>    was inappropriate given the PWG model and its actors capable of activity;
>    - Restored the definition of "job-password" and removed the added Job
>    Status definitions of "job-password" and "job-password-encryption" because
>    the internal Printer / Job values are not to be defined as "hidden Job
>    Status attributes";
>    - Changed all uses of the word "deprecated" to "DEPRECATED" other than
>    those uses in the IANA Considerations section;
>    - Fixed the IANA Considerations to reflect the state of the rest of
>    the document; and
>    - Restructured and updated the definition of "proof-copies".
>
>
> August 15, 2020:
>
>    - Renamed and simplified the "proof-and-hold" collection to become
>    "proof-copies" (integer(1:MAX));
>    - Refactored sections 4.4 and 4.5 to now be sub-sections of a new 4.4
>    "Proof Printing". Also renamed "Proof and Hold" to be "Job Proof
>    and Suspend" and restored "Job Proof Print" as the feature name from the
>    original 5100.11-2010.
>    - Removed the "Feature Interoperability" sub-section of section 4 and
>    instead distributed the points to other relevant areas of the document;
>    - Updated language for "parent-job-id" and "parent-job-uuid" as per
>    minutes. Also added a new subsection in section 7 to state that a
>    Printer implementing the Resubmit-Job operation is required to add these
>    attributes to the new copy of the Job;
>    - Moved the tables listing the standard keywords to the section
>    defining the Job Template attribute or operation attribute, not the
>    Printer Description attribute ("xxx-supported") and added a note in the new
>    PWG document style policy draft;
>    - Added definitions for Control Console and End User and simplified
>    the definition of Password Release Job;
>    - Clarified and expanded the definition of the Job Release feature;
>    - Extensively rewrote the definition of the Job Storage feature;
>    - Added minor clarifications to the Get-User-Printer-Attributes
>    operation definition;
>    - Moved the portions of the "job-password" and
>    "job-password-encryption" definitions concerning printer processing to new
>    Job Status attribute definitions, since that is really where such
>    discussion belongs;
>    - Clarified the definition of the "job-cancel-after" attribute;
>    - Fixed the table formatting for the
>    "job-password-encryption-supported" keyword listing;
>    - Updated keywords for "ipp-features-supported" to specify keywords
>    for all conceptual features defined in this draft;
>    - Updated Conformance Requirements and IANA Considerations; and
>    - Fixed many instances of passive voice and other issues once the
>    grammar checker had additional checking criteria enabled.
>
>

---

From: "Kennedy, Smith \(Wireless & IPP Standards\) via ipp" <[email-masked]>
Date: Wed, 26 Aug 2020 14:50:34 +0000

Oh well, I guess my mail client botched generating the links somehow. Here they are again:

https://ftp.pwg.org/pub/pwg/ipp/wd/wd-ippepx20-20200826.docx <https://ftp.pwg.org/pub/pwg/ipp/wd/wd-ippepx20-20200826.docx>
https://ftp.pwg.org/pub/pwg/ipp/wd/wd-ippepx20-20200826.pdf <https://ftp.pwg.org/pub/pwg/ipp/wd/wd-ippepx20-20200826.pdf>
https://ftp.pwg.org/pub/pwg/ipp/wd/wd-ippepx20-20200826-rev.docx <https://ftp.pwg.org/pub/pwg/ipp/wd/wd-ippepx20-20200826-rev.docx>
https://ftp.pwg.org/pub/pwg/ipp/wd/wd-ippepx20-20200826-rev.pdf <https://ftp.pwg.org/pub/pwg/ipp/wd/wd-ippepx20-20200826-rev.pdf>
https://ftp.pwg.org/pub/pwg/ipp/wd/wd-ippepx20-20200826-rev-20200815.docx <https://ftp.pwg.org/pub/pwg/ipp/wd/wd-ippepx20-20200826-rev-20200815.docx>
https://ftp.pwg.org/pub/pwg/ipp/wd/wd-ippepx20-20200826-rev-20200815.pdf <https://ftp.pwg.org/pub/pwg/ipp/wd/wd-ippepx20-20200826-rev-20200815.pdf>

Smith

/**
    Smith Kennedy
    HP Inc.
*/

> On Aug 26, 2020, at 7:36 AM, Ira McDonald <[email-masked]> wrote:
> 
> Hi Smith,
> 
> Ira McDonald (Musician / Software Architect)
> Co-Chair - TCG Trusted Mobility Solutions WG
> Co-Chair - TCG Metadata Access Protocol SG
> Chair - Linux Foundation Open Printing WG
> Secretary - IEEE-ISTO Printer Working Group
> Co-Chair - IEEE-ISTO PWG Internet Printing Protocol WG
> IETF Designated Expert - IPP & Printer MIB
> Blue Roof Music / High North Inc
> http://sites.google.com/site/blueroofmusic <http://sites.google.com/site/blueroofmusic>
> http://sites.google.com/site/highnorthinc <http://sites.google.com/site/highnorthinc>
> mailto: [email-masked] <mailto:[email-masked]>
> (permanent) PO Box 221  Grand Marais, MI 49839  906-494-2434
> 
> 
> On Wed, Aug 26, 2020 at 9:29 AM Kennedy, Smith (Wireless & IPP Standards) via ipp <[email-masked] <mailto:[email-masked]>> wrote:
> Greetings,
> 
> https://ftp.pwg.org/pub/pwg/ipp/wd/ <https://ftp.pwg.org/pub/pwg/ipp/wd>wd-ippepx20-20200826.docx
> https://ftp.pwg.org/pub/pwg/ipp/wd/ <https://ftp.pwg.org/pub/pwg/ipp/wd/>wd-ippepx20-20200826.pdf
> https://ftp.pwg.org/pub/pwg/ipp/wd/ <https://ftp.pwg.org/pub/pwg/ipp/wd/>wd-ippepx20-20200826-rev.docx
> https://ftp.pwg.org/pub/pwg/ipp/wd/ <https://ftp.pwg.org/pub/pwg/ipp/wd/>wd-ippepx20-20200826-rev.pdf
> https://ftp.pwg.org/pub/pwg/ipp/wd/wd-ippepx20-20200826-rev-20200815.docx <https://ftp.pwg.org/pub/pwg/ipp/wd/wd-ippepx20-20200826-rev-20200815.docx>
> https://ftp.pwg.org/pub/pwg/ipp/wd/ <https://ftp.pwg.org/pub/pwg/ipp/wd/>wd-ippepx20-20200826-rev-20200815.pdf
> 
> [email-masked] <mailto:[email-masked]>
> https://www.pwg.org/mailman/listinfo/ipp <https://www.pwg.org/mailman/listinfo/ipp>