Subject: [IPP] IPP WG Last Call: IPP Everywhere v1.1 Printer Self-Certification Tools Update 2

From: Michael Sweet via ipp <[email-masked]>
Date: Wed, 7 Oct 2020 19:31:09 -0400

[This last call will end no earlier than October 22, 2020 at 10pm PT and requires a positive response from at least two members]

All,

I have posted yet another update of the IPP Everywhere v1.1 Printer Self-Certification Tools to:

	https://ftp.pwg.org/pub/pwg/ipp/wd/sw-ippeveselfcert11-20201007-macos.zip
	https://ftp.pwg.org/pub/pwg/ipp/wd/sw-ippeveselfcert11-20201007-rhel.tar.gz
	https://ftp.pwg.org/pub/pwg/ipp/wd/sw-ippeveselfcert11-20201007-ubuntu.tar.gz
	https://ftp.pwg.org/pub/pwg/ipp/wd/sw-ippeveselfcert11-20201007-windows.msi

This update of the tools fixes the following issues:

- Documentation updates (Issue #55)
- The "printer-alert" test did not allow an index value of -1 (Issue #58)
- The I-10 test didn't allow 'name' values for the
  "finishing-template-supported" attribute (Issue #59)
- Now allow the I-10.3 test to return the
  'successful-ok-ignored-or-substituted-attributes' status code (Issue #60)
- Now allow empty "printer-alert" values since PWG 5100.9 is ambiguous about
  how to report the absence of alerts (Issue #61)
- The "ippevesubmit" tool now supports the "-r" (replay) option for replaying
  the results of a test (Issue #65)
- The "dnssd-tests.sh" script did not correctly report errors on monochrome
  printers.

Please download and test this update with your printers and, if at all possible, report back before October 22, 2020 so that we can approve the updated tools.  You can respond to this email *or* file issues against the Github project at:

	https://github.com/istopwg/ippeveselfcert/issues

Thanks!

________________________
Michael Sweet

_______________________________________________
ipp mailing list
[email-masked]
https://www.pwg.org/mailman/listinfo/ipp

---

From: Michael Sweet via ipp <[email-masked]>
Date: Fri, 16 Oct 2020 12:34:04 -0400

Jeremy,

Thank you for the feedback!

I can look at updating the document format tests to wait for completion after each job.  Certainly we can bump the repeat count to keep the tests from failing as well.

As for media sizes, it shouldn't be too hard to add a prompt before each group of tests.

https://github.com/istopwg/ippeveselfcert/issues/66

> On Oct 16, 2020, at 11:19 AM, Jeremy Leber <[email-masked]> wrote:
> 
> Hi Michael,
> 
> My team reported the following:
> 
> It appears that the tool blasts down as many print files as the printer will accept.   On a slower color printer, which takes quite a while to print the jobs, the test script times out while the jobs are still printing.  We manually added some delays in the test script which seemed to resolve the problem.   Ideally, the test should query for "job completed" before sending the next job.  I would also be nice to see the test prompt to load the correct paper size in the tray whenever the job uses paper sizes that are different from Letter/A4.
> 
> Thanks,
> Jeremy
> 
> Jeremy Leber
> Area Owner, Network & Mobile Firmware Development
> 
> O  +1 859 825-4505
> [email-masked]
> 
> 
> www.lexmark.com
> From: ipp <[email-masked]> on behalf of Michael Sweet via ipp <[email-masked]>
> Sent: Wednesday, October 7, 2020 7:31 PM
> To: PWG IPP Workgroup <[email-masked]>
> Subject: [IPP] IPP WG Last Call: IPP Everywhere v1.1 Printer Self-Certification Tools Update 2
>  

________________________
Michael Sweet

---

From: "Kennedy, Smith \(Wireless & IPP Standards\) via ipp" <[email-masked]>
Date: Fri, 16 Oct 2020 18:19:51 +0000

Hi Mike and Jeremy,

Two points of feedback:

1. Timeouts: For all tests, we should either eliminate them and have them depend more on the printer state, or make the timeout values really big. HP ran into some similar timeouts with the early 1.1 toolsets.

2. Prompts: I do agree that it is important to test the case where the Job provides one media size but that media size isn't loaded. It is OK to include a few prompts, but I'd like to minimize their use. There is only one use of PAUSE, and that is in "ipp-tests.test".

I filed Issue #62 in ippeveselfcert (Add options to allow the IPP Everywhere Self-Certification tool set to be run non-interactively <https://github.com/istopwg/ippeveselfcert/issues/62> - https://github.com/istopwg/ippeveselfcert/issues/62 <https://github.com/istopwg/ippeveselfcert/issues/62>) because I think we ought to be able to run most of the tests non-interactively when the test scripts are run with a particular option or when an environment variable is set or whatever turns that mode on. This will facilitate integrating IPP Everywhere certification tools into automated firmware certification test systems without local modifications.

My $0.02,

Smith

/**
    Smith Kennedy
    HP Inc.
*/

> On Oct 16, 2020, at 10:34 AM, Michael Sweet via ipp <[email-masked]> wrote:
> 
> Jeremy,
> 
> https://github.com/istopwg/ippeveselfcert/issues/66 <https://github.com/istopwg/ippeveselfcert/issues/66>
> 
> 
> > www.lexmark.com <http://www.lexmark.com>
> > https://ftp.pwg.org/pub/pwg/ipp/wd/sw-ippeveselfcert11-20201007-macos.zip <https://ftp.pwg.org/pub/pwg/ipp/wd/sw-ippeveselfcert11-20201007-macos.zip>
> > https://ftp.pwg.org/pub/pwg/ipp/wd/sw-ippeveselfcert11-20201007-rhel.tar.gz <https://ftp.pwg.org/pub/pwg/ipp/wd/sw-ippeveselfcert11-20201007-rhel.tar.gz>
> > https://ftp.pwg.org/pub/pwg/ipp/wd/sw-ippeveselfcert11-20201007-ubuntu.tar.gz <https://ftp.pwg.org/pub/pwg/ipp/wd/sw-ippeveselfcert11-20201007-ubuntu.tar.gz>
> > https://ftp.pwg.org/pub/pwg/ipp/wd/sw-ippeveselfcert11-20201007-windows.msi <https://ftp.pwg.org/pub/pwg/ipp/wd/sw-ippeveselfcert11-20201007-windows.msi>
> >
> > https://github.com/istopwg/ippeveselfcert/issues <https://github.com/istopwg/ippeveselfcert/issues>
> >
> > Thanks!
> >
> > ________________________
> > Michael Sweet
> >
> >
> >
> > https://www.pwg.org/mailman/listinfo/ipp <https://www.pwg.org/mailman/listinfo/ipp>
> 
> ________________________
> Michael Sweet
> 
> 
> 
> https://www.pwg.org/mailman/listinfo/ipp <https://www.pwg.org/mailman/listinfo/ipp>

---

From: Michael Sweet via ipp <[email-masked]>
Date: Thu, 22 Oct 2020 16:25:36 -0400

All,

The 1.1 update 2 tools were approved during today's IPP workgroup conference call.  The reported issues with the document format tests (where the tests got ahead of the printer and started timing out) will be addressed in a future update of the 1.1 tools.

I will post updated links and changes to the self-certification pages soon.

> On Oct 7, 2020, at 7:31 PM, Michael Sweet <[email-masked]> wrote:
> 

________________________
Michael Sweet