Subject: [IPP] Question about "printer-finisher-supplies" in IPP Finishings 2.2

From: Steven Young via ipp <[email-masked]>
Date: Mon, 16 Nov 2020 20:16:01 +0000

Hi, Smith,

I have a question from our Firmware Engineer at Canon Inc. regarding "printer-finisher-supplies".

In 6.18.1 "Keywords for printer-finisher" Notes:1 (page 48, Line 1480), it says "If "printer-finisher-supplies" is implemented, then finDeviceIndex is REQUIRED."

  *   Question: Does it mean that the implementation of finDeviceIndex attribute, which is an attribute of Finishing MIB, is required when IPP "printer-finisher-supplies" is implemented? Some EP products have finishers but do not support the Finishing MIB.

Also, in 6.20.1 Keywords for printer-finisher-supplies" Notes:2, it says "finSupplyDeviceIndex is REQUIRED in "printer-finisher-supplies" because a connection between the supply and the finisher is needed if User / Operator engagement is required for resolving a supply level condition."

  *   Question: Some finishes do not have a Supply. For example, a stapleless stapler that does not use staplers. In this case, it does not appear in the Index because it does not have a finSupply.

Regards,

Steven

_______________________________________________
ipp mailing list
[email-masked]
https://www.pwg.org/mailman/listinfo/ipp

---

From: "Kennedy, Smith \(Wireless & IPP Standards\) via ipp" <[email-masked]>
Date: Tue, 17 Nov 2020 18:10:40 +0000

Hi Steven,

> On Nov 16, 2020, at 1:16 PM, Steven Young via ipp <[email-masked]> wrote:
> 
> Hi, Smith,
> 
> I have a question from our Firmware Engineer at Canon Inc. regarding “printer-finisher-supplies”.
> 
> In 6.18.1 “Keywords for printer-finisher” Notes:1 (page 48, Line 1480), it says “If "printer-finisher-supplies" is implemented, then finDeviceIndex is REQUIRED.”
> Question: Does it mean that the implementation of finDeviceIndex attribute, which is an attribute of Finishing MIB, is required when IPP "printer-finisher-supplies" is implemented? Some EP products have finishers but do not support the Finishing MIB.

I believe this is a typo - it is referring to the "index" keyword. Basically, if the Printer implements the "printer-finisher-supplies" Printer Description attribute, it MUST also provide the "index" key in "printer-finisher". So it ought to instead say something like:

A Printer MUST supply the "index" key if the Printer supports the "printer-finisher-supplies" Printer Description attribute.

I'll fix that in the next revision I publish. (Reading this after editing the IPP Driverless Printing Extensions v2.0 (NODRIVER) and IPP Enterprise Printing Extensions v2.0 specs, I think I need to do more than just fix the several errata issues. So much for a light touch update. )

> 
> Also, in 6.20.1 Keywords for printer-finisher-supplies” Notes:2, it says “finSupplyDeviceIndex is REQUIRED in "printer-finisher-supplies" because a connection between the supply and the finisher is needed if User / Operator engagement is required for resolving a supply level condition.”
> Question: Some finishes do not have a Supply. For example, a stapleless stapler that does not use staplers. In this case, it does not appear in the Index because it does not have a finSupply.

I think we need to clean up all the normative language in 6.20 because it isn't clear what a Printer needs to do if it, for instance, only has finishing modules that don't require any supplies, or a mixture of finishing modules that do and don't require supplies. I've made a comment in my working draft master copy.

> [email-masked] <mailto:[email-masked]>
> https://www.pwg.org/mailman/listinfo/ipp <https://www.pwg.org/mailman/listinfo/ipp>