Subject: [IPP] IPP Enterprise Printing Extensions v2.0: Restrict Job Release to only those that support spooling?

From: "Kennedy, Smith \(Wireless & IPP Standards\) via ipp" <[email-masked]>
Date: Thu, 3 Dec 2020 22:01:44 +0000

Greetings,

>From our November 2020 F2F review*** of IPP Enterprise Printing Extensions v2.0, an unanswered question was whether the specification ought to require that the Printer spool the Job, and so restrict the Job Release feature to only those Printers that report 'spool' or 'automatic' for "job-spooling-supported", and if the Printer reports 'automatic', then it MUST spool Jobs that include the "job-release" Job Template attribute.

Is there is a need to support Job Release on printers that cannot spool (store the Job before processing)?

Thanks for any thoughts,

Smith

/**
    Smith Kennedy
    HP Inc.
*/

_______________________________________________
ipp mailing list
[email-masked]
https://www.pwg.org/mailman/listinfo/ipp

---

From: Sean Kau via ipp <[email-masked]>
Date: Mon, 7 Dec 2020 15:55:34 -0800

I could see a desire to support job-release on lower end printers that
wouldn't have enough memory to spool a job.  However, I think this is
undesirable from a service perspective as this will likely cause a print
spooler to hang, waiting forever for the printing to start.  However, what
do we do if the printer "supports" spooling but the job is too large?  This
would require similar resolution (unless we reject those jobs).

Sean

On Thu, Dec 3, 2020 at 2:01 PM Kennedy, Smith (Wireless & IPP Standards)
via ipp <[email-masked]> wrote:

> Greetings,
>
> From our November 2020 F2F review*** of IPP Enterprise Printing Extensions
> v2.0, an unanswered question was whether the specification ought to require
> that the Printer spool the Job, and so restrict the Job Release feature to
> only those Printers that report 'spool' or 'automatic' for
> "job-spooling-supported", and if the Printer reports 'automatic', then it
> MUST spool Jobs that include the "job-release" Job Template attribute.
>

-- 
Sean Kau

---

From: Michael Sweet via ipp <[email-masked]>
Date: Tue, 8 Dec 2020 10:41:59 -0500

Sean,

> On Dec 7, 2020, at 6:55 PM, Sean Kau via ipp <[email-masked]> wrote:
> 
> I could see a desire to support job-release on lower end printers that wouldn't have enough memory to spool a job.  However, I think this is undesirable from a service perspective as this will likely cause a print spooler to hang, waiting forever for the printing to start.  However, what do we do if the printer "supports" spooling but the job is too large?  This would require similar resolution (unless we reject those jobs).

Typically, if a *document* is too large a printer will return the 'server-error-too-many-documents' or 'server-error-busy' status-code, with 'spool-area-full' in the "printer-state-reasons" attribute.  We also have attributes reporting the maximum document size in k-octets (1024 bytes or "kibibytes"): "job-k-octets-supported", "pdf-k-octets-supported", and "jpeg-k-octets-supported" (the latter two were added so that a Client doesn't need to query the printer multiple times for those two popular formats).

If we decide that job release requires spooling support (and I think we should), it might be useful to have EPX require a minimum amount of job spooling space (AirPrint requires 64MiB or 65536 k-octets) for interoperability.  Of course, if you have complex PDF documents with multiple embedded high-resolution images the size of the PDF can easily grow beyond 64MiB, but typical office documents are much smaller, e.g., PWG 5108.1-2011 (MFD Model 1.0) is the largest of our specifications and comes in at 10.2MiB for 216 pages...

________________________
Michael Sweet

---

From: "Kennedy, Smith \(Wireless & IPP Standards\) via ipp" <[email-masked]>
Date: Tue, 8 Dec 2020 17:53:52 +0000

Hi Mike and Sean,

> On Dec 8, 2020, at 8:41 AM, Michael Sweet <[email-masked]> wrote:
> 
> Sean,
> 

Yep, what Mike said...

> If we decide that job release requires spooling support (and I think we should), it might be useful to have EPX require a minimum amount of job spooling space (AirPrint requires 64MiB or 65536 k-oc…

I agree with this suggestion. Even if we doubled the required minimum job spooling space to 128MB, at this point that shouldn't be onerous. And many printers that traditionally supported features similar to Job Release have substantial secondary storage (spinning platter or SSD hard drive) available so these limits are really only for "small" devices.
_______________________________________________
ipp mailing list
[email-masked]
https://www.pwg.org/mailman/listinfo/ipp