Subject: [IPP] References to hashing algorithms in definition of "job-password-encryption"?

From: "Kennedy, Smith \(Wireless & IPP Standards\) via ipp" <[email-masked]>
Date: Thu, 17 Dec 2020 20:17:29 +0000

Hi Ira,

Can you suggest specifications that we might reference for the hashing algorithm keywords defined for "job-password-encryption"? We currently reference FIPS180-4 and FIPS202 but it was suggested that those were not suitable as references in a PWG specification, because of inaccessibility because of paywalls, etc.

Thanks for any help!

Smith

/**
    Smith Kennedy
    HP Inc.
*/

_______________________________________________
ipp mailing list
[email-masked]
https://www.pwg.org/mailman/listinfo/ipp

---

From: Ira McDonald via ipp <[email-masked]>
Date: Thu, 17 Dec 2020 15:36:19 -0500

Hi Smith,

Crossed wires here.

All US NIST documents (FIPS, SP800, SP500, etc.) are free and have durable
URLs.
I think there was a delusion that, because of *not* using the equivalent
ISO specs
(which are behind paywalls), we needed to shift to IETF RFCs.  Since our
references
are specifically relative to hash algorithms or encryption algorithms, I
suggest that we
should have both US NIST and IETF references to free standards.  NIST has
written
about implementation details much more deeply for most hash algorithms
(i.e., I would
not want to implement based only on the IETF RFCs).

I'll look at your IPP standard draft for the details and recommend
(probably) a few more
US NIST standards (updated ones) and associated IETF RFCs.

Cheers,
- Ira

*Ira McDonald (Musician / Software Architect)*

*Chair - SAE Trust Anchors and Authentication TF*
*Co-Chair - TCG Trusted Mobility Solutions WG*

*Co-Chair - TCG Metadata Access Protocol SG*

*Chair - Linux Foundation Open Printing WGSecretary - IEEE-ISTO Printer
Working GroupCo-Chair - IEEE-ISTO PWG Internet Printing Protocol WGIETF
Designated Expert - IPP & Printer MIBBlue Roof Music / High North
Inchttp://sites.google.com/site/blueroofmusic
<http://sites.google.com/site/blueroofmusic>http://sites.google.com/site/highnorthinc
<http://sites.google.com/site/highnorthinc>mailto: [email-masked]
<[email-masked]>(permanent) PO Box 221  Grand Marais, MI 49839
906-494-2434*

On Thu, Dec 17, 2020 at 3:17 PM Kennedy, Smith (Wireless & IPP Standards) <
[email-masked]> wrote:

> Hi Ira,
>
> Can you suggest specifications that we might reference for the hashing
> algorithm keywords defined for "job-password-encryption"? We currently
> reference FIPS180-4 and FIPS202 but it was suggested that those were not
> suitable as references in a PWG specification, because of inaccessibility
> because of paywalls, etc.
>
> Thanks for any help!
>
> Smith
>
> /**
>     Smith Kennedy
>     HP Inc.
> */
>
>

---

From: Ira McDonald via ipp <[email-masked]>
Date: Mon, 21 Dec 2020 11:31:42 -0500

Hi Smith,

I'm working on the IETF RFC references and checking the US NIST references
for the hash algorithms in Table 10 of EPX.

I downloaded the MS Word source "wd-ippepx20-20201029.docx" just now.  My
copy of MS Word 2019 cannot open it - says it contains "unreadable" content
and
suggests a recovery attempt - I didn't try it.

OTOH, the MS Word source "wd-ippepx20-20201029-rev.docx" does open OK
without warnings.

I'm not sure what version of MS Word you're using or what OS platform.  But
the
source of the eventual published version needs to be stable and readable for
future maintenance.

More later on the hash algorithm references.

Cheers,
- Ira

---

From: "Kennedy, Smith \(Wireless & IPP Standards\) via ipp" <[email-masked]>
Date: Mon, 21 Dec 2020 17:19:05 +0000

Hi Ira,

> On Dec 21, 2020, at 9:31 AM, Ira McDonald <[email-masked]> wrote:
> 
> copy of MS Word 2019 cannot open it - says it contains "unreadable" content and
> I'm not sure what version of MS Word you're using or what OS platform.  But the

My local copy opens without complain on both macOS and Windows 10, but the one on the FTP site is broken. I am not sure why the upload got messed up but the SHA256 hashes of my local copy of "wd-ippepx20-20201029.docx" and the one on the FTP site don't match. I just pushed up a new copy and it loads as expected  - try again:

https://ftp.pwg.org/pub/pwg/ipp/wd/wd-ippepx20-20201029.docx <https://ftp.pwg.org/pub/pwg/ipp/wd/wd-ippepx20-20201029.docx>

---

From: Ira McDonald via ipp <[email-masked]>
Date: Mon, 21 Dec 2020 12:41:26 -0500

Hi Smith,

Thanks for uploading the correct clean draft to the FTP site.

Attached is your latest "-rev" MS Word version with all of the necessary
IETF RFC references added
(or corrected) and the US NIST FIPS references added.  I also added a few
informative MS Word
comments for your use (please read them).  I updated the Normative and
Informative References
sections accordingly.

Cheers,
- Ira

On Mon, Dec 21, 2020 at 12:19 PM Kennedy, Smith (Wireless & IPP Standards) <
[email-masked]> wrote:

> My local copy opens without complain on both macOS and Windows 10, but the
> one on the FTP site is broken. I am not sure why the upload got messed up
> but the SHA256 hashes of my local copy of "wd-ippepx20-20201029.docx" and
> the one on the FTP site don't match. I just pushed up a new copy and it
> loads as expected  - try again:
>
> https://ftp.pwg.org/pub/pwg/ipp/wd/wd-ippepx20-20201029.docx
>
>
>
>

---

From: "Kennedy, Smith \(Wireless & IPP Standards\) via ipp" <[email-masked]>
Date: Tue, 22 Dec 2020 18:00:24 +0000

Thanks Ira! I've saved your file to incorporate it into the next revision. I'll let you know if I have any questions.

Smith

> On Dec 21, 2020, at 10:41 AM, Ira McDonald <[email-masked]> wrote:
> 
> Hi Smith,
> 
> Attached is your latest "-rev" MS Word version with all of the necessary IETF RFC references added
> (or corrected) and the US NIST FIPS references added.  I also added a few informative MS Word
> comments for your use (please read them).  I updated the Normative and Informative References
> sections accordingly.
> 
> Cheers,
> - Ira
> 
> 
> Ira McDonald (Musician / Software Architect)
> Chair - SAE Trust Anchors and Authentication TF
> Co-Chair - TCG Trusted Mobility Solutions WG
> Co-Chair - TCG Metadata Access Protocol SG
> Chair - Linux Foundation Open Printing WG
> Secretary - IEEE-ISTO Printer Working Group
> Co-Chair - IEEE-ISTO PWG Internet Printing Protocol WG
> IETF Designated Expert - IPP & Printer MIB
> Blue Roof Music / High North Inc
> http://sites.google.com/site/blueroofmusic <http://sites.google.com/site/blueroofmusic>
> http://sites.google.com/site/highnorthinc <http://sites.google.com/site/highnorthinc>
> mailto: [email-masked] <mailto:[email-masked]>
> (permanent) PO Box 221  Grand Marais, MI 49839  906-494-2434
> 
> 
> On Mon, Dec 21, 2020 at 12:19 PM Kennedy, Smith (Wireless & IPP Standards) <[email-masked] <mailto:[email-masked]>> wrote:
> Hi Ira,
> 
>> On Dec 21, 2020, at 9:31 AM, Ira McDonald <[email-masked] <mailto:[email-masked]>> wrote:
>> 
> <wd-ippepx20-20201029-rev-ira.docx>