Subject: RE: [ippm] concatenation of QoS parameters

From: Grotefeld Glenn-cecl03 <[email-masked]>
Date: Thu, 14 Feb 2002 11:14:26 -0600

"On the other hand, if there exist global
~congestion oscillation phenomena (and why wouldn't they?) the
~assumption would be incorrect."

Or, in another form, you can expect significant "tidal" effects such as time-of-day/day-of-week.  While IP traffic may not have a "Mother's Day (US)" causing a huge spike in traffic like the phone system has, there may other equivalents in the IP that I just do not recognize.

Glenn Grotefeld

Motorola, Inc.
[email-masked]
US  847 435-0730
      847 632-6800 FAX

~-----Original Message-----
~From: stanislav shalunov [mailto:[email-masked]]
~Sent: Thursday, February 14, 2002 11:04 AM
~To: [email-masked]
~Cc: IPPM Working Group
~Subject: Re: [ippm] concatenation of QoS parameters
~
~
~This is probably outside of scope of IPPM WG activities (and in the
~realm of a statistics), but: Everything hinges on the assumption of
~independent distribution of the delay variables for different domains.
~On one hand, since the next domain doesn't explicitly know about
~treatment in the previous one you could say that the independence
~assumption should be true.  On the other hand, if there exist global
~congestion oscillation phenomena (and why wouldn't they?) the
~assumption would be incorrect.
~
~Further, you do not specify your metrics.  Averages, for example,
~would be much easier to analyze in this way than medians.
~
~Victor Reijs <[email-masked]> writes:
~
~> . OWD. I assume, I can just add figures in case of concatenation of
~> domains.
~
~Sum is correct for averages regardless of independence.
~
~> . IPDV. This is a difficult one. I would tend to say one can not just
~> added the figures. I once heard a convolution is needed 
~here. What are
~> your ideas?
~
~Sum is correct for variances provided that there is independence.
~
~> . IP Packet Loss.
~
~Loss probability, assuming independence, is, of course, 1-\Pi(1-p_i).
~Accidentally, for small values of p_i the first order approximation of
~this quantity happens to be \Sigma p_i.
~
~> . IP Loss patterns.
~
~No numeric parameter.
~
~> . IP packet reordering:
~
~No defined metric and no defined model.
~
~> The above was for the millisec range, perhaps other ideas are needed
~> in microsec range.
~
~Scale doesn't matter.
~
~-- 
~Stanislav Shalunov		http://www.internet2.edu/~shalunov/
~
~"You wake me up early in the morning to tell me I am right?  Please
~wait until I am wrong."	-- John von Neumann, on being 
~phoned at 10 a.m.
~_______________________________________________
~ippm mailing list
[email-masked]
~http://mailhost.advanced.org/mailman/listinfo/ippm
~
_______________________________________________
ippm mailing list
[email-masked]
http://mailhost.advanced.org/mailman/listinfo/ippm

---

From: stanislav shalunov <[email-masked]>
Date: 14 Feb 2002 12:56:39 -0500

Grotefeld Glenn-cecl03 <[email-masked]> writes:

> Or, in another form, you can expect significant "tidal" effects such
> as time-of-day/day-of-week.  While IP traffic may not have a
> "Mother's Day (US)" causing a huge spike in traffic like the phone
> system has, there may other equivalents in the IP that I just do not
> recognize.

Glenn,

I believe the tidal effects with timescales much larger than the time
of delivery of a single packet per se do not violate the independence
assumption for the purposes of our argument.

However, tidal effects with timescales similar to those required to
deliver a packet would destroy the independence assumption completely.
While I don't have evidence of their existence, I don't see why it
would be obvious that they do not exist.  The assumption of
independence is not self-evident and should be spelled out when used.

-- 
Stanislav Shalunov		http://www.internet2.edu/~shalunov/

Al your Qaeda are belong to US.
_______________________________________________
ippm mailing list
[email-masked]
http://mailhost.advanced.org/mailman/listinfo/ippm