Subject: RE: [ippm] test packet size over IP network

From: <[email-masked]>
Date: Fri, 26 Jul 2002 08:01:41 +0300

Hi,

just to provide a further viewpoint in addition to the previous answers: small packet sizes are probably desirable for generic one-way delay tests, whereas a larger packet size may give useful information about performance for a particular application. This issue has been mentioned in the "periodic measurements" (npmps) draft.

The two approaches are complementary to each other, and may have different uses. For example, most of the test streams may be performed with Poisson sampling and small packet sizes, but occasionally an "application level performance" test can be conducted with regular test packet spacing & packet size corresponding to a VoIP codec, for example.

	BR,
	  Vilho

> -----Original Message-----
> From: ext raymond zhang [mailto:[email-masked]]
> Sent: 25 July 2002 20:54
> To: Matthew J Zekauskas
> Cc: [email-masked]
> Subject: Re: [ippm] test packet size over IP network
> 
> 
> At 12:35 PM 7/25/2002 -0400, you wrote:
> >>I wonder if anyone can provide some references or input in 
> selecting test
> >>packet size for measuring one-way-delay.
> >
> >draft-ietf-ippm-owmetric-as-00.txt is a (very) initial 
> attempt to try to
> >address this, among other issues.
> >
> >As always, "it depends on what you are trying to measure".
> >
> >I can tell you what the two systems I know well do.  The 
> Surveyor system
> >used minimal-sized UDP packets, which in our case was 12 
> bytes (so the
> >physical packet size adds the UDP, IP, and any MAC header).  
> The RIPE-TT
> >system used 100 byte UDP packets the last time I looked.
> >
> >The idea behind small packets was to not send significant 
> traffic, and just
> >get a broad overview of the network's health.
> 
> If this is the goal, then the smaller test probe packets 
> seems to be a 
> better choice without putting whole of traffic over the 
> network.   Private 
> IP networks seem to have bigger average packet sizes than ones in the 
> public internet so 64 byte packet may be too small so 100 
> byte (including 
> payload, udp and ip) seems to be the balance.
> 
> 
> >I'd be interested in what other vendors use and why (I know there are
> >a few on the list).
> >'
> 
> 
> I'd also be interested in what other SPs use as well...
> 
> 
> >--Matt
> 
> 
> _______________________________________________
> ippm mailing list
> [email-masked]
> http://mailhost.advanced.org/mailman/listinfo/ippm
> 

_______________________________________________
ippm mailing list
[email-masked]
http://mailhost.advanced.org/mailman/listinfo/ippm

---

From: "Balaji H. Kasal" <[email-masked]>
Date: Fri, 26 Jul 2002 17:05:02 +0530

Dear friends,

   There is no single packet size which can be used for measurement, bec' 
of large variation in packet sizes in Internet. 
   To study true application performance one should use different packet 
sizes and find out the distribution. (That was most appl does... 
streaming...)
   Ofcourse, it is not smart to probe large packets of different sizes for 
measurement. One can findout "optimal" packet size for measurement. We can 
define "optimal" packet size which represents (almost... median???) 
overall distribution.
   
With Best Wishes,
--Balaji	

-- 
Regards,
--Balaji

---

From: Emmanuel Tychon <[email-masked]>
Date: 26 Jul 2002 14:16:33 +0200

On Fri, 2002-07-26 at 13:31, Balaji H. Kasal wrote:

> Of course, it is not smart to probe large packets of different sizes for 

I guess that what IMIX distribution[1] try to do. This represents, based
on observation, a best model of today's internet most frequent packet
size. This is not the panacea, but it's quite interesting anyway.

[1]
http://advanced.comms.agilent.com/RouterTester/member/journal/1MxdPktSzThroughput.html

e.

---

From: stanislav shalunov <[email-masked]>
Date: 26 Jul 2002 14:55:56 -0400

"Balaji H. Kasal" <[email-masked]> writes:

> We can define "optimal" packet size which represents
> (almost... median???)  overall distribution.

1. The distribution of packet sizes is different for different
   networks.

2. The distribution of packet sizes changes over time.

3. What do you care about delay of a median-sized packet if your
   packets are twice larger (or smaller)?

-- 
Stanislav Shalunov		http://www.internet2.edu/~shalunov/

"You wake me up early in the morning to tell me I am right?  Please
wait until I am wrong."	-- John von Neumann, on being phoned at 10 a.m.
_______________________________________________
ippm mailing list
[email-masked]
http://mailhost.advanced.org/mailman/listinfo/ippm