Subject: RE: [ippm] IPPM REPORTING MIB UTC Synchonization state

From: "STEPHAN Emile FTRD/DAC/LAN" <[email-masked]>
Date: Tue, 13 Aug 2002 00:15:59 +0200

Hi Henk, Stan

from my point of  view the semantic of the bit S has to be clarify. 
It has to indicate clealy that the probe has no external time reference;
It has to indicate the synchronisation state of the clock used to
timestamp the packet send by the source: The results of the measure have
to describe the variation of the state of network, not the uncertainty
of the clock.

As the semantic of the states have to be the same in the IPPM REPORTING
MIB and OWAMP I propose that we modify the ippmSynchonizationState
definition during the discution.

	ippmUTCSynchonizationState OBJECT-TYPE
	SYNTAX INTEGER  {
		other(0),
		unsynchronized(1),
		synchronizing(2),
		synchronized(4)
	}
	MAX-ACCESS read-only
	STATUS     current
	DESCRIPTION
" ippmUTCSynchonizationState describes the state of the clock
synchronization.
The states not managed must be listed in the object
ippmSystemSynchonizationDescription. 

The following state machine is proposed:

--- other -----------    ------- unsynchronized --------
       |                               ^
       |                               |
  External clock                       |
  reference                    synchronization done 
  on board                     in a duration > to
       |                       ippmSynchronizationTimeout
       |                               |
       |                               |
       V                               |
 --- synchronizing ---------------------------------------
       |                               ^    
       |                               |    
       |                               |      
 synchronization done           synchronization
 in a duration < to               lost
 ippmSynchronizationTimeout            |
       |                               |
       |                               |
       |                               |
       V                               |
 --- synchronized ---------------------------------------

Other(0)
The status of the synchronization is unknown.
example: 
	A clock not synchronized to an external clock is 'Other'.

unsynchronized(1)
The system is not synchronized. 
example:
	The probe can only get time from a GPS card but the antenna is
disconnected.

synchronizing(2) 
The system is receiving synchronization information but is not yet
synchronized. 
example:
The synchonisation task switch to a stratum 1 backup because the window
is temporarily blocked.

synchronized(4) 
The system is synchronized. 
"

regards
Emile

> -----Message d'origine-----
> De : stanislav shalunov [mailto:[email-masked]]
> Envoye : vendredi 2 aout 2002 09:52
> A : STEPHAN Emile FTRD/DAC/LAN
> Cc : [email-masked]
> Objet : Re: [ippm] Synchonization state: 'initializing'
> 
> 
> "STEPHAN Emile FTRD/DAC/LAN" 
> <[email-masked]> writes:
> 
> > 	Management systems need generic state to decide when the
> > measure issued = from the probes may be used or not to compute
> > trustable results.
> > 
> > the 'initializing' state is generic enough to describe that they are
> > not = yet synchrnized and that they consider to gain the
> > synchronized state = soon.=20
> 
> How soon?
> 
> If I was getting the time from my GPS card and I am in the process of
> switching to a stratum 1 backup because the window is temporarily
> blocked, am I `initializing'?
> 
> If I only can get time from my GPS card, boot up and start up ntpd,
> but the antenna is disconnected, am I `initializing'?  It might take
> me a day or two to synchronize.
> 
> -- 
> Stanislav Shalunov		http://www.internet2.edu/~shalunov/
> 
> "Which one is worse?  Both are worse."		-- V. I. Lenin
> 

_______________________________________________
ippm mailing list
[email-masked]
http://mailhost.advanced.org/mailman/listinfo/ippm

---

From: stanislav shalunov <[email-masked]>
Date: 12 Aug 2002 18:28:41 -0400

> 		synchronized(4)

Emile,

I don't see the difference between the first three states (other,
unsynchronized, and synchronizing).

What exactly is `other'?

How is synchronizing different from unsynchronized?  If the difference
is that synchronizing plans to become synchronized at some future time
while unsynchronized makes a promise to never ever become
synchronized, then why would anyone possibly care to know it?  A
synchronizing clock is still unsynchronized.  There's no indication
when it will become synchronized.

Religion is the opium of them asses.		--Karlm Arx
_______________________________________________
ippm mailing list
[email-masked]
http://mailhost.advanced.org/mailman/listinfo/ippm