Subject: RE: [ippm] availability

From: Grotefeld Glenn-cecl03 <[email-masked]>
Date: Thu, 1 Aug 2002 08:03:26 -0500

However, I find most of the ITU documents so generic that the "devil is in
the details" of determining what constitutes pass/fail performance (again,
at least starting with E.800, the ITU approach is very much 0/1 on
performance).

> Glenn Grotefeld
> Motorola, Inc.
> [email-masked]
> US  847 435-0730
>       847 632-6800 FAX

-----Original Message-----
From: Robert Holley [mailto:[email-masked]]
Sent: Thursday, August 01, 2002 7:32 AM
To: Henk Uijterwaal \(RIPE-NCC\); Henrik Holland
Cc: IPPM IETF
Subject: RE: [ippm] availability

Henrik,
Henk,

This is a somewhat delayed response to the request on availability, but I
would like to throw this out.

The ITU has developed a very generic framework for developing availability
definitions for network services independent of technology.

The defintion is spread out over several different documents. Logically, it
explains a method for developing definitions on availability. In the case of
IP networks, I can speculate that the defintions from the IPPM group would
be used to feed the upstream definitions. The upstream defintions could be
used to describe how the network is performing overtime. The IPPM metrics
supply a measurement set that records the state of the network at one point
in time. Multiple measurement sets would be rolled up and used to determine
"availabilty" overtime such as on a monthly or yearly basis.

regards
============================================
Robert Holley
Network Consulting Engineer
Global Solutions Engineering

Cisco Systems
7025 Kit Creek Road.
Research Triangle Park, NC 27709
Phone:  +1 919-392-2359
Pager:   +1 800-796-7363 pin 100-9187
============================================

> -----Original Message-----
> From: [email-masked] [mailto:[email-masked]]On Behalf
> Of Henk Uijterwaal (RIPE-NCC)
> Sent: Friday, July 12, 2002 5:46 AM
> To: Henrik Holland
> Cc: IPPM IETF
> Subject: Re: [ippm] availability
>
>
> Hi Henrik,
>
> > This may not be directly IPPM but maybe some of you can help me. In
> > http://netperformance.genuity.com/documents/Methodology1.pdf I find:
> >
> > "The Internet Engineering Task Force (IETF) specifies that a network
> > element is "available" if it responds successfully to a minimum
> of 15 pings
> > out of 20 it receives."
> >
> > Can anyone tell me where (in what doc) the IETF specifies this?
>
> It is definitely not in any IPPM document.
>
> It would also be a very silly metric: if I'm accessing a device through
> protocol X, I want to know if it responds to that protocol, not if it
> responds to another protocol.
>
> Henk
>
>
> ------------------------------------------------------------------
> ------------
> Henk Uijterwaal                    Email: [email-masked]
> RIPE Network Coordination Centre     WWW: http://www.ripe.net/home/henk
> Singel 258                         Phone: +31.20.5354414
> 1016 AB Amsterdam                    Fax: +31.20.5354445
> The Netherlands                   Mobile: +31.6.55861746
> ------------------------------------------------------------------
> ------------
>
> That problem that we weren't having yesterday, is it better? (Big ISP NOC)
>
> NOTE: My email address (and a hole in our mailing list software) is being
>       abused by a spammer.  We are working on fixing this hole
> and tracking
>       the spammer down.  If you receive mail from "[email-masked]" that is
>       obviously spam, please send me a copy of the mail including
> ALL headers.
>       I'm sorry for any inconvenience caused by this.
>
> _______________________________________________
> ippm mailing list
> [email-masked]
> http://mailhost.advanced.org/mailman/listinfo/ippm
>

_______________________________________________
ippm mailing list
[email-masked]
http://mailhost.advanced.org/mailman/listinfo/ippm
_______________________________________________
ippm mailing list
[email-masked]
http://mailhost.advanced.org/mailman/listinfo/ippm

---

From: "Robert Holley" <[email-masked]>
Date: Thu, 1 Aug 2002 09:16:53 -0400

True, details are problematic. However, in this case, the details of the
measurements are being provided by the IETF IPPM group. Which values of
those measurements consitute a pass/fail would be defined in an
"Availability Function". There can be provisional values recommended, but in
general the definition of the availability function is ultimiately left to
the administrator who deploys the system to monitor a network service. The
benitif of flexibility is that different administrator may have differnt
requirements for what constitutes a pass/fail condition.

After the pass/fail crieteria have been defined, they are applied to single
set of measurements on a single set of measurement end-points to determine
if that single set of measurements passes or fails.

The next level is the "Availability Performance".

The availability performance would define how often the set of measurements
should be collected, on how many and which endpoints collections should be
made, and after considering multiple sets of pass/fail data, what is the
availabilty over time for a service deployed across the network.

regards

Cisco Systems
7025 Kit Creek Road.

> From: Grotefeld Glenn-cecl03 [mailto:[email-masked]]
> Sent: Thursday, August 01, 2002 9:03 AM
> To: 'Robert Holley'; Henk Uijterwaal \(RIPE-NCC\); Henrik Holland
> Cc: IPPM IETF