Subject: [ippm] [Fwd: State of MPLS deployments today]

From: Robert Raszuk <[email-masked]>
Date: Thu, 03 Oct 2002 12:23:31 +0200

Kava,

> first of all I should mention that MPLS deployment is far from being done (I
> don't think that it has been deployed even in a large network operator) and
> I largely suspect that it will never be deployed in a large scale to be the
> primary backbone technology !!!!

Would you mind sharing with me your definition of "large network
operator" ? For me operators like ATT, BT, DT, FT, TI, Level3, Worldcom,
JT, KDDI and many many more are of the size I would considered as
"large" on this planet. 

All of them are using MPLS and MPLS applications in their backbones. 

Only a very few IP purists who get high blood pressure when one next to
them says MPLS don't use it and that is also absolutely fine. 

Just one more comment:

MPLS was never intended to boost network performance but to offer a new
paradigm for various applications which benefit from not pure
traditional dst based lookup at each hop. Sure IP can emulate it as well
with tunnels, but it is obvious that in this case, when talking about
production deployements IP is catching up with applications already
offered by MPLS today in a scalable way.

Rgs,
R.

> From: Kavé Salamatian <[email-masked]>
> To: Shen Jing <[email-masked]>, [email-masked]
> Cc: [email-masked]
> Subject: RE: [ippm] [e2e] Mathematical analysis of e2e lable switching path
> Date: 03 Oct 2002 09:56:39 +0200
> 
> Dear Shen,
> 
> first of all I should mention that MPLS deployment is far from being done (I
> don't think that it has been deployed even in a large network operator) and
> I largely suspect that it will never be deployed in a large scale to be the
> primary backbone technology !!!!
> 
> >From the point of view of measurement, LSP networks should not have too much
> difference from traditional IP networks as nowadays IP routing performance
> is getting very  close to Label switching performance, meaning that the
> delay of crossing an LSP network should not be significantly larger than an
> IP network. The difference may come from a simpler  traffic engineering in
> MPLS. Meaning that we should evaluate the effect of traffic engineeringon
> performance, not the particuliar behaviour of MPLS network.
> 
> Bests
> 
> Kv
> -----Message d'origine-----
> De?: [email-masked] [mailto:[email-masked]]De la part de
> Shen Jing
> Envoyé?: dimanche 29 septembre 2002 04:28
> à?: [email-masked]
> Cc?: [email-masked]
> Objet?: [ippm] [e2e] Mathematical analysis of e2e lable switching path
> 
> 
> Hi there,
> 
> I've some question on e2e performance analysis of
> label switching path.
> 
> There has been many research on e2e performance
> analysis for IP routing. Nearly all of them take the
> model of "network of queue", and under assumpiton of
> Possion Arrival, exponential flow size etc. To my
> limited knowledge, this is not to the state of
> Internet which experiences LRD. On the other hand,
> different router archtecture must have different
> effect on transmission performance.
> As MPLS proceeds to be the primary backbone
> technology, I think there must be something new
> introduced into the e2e performance in internet.
> 
> So, I want to know, whether there is some work with
> methematical modeling of LSP networks? and, are there
> anyone would do me a favor to recommend some refrence
> book, web page, research paper or the like ?
> 
> Thank you very much.
> 
> Best regards
> 
> 
> =====
> Jing Shen
> 
> State Key Lab of CAD&CG
> ZheJiang University(YuQuan)
> HangZhou, ZheJiang Province 310027
> P.R.China
> 
> _________________________________________________________
> Do You Yahoo!?
> "发短信赢手机,快来参加雅虎巨星秀!"
> http://cn.ent.yahoo.com/star/midautumn/index.html
> 
> _______________________________________________
> ippm mailing list
> [email-masked]
> http://mailhost.advanced.org/mailman/listinfo/ippm
> 
> _______________________________________________
> ippm mailing list
> [email-masked]
> http://mailhost.advanced.org/mailman/listinfo/ippm
_______________________________________________
ippm mailing list
[email-masked]
http://mailhost.advanced.org/mailman/listinfo/ippm

---

From: Kavé Salamatian <[email-masked]>
Date: Thu, 3 Oct 2002 21:38:31 +0200

>JT, KDDI and many many more are of the size I would considered as
I was saying that today we don't have yet (or at least I have not heard of)
a full MPLS large network. I was not meaning that nobody is using MPLS in
portion of his network.

But obviously there are large full IP network that operate well (at least in
their core) and does not seem to believe to an urgent need for MPLS.

>All of them are using MPLS and MPLS applications in their backbones.
Nice for MPLS constructors

>them says MPLS don't use it and that is also absolutely fine.
It seems that the search for purity is not restricted to IPist there are
also some MPLS zeloat around :-) sorry to give you high blood pressure.

Bests

Kv

---

From: Randy Bush <[email-masked]>
Date: Thu, 03 Oct 2002 13:53:24 -0700

> It is quite known that university professors are pretty much out of
> touch with real networks and reality.

as opposed to out of touch with manners or clue?

---

From: Robert Raszuk <[email-masked]>
Date: Thu, 03 Oct 2002 23:06:18 +0200

Hi Randy,

As far as the clue part I would recommed to wait for VPRN presentation
to go public at next nanog so everybody can judge who is clufull or
clueless reg MPLS applications especially 2547bin :-).

R.

> Randy Bush wrote:

---

From: Robert Raszuk <[email-masked]>
Date: Thu, 03 Oct 2002 22:31:43 +0200

Dear Prof. Kavé Salamatian,

It is quite known that university professors are pretty much out of
touch with real networks and reality. To help you overcome this I guess
we need to step back to MPLS 101 with you and find out what "MPLS"
really means. Let me ask you a basic question - why would anyone run TDP
& LDP only in partion of his network ? That is one of few MPLS
forwarding mechanisms used very widely today across multiple world scale
providers. 

Just as a tiny reference not related to any vendor take a look at the
folowing URL and download "MPLS Unofficial List":
http://cellstream.com/MPLS_List.htm or just click on
http://www.mplsrc.com/faq3.shtml and browse to all MPLS-VPN providers.
Keep in mind that 99% of MPLS-VPN providers use TDP or LDP in their
ENTIRE backbone.

> also some MPLS zeloat around :-) sorry to give you high blood pressure.

He he he - I am not effected by this at all, I just try to make sure
that the information on the public lists are correct :). 

R.

---

From: Antoine Bagula <[email-masked]>
Date: Fri, 4 Oct 2002 11:39:07 +0200 (SAST)

I have the impression that Robert's type of answer is typical on this list
when pros and cons MPLS is concerned. Thanks to Randy and Bob for their
interventions which i hope will help us avoid agressive answers on the
list in the future. I also think that as far as MPLS efficiency, utility
or whatever people should call as synonym of efficiency, several questions stand
unanswered:
1) Can people express their opinion on the list concerning limitations of MPLS ?
2) Can those who have solutions to these limitations also propose
these solutions ?
3) Did someone on the list gave an answer to the concern of professor Kave
:  what is the effect of traffic engineering on network performance?

BA. Bagula.

On Thu, 3 Oct 2002, Robert Raszuk wrote:

> -------
> The MPLS-OPS Mailing List
> Subscribe/Unsubscribe:  http://www.mplsrc.com/mplsops.shtml
> Archive: http://www.mplsrc.com/mpls-ops_archive.shtml
>

---

From: Ajay Simha <[email-masked]>
Date: Fri, 4 Oct 2002 11:11:53 -0400 (EDT)

On Fri, 4 Oct 2002, Antoine Bagula wrote:

>AB:I have the impression that Robert's type of answer is typical on this list
>AB:when pros and cons MPLS is concerned. Thanks to Randy and Bob for their
>AB:interventions which i hope will help us avoid agressive answers on the
>AB:list in the future. I also think that as far as MPLS efficiency, utility
>AB:or whatever people should call as synonym of efficiency, several questions stand
>AB:unanswered:
>AB:1) Can people express their opinion on the list concerning limitations of MPLS ?
>AB:2) Can those who have solutions to these limitations also propose
>AB:these solutions ?
>AB:3) Did someone on the list gave an answer to the concern of professor Kave
>AB::  what is the effect of traffic engineering on network performance?

Sorry... this thread *has* lost focus (at least for me). I'll attempt to
answer the last question (3)....

My experience has been with MPLS-TE (opposed to general TE).

For the sake of this discussion let's agree that the definitions of "large SP"
as those who have say 30 to 50 POPs.

Some of the SPs have what we call *strategic* TE which involves a
full mesh of TE tunnels (either in the core or edge). The largest network that
we have seen today with MPLS-TE involved about 10k tunnels in the network.

Some of the testing we did in our labs showed:

600 headends, 10,000 midpoints/tail scaled pretty well.

So... going back to a network with 10k (This number comes from having 100
routers in a full mesh), it means even if this network grew 6 times it would
be within the scaling limits.

Now moving forward in time... There have been optimizations within RSVP (Sorry
cannot talk about CR-LDP because I have no experience in that) and routers
have gotten bigger and better and these scaling numbers increase.

For the foreseeable future I think talking 100 routers in mesh is a good number
to consider as a *large* network. So I'd say it is fair to conclude that TE
scales pretty well in a practical/real network.

Now if the question was geared more towards forwarding performance in a TE
environment, I'd say that in an MPLS forwarding core, it makes no difference if
the labels were exchanged due to RSVP or LDP it does not matter when a packet
needs be switched. The LFIB is consulted and the packet is forwarded much in
the same way as it is done in Frame Relay or ATM switch.

I hope this answers at least some of the questions/issues.

-ajay

>AB:
>AB:BA. Bagula.
>AB:
>AB:On Thu, 3 Oct 2002, Robert Raszuk wrote:
>AB:
>AB:> Hi Randy,
>AB:>
>AB:> As far as the clue part I would recommed to wait for VPRN presentation
>AB:> to go public at next nanog so everybody can judge who is clufull or
>AB:> clueless reg MPLS applications especially 2547bin :-).
>AB:>
>AB:> R.
>AB:>
>AB:> > Randy Bush wrote:
>AB:> >
>AB:> > >> I was saying that today we don't have yet (or at least I have not heard of)
>AB:> > >> a full MPLS large network. I was not meaning that nobody is using MPLS in
>AB:> > >> portion of his network.
>AB:> > > It is quite known that university professors are pretty much out of
>AB:> > > touch with real networks and reality.
>AB:> >
>AB:> > as opposed to out of touch with manners or clue?
>AB:> >
>AB:> > _______________________________________________
>AB:> > ippm mailing list
>AB:> > [email-masked]
>AB:> > http://mailhost.advanced.org/mailman/listinfo/ippm
>AB:>
>AB:> -------
>AB:> The MPLS-OPS Mailing List
>AB:> Subscribe/Unsubscribe:  http://www.mplsrc.com/mplsops.shtml
>AB:> Archive: http://www.mplsrc.com/mpls-ops_archive.shtml
>AB:>
>AB:
>AB:-------
>AB:The MPLS-OPS Mailing List
>AB:Subscribe/Unsubscribe:  http://www.mplsrc.com/mplsops.shtml
>AB:Archive: http://www.mplsrc.com/mpls-ops_archive.shtml
>AB:

---

From: "Bradley J. Passwaters" <[email-masked]>
Date: Fri, 4 Oct 2002 10:55:44 -0400 (EDT)

> that the information on the public lists are correct :). 

If your goal is actually to help insure the list have correct
information allow me to offer some advice:

> really means.

Gratituious attacks on random groups of people followed by patronizing
them aren't usually a help.

>them says MPLS don't use it and that is also absolutely fine.

Claiming that anyone who doesn't use a protocol is merely doing so because
they are a purist is not likely to give the impression that you are a
level headed reasonable person just out to contribute.

>traditional dst based lookup at each hop.

I believe that this statement is incorrect.  If you look at the history
of MPLS and its precursors you will see that improved performance of the 
the devices that run the network and hence the network itself was a goal.
I think what you want to say is that while that might have been a goal
at one time it is not the primary goal especially in the current
environment.

>Let me ask you a basic question - why would anyone run TDP

I think you are asking this because of Kav Salamatian's "full MPLS large
network" remark right?  I took his remark to not mean full in the sense of
deployed everywhere in the network but in terms of taking advantage of
most/all of the features that MPLS offers.  

As always YMMV

[email-masked]                        |  Disclaimer:  Can you be sure I even
uunet!eng.umd.edu!istari               |  exist:  Let alone represent anyone
Brad Passwaters (Network Ronin)        |  or anything.
-------------------------------------------------------------------------------
Here we are. Born to be kings. We're the princes of the universe.
Here we belong, fighting to survive in a war with the darkest power.
                        Network Manager's Theme Song (QUEEN)

---

From: Antoine Bagula <[email-masked]>
Date: Mon, 7 Oct 2002 09:23:54 +0200 (SAST)

On Fri, 4 Oct 2002, Ajay Simha wrote:

> >AB:3) Did someone on the list give an answer to the concern of professor Kave

Thanks Ajay. This sheds some light on the topic.

Antoine.