Subject: [ippm] OWAMP implementations

From: "Hélder Veiga e Teresa Pinho" <[email-masked]>
Date: Mon, 17 May 2004 18:41:45 +0100

Dear all,

We are a group of researchers at the Institute of 
Telecommunications / University of Aveiro, involved in the 
area of Traffic Measurements.

We have an implementation of OWAMP (version 8, May 
2004)almost ready. Our aim now is to carry out conformance 
tests (as extensive as possible). Thus we are looking for 
other implementations of the OWAMP.

Do you know of any other implementations?

Best regards.

Teresa Pinho
Hélder Veiga
José Luis Oliveira
Rui Valadas

_______________________________________________
ippm mailing list
[email-masked] 
https://www1.ietf.org/mailman/listinfo/ippm

---

From: stanislav shalunov <[email-masked]>
Date: 17 May 2004 14:38:10 -0400

"HИlder Veiga e Teresa Pinho" <[email-masked]> writes:

> We have an implementation of OWAMP (version 8, May 2004) almost ready.

Wonderful.

> Our aim now is to carry out conformance tests (as extensive as
> possible). Thus we are looking for other implementations of the OWAMP.

You could try interoperating with the implementation made available at
http://e2epi.internet2.edu/owamp/

(It is our goal to have a reference implementation that uses all
features of the protocol so that complete interoperability testing can
be done.)

-- 
Stanislav Shalunov		http://www.internet2.edu/~shalunov/

This message is designed to be viewed at room temperature.

---

From: stanislav shalunov <[email-masked]>
Date: 17 May 2004 14:38:10 -0400

Wonderful.

---

From: "Jeff W. Boote" <[email-masked]>
Date: Wed, 19 May 2004 10:39:53 -0600

> features of the protocol so that complete interoperability testing can

The http://e2epi.internet2.edu/owamp/ has not been updated to version 8 of the
specification yet.

Basically, it does not support any of the TTL functionality. (This includes the
data format changes to the Fetch-Session response.)

Also, the current version does not quite conform to the specification for
partial sessions yet. (The "Session Packets Sent" portions of the
"Stop-Sessions" message is currently always using the special value indicating
that the number of packets sent could not be determined.)

I believe these are the only areas of non-conformance at this time. I intend to
address this over the next two weeks.

jeff

---

From: "Jeff W. Boote" <[email-masked]>
Date: Wed, 19 May 2004 10:39:53 -0600

jeff