Subject: RE: [ippm] IPPM MIB (fwd)

From: "STEPHAN Emile RD-CORE-LAN" <[email-masked]>
Date: Fri, 8 Oct 2004 20:03:05 +0200

Dear Henk and Matt,

In the mail sent in the list you never proposed that the IPPM MIB will be removed from the charter. You said "...In that case, the existing document will be finished and a published as an informational RFC."

I consider that what is happening is against the spirit of a standardization process for the following reasons:

-1- Attendees don't care if a WG MIB is informational or BCP or standard track. Consequently I think that most of them understood that if they were not enough reaction the IPPM MIB will become an informational WG draft. So you should have clearly said to the list that "...In that case, the existing document will be finished and a published as an individual informational RFC.".

-2- Making an implementation is part of the standardization process of the IETF. France Telecom decided to make an implementation to validate the specification after the document became a WG item and after the mail from Andy (19/11/2001) telling both to ippm and rmon lists that he wanted a MIB that exposed aggregated statistics based directly on the IPPM metrics. 

-3- I have taken in account all the requests from other WG. I extracted the IPPM REGISTRY from the IPPM MIB to satisfy the needs of other MIBs. I removed any informational reference to the IPPM MIB in the IPPM REGISTRY to facilitate the evolution of the TPM MIB (which has a normative reference to IPPM REGISTRY). 

-4- Before the last meeting, an expert from another WG proposed to co author the IPPM MIB because the design of IPPM MIB fits specific needs related to scalability and user separation... That should be a good opportunity to complete this IPPM MIB while taking in account the constraints of the integration in routers. He retracted because he heard that the IPPM MIB was kill. So if your decision was taken before the last meeting you should have clearly announced in the list that the IPPM MIB will be removed from the charter if there were not more interest: You should never have said that this WG item will became informational.

So I consider that the IPPM MIB should become an informational WG document as proposed in the ippm list in August and because this WG item was accepted and motivated by both the chairs and the TA. 

Regards
Emile

-----Message d'origine-----
De : [email-masked] [mailto:[email-masked]] De la part de Henk Uijterwaal (RIPE NCC)
Envoyé : jeudi 7 octobre 2004 19:59
À : [email-masked]
Cc : Matthew J Zekauskas; Allison Mankin
Objet : [ippm] IPPM MIB (fwd)

IPPM group,

On August 16, we asked the working group for feedback on the question
"what information would you like to see in the management interface of a
network measurement system".  There have been almost no responses to the
list on this question.

We conclude that the members of this WG are, at the moment, not interested
in the development of an IPPM MIB.  As a result, we propose to remove this
work item from the agenda.

We realize that a considerable amount of work has been put into
draft-ietf-ippm-reporting-mib-06.txt. In order to save this work for the
future, we encourage the authors to finish this document, then submit it
as an individual, informational RFC.

The chairs,
Matt & Henk

------------------------------------------------------------------------------
Henk Uijterwaal                           Email: henk.uijterwaal(at)ripe.net
RIPE Network Coordination Centre          http://www.amsterdamned.org/~henk
P.O.Box 10096          Singel 258         Phone: +31.20.5354414
1001 EB Amsterdam      1016 AB Amsterdam  Fax: +31.20.5354445
The Netherlands        The Netherlands    Mobile: +31.6.55861746
------------------------------------------------------------------------------

In a room with a window in the corner, I found truth.            (Ian Curtis)

_______________________________________________
ippm mailing list
[email-masked] 
https://www1.ietf.org/mailman/listinfo/ippm
_______________________________________________
ippm mailing list
[email-masked] 
https://www1.ietf.org/mailman/listinfo/ippm

---

From: "Henk Uijterwaal (RIPE NCC)" <[email-masked]>
Date: Sat, 9 Oct 2004 17:44:55 +0200 (CEST)

Dear Emile,

> In the mail sent in the list you never proposed that the IPPM MIB will
> be removed from the charter. You said "...In that case, the existing
> document will be finished and a published as an informational RFC."
>
> I consider that what is happening is against the spirit of a
> standardization process for the following reasons:

I agree that I could have put the word "individual" in the sentence above.
However, you are quoting only 1 sentence out of a fairly long mail. The
same mail said that if there was little or no feedback on the questions
asked in the mail, we would conclude that the IPPM WG had no interest in
producing a MIB at this time.  There was, in fact, very little feedback,
so I believe the conclusion that the WG is not interested in this, is
correct.

I think the key of a standardization process in a working group, is that
the participants get together and discuss what should be in the standard.
That has not happened for this document in the past 3 years: the 2 authors
were the only (major) contributors to the document and the document was
read by maybe 3 to 6 people.

So, the document that is there now, IMHO, cannot be considered a product
of the working group and thus should not be published as the product of
the working group.

And this is exactly what we propose: the WG is not interested in this at
the moment, but a significant amount of work has been done by a small
group of people.  That should be saved for the future, so we encourage you
to finish the document and publish it as your work under your name.

Obviously, I'll be happy to explain all this to the IESG when you submit
your document.

> -2- Making an implementation is part of the standardization process of
> the IETF. France Telecom decided to make an implementation to validate
> the specification

I appreciate the work done by France Telecom, but none of the other
operators I spoke to appeared to be interested in this work.

> [...] after the document became a WG item and after the mail
> from Andy (19/11/2001) telling both to ippm and rmon lists that he
> wanted a MIB that exposed aggregated statistics based directly on the
> IPPM metrics.

I wasn't a WG chair at the time but I was in the meeting where this
happened.  At that point, there was some interest in this and the WG
expected that a number of people would stand up and contribute.  Now,
3 years later, it turns out that this conclusion was wrong.

> -4- Before the last meeting, an expert from another WG proposed to co
> author the IPPM MIB [...]  He retracted because he heard
> that the IPPM MIB was kill.

Until the beginning of this week, no decision had been made.  In fact, I
had hoped that others would stand up and contribute to this effort.  That
did not happen.

Kind regards,

Henk