Subject: RE: [ippm] Way to store traceroutes

From: "Saverio Niccolini" <[email-masked]>
Date: Thu, 13 Jan 2005 13:45:38 +0100

Dear all,
thanks a lot for your comments.

> -----Original Message-----
> From: stanislav shalunov [mailto:[email-masked]]
> Sent: 12 January 2005 18:35
> To: Saverio Niccolini
> Cc: [email-masked]
> Subject: Re: [ippm] Way to store traceroutes
> 
> Saverio,
> 
> I think that, conceptually, the draft should define a standard
> representation (textual or binary) of a data structure that would hold
> the results of a traceroute measurement.  It would seem to me that the
> data structure itself should look something like (using a made-up
> pseudocode):
> 
> RECORD
>   date and time of start of measurement
>   duration of single running
>   IP address version (4 or 6)
>   source IP address
>   destination IP address
>   u_int8_t protocol version (1 for ICMP, 6 for TCP, 17 for UDP, etc.)
>   u_int16_t source port (unused of not meaningful -- e.g., ICMP)
>   u_int16_t destination port (unused of not meaningful -- e.g., ICMP)
>   u_int8_t maximum TTL
>   ARRAY with indices from 1 to maximum TTL
>     LIST of individual probe results
>       IP address
>       u_int8_t protocol version of response (usually 1, except for
last)
>       ICMP message description (Time Exceeded, etc.; special value for
> NaN)
>       delay (with a special value for infinity)
> 
> Things to decide before sitting down to write the draft:
> 
> * Is this the right data structure?
> 
> * Are there any missing fields?  Unnecessary fields?

We agree, we are currently working on this and we will include your
suggestions and the ones sent by Henk.
	
> 
> * How would it be represented?  (My hunch would be to define either
>   just a textual representation or both textual and binary
>   representations.)
> 
> One thing I'd argue against would be the use of XML for textual
> representations without a standard binary representation.  That would
> encourage wasteful practices: XML is expensive to parse.  A textual
> representation that doesn't require parsing without a binary
> representation would be fine as far as I am concerned.

In our opinion the first thing to do is to define an information model
that can be later mapped to one or more data model (be it XML or simpler
text, or binary, or a combination of the two).
We will first of all define the information model and in the meantime we
can try to discuss on the list what the preferred data model is.

Best regards,
Saverio Niccolini

_______________________________________________
ippm mailing list
[email-masked] 
https://www1.ietf.org/mailman/listinfo/ippm

---

From: stanislav shalunov <[email-masked]>
Date: 14 Jan 2005 00:50:26 -0500

> can try to discuss on the list what the preferred data model is.

Seems like a sound strategy to me.

-- 
Stanislav Shalunov		http://www.internet2.edu/~shalunov/

"Nuclear war would really set back cable [television]."  -- Ted Turner