Subject: RE: [ippm] RE: 'IPPM' IDs on multicast and spatial measure / PCE metric to measure path quality

From: "STEPHAN Emile RD-CORE-LAN" <[email-masked]>
Date: Thu, 3 Feb 2005 18:59:57 +0100

Dear Lei,

The following comments focus on one idea: preparing a draft acceptable from the IPPM framework point of view, which defines the minimal set of metrics we need. 

Regarding point 1:
I consider that one-to-group metrics are easy to define on the top of the metrics already defined by the IPPM WG.

On the opposite group-to-one metrics are not easy to define while being respectful of the IPPM framework mainly because a group-to-one metric doesn't rely on one event but on a set of different packets, sent at different time, arriving at different time... 

I have the same issue with the aggregation of end-to-end one-way delays over a path: the IPPM framework does not apply because it relies on measures made at different times.

So, in a way to merge ours drafts in a single IPPM one I propose to ignore both the group-to-one metrics definitions and the definitions of metrics for aggregation of end-to-end one-way delays and loss (and obviously jitter!);
	
Regarding point 2:
I agree, spatial metrics are applicable to multicast, to TE, to interdomain...but this doesn't look to be a hot topic at IETF :-)

Regarding points 3 and 7:
The definitions of One-to-group streams of delay or of loss are needed only to write unambiguous definitions of statistics. The way the measures of singletons of end-to-end metrics are collected is out of the scope of the definition.

Regarding points 4 and 8: 
	Several metrics can merge. We can use the name group-to-one...

Regarding points 5 and 6:
	I agree. Jitter is needed.

What about the next step. I propose that we write quickly an I-D considering the comments above in a way to present it during the next meeting in Minneapolis. I am quite that Henk will give us at least 5 minutes to present it.

I can send you a first template in xml if you agree.

Regards
Emile

 qclearly define statistic metrics on it stream
-----Message d'origine-----
De : Lei Liang [mailto:[email-masked]] 
Envoyé : jeudi 3 février 2005 17:30
À : STEPHAN Emile RD-CORE-LAN
Cc : Henk Uijterwaal; pce; ippm; Zhili SunZhiliSun
Objet : RE: [ippm] RE: 'IPPM' IDs on multicast and spatial measure / PCE metric to measure path quality

Dear Emile,
  Thanks for your sugguestion. I have read through the mulitcast metrics
and got some comments here. 

1:the general difference of your draft and mine is our view point. your
draft mainly consided the individual users in the group while mine
emphasized the group. I am trying to view the group as one client with
special consideration on the relative QoS.   

2: your spatial metrics can be for more general measurement cases rather
than only limited to multicast.  It can provide very detail information
for each multicast branch that is extremely useful to identify the
problem network segment for inter-domain connctions.

3:regarding your Instantaneous One-way Delay Stream, it is trying to
collect a set of unicast measurement results together if I didn't
misunderstand. I have one question here that if we extremely need such a
collection to form a new metric while we actually can have the unicast
one-way metric first. The potential problem might be the metric size
while we have huge size multicast groups, e.g. internet gaming, live tv,
etc. 

4: regarding the Type-P-Multicast-Instantaneous-Hop-One-way-Delay, it is
quite similar to the one-to-group mean delay defined in my draft. I
suggest we can merge them together.

5:the mean, or average, of the one-way delay can't present the relative
delay which is also very important for group communication as I
mentioned in my draft. so I suggest to keep the consideration on the
delay variation.

6: moreover, the jitter is also very important for the highly
interactive communications and we can not ignore it.

7: the relevant metrics you defined for packet loss is more concern with
individual users, as i said above, and can be very useful for problem
identification. the problem is still regarding the huge group size. 

8: I suggest we use mean instead of median because it can reflect the
trend of the QoS among the group members.

Those are the comments for now. Your response will be appreciated.
Regards,
lei  

On Wed, 2005-02-02 at 16:41, STEPHAN Emile RD-CORE-LAN wrote:
> Dear Lei,
> 
> You might take a glance at the old draft defining multicast metrics too. As an example the section 7 defines the metric Type-P-Multicast-Instantaneous-One-way-Delay-Stream. This stream is the list of the instantaneous delays between one source and a group of receiver. So from my point of view it provides directly the material for computing One-to-group statistics.
> 
> These drafts are no more available on the IETF site, but they are still online
> 	http://www.watersprings.org/pub/id/draft-stephan-ippm-multicast-metrics-00.txt
> 	http://www.watersprings.org/pub/id/draft-stephan-ippm-spatial-metrics-01.txt
> 
> Regards
> Emile
> 
> -----Message d'origine-----
> De : Lei Liang [mailto:[email-masked]] 
> Envoyé : mercredi 2 février 2005 13:42
> À : STEPHAN Emile RD-CORE-LAN
> Cc : Henk Uijterwaal; [email-masked]; [email-masked]; Zhili SunZhiliSun
> Objet : Re: [ippm] RE: 'IPPM' IDs on multicast and spatial measure / PCE metric to measure path quality
> 
> Dear Emile and Henk,
>   Thank you very much for your comments on the draft. I will read
> through draft-stephan-ippm-spatial-metrics-01.txt to help merge these
> two drafts together according to the comments
> 
> cheers,
> lei
> 
>  Tue, 2005-02-01 at 18:15, STEPHAN Emile RD-CORE-LAN wrote:
> > Dear Henk,
> > 
> > >From my point of view these 3 drafts may merge and in a WG draft that defines the minimal set of metrics to permit spatial and multicast measurements.
> > 
> > These metrics are the ones needed in the PCE WG to measure path quality and the ones needed to measure multicast tree performance:
> > 
> > - The decomposition of 'singletons' of IPPM one-way delay, packet loss and jitter over a path: 
> > 	Samples of instantaneous per hop performance;
> > 
> > - The delay, loss and jitter of a hop of a path;
> > 	An item of the previous decomposition; 
> > 
> > - The aggregation of end-to-end one-way delays over a path is needed too:
> > 	Permits aggregation of inter domain delay and aggregation of delay of a branch of a multicast tree.
> > 
> > - The samples ofcomment 'singletons' of IPPM one-way delay, packet loss and jitter for a group of receiver: 
> > 	Permit multiparty statistics;
> > 
> > 
> > Regards
> > Emile
> > 
> > -----Message d'origine-----
> > De : Henk Uijterwaal [mailto:[email-masked]] 
> > Envoyé : lundi 31 janvier 2005 08:26
> > À : STEPHAN Emile RD-CORE-LAN; [email-masked]
> > Cc : Matthew J Zekauskas
> > Objet : Re: 'IPPM' IDs on multicast an spatial measure
> > 
> > Dear Emile,
> > 
> > >During the last WG meeting Matt asked me to reread the draft 
> > >draft-liang-multiparty-para-00.txt while considering the previous IDs I 
> > >posted on spatial and multicast metrics.
> > >
> > >I reread them. Following is the list of metrics I found. I can make 
> > >further classifications, comparisons or comments if needed.
> > 
> > Based on your reading of this draft, do you have any opinion on how
> > we should proceed with draft-liang-multiparty...  Pick it up as a WG
> > item?  Leave it to the authors to pursue as an individual submission?
> > 
> > Kind regards,
> > 
> > Henk
> > 
> > 
> > 
> > 
> > >Regards
> > >
> > >Emile
> > 
> > 
> > 
> > >--------------- draft-stephan-ippm-multicast-metrics-00.txt ----------------
> > >
> > >The draft defines 1 network metrics:
> > >
> > >         + Type-P-spatial-hop-one-way-delay
> > >
> > >
> > >
> > >The draft defines several aggregation metrics:
> > >
> > >         + Type-P-spatial-one-way-delay-stream
> > >
> > >         + Type-P-spatial-one-way-delay
> > >
> > >         + Type-P-Multicast-Instantaneous-Hop-One-way-Delay
> > >
> > >         + Type-P-Multicast-Instantaneous-One-way-Delay-Percentile
> > >
> > >         + Type-P-Multicast-Instantaneous-One-way-Delay-Median
> > >
> > >         + Type-P-Multicast-Instantaneous-One-way-Delay-Inverse Percentile
> > >
> > >         + Type-P-Multicast-Instantaneous-Packet-Loss-Stream
> > >
> > >         + Type-P-Multicast-Instantaneous-Packet-Loss-Percentile
> > >
> > >         + Type-P-Multicast-Instantaneous-Packet-Loss-Median
> > >
> > >         + Type-P-Multicast-Instantaneous-Packet-Loss-Inverse Percentile
> > >
> > >         + Type-P-Multicast-Instantaneous-Connectivity
> > >
> > >
> > >
> > >--------------- draft-stephan-ippm-spatial-metrics-01.txt ---------------
> > >
> > >
> > >
> > >The draft defines 2 network metrics:
> > >
> > >         + Type-P-spatial-one-way-delay
> > >
> > >         + Type-P-Spatial-packet-loss
> > >
> > >
> > >
> > >The draft defines several path aggregation metrics :
> > >
> > >         + Type-P-one-way-delay-trajectory
> > >
> > >         + Type-P-aggregated-one-way-delay
> > >
> > >         + Type-P-asynchronous-one-way-delay-trajectory
> > >
> > >         + Type-P-asynchronous-aggregated-one-way-delay
> > >
> > >         + Type-P-Spatial-packet-loss-stream
> > >
> > >         + Type-P-Spatial-packet-loss-Average
> > >
> > >
> > >
> > >--------------- draft-liang-multiparty-para-00.txt ---------------
> > >
> > >The draft defines statistics for end to end multicast performance, mainly 
> > >to identify the variation of the performance between the member of a group.
> > >
> > >Actually the draft has 4 groups of statistics metrics:
> > >
> > >         One-to-group-Mean-Paramater
> > >
> > >         One-to-group-Variation-Paramater
> > >
> > >         Group-to-one-Mean-Paramater
> > >
> > >         Group-to-one-Variation-Paramater
> > >
> > >The value of Parameter depends on what one-way metric is used from delay, 
> > >loss ot jitter.
> > >
> > >To permit comparison I extended the list of metrics defined using IPPM 
> > >metrics terminology:
> > >
> > >         + Type-P-One-to-group-Mean-one-way-delay;
> > >
> > >         + Type-P-One-to-group-Mean-Packet-Loss;
> > >
> > >         + Type-P-One-to-group-Mean-ipdv;
> > >
> > >
> > >
> > >         + Type-P-One-to-group-Variation-one-way-delay;
> > >
> > >         + Type-P-One-to-group-Variation-Packet-Loss;
> > >
> > >         + Type-P-One-to-group-Variation-ipdv;
> > >
> > >
> > >
> > >         + Type-P-Group-to-one-Mean-one-way-delay;
> > >
> > >         + Type-P-Group-to-one-Mean-Packet-Loss;
> > >
> > >         + Type-P-Group-to-one-Mean-ipdv;
> > >
> > >
> > >
> > >         + Type-P-Group-to-one-Variation-one-way-delay;
> > >
> > >         + Type-P-Group-to-one-Variation-Packet-Loss;
> > >
> > >         + Type-P-Group-to-one-Variation-ipdv;
> > 
> > ------------------------------------------------------------------------------
> > Henk Uijterwaal                           Email: henk.uijterwaal(at)ripe.net
> > RIPE Network Coordination Centre          http://www.amsterdamned.org/~henk
> > P.O.Box 10096          Singel 258         Phone: +31.20.5354414
> > 1001 EB Amsterdam      1016 AB Amsterdam  Fax: +31.20.5354445
> > The Netherlands        The Netherlands    Mobile: +31.6.55861746
> > ------------------------------------------------------------------------------
> > 
> > Look here junior, don't you be so happy.
> > And for Heaven's sake, don't you be so sad.                 (Tom Verlaine) 
> > 
> > 
> > _______________________________________________
> > ippm mailing list
> > [email-masked] 
> > https://www1.ietf.org/mailman/listinfo/ippm

_______________________________________________
ippm mailing list
[email-masked] 
https://www1.ietf.org/mailman/listinfo/ippm

---

From: Henk Uijterwaal <[email-masked]>
Date: Fri, 04 Feb 2005 10:46:38 +0100

Hi,

>What about the next step. I propose that we write quickly an I-D 
>considering the comments above in a way to present it during the next 
>meeting in Minneapolis. I am quite that Henk will give us at least 5 
>minutes to present it.

I agree and you have a slot.