Subject: Re: [ippm] RD and TCP retransmit analysis

From: "Nischal M. Piratla" <[email-masked]>
Date: Fri, 01 Apr 2005 16:31:50 -0700

Al Morton wrote:

> Consider this example:
> Arrivals:            1   4   5   6   7   3   2
> ACKs:                   2   2  2   2  2   2
> Receive_index:       1   2   3   4   5   6   7
> Displacement:        0  -2  -2  -2  -2   3   5
>
> Is this an example of one of the circumstances you've excluded?
> (with the following sentence)
>
>> In addition, if a packet is reordered then the following packets
>> in the sequence are not reordered with same or higher displacement.
>
No, there is always a duplicate ACK per packet after an out-of-order 
arrival. So, 2 will be retransmitted after 3rd duplicate ACK arrives, 
i.e., retransmitted packet arrives after 6. Thus, there is no packet 
with displacement greater than 3 before packet with sequence number 2.

>
> In any case, how many arrivals must occur before Displacement
> can be evaluated again?
> IOW, the condition quoted above may also exclude this case:
> Arrivals:  1 3 4 5 6 2 7 9 10 11 12 8
> Displacement:        4              4
> but this seems to be a case where there may be two re-transmissions.
>
Again, per packet ACK after an out-of-order answers this concern.

> We have not placed strong requirements like this on the measured
> stream in the past, and this one appears to need some refinement.

Unless, I am mistaken there was no such explicit analysis for any of the 
metrics. So, I am not sure what it means when you say we have not placed 
strong requirements in the past. This analysis was made taking 
statements from RFC 2581 and RFC 1122 into consideration. However, we 
will  welcome your comments/suggestions on any refinements, if you feel 
are necessary.
- Nischal
_______________________________________________
ippm mailing list
[email-masked] 
https://www1.ietf.org/mailman/listinfo/ippm

---

From: Al Morton <[email-masked]>
Date: Fri, 01 Apr 2005 23:36:57 -0500

This last message talks about how TCP works,
but it doesn't really address the issue of an unclear
requirement on the packet stream.  Worse, you
now seem to be changing the definition used
to detect unnecessary re-transmissions using RD.

At 05:02 PM 03/11/2005, Nischal M Piratla wrote:
>Thus, the displacement (according to RD definitions) is greater than 2 for
>retransmitted packets.
>Therefore, "Sum of (all RD[k] for k >= 2) corresponds to fraction of packets
>that is unnecessarily retransmitted."

I created an example containing two closely spaced packets
with displacement > 2 (3 and 5). The metric above seems to
predict two re-transmissions where only one would occur,
unless some clarified version of the requirement on reordered
packets in the stream came into play.

But then,

>Thus, there is no packet with displacement greater than 3
>before packet with sequence number 2.

Ideally, there would be no requirements on the reordering of
the packet stream for the metric to be valid
(beyond "stream must be possible on a real network" of course).

There hasn't been much productive exchange in any of these
RD/RBD threads, IMO.  I invested time to re-read the
draft and offer what I thought were clear comments,
only to precipitate evasive stuff like this.
I'm not convinced there is value in pursuing this further.

Al

At 06:31 PM 04/01/2005, Nischal M. Piratla wrote:
>i.e., retransmitted packet arrives after 6. Thus, there is no packet with 
>displacement greater than 3 before packet with sequence number 2.
>>
>strong requirements in the past. This analysis was made taking statements 
>from RFC 2581 and RFC 1122 into consideration. However, we will  welcome 
>your comments/suggestions on any refinements, if you feel are necessary.
>- Nischal