Subject: RE: [ippm] comments on draft-morton-ippm-composition-00.txt

From: [email-masked]
Date: Thu, 18 Aug 2005 15:20:03 -0400

apparently the message was rejected by the anti-spam filter .. so I am
resending it.
I apologize for the (potentially) multiple copies of the email...
roman
----- Forwarded by Roman Krzanowski/EMPL/NY/Verizon on 08/18/2005 03:18 PM
-----
                                                                                                                                  
                      Roman Krzanowski                                                                                            
                                               To:      "Al Morton" <[email-masked]>                                            
                      08/17/2005 06:32         cc:      "STEPHAN Emile RD-CORE-LAN" <[email-masked]>,            
                      PM                       [email-masked], [email-masked], [email-masked]                           
                                               Subject: RE: [ippm] comments on draft-morton-ippm-composition-00.txt(Document      
                                               link: Roman Krzanowski)                                                            

Al

My few thoughts:

(1) regarding the delay variation metric
would we follow the ITU proposal or 2 point IPPM definition .. what would
be our preference?
My initial take on the ITU  delay variation proposal is negative. It is
different from MEF and from what we already use
as well as it is not very practical - my view..
can we have a discussion on it?

(2) I can draft  the availability and packet loss metric section , is this
OK with you. I am not sure how far you are on it

(3) We need some generic definition of the composite metric itself - my
view:

few takes on it:

Composite metric - Definition

A composite metric CM is a metric that is not obtained from a single
measurement but is obtained by the combination ( specific to the particular
metric) of the series of measurements. To be clear the CM refers to the
spatial composition of metrics not to the statistical averages or other
statistics derived from some individual metrics. Specifically, CM refers to
the metric allocated to some network segment composed of the sub segments (
non overlapping).

Composite metric – properties-
   Accuracy
   Time Specificity
   Topology Specificity
   ..........

Accuracy  to the end to end metric – defined as an approximation level  to
the end to end metric the composite metric is representing

      The composite metric – CM, must have defined some level of
      approximation to the true metric TM – to be of any use. The
      approximation may be done on different levels:
·     On the levels of singleton measurements
·     On the level of time synchronized per test averages
·     On the level of time synchronized per period T averages.

      What is the measure of accuracy/ approximation of the CM ?

Accuracy to the segment measured – this is nothing new; a metric should
represent the performance aspect of the segment that is referring to

(4) Rationale for the draft

In several situations the end to end performance measurements cannot be
implemented for practical reasons. With thousands and thousands of end
points implementing end to end  measurements between all end points is
impractical and operationally impossible.

The only way to get the end to end performance is to do the segmented
measurements and then combine the measurements into a composite end to end
metric that is an approximation of the true end to end metric. I see two
generic  cases where the end to end composite metric will be used:
·     Measurements of end to end in the provider network spanning an
customer premises, access,  aggregation, distribution and core transport
networks
·     Measurements across several different providers

I am sure more cases for the use of composite metrics may be defined in
addition to these generic ones.

                      "Al Morton"                                                                                                 
                      <[email-masked]        To:       "STEPHAN Emile RD-CORE-LAN" <[email-masked]>            
                      >                        cc:       [email-masked], [email-masked]                                        
                      Sent by:                 Subject:  RE: [ippm] comments on draft-morton-ippm-composition-00.txt              
                      ippm-bounces@ietf                                                                                           
                      .org                                                                                                        

                      08/16/2005 03:47                                                                                            
                      PM                                                                                                          

Hi Emile,

At 11:43 AM 8/9/2005, STEPHAN Emile RD-CORE-LAN wrote:
>How do we arrange the way the contribution to the composition draft ?
>As a first step, to prepare the version 01 of the draft I propose to send
>you my definitions of composition metrics.

Let's try that.  If you can follow the outline
I used for the example that is already in the draft,
that would be good.

>Regarding passive metrics, I will propose a definition of a passive one
>way delay metric based on the Type-P-Spatial-One-way-Delay-Stream defined
>in draft-stephan-ippm-multimetrics-01.txt.
OK.

Al

_______________________________________________
ippm mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/ippm

_______________________________________________
ippm mailing list
[email-masked] 
https://www1.ietf.org/mailman/listinfo/ippm

---

From: Al Morton <[email-masked]>
Date: Sun, 21 Aug 2005 11:02:42 -0400

Hi Roman,

Thanks for your comments, see initial responses below:

>can we have a discussion on it?

We've had some good discussions comparing these metrics on ippm-list
(my guess is that the 2001 archive has most of the exchange).
It's worthwhile pointing out that when one of the selected packets in
the pair (as in RFC3393) is always the packet with the minimum delay,
the IPPM and ITU definitions are equivalent.  I don't know if the same
flexibility exists in the MEF definition.  In any case, we have the
freedom to consider both in this effort, and I suggest we do just that.

Personally, I think we may have more success with compositions of the
ITU-T delay histogram.  The traditional version of IPPM's
adjacent packet pair metric depends on packet spacing, and
that may make compositions more challenging, somewhat like reordering.

>OK with you. I am not sure how far you are on it

I have some material on Loss already, so start with availability.
(I'll send you a template to make things easier.)
What IPPM (or ITU) metric will you start with to compose availability?

>(3) We need some generic definition of the composite metric itself - my

Thanks, I'll look at working these ideas into the draft.  Clearly we need
a new section containing definitions. I also like some of the
definitions composed by Andreas Åkre Solberg.  This topic really seems
to be of wide interest...

Al

---

From: "Robert Holley \(rholley\)" <[email-masked]>
Date: Wed, 24 Aug 2005 13:45:06 -0400

Al,
Roman,

I've been (rather passively) monitoring the list's discussions on this subject.

However, I didn't see any responses on the availability metric mentioned below.

Have I missed it, or am I just jumping ahead?

Regards
Bob 

> -----Original Message-----
> From: [email-masked] [mailto:[email-masked]] On 
> Behalf Of Al Morton
> Sent: Sunday, August 21, 2005 11:03 AM
> To: [email-masked]
> Cc: [email-masked]; [email-masked]
> Subject: RE: [ippm] comments on draft-morton-ippm-composition-00.txt
> 
> Hi Roman,
>