Subject: RE: [ippm] draft-shalunov-ippm-reporting-00.txt - availability

From: "Schmoll, Carsten" <[email-masked]>
Date: Tue, 2 May 2006 18:50:57 +0200

Please see comments inline. 

> -----Original Message-----
> From: stanislav shalunov [mailto:[email-masked]] 
> Sent: Tuesday, May 02, 2006 6:17 PM
> Subject: Re: [ippm] draft-shalunov-ippm-reporting-00.txt - 
> availability
> 
> "Schmoll, Carsten" <[email-masked]> writes:
> 
> > Technically there is not much of a difference between
> > "delay to X < inf"  and  "connectivity with X exists"
> 
> With current definitions,
> 
> delay < +infinity is equivalent to loss < 50%

Yes, you're right. I overlooked that detail.

> When would
> connectivity *not* be derived from the five metrics already in there?

If we consider connectivitiy on the IP level only,
then I cannot think of any case. Sill, some text in the draft 
about how to derive "connectivity" would still be helpful, 
since e.g. a fine delay+loss value for one direction only would 
not be enough to imply in general that connectivity = TRUE.

> Such a metric would essentially require an entire troubleshooting
> algorithm.  This is way beyond the very limited summarization of
> measurement results I'm trying to do with this draft...

I agree, as much as I'd like to see work on such topic, it
is clearly beyond the scope of your draft.

Regards,
Carsten.

PS - there is one general question to the draft I have:
Do you consider also reporting for *which* traffic the 
metrics have been measured (e.g. for UDP only, for DSCP=3)?

_______________________________________________
ippm mailing list
[email-masked] 
https://www1.ietf.org/mailman/listinfo/ippm

---

From: stanislav shalunov <[email-masked]>
Date: 02 May 2006 16:08:02 -0400

> not be enough to imply in general that connectivity = TRUE.

The connectivity RFC defines both unidirectional and bidirectional
connectivity.  The draft is also applicable to unidirectional and
bidirectional (or even passive) measurements.  There might be scope
somewhere for conversion of unidirectional measurements into
bidirectional ones (e.g., delay <- delay1 + delay2, loss <- 1 -
(1-loss1)*(1-loss2), connectivity <- connectivity1 AND connectivity2),
but it's not clear why these things should go into a user reporting
draft...

> metrics have been measured (e.g. for UDP only, for DSCP=3)?

Yes, it should report that in some concise (and unspecified) format.
I'll add some text to that effect.

-- 
Stanislav Shalunov		http://www.internet2.edu/~shalunov/

Clothes make the man.  Naked people have little or no influence on
society.                                             -- Mark Twain