Subject: Re: [ippm] I-D ACTION:draft-ietf-ippm-bw-capacity-01.txt

From: Al Morton <[email-masked]>
Date: Wed, 17 May 2006 10:30:12 -0400

Joseph and Phil,

While reading the latest draft, I came up with a few suggestions,
but otherwise the definitions appear well-constructed to me.
(the points appear to apply to the working text, as well)

hope this helps,
Al

Sec2: some rearrangement/modification of the phrases might help
OLD

    IP Layer Link Usage:
       The average usage of a link L, Used(L,T,I), is the actual number
       of IP layer bits correctly transmitted from any source over link L
       during the interval [T, T+I], divided by I.
NEW

    IP Layer Link Usage:
       The average usage of a link L, Used(L,T,I), is the actual number
       of IP layer bits from any source, correctly received over link L
       during the interval [T, T+I], divided by I.

OLD
    An important distinction between usage and capacity is that
    Used(L,T,I) is not the maximum amount, but rather, the actual amount
    of IP bits that are sent. ...

NEW
    An important distinction between usage and capacity is that
    Used(L,T,I) is not the maximum amount, but rather, the actual amount
    of IP bits that are correctly received. ...

OLD
    Since measurements of available capacity are more volatile that that
NEW
    Since measurements of available capacity are more volatile than that

Sec 3.5: Type-P

Suggest referring to explicit packet markings as the attribute of Type P
associated with the link/path capacity, instead of QoS classes.
As you say, any sort of QoS class arrangement might be encountered
on the path (including null/default), but the marking (and possibly
other factors) determine the treatment, or QoS class assignment.
Your example of "estimated EF IP Link/Path Capacity" is consistent
with this suggestion, but the paragraphs below go on to refer to
QoS classes (and these are more nebulous).

The packet marking (DSCP) may result in:
  - preferred treatment in some nodes/links, but not on others.
  - longer/shorter queue depths than other markings,
    depending on cross traffic with similar markings & marking itself.
  - discard
  - remarking (lesser drop precedence, after policing)
  - gross remarking (reclassification, like reset to default)

So, it's possible to have an "estimated EF IP Link/Path Capacity"
of zero, or something higher, and this would be good to know.
This seems to be worthwhile (to me) to expand and formally include
in the draft (possibly introducing Type-P into the fundamental
definitions?).

_______________________________________________
ippm mailing list
[email-masked] 
https://www1.ietf.org/mailman/listinfo/ippm

---

From: Dana Blair <[email-masked]>
Date: Thu, 18 May 2006 10:22:44 -0400

Why the change from transmitted to received ?

Dana

On May 17, 2006, at 10:30 AM, Al Morton wrote:

> [email-masked] https://www1.ietf.org/mailman/listinfo/ippm
>

---

From: Al Morton <[email-masked]>
Date: Thu, 18 May 2006 15:33:29 -0400

>Why the change from transmitted to received ?

In this memo, data that is in error cannot be counted
as successfully received, see section 3.1.

The suggestion to change the definition of IP Link Layer Usage
was kind of a backlash from the suggested change in the text below
(which was: s/sent/correctly received/ )

hth,
Al

---

From: Joseph Ishac <[email-masked]>
Date: Thu, 18 May 2006 17:57:51 -0400

Al, thanks for the comments!

Just a quick note for folks.  What Al refers to as working text, has
just recently become version 02 of the draft.  Like Al mentions, these
comments are still applicable to this latest revision.

Thanks,

-Joseph