Subject: [ippm] Draft on traceroute storage: MPLS results to be included

From: "Sandra Tartarelli" <[email-masked]>
Date: Fri, 9 Jun 2006 12:36:22 +0200

Dear all, 

We are currently working on the next version of the draft on how to store traceroute measurements. Following some feedback we received on the ippm mailing list, we would like to also include MPLS results, since some traceroute implementations report them. However, the way such results are reported may differ quite significantly for different implementations. Below, are three examples we found, but there are also others:

1) 10.150.44.14 [MPLS: Labels 71 Exp 0] 16 msec 17 msec 16 msec
2) 211.33.7.5 [MPLS:Labels 117/71 Exp 0] 8 msec
3) 10.1.13.2 (10.1.13.2)  0.866 ms  0.746 ms  0.724 ms MPLS Label=100912 CoS=0 TTL=1 S=1

We would like to get precise feedback from the mailing list about a set of parameters that we should include.
Does anyone on the list have a strong opinion on this?

Thanks,
Sandra

--
Dr. Sandra Tartarelli
Network Laboratories
NEC Europe Ltd.
Kurfürsten-Anlage 36
D-69115 Heidelberg, Germany

Phone:  +49 6221 4342 132
Fax:     +49 6221 4342 155

_______________________________________________
ippm mailing list
[email-masked] 
https://www1.ietf.org/mailman/listinfo/ippm

---

From: "Schmoll, Carsten" <[email-masked]>
Date: Fri, 9 Jun 2006 14:24:46 +0200

Dear Sandra,

I believe that the question what can be reported must
center on the protocol fields more than on what the
tools actually do report. A special tool may 
report incomplete information from the MPLS stack.

In each level of the stack we have:

Label                           20 bits
Class of Service (experimental)  3 bits
TTL                              8 bits
(see http://www.ietf.org/rfc/rfc3032.txt)

IMO only the first two are useful for reporting.

Does anyone know if CoS usually changes in the
label stack?  Else it would be ok to report it only
once for a stack.

Kind regards,
Carsten.

> -----Original Message-----
> From: Sandra Tartarelli [mailto:[email-masked]] 
> Sent: Friday, June 09, 2006 12:36 PM
> To: [email-masked]
> Subject: [ippm] Draft on traceroute storage: MPLS results to 
> be included 
> 
> Dear all, 
> 
> We are currently working on the next version of the draft on 
> how to store traceroute measurements. Following some feedback 
> we received on the ippm mailing list, we would like to also 
> include MPLS results, since some traceroute implementations 
> report them. However, the way such results are reported may 
> differ quite significantly for different implementations. 
> Below, are three examples we found, but there are also others:
> 
> We would like to get precise feedback from the mailing list 
> about a set of parameters that we should include.