Subject: Re: [ippm] I-D ACTION:draft-ietf-ippm-multimetrics-04.txt

From: "Geib, Ruediger" <[email-masked]>
Date: Fri, 20 Jul 2007 10:03:06 +0200

Emile,

I just noticed that the 04 version includes text on "Spatial Segments metrics definitions", which in the case of delay follows my proposal. I appreciate that.

The section on "A Definition of a sample of Packet Loss of a segment of the path" correctly includes an 

o  a value of Lk of 2 means that Bk.a has a value of 1 (not observed)
   and that Bk.b have a value of 0 (observed);

The discussion qualifies this as

o  A value of Lk of 2 (1,0) corresponds to a mistake in the ordering
   of Ha and Hb over the path coming either from the configuration
   (asumption on the path) or from the processing of the vectors: bad
   scrutening of the path ordering information, or some other mistake
   in the measure or the reporting.  It is not in the scope of this
   document to go in further details which are mostly implementation
   dependent.  This value MUST not be used to compute packet lost
   statistics.

After talking with Nicolai Leymann (having multicast expertise) I learned that after a rerouting event, a passive monitor along a path may indeed no longer be in it, if the new route is around (also a replication point may change). That means, a value of Lk of 2 can result from a usual re-routing event, it is not an anomaly. In that case, the results should be considered.

I think all metric definitions should respect this case.

I've only searched for the wird "reroute" in the current version and found it once. Sgould my comment be discussed already, I apologize for not having read that section.

Regards

Ruediger

_______________________________________________
ippm mailing list
[email-masked] 
https://www1.ietf.org/mailman/listinfo/ippm

---

From: "STEPHAN Emile RD-CORE-LAN" <[email-masked]>
Date: Mon, 23 Jul 2007 19:19:50 +0200

Hi Ruediger,

See inline.

> -----Message d'origine-----
> De : Geib, Ruediger [mailto:[email-masked]]
> Envoyé : vendredi 20 juillet 2007 10:03
> À : STEPHAN Emile RD-CORE-LAN
> Cc : [email-masked]; [email-masked]
> Objet : Re: [ippm] I-D ACTION:draft-ietf-ippm-multimetrics-04.txt
> 
> Emile,
> 
> I just noticed that the 04 version includes text on "Spatial Segments
> metrics definitions", which in the case of delay follows my proposal. I
> appreciate that.

I refurbished the whole draft to have it more consistent while avoiding duplication. I renamed 'subpath metric' to 'segment metric' to have this metric more close to operational needs. 
 
> After talking with Nicolai Leymann (having multicast expertise) I learned
> that after a rerouting event, a passive monitor along a path may indeed no
> longer be in it, if the new route is around (also a replication point may
> change). That means, a value of Lk of 2 can result from a usual re-routing
> event, it is not an anomaly. In that case, the results should be
> considered.

Spatial metrics are defined on the top of a one-to-one framework (one-to-many covered by the second part of the draft), just adding the knowledge of the Path digest. So the path digest is known for each metric result. But this does not preclude that the path does not change between 2 results of the same measure.

> I think all metric definitions should respect this case.

Not sure I understand. Which metrics ?

> 
> I've only searched for the wird "reroute" in the current version and found
> it once. Sgould my comment be discussed already, I apologize for not
> having read that section.

> Ruediger

Regards
emile

---

From: "Geib, Ruediger" <[email-masked]>
Date: Tue, 24 Jul 2007 09:02:07 +0200

Hi Emile,

|Spatial metrics are defined on the top of a one-to-one 
|framework (one-to-many covered by the second part of the 
|draft), just adding the knowledge of the Path digest. So the 
|path digest is known for each metric result. But this does not 
|preclude that the path does not change between 2 results of 
|the same measure.

Allright, looks like my knowledge of the IPPM terminology is 
too poor. If "knowledge of the path digest" means, that the 
actual path is always known to the measurement system,  
LK 2 must result from some unusual network configuration.

If the path digest is monitored by periodic traceroute, LK 2 
may may occur immediately after a reroute event (may LK 2 
be used to trigger a path detection?)

Regards,

Ruediger