Subject: [ippm] Advancement of metrics to standards draft

From: <[email-masked]>
Date: Mon, 6 Jul 2009 14:19:58 +0200

Henk, Matt,

the submitted draft on the advancement of metrics to standards hopefully is clear enough on the suggested methodology and its execution.

I won't participate in the Stockholm meeting. If the WG welcomes continuation of the work on this document, then the areas requiring more input I'm aware of are:
- statistical tests on time series producing verifyable results with the desired confidence 
  (suggested default 95%). And a review by a statistician in general.
- Measurement and networking expert to define what are sufficiently "identical network 
  conditions", as that's a basic assumption for the suggested metric test.

As a detailed comment, a reference and code for the Anderson Darling k test is required.

I hope, the draft may be found here:

http://www.ietf.org/internet-drafts/draft-geib-ippm-metrictest-00.txt

Regards,

Ruediger 

Deutsche Telekom Netzproduktion GmbH 
Zentrum Technik Einführung 
Technik Internet Backbone, TE142-19
Rüdiger Geib
Heinrich Hertz Str. 3-7
64297 Darmstadt
Tel.: 06151/6282747
Fax: 0251/7985109

Deutsche Telekom Netzproduktion (DT NP) GmbH
Aufsichtsrat: Timotheus Höttges (Vorsitzender)
Geschäftsführung: Dr. Bruno Jacobfeuerborn (Vorsitzender), Albert Matheis, Klaus Peren
Handelsregister: Amtsgericht Bonn HRB 14190
Sitz der Gesellschaft: Bonn
USt-IdNr.: DE 814645262

---

From: Henk Uijterwaal <[email-masked]>
Date: Mon, 06 Jul 2009 14:47:20 +0200

Ruediger et al,

Thanks for all the work so-far, we'll discuss the
document in Stockholm and let you know about next steps.

Henk

-- 
------------------------------------------------------------------------------
Henk Uijterwaal                           Email: henk.uijterwaal(at)ripe.net
RIPE Network Coordination Centre          http://www.xs4all.nl/~henku
P.O.Box 10096          Singel 258         Phone: +31.20.5354414
1001 EB Amsterdam      1016 AB Amsterdam  Fax: +31.20.5354445
The Netherlands        The Netherlands    Mobile: +31.6.55861746
------------------------------------------------------------------------------

Belgium: an unsolvable problem, discussed in endless meetings, with no
          hope for a solution, where everybody still lives happily.

---

From: Al Morton <[email-masked]>
Date: Mon, 06 Jul 2009 15:09:01 -0400

Ruediger and all,

Rather that write a long e-mail on this topic
(that few people will read), I wrote a short memo
(that few people will read). This memo is intended
as a background for discussion of some of the issues
Ruediger touched-on, and several new issues that occurred to me.
It is intended to help advance (not replace)
either the geib or bradner versions of the metrictest memos.

Whenever the advancing metrics topic comes up,
I've made a taken a position at the microphone that
may not have been fully understood. So, I've given-up
some of my holiday weekend and included details of my rant
in this short memo.  I hope it will be useful
to IPPM as we seek a way *up* the standards track that works.

Al

A New Internet-Draft is available from the on-line Internet-Drafts directories.

         Title           : Problems and Possible 
Solutions for Advancing Metrics on the Standards Track
         Author(s)       : A. Morton
         Filename        : draft-morton-ippm-advance-metrics-00.txt
         Pages           : 11
         Date            : 2009-07-06

This memo identifies some issues with the process of progressing
performance metric RFCs along the standards track.  This memo takes
the position that the metric definitions themselves should be the
primary focus, rather than the implementations of metrics.  This
appears to allow some simplification of the task at hand and
subsequently leads to solutions for the issues raised.

A URL for this Internet-Draft is:
http://www.ietf.org/internet-drafts/draft-morton-ippm-advance-metrics-00.txt

At 08:47 AM 7/6/2009, Henk Uijterwaal wrote:
>>the submitted draft on the advancement of 
>>metrics to standards hopefully is clear enough 
>>on the suggested methodology and its execution.
>>I won't participate in the Stockholm meeting. 
>>If the WG welcomes continuation of the work on 
>>this document, then the areas requiring more input I'm aware of are:
>>- statistical tests on time series producing 
>>verifyable results with the desired 
>>confidence   (suggested default 95%). And a 
>>review by a statistician in general.
>>- Measurement and networking expert to define 
>>what are sufficiently "identical 
>>network   conditions", as that's a basic 
>>assumption for the suggested metric test.
>>Deutsche Telekom Netzproduktion GmbH Zentrum 
>>Technik Einführung Technik Internet Backbone, TE142-19
>>Rüdiger Geib
>>Heinrich Hertz Str. 3-7
>>64297 Darmstadt
>>Tel.: 06151/6282747
>>Fax: 0251/7985109
>>
>>Geschäftsführung: Dr. Bruno Jacobfeuerborn 
>>(Vorsitzender), Albert Matheis, Klaus Peren
>_______________________________________________
>ippm mailing list
>[email-masked]
>https://www.ietf.org/mailman/listinfo/ippm

---

From: <[email-masked]>
Date: Tue, 7 Jul 2009 09:30:38 +0200

Al,

thanks for your work. At least the two of us read each others 
documents.

I think it is good to work out general principles and 
carefully go to details later on. Your draft contains a bit 
of both.

The really bad thing is, that as soon we go to a detailed 
description, we face issues. That's why I would suggest 
to start by the general approach.

I however prefer a sufficiently defined statistical test, 
if our purpose is to avoid "everything" to be IPPM 
compliant. But may have overlooked other possibilities 
to reach this aim.

Regards,

Ruediger

-----Original Message-----
From: Al Morton [mailto:[email-masked]] 
Sent: Monday, July 06, 2009 9:09 PM
To: Henk Uijterwaal; Geib, Rüdiger
Cc: [email-masked]; [email-masked]
Subject: Re: [ippm] Advancement of metrics to standards draft

Ruediger and all,

Al