Subject: [ippm] Comments on draft-ietf-ippm-spatial-composition

From: <[email-masked]>
Date: Tue, 8 Dec 2009 12:13:35 +0100

Al, Emile,

the draft is indeed in a good shape and I support it progressing through last call. Hope I'm not too late again with the two comments I have.

   5.3.2.  Definition and Metric Units of the Minimum Statistic

Defines how to determine the minimum delay (singleton or sample) of each sub path.

   5.3.5.  Composition Function: Sum of Minima

   The Type-P-Finite--Composite-One-way-Delay-Minimum, or CompMinDelay,
   for the complete Source to Destination path can be calculated from
   sum of the Minimum Delays of all its S constituent sub-paths.

   5.3.9.  Specific cases where the conjecture might fail

   If the routing on any of the sub-paths is not stable, then the
   measured minimum may not be stable.  In this case the composite
   minimum would tend to produce an estimate for the complete path that
   may be too low for the current path.

5.3.9 may not address transmission layer resilience (or effects of load balancing) sufficiently well. Should routing/resilience in other layers be mentioned here explicitely? Maybe a reference to section "4.1.8 Sources of Deviation from the Ground Truth" may be useful here.

-------

   7.1.5.1.  Approximate Convolution

   The Type-P-Finite-One-way-Delay-Poisson/Periodic-Stream samples from
   each sub-path are summarized as a histogram with 1 ms bins
   representing the one-way delay distribution.

   7.1.8.  Sources of Deviation from the Ground Truth

   In addition to the common deviations, a few additional sources exist
   here.  For one, very tight distributions with range on the order of a
   few milliseconds are not accurately represented by a histogram with 1
   ms bins.  This size was chosen assuming an implicit requirement on
   accuracy: errors of a few milliseconds are acceptable when assessing
   a composed distribution quantile.

There may be a hidden assumption on the measurement points, network bandwidth and load conditions or measurement intervals and average singleton frequency applicable here. It may be helpful to add a little more text, under which conditions this convolution produces useful results (or mention that these factors have an impact). More explicit: if there need to be results in more than one or two millisecond bins to apply this metric, this should be mentioned. 

--------

Regards, Ruediger

Deutsche Telekom Netzproduktion GmbH
Zentrum Technik Einführung
Rüdiger Geib
Heinrich-Hertz-Straße 3-7, 64295 Darmstadt
+49 6151 628-2747 (Tel.)
+49 251 7985 209 (Fax)
http://www.telekom.com

Deutsche Telekom Netzproduktion GmbH
Aufsichtsrat: Dr. Steffen Roehn (Vorsitzender)
Geschäftsführung: Dr. Bruno Jacobfeuerborn (Vorsitzender), Albert Matheis, Klaus Peren
Handelsregister: Amtsgericht Bonn HRB 14190
Sitz der Gesellschaft: Bonn
USt-IdNr. DE 814645262

---

From: Al Morton <[email-masked]>
Date: Tue, 08 Dec 2009 11:51:14 -0500

Hi Ruediger,

Thanks for your (not too late) review and comments.
Last year, I lost some comments on this topic that
arrived during December. I hope that doesn't happen
this time...

regards,
Al

At 06:13 AM 12/8/2009, [email-masked] wrote:
>Al, Emile,
>
>the draft is indeed in a good shape and I 
>support it progressing through last call. Hope 
>I'm not too late again with the two comments I have.
>
>5.3.9 may not address transmission layer 
>resilience (or effects of load balancing) 
>sufficiently well. Should routing/resilience in 
>other layers be mentioned here explicitely? 
>Maybe a reference to section "4.1.8 Sources of 
>Deviation from the Ground Truth" may be useful here.
>
>-------
>
>There may be a hidden assumption on the 
>measurement points, network bandwidth and load 
>conditions or measurement intervals and average 
>singleton frequency applicable here. It may be 
>helpful to add a little more text, under which 
>conditions this convolution produces useful 
>results (or mention that these factors have an 
>impact). More explicit: if there need to be 
>results in more than one or two millisecond bins 
>to apply this metric, this should be mentioned.
>
>--------
>
>Regards, Ruediger
>
>Geschäftsführung: Dr. Bruno Jacobfeuerborn 
>(Vorsitzender), Albert Matheis, Klaus Peren