Subject: [ippm] TWAMP in layer 2

From: Rakeshkumar Patel <[email-masked]>
Date: Fri, 02 Dec 2011 13:45:32 -0500

What's the TWAMP application in layer 2 network ? Is Y.1731 (Delay
measurement) serve TWAMP purpose in layer 2 network ?

---

From: Yaakov Stein <[email-masked]>
Date: Thu, 15 Dec 2011 13:56:13 +0000

Y.1731 has several functions that may overlap OWAMP or TWAMP functions.
As does 802.3 Clause 57 (EFM OAM).

However, Y.1731 divides up the functionality into separate packets,
one type for packet loss, one type for delay measurement, etc.
Each of these functions triggers calculation at the OAM endpoints,
rather than sending the raw data to a controller for processing.

Also, Y.1731 is typically often used continuously, or at least periodically,
rather than setting up a test session as in xWAMP.

Finally, Y.1731 does not define a security mechanism.
although it could be used in association with one (e.g., MACsec).

Y(J)S

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf Of Rakeshkumar Patel
Sent: Friday, December 02, 2011 20:46
To: [email-masked]
Subject: [ippm] TWAMP in layer 2

_______________________________________________
ippm mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/ippm

---

From: Rakeshkumar Patel <[email-masked]>
Date: Thu, 15 Dec 2011 10:47:03 -0500

Y.1731 is widely adopted standard and many vendors support it. Is TWAMP
also widely adopted ?

Y.1731 can be configured per vlan. Does TWAMP needs to be per vlan ?

Is it possible to implement TWAMP security mechanism in hardware ? If it
is not, how efficient its implementation in software ?

---

From: Al Morton <[email-masked]>
Date: Thu, 15 Dec 2011 11:06:39 -0500

>Y.1731 is widely adopted standard and many vendors support it. Is TWAMP

Yes, "About 12,600 results" on Google...

>Y.1731 can be configured per vlan. Does TWAMP needs to be per vlan ?

you can put the test stream in a VLAN, If that's the question.

>is not, how efficient its implementation in software ?
with the mixed-mode feature, efficiency is less of an issue...
http://tools.ietf.org/html/rfc5618

-- Agree with Yaakov, one TWAMP test session does ~all,
Al