Subject: [ippm] Call for agenda slots, IPPM at IETF 89 London

From: Brian Trammell <[email-masked]>
Date: Mon, 10 Feb 2014 08:32:04 +0100

Greetings, all,

Please send requests for agenda slots in Vancouver to [email-masked] by Thursday, February 13. 

As usual, we'd like to have slots for (in priority order):

- each of the current working group drafts
- the results of the Registry Design Team effort
- any new work fitting in our charter
- significant updates of work already presented

Many thanks, best regards,

Brian

---

From: Brian Trammell <[email-masked]>
Date: Mon, 10 Feb 2014 08:40:10 +0100

Greetings, all,

Apologies for the copy/paste error: please send requests for agenda slots in _London_, of course. :) FYI, we're presently scheduled to meet for two hours on Monday afternoon 3 March at 13:00.

Best regards,

Brian

On 10 Feb 2014, at 08:32, Brian Trammell <[email-masked]> wrote:

> _______________________________________________
> ippm mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/ippm

---

From: Dave Taht <[email-masked]>
Date: Mon, 10 Feb 2014 08:22:57 -0800

I severely doubt at this point that this will be ready before this ietf meeting.

http://snapon.lab.bufferbloat.net/~d/draft-taht-twd-00.html

The core technique will hopefully migrate into d-itg this month and
possibly a few other benchmarks. Some prototypes of the code, designed
to minimize host scheduler impact, exist at:

https://github.com/dtaht/twd

But: I am mostly thinking of throwing out the protocol design and
migrating to  Quic.

-- 
Dave Täht

Fixing bufferbloat with cerowrt: http://www.teklibre.com/cerowrt/subscribe.html

---

From: Steve Baillargeon <[email-masked]>
Date: Mon, 10 Feb 2014 17:44:54 +0000

Hi Dave
Take a look at http://tools.ietf.org/pdf/draft-hedin-ippm-type-p-monitor-02.pdf

It describes a new mode to monitor DSCP and/or ECN using TWAMP. 
I believe it addresses the following 2 points (at least the protocol changes) highlighted in your draft:

.respect for and preservation of diffserv bits 
.respect for and preservation ecn-related bits

-Steve

-----Original Message-----
From: ippm [mailto:[email-masked]] On Behalf Of Dave Taht
Sent: February-10-14 11:23 AM
To: Brian Trammell
Cc: [email-masked]
Subject: Re: [ippm] Call for agenda slots, IPPM at IETF 89 London

The core technique will hopefully migrate into d-itg this month and possibly a few other benchmarks. Some prototypes of the code, designed to minimize host scheduler impact, exist at:

But: I am mostly thinking of throwing out the protocol design and migrating to  Quic.

--
Dave Täht

---

From: Dave Taht <[email-masked]>
Date: Mon, 10 Feb 2014 09:51:15 -0800

helpful, thank you!

I note that what I was trying to roll was a system, code architecture
and method for measuring one way delays in each direction
simultaneously.

It turned out that timestamping right-off-the-hw device ringbuffer has
an API in linux that looked quite usable.

-- 
Dave Täht