Subject: [ippm] Fwd: Call for adoption: IPPM Registry Drafts

From: Brian Trammell <[email-masked]>
Date: Tue, 4 Mar 2014 16:07:21 +0000

Greetings, all,

At yesterday's IPPM WG meeting in London, we started a call for adoption on the following three drafts as working group items in support of our charter item to define a performance metric registry.

draft-manyfolks-ippm-metric-registry-00

draft-mornuley-ippm-registry-active-00

draft-akhter-ippm-registry-passive-01

There was clear consensus in the room to adopt, with the understanding that possible questions about the scope of the metrics defined in this registry would need to be addressed in the working group and across areas. 

I would propose the following milestones:

Aug 2014 Submit draft on core registry for performance metrics to IESG as Proposed Standard
Aug 2014 Submit draft on registry for active performance metrics to IESG as Proposed Standard
Dec 2014 Submit draft on registry for passive performance metrics to IESG as Proposed Standard

This would give us about six months (and one meeting) to discuss core and active registry issues, and nine months (two meetings) for passive issues. 

We'd like to hear any comments on adoption from those not in the room, and/or additional comments from all (especially on milestones and timing) until next Tuesday 11 March 2014.

Thanks, best regards,

Brian

---

From: Joachim Fabini <[email-masked]>
Date: Wed, 05 Mar 2014 08:52:17 +0100

Brian, IPPM,

being one of the off-liners I support the call for adoption.
Two comments:

1. I DO support a metric registry which goes beyond the scope of IPPM. 
There should be one central-point-of-contact where users and other 
organizations can search for registries. Imho central topics with this 
respect:
(a) to find out if the IETF process allows for this broad registry scope 
as mentioned during the meeting for the case of MPLS. I'm sure that 
there are other groups, too, defining metrics which fit into the 
registry. For instance SIP signaling metrics (RFC6076) might be another 
candidate, BMWG has, for sure, to add some more...
(b) to conduct a survey on which WGs would be affected, if/how their 
requirements impact on the registry structure and how this input could 
be gathered and fed into the registry design process.

2. Registries for active and passive metrics should be aligned to each 
other, i.e., share as much as possible of structure and names. For 
instance consider the Packet-Type-P column for active measurements and 
the Filter Criteria column for passive measurements. These two imho 
might denote the same concept with Packet-Type-P being formally defined 
in RFC2330. However, filtering considers also packet content (runtime 
information) as opposed to Packet-Type-P, which (iirc) affects only 
packet protocol/type/control information.
It might be also interesting to discuss to which extent sampling for 
passive measurements and traffic generation for active measurements 
use/share identical methodologies and algorithms. A framework document 
for passive measurements would help tremendously.

Summarizing: the broader the scope of the registry documents is, the 
higher the registry value to (IETF-internal and -external) users will 
be. Naming and structure of active and passive registries should be 
aligned if feasible, commonalities worked out.
Having no passive measurements framework document yet, my feeling is 
that the proposed time schedule is pretty tight. The content of a 
(future) passive measurement RFC will likely influence on the registry 
structure. I might be desirable to start work on the passive measurement 
framework draft in parallel to the registry design...

jm2c,
best regards
Joachim

On 04.03.2014 17:07, Brian Trammell wrote:
> _______________________________________________
> ippm mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/ippm
>

---

From: Brian Trammell <[email-masked]>
Date: Tue, 11 Mar 2014 21:59:16 +0100

Greetings, all,

As there has been no negative comment since our meeting in London, I see clear consensus in the IPPM WG to adopt these three drafts for the registry definition charter item (paragraph 7 of the charter item).

Authors, please submit working group revisions of these documents:

draft-ietf-ippm-registry for draft-manyfolks-ippm-metric-registry-00

draft-ietf-ippm-registry-active for draft-mornuley-ippm-registry-active-00

draft-ietf-ippm-registry-passive for draft-akhter-ippm-registry-passive-01

The work of the registry design team is now concluded; many, many thanks for putting together a strong basis for work on the registry within the WG!

Best regards,

Brian

---

From: Vero Zheng <[email-masked]>
Date: Thu, 13 Mar 2014 02:23:40 +0000

> Having no passive measurements framework document yet, my feeling is that
> the proposed time schedule is pretty tight. The content of a
> (future) passive measurement RFC will likely influence on the registry structure.
> I might be desirable to start work on the passive measurement framework
> draft in parallel to the registry design...

+1
I also see there is requirement from service provider, both on passive measurement methodology and metrics. And I also see there's people working on it in IPPM.
I actually had a talk with Brian in London and Brian also see the importance of a passive measurement framework. I'm personally interested in working on this, and plan to submit the 00 framework draft before Toronto meeting. People who has interest please contact me offline.

BR,
Vero

> -----Original Message-----
> From: ippm [mailto:[email-masked]] On Behalf Of Joachim Fabini
> Sent: Wednesday, March 05, 2014 3:52 PM
> To: Brian Trammell; [email-masked]
> Subject: Re: [ippm] Fwd: Call for adoption: IPPM Registry Drafts
> 
> Brian, IPPM,
> 
> (a) to find out if the IETF process allows for this broad registry scope as
> mentioned during the meeting for the case of MPLS. I'm sure that there are
> other groups, too, defining metrics which fit into the registry. For instance SIP
> signaling metrics (RFC6076) might be another candidate, BMWG has, for sure,
> to add some more...
> requirements impact on the registry structure and how this input could be
> gathered and fed into the registry design process.
> 
> 2. Registries for active and passive metrics should be aligned to each other, i.e.,
> share as much as possible of structure and names. For instance consider the
> Packet-Type-P column for active measurements and the Filter Criteria column
> for passive measurements. These two imho might denote the same concept
> with Packet-Type-P being formally defined in RFC2330. However, filtering
> considers also packet content (runtime
> information) as opposed to Packet-Type-P, which (iirc) affects only packet
> protocol/type/control information.
> It might be also interesting to discuss to which extent sampling for passive
> measurements and traffic generation for active measurements use/share
> identical methodologies and algorithms. A framework document for passive
> measurements would help tremendously.
> 
> Summarizing: the broader the scope of the registry documents is, the higher
> the registry value to (IETF-internal and -external) users will be. Naming and
> structure of active and passive registries should be aligned if feasible,
> commonalities worked out.
> Having no passive measurements framework document yet, my feeling is that
> the proposed time schedule is pretty tight. The content of a
> (future) passive measurement RFC will likely influence on the registry structure.
> I might be desirable to start work on the passive measurement framework
> draft in parallel to the registry design...
> 
> jm2c,
> best regards
> Joachim
> 
> > At yesterday's IPPM WG meeting in London, we started a call for adoption on
> the following three drafts as working group items in support of our charter item
> to define a performance metric registry.
> >
> > There was clear consensus in the room to adopt, with the understanding that
> possible questions about the scope of the metrics defined in this registry would
> need to be addressed in the working group and across areas.
> >
> > Aug 2014 Submit draft on core registry for performance metrics to IESG
> > as Proposed Standard Aug 2014 Submit draft on registry for active
> > performance metrics to IESG as Proposed Standard Dec 2014 Submit draft
> > on registry for passive performance metrics to IESG as Proposed
> > Standard
> >
> > This would give us about six months (and one meeting) to discuss core and
> active registry issues, and nine months (two meetings) for passive issues.
> >
> > We'd like to hear any comments on adoption from those not in the room,
> and/or additional comments from all (especially on milestones and timing) until
> next Tuesday 11 March 2014.
> >
> > Thanks, best regards,
> >
> > Brian
> >

---

From: lingli deng <[email-masked]>
Date: Fri, 14 Mar 2014 08:42:10 +0800

hi vero,

i would be happy to be involved.
as expressed earlier, i believe there are cases where passive measurement
is expected to be more helpful.

lingli

>> (future) passive measurement RFC will likely influence on the registry
structure.
> I also see there is requirement from service provider, both on passive
measurement methodology and metrics. And I also see there's people working
on it in IPPM.
> I actually had a talk with Brian in London and Brian also see the
importance of a passive measurement framework. I'm personally interested in
working on this, and plan to submit the 00 framework draft before Toronto
meeting. People who has interest please contact me offline.
>> (a) to find out if the IETF process allows for this broad registry scope
as
>> 2. Registries for active and passive metrics should be aligned to each
other, i.e.,
>> information) as opposed to Packet-Type-P, which (iirc) affects only
packet
>> It might be also interesting to discuss to which extent sampling for
passive
>> Summarizing: the broader the scope of the registry documents is, the
higher
>> (future) passive measurement RFC will likely influence on the registry
structure.

-- 
邓灵莉/Lingli Deng
中国移动通信研究院/China Mobile Research Institute
e-mail: [email-masked]
tel: 15801696688-3367
mobile: 13810597148