Subject: Re: [ippm] [lmap] active and passive measurement method / task definition

From: "marc.ibrahim" <[email-masked]>
Date: Thu, 29 May 2014 17:06:03 +0300

Juergen,

I am just trying to discuss what I felt is unclear in the definitions.
Let me give a practical example from a project i'm doing.
We have MA1 sending UDP traffic to MA2. MA2 will receive UDP packet and compute jitter. 
This is clearly an active measurement task for MA1.
What is unclear for me is how to define MA2 tasks.
Is it just one active task consisting in receiving packets from MA1 and computing 
jitter, or two tasks:

- One active task consisting in receiving the active traffic generated by MA1, 
- One passive task consisting in measuring jitter for the udp flow. It is passive 
according to the definition since MA2 does not generate the observed flow. 

BR,
Marc.

On Thu, 29 May 2014 15:36:28 +0200, Juergen Schoenwaelder wrote
> On Thu, May 29, 2014 at 04:24:01PM +0300, marc. ibrahim wrote:
> > According to the current Passive Measurement Method definition, an MA observing an 
> > active traffic measurement sent to it is performing a passive task. But in the same 
time 
> > it is an active task according the active definition.
> > 
> > As I said in my previous mail, the definitions should not be relative to a single 
MA.
> >
> 
> I believe, for LMAP the definitions are good enough. In particular for
> a passive/active measurement _task_ since tasks are executed by MAs.
> It seems you want to separate out passive/active measurement _method_,
> right? So what is the concrete proposal?
> 
> /js
> 
> -- 
> Juergen Schoenwaelder           Jacobs University Bremen gGmbH
> Phone: +49 421 200 3587         Campus Ring 1, 28759 Bremen, Germany
> Fax:   +49 421 200 3103         <http://www.jacobs-university.de/>
> 
> _______________________________________________
> lmap mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/lmap

--
Open WebMail Project (http://openwebmail.org)

---

From: "marc.ibrahim" <[email-masked]>
Date: Thu, 29 May 2014 19:59:18 +0300

On Thu, 29 May 2014 16:43:54 +0000, KEN KO wrote
> I have always viewed Measurement Method/Task as independent from the viewpoint 
> of a specific MA - holistic, if you will. I would support any necessary 
> terminology that clarifies that definition.
> 
> Even if we all accept the above interpretation, I don't think we need new 
> terms in lmap. The 'initiating' MA's operational role should be fully defined 
> by the configuration and scheduling of a Measurement Task. Any other MAs roles 
> are communicated to them by the initiating MA, either in the form of messages 
> (eg, http GET) or something more specific to the Measurement Method - again, 
> fully defined via the configuration of the Task. Do we really need something new?

I agree with this view. I tend to say that the task transcends individual MA.

In a simple A-B ping example, it is a single task initiated by A that is executing an 
active task that has been instructed by the controller, while B is just "participating" 
in the task. I don't see that we can we talk about a task being executed by B. Is 
replying to a ping a full task that can be instructed and scheduled by the controller? I 
don't see that. 

BR,

Marc.
> 
> > -----Original Message-----
> > From: ippm [mailto:[email-masked]] On Behalf Of STARK, BARBARA
> > H
> > Sent: Thursday, May 29, 2014 12:14 PM
> > To: marc.ibrahim; Nalini Elkins; Juergen Schoenwaelder; Vero Zheng
> > Cc: [email-masked]; [email-masked]
> > Subject: Re: [ippm] [lmap] I-D Action: draft-ietf-lmap-framework-05.txt
> > 
> > > I think the confusion comes from whether or not to consider individual MA.
> > > For a single MA, measuring existing traffic is passive relatively to
> > > this given MA.
> > > But if this traffic was sent from another MA, then the whole method is
> > > active since somebody has injected traffic.
> > >
> > > I think the definitions of active and passive methods are not relative
> > > to an MA but to all MAs/MPs involved each measurement. If this is the
> > > case, "Receiving" is not really different from "generating" since an
> > > MA will receive and measure what has been generated.
> > 
> > I'm not sure if it's confusion so much as it is the term ippm needs vs. the term
> > lmap needs. Lmap looks at the world from the perspective of the MA, and
> > from the perspective of the operation systems. Ippm looks at the world from
> > the perspective of metrics (and what needs to happen to generate the
> > metrics).
> > 
> > Lmap needs terms that describe (generally and as a specific instantiation of
> > the general term) what an MA does to accomplish its role in the term that
> > ippm needs.
> > It sounds like Ippm needs a term to describe holistically what is involved in
> > generation of a particular metric.
> > 
> > Using the same term (Measurement Method or its Measurement Task
> > instantiation) as both the MA functional role and as the holistic metric
> > generation method (task) is problematic. These need to be distinct terms.
> > 
> > In the context of the ippm registry, we really need registry entries to provide
> > specifics for configuring each MA role that is part of the holistic system
> > needed for the metric.
> > 
> > So if Measurement Method / Task describe the holistic technique, then lmap
> > needs new terms. If Measurement Method / Task describe an MA's specific
> > role, then ippm needs new terms for the holistic technique (and holistic
> > instantiations of that technique).
> > Barbara
> > 
> > 
> > ippm mailing list
> > [email-masked]
> > https://www.ietf.org/mailman/listinfo/ippm
>

---

From: "MORTON, ALFRED C (AL)" <[email-masked]>
Date: Thu, 29 May 2014 18:06:25 -0400

Long thread today...

I think it ended-up in a productive place, a logical examination
of a realistic scenario and whether the framework and (more importantly)
the Information Model have the flexibility to instantiate it 
( A - C - B hosts observing  or performing ICMP echo req/replies).
It's a similar concept to one we examined in IPPM and wrote about: 
http://tools.ietf.org/html/rfc5644

The key factor in determining the type of measurement in this RFC was the
a priori knowledge of the packet (or stream) from the source.
Packet loss could be measured at  mid-point  "C"(and subsequent points)
because the measurement system knew when packets were sent from "A"
could distinguish between different packets of the same stream, and knew 
how long to wait for them. 

Once we are satisfied that the Information Model allows the needed flexibility
for control, it would be good to take another step: The Information Model
depends on the Performance Metrics Registry, which we have split into
active and passive sub-registries. If the observations you want to make at
mid-point "C" can be supported with a metric from the passive registry,
that's input to the measurement categorization. If not, try the active registry.
If the active and/or passive registries support some important scenarios, 
then we've come a long way.

regards,
Al

________________________________________
From: ippm [[email-masked]] On Behalf Of KEN KO [[email-masked]]
Sent: Thursday, May 29, 2014 2:15 PM
To: STARK, BARBARA H; marc.ibrahim; Nalini Elkins; Juergen Schoenwaelder; Vero Zheng; [email-masked]; [email-masked]
Cc: [email-masked]; [email-masked]
Subject: Re: [ippm] [lmap] I-D Action: draft-ietf-lmap-framework-05.txt

Barbara,

I agree with most of what you are saying.

Measurement Methods can be complex and can create different roles for different MAs, and it is very possible for each MA to be configured only with its own role. There may be Methods for which MA A could participate with MAs B and C without a priori knowledge of their roles, and get completely different yet equally proper responses from each of them. I hadn't considered this and it contradicts my earlier comment (which I rescind) about the initiating MA having all information relevant to a Task.

Having said all that, I still don't see the need for a new term beyond the language we have already used - that is, each MA's role in executing a Task.

While we're at it, we might want to consider the above scenario with regard to the draft Information Model. Can we currently configure a Task as being triggered by something other than a Schedule - in response to an external stimulus like a message from a remote MA? I think we can:
- One or more ma-task-options objects within ma-task-obj specifies the non-Schedule conditions under which the Task is initiated. Unless Schedule-based initiation is also desired, the Measurement Task Configuration would not be referenced in a local Schedule.

However, I don't see this addressed explicitly in either the framework or the information model, and if this behavior is in scope I think it needs language for clarity.

The other area you touch on (unilateral exceptions where, for instance, a MA does not respond to MAs outside a configured address range) seems equally valid, and I'm more open to a new term  to describe it. Does "exceptions" fit the bill?

Ken

> From: STARK, BARBARA H [mailto:[email-masked]]
> Sent: Thursday, May 29, 2014 1:20 PM
> To: marc.ibrahim; KEN KO; Nalini Elkins; Juergen Schoenwaelder; Vero Zheng
> Cc: [email-masked]; [email-masked]
> Subject: RE: [lmap] [ippm] I-D Action: draft-ietf-lmap-framework-05.txt
>
> > In a simple A-B ping example, it is a single task initiated by A that
> > is executing an active task that has been instructed by the
> > controller, while B is just "participating"
> > in the task. I don't see that we can we talk about a task being executed by
> B.
> > Is replying to a ping a full task that can be instructed and scheduled
> > by the controller? I don't see that.
>
> I think it would be possible to schedule B to only respond to pings at certain
> times of day. Responding to ping is something that can be enabled/disabled.
> In which case it can be enabled and disabled according to a schedule. The
> enabling/disabling of B's ability to respond to pings can be completely and
> totally distinct from any schedules that involve B initiating ping -- they are 2
> distinct roles. Configuration of these roles is also distinct (responding may not
> require any configuration other than the schedule, or it could be configured
> to only respond to pings from certain IP addresses). It may even be that an
> MA only has the ability to initiate ping and never respond, or vice versa.
>
> I very much believe that from the MA perspective (lmap), it is critical that we
> be able to talk about the MA's role in a holistic technique. I also believe that
> the MA can have a passive role (does not generate measurement traffic) or
> an active role (generates measurement traffic) independent of how ippm
> may choose to characterize the holistic technique.
> Barbara

---

From: Mach Chen <[email-masked]>
Date: Fri, 30 May 2014 03:36:00 +0000

Hi Greg and all,

I totally agree with Greg’s point here. I like the idea of “Measurement Domain object”.

Best regards,
Mach

From: ippm [mailto:[email-masked]] On Behalf Of Greg Mirsky
Sent: Friday, May 30, 2014 12:34 AM
To: KEN KO
Cc: [email-masked]; marc.ibrahim; [email-masked]; [email-masked]
Subject: Re: [ippm] [lmap] I-D Action: draft-ietf-lmap-framework-05.txt

Hi Ken,
I agree with the point Marc and you have brought up. I think that to differentiate whether articular method is Active or Passive may require introduction of a Measurement Domain object as set of cooperating MAs and MPs. Then measuring explicitly traffic that been injected by MA(s) in the same Measurement Domain would be Active Measurement Method/Task. But measuring on overall traffic even if that may include injected traffic, IMO, would be Passive Measurement Method/Task.
Regards,
Greg

On Thu, May 29, 2014 at 7:17 AM, KEN KO <[email-masked]<mailto:[email-masked]>> wrote:
I agree with Marc’s comments, e.g., a Measurement Method is Active if any MA involved in the measurement is generating measurement traffic. And yes, PING is an Active Measurement Method.

However, traffic measured by a Passive Method can easily include measurement traffic generated by an unrelated Active Method. In this context for instance, a Measurement Method that does nothing but count received packets is still Passive, even if some of those packets are due to unrelated PINGs (or throughput tests, etc.).

From: lmap [mailto:[email-masked]<mailto:[email-masked]>] On Behalf Of Nalini Elkins
Sent: Thursday, May 29, 2014 9:31 AM
To: marc.ibrahim; STARK, BARBARA H; Juergen Schoenwaelder; Vero Zheng
Cc: [email-masked]<mailto:[email-masked]>; [email-masked]<mailto:[email-masked]>; [email-masked]<mailto:[email-masked]>

Subject: Re: [lmap] [ippm] I-D Action: draft-ietf-lmap-framework-05.txt

The problem is what to consider as "injected traffic".  For example, on many networks, various devices, for their own purposes do PING commands.    So, then does that convert the entire measurement to active?

Thanks,

Nalini Elkins
Inside Products, Inc.
(831) 659-8360<tel:%28831%29%20659-8360>
www.insidethestack.com<http://www.insidethestack.com>

________________________________
From: marc.ibrahim <[email-masked]<mailto:[email-masked]>>
To: "STARK, BARBARA H" <[email-masked]<mailto:[email-masked]>>; Nalini Elkins <[email-masked]<mailto:[email-masked]>>; Juergen Schoenwaelder <[email-masked]<mailto:[email-masked]>>; Vero Zheng <[email-masked]<mailto:[email-masked]>>
Cc: "[email-masked]<mailto:[email-masked]>" <[email-masked]<mailto:[email-masked]>>; "[email-masked]<mailto:[email-masked]>" <[email-masked]<mailto:[email-masked]>>; "[email-masked]<mailto:[email-masked]>" <[email-masked]<mailto:[email-masked]>>
Sent: Thursday, May 29, 2014 6:14 AM
Subject: Re: [lmap] [ippm] I-D Action: draft-ietf-lmap-framework-05.txt

Hi,

I think the confusion comes from whether or not to consider individual MA.
For a single MA, measuring existing traffic is passive relatively to this given MA.
But if this traffic was sent from another MA, then the whole method is active since
somebody has injected traffic.

I think the definitions of active and passive methods are not relative to an MA but to
all MAs/MPs involved each measurement. If this is the case, "Receiving" is not really
different from "generating" since an MA will receive and measure what has been
generated.

BR,

Marc.

On Thu, 29 May 2014 12:57:35 +0000, STARK, BARBARA H wrote
> ?? Receiving does or doesn't need to be a portion of the Active Measurement
> Method definition? If a Passive Measurement Method is any method that measures
> traffic without injecting traffic, doesn't that cover a Measurement Method
> that measures received traffic? Barbara
>
> From: Nalini Elkins [mailto:[email-masked]<mailto:[email-masked]>]
> Sent: Thursday, May 29, 2014 8:49 AM
> To: STARK, BARBARA H; Juergen Schoenwaelder; Vero Zheng
> Cc: [email-masked]<mailto:[email-masked]>; [email-masked]<mailto:[email-masked]>; [email-masked]<mailto:[email-masked]>
> Subject: Re: [lmap] [ippm] I-D Action: draft-ietf-lmap-framework-05.txt
>
> /*snip*/
> >>> Active Measurement Method - The process of measuring some performance or
reliability parameter associated with the transfer of Traffic by generating and/or
receiving Active Measurement Traffic.
> >>>
> /*snip*/
> >>> Passive Measurement Method- The process of measuring some performance or
reliability parameter associated with the existing traffic on the network.
> /*snip*/
>
> >>But what if I have an MA passively measuring traffic that was injected
> >>(perhaps by some other MA) for the purpose of measuring it? Why is
> >>this distinction REAL vs non-REAL useful? And what is the definition
> >>of REAL of "existing traffic" anyway? If I inject measurement traffic
> >>observed by some MA, it is "existing traffic", no?
>
> > Yes, point well taken.  The distinction we wanted to make is that the passive
measurement technique does not inject traffic.  Other MA's or indeed other devices on
the network create traffic for their own purposes, some of which may be performance
measurement.  We also wanted to come up with a good definition for passive measurement
that would work for all parties.  How is the following?
>
> > Passive Measurement Method- The process of measuring some performance or reliability
parameter associated with the traffic on the network.  The passive measurement method
does not inject traffic for the purposes of measurement.
>
> >>Would that mean that the definition of Active Measurement Method wouldn't involve
receiving Active Measurement Traffic, and only generated (injecting)?
> >>Active Measurement Method - The process of measuring some performance or reliability
parameter associated with the transfer of traffic by generating Active Measurement
Traffic.
>
> Indeed, the word "receiving" needs to be a portion of the Active Measurement
> Method definition.  Thanks!
>
> Nalini
>
> [email-masked]<mailto:[email-masked]><mailto:[email-masked]<mailto:[email-masked]>>

--
Open WebMail Project (http://openwebmail.org<http://openwebmail.org/>
)

_______________________________________________
lmap mailing list
[email-masked]<mailto:[email-masked]>
https://www.ietf.org/mailman/listinfo/lmap

---

From: Mach Chen <[email-masked]>
Date: Fri, 30 May 2014 03:45:36 +0000

Hi Greg,

IMHO, whether C is doing Active or Passive is dependent on whether it belongs to the same Measurement Instance of A and B. If it is, then it is Active, otherwise Passive.

Best regards,
Mach

From: ippm [mailto:[email-masked]] On Behalf Of Greg Mirsky
Sent: Friday, May 30, 2014 12:41 AM
To: STARK, BARBARA H
Cc: marc.ibrahim; [email-masked]; [email-masked]
Subject: Re: [ippm] [lmap] I-D Action: draft-ietf-lmap-framework-05.txt

Hi Barbara,
I think that if MA C counts only PINGs generated by A and B, then it is still Active Measurement Task. If MA C counts any PING it sees, then I'd consider it performing Passive Measurement in Measurement Domain that includes MAs A, B, and C.
On the second set of questions:
I agree with #3
Regards,
Greg

On Thu, May 29, 2014 at 8:01 AM, STARK, BARBARA H <[email-masked]<mailto:[email-masked]>> wrote:
I still have questions. I feel there’s still ambiguity and overlap in proposed definitions. My main goal is to get rid of ambiguity and overlap.

One thing I read in Marc’s email was:

This is clearly an active measurement task for MA1.
This to me suggests an idea that Active Measurement Method (or Task, which so far has been defined as an instantiation of a Method) doesn’t need to actually measure anything at all. It just needs to generate (inject) Active Measurement Traffic. It may or may not measure any performance or reliability parameters. That is, there was no description of MA1 measuring the UDP traffic it sent to MA2, as a qualifier for identifying this as an Active Measurement Task.

Looking at PING again. Let’s consider a system where there is a MA (A) generating a PING message, receiving a response message, and calculating the time between these 2 events, an MA (B) receiving the PING and generating a response, and an MA (C) that is in between A and B and counts the number of PING messages it sees. What I think I’m reading is:

1.       A is doing an Active Measurement Task.

2.       B is doing an Active Measurement Task. [Note that B hasn’t measured anything.]

3.       C is doing a Passive Measurement Task.
If the above is correct, I’d be fine with that.

So here’s a multiple choice question for y’all:
B starts counting received PING messages. Select the correct answer from those below, or invent a different answer.

1.       B’s counting of received PINGs is a new Passive Measurement Task, unrelated to the PING responding Task.

2.       B’s counting of received PINGs is part of the existing Active Measurement Task that involves responding to PINGs.

3.       B’s counting of received PINGs is part of a new Active Measurement Task, unrelated to the PING responding Task.

4.       All of the above could be true, depending on how the Measurement Methods are defined.

5.       1 or 2 could be true, depending on how the Measurement Methods are defined.

Barbara

From: KEN KO [mailto:[email-masked]<mailto:[email-masked]>]
Sent: Thursday, May 29, 2014 10:18 AM
To: Nalini Elkins; marc.ibrahim; STARK, BARBARA H; Juergen Schoenwaelder; Vero Zheng
Cc: [email-masked]<mailto:[email-masked]>; [email-masked]<mailto:[email-masked]>; [email-masked]<mailto:[email-masked]>
Subject: RE: [lmap] [ippm] I-D Action: draft-ietf-lmap-framework-05.txt

From: lmap [mailto:[email-masked]] On Behalf Of Nalini Elkins

Thanks,

Nalini Elkins
Inside Products, Inc.

Hi,

BR,

Marc.

_______________________________________________
ippm mailing list
[email-masked]<mailto:[email-masked]>
https://www.ietf.org/mailman/listinfo/ippm

---

From: "Romascanu, Dan (Dan)" <[email-masked]>
Date: Fri, 30 May 2014 07:36:37 +0000

> From: lmap [mailto:[email-masked]] On Behalf Of STARK, BARBARA H
> Sent: Friday, May 30, 2014 12:26 AM
> To: KEN KO; marc.ibrahim; Nalini Elkins; Juergen Schoenwaelder; Vero Zheng;
> [email-masked]; [email-masked]
> > Measurement Methods can be complex and can create different roles for
> > different MAs, and it is very possible for each MA to be configured
> > only with its own role. There may be Methods for which MA A could
> > participate with MAs B and C without a priori knowledge of their
> > roles, and get completely different yet equally proper responses from
> > each of them. I hadn't considered this and it contradicts my earlier
> > comment (which I rescind) about the initiating MA having all information
> relevant to a Task.
> >
> > Having said all that, I still don't see the need for a new term beyond
> > the language we have already used - that is, each MA's role in executing a
> Task.
> 
> I'm becoming ever more strongly convinced that either ippm or lmap needs a
> new term -- I don't care which. But my reading of framework and the
> information model is that what lmap is calling a Measurement Method and
> Measurement Task is related to the specific role the MA plays in the holistic
> technique. The MA absolutely does not need to know what other roles do or
> how they are configured. It doesn't care what they do. It only knows what it
> has to do. I think this is also important to understand in the design of the
> registry -- if there is some metric in the registry that requires proper
> configuration of multiple roles, the registry needs to be able to express what
> the proper configuration is for each distinct role. As a compromise (since
> many seem to want Measurement Method to be the holistic technique)
> maybe we should use Measurement Method for the holistic technique (and
> ippm can define that, because it's not really central to lmap), Measurement
> Method Role for the role of the Meas  urement Method that is implemented
> on a MA, and Measurement Task is an instantiation of a Measurement
> Method Role (which means a Task is *not* an instantiation of the
> Measurement Method -- which assumes ippm doesn't need a term for an
> instantiation of the holistic technique). Then lmap can have a Measurement
> Method Active Role that generates measurement traffic and may measure
> parameters, and a Measurement Method Passive Role that does not
> generate traffic and measures parameters. Ippm can define if there're such
> things as Active or Passive Measurement Methods. In lmap, we really only
> need to care about whether the role is active or passive, and not how the
> holistic technique is characterized.
> 

Hi Barbara.

Doesn't become too complicated? What is the difference between the Measurement Method Role and Measurement Task and why do we need the two distinct terms? Maybe it would help if you can provide a definition of Measurement Method Role because I frankly cannot compile ' Measurement Task is an instantiation of a Measurement Method Role', in other words why do we need a generic term and an instantiation? 

Thanks and Regards,

Dan
(speaking as contributor)

---

From: 邓灵莉/Lingli Deng <[email-masked]>
Date: Fri, 30 May 2014 18:24:50 +0800

Hi Al,

I agree with you on all your points, except the use of the word "observation" for passive measurement.
More inline.

> a priori knowledge of the packet (or stream) from the source.
[邓灵莉/Lingli Deng] Support. From the perspective of an MP performing a passive task, it has to do the measurement without any reliance on the prior knowledge from the source about the targeted traffic (when to expect it, how long and how large it would be, etc.). While in contrast, there is an active traffic generator in any active measurement task acting as the source, to ensure the participating MPs measures metrics for targeted traffic with known characteristics. 

> how long to wait for them.
[邓灵莉/Lingli Deng] There are also passive measurement methods, which can measure packet loss at mid-point by doing a little more than pure observation.
Examples include http://tools.ietf.org/html/draft-elkins-ippm-pdm-metrics-04 and http://tools.ietf.org/html/draft-chen-ippm-coloring-based-ipfpm-framework-01 (where the IP header is being marked/appended by an upstream MP to coordinate with the downstream MP for measurement on existing traffic and no traffic is injected for the purpose of measurement therefore no prior knowledge other than the appended/markded information piggybacked to the targeted traffic can be assumed for any participating MP).
> then we've come a long way.
[邓灵莉/Lingli Deng] I would like it more if the word "observation" is replaced by "measurement".
It gives two implications which I think Vero and Nalini wanted to avoid by raising the discussion in the first place.
1, It gives one the impression that a passive measurement task is always performed by an individual MP and does not need any coordination from outside. 
2, An MP doing passive measurement is not supposed to "touch" the traffic, but only "observes" them, in which case packet loss can hardly be measured.

Given the fact that "passive measurement" has a lot of possibilities more than pure observation, I echo Vero and Nalini that one should cease using "observation" as an synonym for passive measurement.

Lingli

---

From: "STARK, BARBARA H" <[email-masked]>
Date: Fri, 30 May 2014 14:14:38 +0000

> Doesn't become too complicated? What is the difference between the
> Measurement Method Role and Measurement Task and why do we need
> the two distinct terms? Maybe it would help if you can provide a definition of
> Measurement Method Role because I frankly cannot compile ' Measurement
> Task is an instantiation of a Measurement Method Role', in other words why
> do we need a generic term and an instantiation?

The information model says:
   The Measurement Task Configuration will include ...  a registry
   entry [I-D....-ippm-...] that defines the Measurement
   Task.  The MA itself will resolve the registry entry to a local
   executable program.  In addition the Measurement Task is specialised
   through a set of configuration Options.  The nature and number of
   these Options will depend upon the Measurement Task and will be
   defined in the Measurement Task Registry.

So the information-model makes the Measurement Task an instantiation of a local executable program. But how does the Controller learn about what registry entries the MA is capable of resolving to local executable programs? That is, how does the Controller know what local executable programs exist on the MA? I had thought this would be part of the capabilities that get reported to the Controller by the MA. Bu the ma-capability object has some distinct other undefined measurement-id urn and doesn't provide the Controller with any list of registry entries that the MA is capable of resolving. Hopefully, this is just something that needs to be fixed in the information-model, and not an intentional lack of relationship between ma-capability and ma-task (or ma-task-registry). 

Anyway, information-model says (wrt capability reporting) that "Capabilities include ... the set of Measurement Tasks that are actually installed or available on the MA." This, to me, is a problematic statement. Now, not only is the term Measurement Task being used to describe an instantiation of a local executable program with a specific set of values for input parameters (ma-task-options<0..*>) and perhaps a particular cycle id (ma-task-cycle-id) with a pointer to the local executable program (ma-task-registry), the term is also being used as synonymous with the local executable program. 

I do not think that "Measurement Task" should be used as another name for the local executable program. I would like to see this fixed. It would also appear that the ma-capability object is supposed to be the object that provides the information regarding these local executable programs that are installed/available on the MA. But the word "capabilities" is also said to include interface details. So "local executable programs" is a subset of "capabilities" (which means "capabilities" is also not an appropriate word to use to just mean "local executable programs"). 

So do these "local executable programs" need a better name, so we aren't tempted to call them "Measurement Task"? Or maybe we can just call them "Local Executable Programs" and define them as functionality in a MA that allows the MA to perform a specific role of a Measurement Method. And Measurement Task is an instantiation of a Local Executable Program. Because Measurement Task is definitely not an instantiation of the holistic Measurement Method. The ping initiator Local Executable Program can be completely distinct from the ping responder Local Executable Program. And it often is.
Barbara

---

From: "Bajpai, Vaibhav" <[email-masked]>
Date: Fri, 30 May 2014 15:42:18 +0000

>   defined in the Measurement Task Registry.

The framework document [1] makes the measurement method refer to the IPPM metrics registries.
The information model (IM) [2] on the other hand, makes the measurement task refer to the 
IPPM metrics registries. If we really want to use both Measurement Method and Measurement Task 
terminologies, perhaps we need to update the IM to adhere better to the framework document:

   object {
       string              ma-method-name;
       urn                 ma-method-registry;
       ma-task-obj         ma-task-obj<0..*>;
   } ma-method-obj; 

   object {
       string              ma-task-name;
       string              ma-task-options<0..*>;
      [string              ma-task-cycle-id;]
   } ma-task-obj; 

> So the information-model makes the Measurement Task an instantiation of a local executable program. But how does the Controller learn about what registry entries the MA is capable of resolving to l…

I also think so:

   object {
       urn                 ma-measurement-id;
      [string              ma-measurement-version;]
       ma-task-obj         ma-task-obj<0..*>;
   } ma-capability-obj;

The ma-tasks<0...*> objects sent in the instruction object will now be subset of the
the ma-tasks<0…*> objects sent by the MA.

> So do these "local executable programs" need a better name, so we aren't tempted to call them "Measurement Task"? Or maybe we can just call them "Local Executable Programs”

A locally executable program can be any program (for e.g. ls) within the MA, no? 
Shouldn’t we restrict the terminology to programs that do measurements?

> and define them as functionality in a MA that allows the MA to perform a specific role of a Measurement Method. And Measurement Task is an instantiation of a Local Executable Program. Because Measurement Task is definitely not an instantiation of the holistic Measurement Method. The ping initiator Local Executable Program can be completely distinct from the ping responder Local Executable Program. And it often is.
> Barbara

[1] http://tools.ietf.org/html/draft-ietf-lmap-framework-05
[2] http://tools.ietf.org/html/draft-ietf-lmap-information-model-00

Best, Vaibhav

-----------------------------------------------------
Vaibhav Bajpai

Research I, Room 86
Computer Networks and Distributed Systems  (CNDS) Lab
School of Engineering and Sciences
Jacobs University Bremen, Germany

www.vaibhavbajpai.com