Subject: Re: [ippm] [lmap] UDP Echo example

From: Juergen Schoenwaelder <[email-masked]>
Date: Sun, 1 Jun 2014 11:42:29 +0200

Yes, I think this is what I wrote.

/js

On Sat, May 31, 2014 at 07:10:19PM +0000, Carey, Timothy (Timothy) wrote:
> Juergen,
> 
> Wouldn't the selected interface for the UDP test instance be part of the options for the task. The options have the "parameters" for the test which is specific for each test, right?
> 
> As for a MA telling the controller its capabilities - wouldn't it be part of the ma-interface-obj?
> 
> BR,
> Tim
> 
> -----Original Message-----
> From: Juergen Schoenwaelder [mailto:[email-masked]] 
> Sent: Friday, May 30, 2014 5:56 PM
> To: STARK, BARBARA H
> Cc: [email-masked]; [email-masked]
> Subject: Re: [lmap] UDP Echo example
> 
> On Fri, May 30, 2014 at 05:20:05PM +0000, STARK, BARBARA H wrote:
> > 
> > If we look at the TR-069 data model in [TR-143], we see that MA1's UDP Echo server functionality has input parameters of (1) a port to listen on and (2) a source IP address (MA1 will only respond to UDP packets from this source IP address). In an LMAP world, I think these would be the information-model ma-task-options<0..*>. There is also an input of the network interface to listen on. [I see that while information-model lets the MA tell the Controller what its interfaces are, there's no current linkage to allow an interface to be specified for a ma-task-obj. I think this is probably just an oversight and needs to be added.] 
> 
> The interface is just another task option.
> 
> /js
> 
> -- 
> Juergen Schoenwaelder           Jacobs University Bremen gGmbH
> Phone: +49 421 200 3587         Campus Ring 1, 28759 Bremen, Germany
> Fax:   +49 421 200 3103         <http://www.jacobs-university.de/>
> 
> 

-- 
Juergen Schoenwaelder           Jacobs University Bremen gGmbH
Phone: +49 421 200 3587         Campus Ring 1, 28759 Bremen, Germany
Fax:   +49 421 200 3103         <http://www.jacobs-university.de/>

---

From: "Carey, Timothy (Timothy)" <[email-masked]>
Date: Sat, 31 May 2014 19:10:19 +0000

Juergen,

BR,
Tim

-----Original Message-----
From: Juergen Schoenwaelder [mailto:[email-masked]] 
Sent: Friday, May 30, 2014 5:56 PM
To: STARK, BARBARA H
Cc: [email-masked]; [email-masked]
Subject: Re: [lmap] UDP Echo example

/js