Subject: [ippm] Benoit Claise's No Objection on draft-ietf-ippm-rate-problem-09: (with COMMENT)

From: "Benoit Claise" <[email-masked]>
Date: Thu, 05 Feb 2015 06:08:05 -0800

Benoit Claise has entered the following ballot position for
draft-ietf-ippm-rate-problem-09: No Objection

When responding, please keep the subject line intact and reply to all
email addresses included in the To and CC lines. (Feel free to cut this
introductory paragraph, however.)

Please refer to http://www.ietf.org/iesg/statement/discuss-criteria.html
for more information about IESG DISCUSS and COMMENT positions.

The document, along with other ballot positions, can be found here:
http://datatracker.ietf.org/doc/draft-ietf-ippm-rate-problem/

----------------------------------------------------------------------
COMMENT:
----------------------------------------------------------------------

- Thanks for the "Operational Considerations" new section, as discussed
with D. Romascanu

- The document tile says problem statement, but it's a mix of problem
statement, use cases, and some protocol requirements with RFC 2119
keywords. I believe the title should be modified accordingly.

- I agree with Stephen regarding the use of RFC 2119.

   Service subscribers and
   authorized users SHOULD obtain their network operator's or service
   provider's permission before conducting tests.

Really, should I have my provider consent before running
http://www.speedtest.net/ ? :-)

-

   Current IETF standardized test protocols do not
   possess the asymmetric size generation capability with two-way
   testing.

Do you mean OWAMP/TWAMP? Please be specific

---

From: "MORTON, ALFRED C (AL)" <[email-masked]>
Date: Thu, 5 Feb 2015 09:20:35 -0500

Hi Benoit,

> -----Original Message-----
...
> draft-ietf-ippm-rate-problem-09: No Objection
...

Let's assume material describing use is necessary for the problem statement,
so how about:

Rate Measurement Test Protocol Problem Statement and Requirements

> - I agree with Stephen regarding the use of RFC 2119.

(overtaken by the title change)

> http://www.speedtest.net/ ? :-)

I understand some service agreements already require notification.

> Do you mean OWAMP/TWAMP? Please be specific

Ok, it's TWAMP (and IPSLAv2).

Al

---

From: "MORTON, ALFRED C (AL)" <[email-masked]>
Date: Thu, 5 Feb 2015 09:20:35 -0500

Hi Benoit,

...
...

Al

---

From: Benoit Claise <[email-masked]>
Date: Thu, 05 Feb 2015 15:30:27 +0100

Hi Al,

Thanks for the quick reaction.
I removed the points of agreements.
> Rate Measurement Test Protocol Problem Statement and Requirements
that's better. thanks.
> I understand some service agreements already require notification.
Maybe you want:

   Service subscribers and
    authorized users SHOULD obtain their network operator's or service
    provider's permission before conducting_heavy_tests.

Or what the right adjective is.
On top of that, I don't get what a RFC 2119 SHOULD add to the document. 
RFC 2119 is for protocol spec, and potentially for requirements.b
Btw, same remark for the next sentence.

    Likewise, a service
    provider or third party SHOULD obtain the subscriber's permission to
    conduct tests, since they might temporarily reduce service quality.

Regards, Benoit

---

From: "MORTON, ALFRED C (AL)" <[email-masked]>
Date: Thu, 5 Feb 2015 09:46:38 -0500

reply at end [ACM]

From: Benoit Claise [mailto:[email-masked]]
Sent: Thursday, February 05, 2015 9:30 AM
To: MORTON, ALFRED C (AL); The IESG
Cc: Dan; [email-masked]; [email-masked]; [email-masked]; [email-masked]
Subject: Re: Benoit Claise's No Objection on draft-ietf-ippm-rate-problem-09: (with COMMENT)

Hi Al,

…

   Service subscribers and

  Service subscribers and

   provider's permission before conducting heavy tests.
Or what the right adjective is.
On top of that, I don't get what a RFC 2119 SHOULD add to the document. RFC 2119 is for protocol spec, and potentially for requirements.b
Btw, same remark for the next sentence.

   Likewise, a service

[ACM]
It's hard to pick a usefully qualifying adjective there, that's why I didn't...

The system hosting the protocol could ask the users for their permission,
or ask if the service provider has been notified.  The protocol could
communicate the permission status, either explicitly or through other means.
Disclosure/Permission is a pillar of the privacy considerations
https://tools.ietf.org/html/draft-ietf-lmap-framework-10#section-8.5.4

hope this helps,
Al

---

From: Benoit Claise <[email-masked]>
Date: Thu, 05 Feb 2015 16:15:52 +0100

On 05/02/2015 15:46, MORTON, ALFRED C (AL) wrote:
>
> reply at end [ACM]
>
> *From:*Benoit Claise [mailto:[email-masked]]
> *Sent:* Thursday, February 05, 2015 9:30 AM
> *To:* MORTON, ALFRED C (AL); The IESG
> *Cc:* Dan; [email-masked]; 
> [email-masked]; [email-masked]; 
> [email-masked]
> *Subject:* Re: Benoit Claise's No Objection on 
> draft-ietf-ippm-rate-problem-09: (with COMMENT)
>
> Hi Al,
>
> On top of that, I don't get what a RFC 2119 SHOULD add to the 
> document. RFC 2119 is for protocol spec, and potentially for 
> requirements.b
Fair enough.
> https://tools.ietf.org/html/draft-ietf-lmap-framework-10#section-8.5.4
And what about my remark: On top of that, I don't get what a RFC 2119 
SHOULD adds to the document. RFC 2119 is for protocol spec, and 
potentially for a protocol requirements.

Regards, Benoit

---

From: "MORTON, ALFRED C (AL)" <[email-masked]>
Date: Thu, 5 Feb 2015 10:19:52 -0500

could add this in the right place:

The protocol SHOULD communicate the permission status once the overall system has obtained it, either explicitly or through other means.

Al

Sent: Thursday, February 05, 2015 10:16 AM

Cc: Dan; [email-masked]<mailto:[email-masked]>; [email-masked]<mailto:[email-masked]>; [email-masked]<mailto:[email-masked]>; [email-masked]<mailto:[email-masked]>

Hi Al,

…

   Service subscribers and

  Service subscribers and

   Likewise, a service

[ACM]

And what about my remark: On top of that, I don't get what a RFC 2119 SHOULD adds to the document. RFC 2119 is for protocol spec, and potentially for a protocol requirements.

Regards, Benoit

hope this helps,
Al

---

From: Benoit Claise <[email-masked]>
Date: Thu, 05 Feb 2015 16:24:06 +0100

On 05/02/2015 16:19, MORTON, ALFRED C (AL) wrote:
> The protocol SHOULD communicate the permission status once the overall 
> system has obtained it, either explicitly or through other means.
>
Fine. Thanks Al.

Regards, B.
> *Sent:* Thursday, February 05, 2015 10:16 AM
>     *Cc:* Dan; [email-masked] <mailto:[email-masked]>;
>     [email-masked]
>     <mailto:[email-masked]>;
>     [email-masked] <mailto:[email-masked]>; [email-masked]
>     <mailto:[email-masked]>
b