Subject: Re: [ippm] Brian Haberman's Discuss on draft-ietf-ippm-ipsec-09: (with DISCUSS)

From: Spencer Dawkins at IETF <[email-masked]>
Date: Wed, 20 May 2015 15:12:47 -0500

Still following up ...

On Mon, Apr 6, 2015 at 12:04 PM, Brian Haberman <[email-masked]>
wrote:

> Hi All,
>
> On 4/6/15 12:44 PM, MORTON, ALFRED C (AL) wrote:
> >
> >> -----Original Message-----
> > ...
> >>> -----Original Message-----
> >>> From: ippm [mailto:[email-masked]] On Behalf Of Brian Haberman
> >> ...
> >>> ----------------------------------------------------------------------
> >>> DISCUSS:
> >>> ----------------------------------------------------------------------
> >>>
> >>> I hope this is a short discussion and I can change my ballot to a
> >> Yes...
> >>>
> >>> The applicability section says "Until an IANA registry for OWAMP Mode
> >>> values is established, the use this feature in OWAMP implementations
> >>> MUST be arranged privately among consenting OWAMP users."
> >>>
> >>> Is there an issue with this document creating that registry?  Or, if
> >>> separation is needed, a companion document spun quickly to create this
> >>> registry?
> >> [ACM]
> >>
> >> I can spin-up a companion doc to create the OWAMP registry, should be
> >> posted in about an hour.
> >>
> >> Al
> >>
> >>
> >
> > http://tools.ietf.org/html/draft-morton-ippm-owamp-registry-00
> >
> > took a little longer than an hour, we had a power outage here.
> > This memo suggests the (new) assignment for IPsec mode in the draft IESG
> > is considering, so perhaps IPsec-09 can continue on its way.
>
> I will cut you some slack on the 1-hour promise given your power outage. :)
>
> One issue we have is that IPsec-09 can't be published before your draft
> is approved and the IANA creates the registry.
>
> The text in IPsec-09 should be updated to reflect the soon-to-be
> existence of the registry.
>
> This is the point where the shepherding AD and WG should chime in.

I see that Al submitted draft-morton-ippm-owamp-registry
<https://datatracker.ietf.org/doc/draft-morton-ippm-owamp-registry/>. Does
the WG think they're adding a normative dependency to that draft?

If so, we can move on, although if the working group requests publication
for that draft, things would happen more quickly ...

Spencer

---

From: Kostas Pentikousis <[email-masked]>
Date: Fri, 29 May 2015 16:38:23 +0200

Dear Brian, Spencer, Al, all,

| Still following up ...

<snip>

| > http://tools.ietf.org/html/draft-morton-ippm-owamp-registry-00
| >
| > took a little longer than an hour, we had a power outage here.
| > This memo suggests the (new) assignment for IPsec mode in the draft IESG
| > is considering, so perhaps IPsec-09 can continue on its way.
| I will cut you some slack on the 1-hour promise given your power outage. :)
|
| One issue we have is that IPsec-09 can't be published before your draft
| is approved and the IANA creates the registry.

<draft editor hat on>I think this would add a significant delay, and would vote to avoid it</hat off>

| The text in IPsec-09 should be updated to reflect the soon-to-be
| existence of the registry.

No have not done this in -10. 

I agree with Brian that "The functionality specified here seems quite applicable to OWAMP and requiring private agreements to use it seems sub-optimal." The issue with the OWAMP registry (or lack thereof) was discussed a few times in the WG, hence this paragraph was added: 

   Although the control procedures described in this document are
   applicable to OWAMP per se, the lack of an established IANA registry
   for OWAMP Mode values akin to that listed in Section 7 technically
   prevents us from extending OWAMP Mode values.  Therefore, independent
   OWAMP implementations SHOULD be checked for full compatibility with
   respect to the use of this Mode value.  Until an IANA registry for
   OWAMP Mode values is established, the use of this feature in OWAMP
   implementations MUST be arranged privately among consenting OWAMP
   users.

I think it will also be suboptimal if this draft is blocked for several months till draft-morton-ippm-owamp-registry becomes an RFC. Perhaps an alternative path could be to keep the first sentence only, and then draft-morton-ippm-owamp-registry updates in a short section this (future) RFC by specifying the OWAMP Mode value we cannot technically extend. 

Best regards,

Kostas

PS: this didn't end up being a short discussion after all.

---

From: "MORTON, ALFRED C (AL)" <[email-masked]>
Date: Fri, 29 May 2015 11:49:56 -0400

Hi Kostas,
see below...

> From: Kostas Pentikousis [mailto:[email-masked]]
> Sent: Friday, May 29, 2015 10:38 AM
...
> I agree with Brian that "The functionality specified here seems quite
> applicable to OWAMP and requiring private agreements to use it seems
> sub-optimal." The issue with the OWAMP registry (or lack thereof) was
> discussed a few times in the WG, hence this paragraph was added:
> 
> I think it will also be suboptimal if this draft is blocked for several
> months till draft-morton-ippm-owamp-registry becomes an RFC. Perhaps an
> alternative path could be to keep the first sentence only, and then
> draft-morton-ippm-owamp-registry updates in a short section this
> (future) RFC by specifying the OWAMP Mode value we cannot technically
> extend.
> 

[ACM] I agree, we shouldn't hold-up the IPsec draft, but also observe
that draft-morton-ippm-owamp-registry-00 is almost 2 months old and might
have reached wg consensus by now if there was interest/support, especially
from IPsec draft authors :-)  

But that's water under the bridge. You seem to be finishing up IPsec on
your own, Kostas, and we all appreciate that. Let's get the registry 
squared away next.

Nice work on the IANA section in -10, too. 

regards,
Al

---

From: Brian Haberman <[email-masked]>
Date: Fri, 29 May 2015 11:54:55 -0400

All,

> your own, Kostas, and we all appreciate that. Let's get the registry 

Before we create what could be a weird set of relationships between
documents, has anyone polled the WG on their interest in
adopting/advancing Al's owamp-registry draft?

It appears from the above comment that the WG hasn't been asked about
its interest in it, at least formally.

Regards,
Brian

---

From: Kostas Pentikousis <[email-masked]>
Date: Fri, 29 May 2015 17:55:26 +0200

Hi Al,

| [ACM] I agree, we shouldn't hold-up the IPsec draft, but also observe that
| draft-morton-ippm-owamp-registry-00 is almost 2 months old and might have
| reached wg consensus by now if there was interest/support, especially from
| IPsec draft authors :-)

Most certainly interested and supporting.

| But that's water under the bridge. You seem to be finishing up IPsec on your
| own, Kostas, and we all appreciate that. Let's get the registry squared away
| next.

No, that's not true, my co-authors are helping throughout!

| Nice work on the IANA section in -10, too.

All kudos go to Brian Trammell for "picking up the ball" and making the text suggestion.

All the best,

Kostas