Subject: Re: [ippm] I-D Action: draft-ietf-ippm-active-passive-00.txt

From: Nalini Elkins <[email-masked]>
Date: Thu, 2 Jul 2015 13:47:18 +0000 (UTC)

Al,

My comments below:

3.4, #3: a priori doesn't have an apostrophe. Ditto 3.8, paragraph 1.  Ditto 4.1, #2
3.8, bullet 2: first "of" ==> "or"

4.1, chart: the labels on the various data points are quite long.  It may not be obvious that they *are* labels on data points. Perhaps they could get single letter designations, with a seperate key to identify each. It would also help to have "Max" and "Min" outside the y axis, so it is clear that they are not points as well.

5. Security Considerations - this appears to consider only privacy.  In our work on implementation of PDM, we have seen that resource depletion type attacks (ex. SYN flood), etc may be created.   This type of attack, of course, is known.  But, it must be considered in implementation.  

Additionally, considerations of what a Man-in-the-middle (MITM) may see with unencrypted data has come up.   I do not believe that viewing either the active testing or hybrid additions give the potential attacker any information.  But, I wonder if you want to discuss this.  We will be discussing this in our PDM draft.

Thanks,

Nalini Elkins
Inside Products, Inc.
(831) 659-8360
www.insidethestack.com

________________________________
From: "[email-masked]" <[email-masked]>
To: [email-masked] 
Cc: [email-masked] 
Sent: Tuesday, June 30, 2015 11:14 AM
Subject: [ippm] I-D Action: draft-ietf-ippm-active-passive-00.txt

A New Internet-Draft is available from the on-line Internet-Drafts directories.
This draft is a work item of the IP Performance Metrics Working Group of the IETF.

        Title           : Active and Passive Metrics and Methods (and everything in-between, or Hybrid)
        Author          : Al Morton
    Filename        : draft-ietf-ippm-active-passive-00.txt
    Pages           : 11
    Date            : 2015-06-30

Abstract:
   This memo provides clear definitions for Active and Passive
   performance assessment.  The construction of Metrics and Methods can
   be described as Active or Passive.  Some methods may use a subset of
   both active and passive attributes, and we refer to these as Hybrid
   Methods.

The IETF datatracker status page for this draft is:
https://datatracker.ietf.org/doc/draft-ietf-ippm-active-passive/

There's also a htmlized version available at:
https://tools.ietf.org/html/draft-ietf-ippm-active-passive-00

Please note that it may take a couple of minutes from the time of submission
until the htmlized version and diff are available at tools.ietf.org.

Internet-Drafts are also available by anonymous FTP at:
ftp://ftp.ietf.org/internet-drafts/

_______________________________________________
ippm mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/ippm

---

From: "MORTON, ALFRED C (AL)" <[email-masked]>
Date: Thu, 2 Jul 2015 09:50:29 -0400

Thanks Nalini, I'me sure we can work out resolutions to your
comments.

regards,
Al

> -----Original Message-----
> From: Nalini Elkins [mailto:[email-masked]]
> Sent: Thursday, July 02, 2015 9:47 AM
> To: IPPM IETF
> Cc: MORTON, ALFRED C (AL)
> Subject: Re: [ippm] I-D Action: draft-ietf-ippm-active-passive-00.txt
> 
> Al,
> 
> My comments below:
> 
> 3.4, #3: a priori doesn't have an apostrophe. Ditto 3.8, paragraph 1.
> Ditto 4.1, #2 3.8, bullet 2: first "of" ==> "or"
> 
> 
> 
> 4.1, chart: the labels on the various data points are quite long.  It
> may not be obvious that they *are* labels on data points. Perhaps they
> could get single letter designations, with a seperate key to identify
> each. It would also help to have "Max" and "Min" outside the y axis, so
> it is clear that they are not points as well.
> 
> 
> 5. Security Considerations - this appears to consider only privacy.  In
> our work on implementation of PDM, we have seen that resource depletion
> type attacks (ex. SYN flood), etc may be created.   This type of attack,
> of course, is known.  But, it must be considered in implementation.
> 
> Additionally, considerations of what a Man-in-the-middle (MITM) may see
> with unencrypted data has come up.   I do not believe that viewing
> either the active testing or hybrid additions give the potential
> attacker any information.  But, I wonder if you want to discuss this.
> We will be discussing this in our PDM draft.
> 
> Thanks,
> 
> Nalini Elkins
> Inside Products, Inc.
> (831) 659-8360
> www.insidethestack.com
> 
> 
> 
> Please note that it may take a couple of minutes from the time of
> submission until the htmlized version and diff are available at
> tools.ietf.org.
>