Subject: [ippm] Ask for adoption// FW: New Version Notification for draft-chen-ippm-coloring-based-ipfpm-framework-04.txt

From: Vero Zheng <[email-masked]>
Date: Thu, 9 Jul 2015 08:47:36 +0000

Dear Brian and Bill,

We have updated the draft-chen-ippm-coloring-based-ipfpm-framework. Things to be noted that:

1, The draft has been progressed during the past couple of years and the mechanism introduced is well understood by the WG. In Dallas, the major concern was the marking bit selection.

In this revision, we made it explicitly clear that this document does not define any marking bit selection, any technology would like to deploy the marking method for performance measurement will define their own marking bit selection in corresponding document.

https://tools.ietf.org/html/draft-chen-ippm-coloring-based-ipfpm-framework-04#page-6

2, There are ongoing discussion of deploy marking method in new encapsulation technology, such as BIER WG and NOV3 WG.

And in BIER WG, the marking method has been adopted, and two OAM bits(marking bits) for performance measurement has been allocated in BIER encapsulation draft-ietf-bier-mpls-encapsulation<https://tools.ietf.org/html/draft-ietf-bier-mpls-encapsulation-01#page-5> .

3, There is also discussion of deploy marking method in matured technology, such as MPLS.

https://tools.ietf.org/html/draft-bryant-mpls-synonymous-flow-labels-01#page-2

The authors of the document believe this document is now ready for adoption, we would like the Chairs to start an adoption call.

Comments and suggestions are always welcome.

BR,

Vero

On behalf of the co-authors

-----Original Message-----
From: [email-masked] [mailto:[email-masked]]
Sent: Monday, July 06, 2015 3:56 PM
To: Mach Chen; Greg Mirsky; Giuseppe Fioccola; Vero Zheng; Mach Chen; Greg Mirsky; Giuseppe Fioccola; Vero Zheng
Subject: New Version Notification for draft-chen-ippm-coloring-based-ipfpm-framework-04.txt

A new version of I-D, draft-chen-ippm-coloring-based-ipfpm-framework-04.txt

has been successfully submitted by Lianshu Zheng and posted to the IETF repository.

Name:               draft-chen-ippm-coloring-based-ipfpm-framework

Revision:  04

Title:                  IP Flow Performance Measurement Framework

Document date:       2015-07-06

Group:               Individual Submission

Pages:               16

URL:            https://www.ietf.org/internet-drafts/draft-chen-ippm-coloring-based-ipfpm-framework-04.txt

Status:         https://datatracker.ietf.org/doc/draft-chen-ippm-coloring-based-ipfpm-framework/

Htmlized:       https://tools.ietf.org/html/draft-chen-ippm-coloring-based-ipfpm-framework-04

Diff:           https://www.ietf.org/rfcdiff?url2=draft-chen-ippm-coloring-based-ipfpm-framework-04

Abstract:

   This document specifies a measurement method, the IP flow performance

   measurement (IPFPM).  With IPFPM, data packets are marked into

   different blocks of markers by changing one or more bits of packets.

   No additional delimiting packet is needed and the performance is

   measured in-service and in-band without the insertion of additional

   traffic.

Please note that it may take a couple of minutes from the time of submission until the htmlized version and diff are available at tools.ietf.org.

The IETF Secretariat

---

From: Brian Trammell <[email-masked]>
Date: Thu, 9 Jul 2015 11:34:26 +0200

hi Vero,

Given that we're after the deadline for Prague, and people should be I'd prefer to issue this call for adoption during the Prague meeting. As we're tight for time, I'd like to start this during the administrative part of the agenda. Does this work for you?

Cheers,

Brian

> On 09 Jul 2015, at 10:47, Vero Zheng <[email-masked]> wrote:
> 
> Dear Brian and Bill,
> 
> And in BIER WG, the marking method has been adopted, and two OAM bits(marking bits) for performance measurement has been allocated in BIER encapsulationdraft-ietf-bier-mpls-encapsulation .
> 
> _______________________________________________
> ippm mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/ippm

---

From: Vero Zheng <[email-masked]>
Date: Fri, 10 Jul 2015 02:25:16 +0000

Hi Brian,

Thanks for offering this. This should work. 
I could also provide one page slide for you, if you see it necessary.

Cheers, Vero

> From: Brian Trammell [mailto:[email-masked]]
> Sent: Thursday, July 09, 2015 5:34 PM
> To: Vero Zheng
> Cc: [email-masked];
> [email-masked];
> [email-masked]
> Subject: Re: [ippm] Ask for adoption// FW: New Version Notification for
> draft-chen-ippm-coloring-based-ipfpm-framework-04.txt
> 
> hi Vero,
> 
> Given that we're after the deadline for Prague, and people should be I'd prefer
> to issue this call for adoption during the Prague meeting. As we're tight for
> time, I'd like to start this during the administrative part of the agenda. Does
> this work for you?
> 
> Cheers,
> 
> Brian
> 
> 
> > 1, The draft has been progressed during the past couple of years and the
> mechanism introduced is well understood by the WG. In Dallas, the major
> concern was the marking bit selection.
> > In this revision, we made it explicitly clear that this document does not define
> any marking bit selection, any technology would like to deploy the marking
> method for performance measurement will define their own marking bit
> selection in corresponding document.
> >
> > 2, There are ongoing discussion of deploy marking method in new
> encapsulation technology, such as BIER WG and NOV3 WG.
> > And in BIER WG, the marking method has been adopted, and two OAM
> bits(marking bits) for performance measurement has been allocated in BIER
> encapsulationdraft-ietf-bier-mpls-encapsulation .
> >
> > The authors of the document believe this document is now ready for adoption,
> we would like the Chairs to start an adoption call.
> > To: Mach Chen; Greg Mirsky; Giuseppe Fioccola; Vero Zheng; Mach Chen;
> Greg Mirsky; Giuseppe Fioccola; Vero Zheng
> > Subject: New Version Notification for
> draft-chen-ippm-coloring-based-ipfpm-framework-04.txt
> >
> >
> > URL:
> https://www.ietf.org/internet-drafts/draft-chen-ippm-coloring-based-ipfpm-fra
> mework-04.txt
> > Status:
> https://datatracker.ietf.org/doc/draft-chen-ippm-coloring-based-ipfpm-framew
> ork/
> > Htmlized:
> https://tools.ietf.org/html/draft-chen-ippm-coloring-based-ipfpm-framework-0
> 4
> > Diff:
> https://www.ietf.org/rfcdiff?url2=draft-chen-ippm-coloring-based-ipfpm-frame
> work-04
> >
> > Abstract:
> > Please note that it may take a couple of minutes from the time of submission
> until the htmlized version and diff are available at tools.ietf.org.
> >
> > The IETF Secretariat
> >