Subject: Re: [ippm] review of draft-ietf-ippm-metric-registry-03

From: <[email-masked]>
Date: Mon, 17 Aug 2015 10:16:28 +0000

Barbara
Sorry for the delay and thank-you very much for the detailed review.

I agree with almost all your comments. Happy to make it clear that the doc establishes a format that can be used by non-iana registries.

> 8.1.2.  Name
> I question the need for a prefix (Act_, Pas_, other) as part of the
> name. I don't find this so important that it needs to be the first
> thing people know about an entry. I don't see why it needs to be part
> of the name, at all. This relates to list items 5, 6, 7, 8, and the
> last paragraph.

I tend to think it's worth including this in the name (although personally would prefer "Active and "Passive"). 
The registry is aimed at human readers, rather than computers. It seems like people may want to know whether this is an active or passive measurement - especially where the same metric (say, sustainable video streaming rate) may be collected actively or passively.
I wonder if it's also worth introducing the possibility "hybrid" (see WG doc https://tools.ietf.org/html/draft-ietf-ippm-active-passive-00 )
Whether active /passive is the *first* thing people want to know - not sure. Anyway, I don't mind whether Act_ appears later in the name.

On the subject of the naming rules. Since we intend that the registry format is used by non-IANA registries, is it worth bringing this out in the name? ie the name includes "IETF_", "BBF_" etc

Also, on a minor point
<< 3.  "MUST use capital letters for the first letter of each component.
       All other letters MUST be lowercase, even for acronyms.
       Exceptions are made for acronyms containing a mixture of
       lowercase and capital letters, such as 'IPv4' and 'IPv6'.">>
why is useful? The rule seems very particular and a bit strange to me. Can we just delete this bullet and leave it to the Performance Metric Experts to decide (see bullet #8).

Best wishes
phil

---

From: "STARK, BARBARA H" <[email-masked]>
Date: Mon, 17 Aug 2015 14:09:22 +0000

Thx Phil. Comment below.
Barbara

> The registry is aimed at human readers, rather than computers. It seems like
> people may want to know whether this is an active or passive measurement
> - especially where the same metric (say, sustainable video streaming rate)
> may be collected actively or passively.
> I wonder if it's also worth introducing the possibility "hybrid" (see WG doc
> https://tools.ietf.org/html/draft-ietf-ippm-active-passive-00 ) Whether
> active /passive is the *first* thing people want to know - not sure. Anyway, I
> don't mind whether Act_ appears later in the name.
> 
> On the subject of the naming rules. Since we intend that the registry format
> is used by non-IANA registries, is it worth bringing this out in the name? ie
> the name includes "IETF_", "BBF_" etc

I would recommend staying away from putting "registry org" in the name. Because then you need to have a way of making sure the "registry org" is standardized and unique (since there is no limit on who might want to have a registry, including all orgs and companies, and maybe even regulatory bodies). Which leads to a registry for "registry org". Which leads to IEEE OUI or CID (since IEEE already has such a registry and recreating it probably isn't a good idea). Which leads to a meaningless-to-human-readers number. I think the domain name speaks volumes.

My problem with the requirements for Act_/Pas_ in the title is when we get to some of the more esoteric uses of a "registry". We said that reporting environmental conditions was done by defining these as a measurement task. So, for example, someone might want to have measurement tasks to get CPU and memory utilization, internal temperature, external temperature and humidity, provisioned max down/up bandwidth, etc. Are these active or passive? Or hybrid? Or none of the above? I wouldn't expect these in the IANA Registry. But given how we've constructed the LMAP information model, I think we need to be able to use the registry format for these. It's also very English-centric (which is fine for the IANA Registry because everything has to be written in English; but what about a registry done by, for example, Orange for their internal use -- why does IETF care and why can't they use French abbreviations, if this is all about the human reader). I would rather this rule be completely optional, or apply only to entries in the IANA Registry.