Subject: Re: [ippm] I-D Action: draft-morton-ippm-2330-stdform-typep-00.txt

From: "MORTON, ALFRED C (AL)" <[email-masked]>
Date: Thu, 1 Oct 2015 13:01:35 -0400

Hi Brian,

Thanks for your comments! Vin has proposed text to address them,
and the co-authors adopted this caveat and other improvements 
in the text of version 01:
https://tools.ietf.org/html/draft-morton-ippm-2330-stdform-typep-01

Further review and comments are welcome, of course.

regards,
Al
for the co-authors

> -----Original Message-----
> From: Brian E Carpenter [mailto:[email-masked]]
> Sent: Sunday, August 16, 2015 4:08 PM
> To: Vinayak Hegde
> Cc: [email-masked]; Fred Baker
> Subject: Re: I-D Action: draft-morton-ippm-2330-stdform-typep-00.txt
> 
> Hi Vinayak,
> 
> I think a caveat should be enough. There is a possibility that stateful
> NAT will lead to unstable performance within a flow, since state needs
> to be created for the first packet of a flow, and may be lost later if
> the NAT runs out of resources. However, that doesn't invalidate the
> Type-P.
> 
> Of course, NAT does mean that the "signature" of Type-P will change
> between the source and the destination. That can be annoying if you want
> to correlate measurements between the two ends of a path.
> 
> Regards
>    Brian
> 
> 
> On 17/08/2015 06:58, Vinayak Hegde wrote:
> > Hi Brian,
> >
> > I looked at the draft that you linked. It recommends against the use
> > of NAT in IPv6 :) and also is stateless.
> >
> > Using NAT can have unpredictable impact on the measurement
> > (unpredictable as in the amount of additional time added) but it is
> > not always possible to control this parameter (as you may not have any
> > control on the underlying network or middleboxes). But this is
> > something that people who do measurements should be aware of. Do you
> > think adding this caveat in draft should suffice or did you have
> > anything else in mind ?
> >
> > Thanks
> > Vinayak
> >
> > On Sun, Aug 16, 2015 at 7:05 AM, Brian E Carpenter
> > <[email-masked]> wrote:
> >> Thanks for doing this. It's the biggest reaction I ever got to a
> >> Gen-ART review comment ;-).
> >>
> >> It looks good to me. One thing I noticed is that neither this draft
> >> nor 2330 mentions NAT. (In fact NPTv6 [RFC 6296] is more relevant for
> >> IPv6). I don't think address translation would invalidate a Type-P
> >> but maybe this should be stated to avoid doubt?
> >>
> >>    Brian
> >>
> >> On 07/08/2015 05:31, [email-masked] wrote:
> >>>
> >>> A New Internet-Draft is available from the on-line Internet-Drafts
> directories.
> >>>
> >>>
> >>>         Title           : Updates for IPPM's Active Metric
> Framework: Packets of Type-P and Standard-Formed Packets
> >>>         Authors         : Al Morton
> >>>                           Joachim Fabini
> >>>                           Nalini Elkins
> >>>                           Michael S. Ackermann
> >>>                           Vinayak Hegde
> >>>       Filename        : draft-morton-ippm-2330-stdform-typep-00.txt
> >>>       Pages           : 10
> >>>       Date            : 2015-08-06
> >>>
> >>> Abstract:
> >>>    This memo updates the IP Performance Metrics (IPPM) Framework RFC
> >>>    2330 with new considerations for measurement methodology and
> testing.
> >>>    The memo updates the definition of standard-formed packets in RFC
> >>>    2330 to include IPv6 packets.  It also augments distinguishing
> >>>    aspects of packets, referred to as Type-P for test packets in RFC
> >>>    2330.
> >>>
> >>>    Two points (at least) are worthwhile discussing further: extent
> of
> >>>    coverage for 6LO and IPv6 Header Compression, and the continued
> need
> >>>    to define a "minimal standard-formed packet".
> >>>
> >>>
> >>>
> >>> The IETF datatracker status page for this draft is:
> >>> https://datatracker.ietf.org/doc/draft-morton-ippm-2330-stdform-type
> >>> p/
> >>>
> >>> There's also a htmlized version available at:
> >>> https://tools.ietf.org/html/draft-morton-ippm-2330-stdform-typep-00
> >>>
> >>>
> >>> Please note that it may take a couple of minutes from the time of
> >>> submission until the htmlized version and diff are available at
> tools.ietf.org.
> >>>
> >>> Internet-Drafts are also available by anonymous FTP at:
> >>> ftp://ftp.ietf.org/internet-drafts/
> >>>
> >>> _______________________________________________
> >>> I-D-Announce mailing list
> >>> [email-masked]
> >>> https://www.ietf.org/mailman/listinfo/i-d-announce
> >>> Internet-Draft directories: http://www.ietf.org/shadow.html or
> >>> ftp://ftp.ietf.org/ietf/1shadow-sites.txt
> >>>
> >

---

From: Brian E Carpenter <[email-masked]>
Date: Fri, 2 Oct 2015 10:34:15 +1300

Yes, that looks very clear to me, thanks.

Regards
   Brian