Subject: [ippm] Comments on draft-tempia-ippm-p3m-02

From: "Alexander Clemm (alex)" <[email-masked]>
Date: Fri, 19 Feb 2016 08:43:05 +0000

Hi,

I have a few comments on draft-tempia-ippm-p3m-02.  I find this a very relevant draft that I hope will get adopted by the the WG.  That said, I do have a couple of comments and suggestions:

-          It would be a good idea to establish some terminology, and add a corresponding terminology section.  For example, we need a term for the "flow blocks" in which a particular marking applies, for the data records that are generated for each flow block, for the coloring intervals and block duration, etc.

-          Section 2:  It would be useful to indicate what you do with the colored "blocks" respectively the measurements associated with them, and what the potential interoperability issues are: for example, are you looking at a standard way of controlling the marking, or a standard way of exporting the measures being taken?  Even if you consider this outside the scope of the document, it would be good to still mention that (even if just to state this is out of scope).

-          It would be good to add a paragraph specifically on the problem of how to determine when a block is terminated, probably around section 3.1.  It would be good to add a little further discussion on assumptions choices, most specifically the lower bound that an interval can have for measurements to still be accurate.  Presumably that would be something like 2*max jitter that can occur (to account for the possibilility of laggards).

-          It would be useful to add an additional diagram, showing the deployment of how/where you perform the measurements (i.e. where the packets are captured, time stamped, etc)

-          It would be useful to add a section at the end regarding interoperability considerations, per the earlier comment, e.g. the control of the markings, the counting, the exporting of the records.  This can be accompanied by an explanation that this is out of scope, but mentioning this would be good.

-          The draft is written as too Telecom Italia specific.  This needs to be framed as a general-purpose problem that is of broader interest across the industry.  There are various associated edits that should be made, perhaps most importantly in the abstract and the introduction.    If you would want to refer to Telecom Italia specifics, you might consider simply referencing a publication (in a conference, journal or such) in the reference section instead.

Kind regards
--- Alex

---

From: Fioccola Giuseppe <[email-masked]>
Date: Wed, 24 Feb 2016 17:13:30 +0000

Hi Alex,
We are glad that you consider this document a very relevant draft and support WG adoption.
Greatly appreciate your valuable and thoughtful considerations.
I'm working on a proposed update to the draft that addresses your comments in addition to the comments we recently received.

Please see my response inline...

Best Regards,

Giuseppe

Da: Alexander Clemm (alex) [mailto:[email-masked]]
Inviato: venerdì 19 febbraio 2016 09:43
A: [email-masked]<mailto:[email-masked]>
Cc: [email-masked]<mailto:[email-masked]>
Oggetto: Comments on draft-tempia-ippm-p3m-02

Hi,

GF: I agree, a terminology section is necessary.

GF: The way of exporting the measures is outside the scope of this document, because it would be a general reference for alternate marking technique. Other related documents should address these topics depending on the application of the methodology. But you are right, we need to specify what we are looking for and what is out of scope.

GF: Certainly, a more detailed paragraph will be added.

GF: Yes, I agree.

GF: For sure. In this document the authors would like to describe marking and counting methodology. The exporting of records is out of scope and is in charge of the related documents.

GF: Of course. It will be address in the new version of the document.

Kind regards
--- Alex

Questo messaggio e i suoi allegati sono indirizzati esclusivamente alle persone indicate. La diffusione, copia o qualsiasi altra azione derivante dalla conoscenza di queste informazioni sono rigorosamente vietate. Qualora abbiate ricevuto questo documento per errore siete cortesemente pregati di darne immediata comunicazione al mittente e di provvedere alla sua distruzione, Grazie.

This e-mail and any attachments is confidential and may contain privileged information intended for the addressee(s) only. Dissemination, copying, printing or use by anybody else is unauthorised. If you are not the intended recipient, please delete this message and any attachments and advise the sender by return e-mail, Thanks.

[rispetta l'ambiente]Rispetta l'ambiente. Non stampare questa mail se non è necessario.