Subject: [ippm] R: FW: New Version Notification for draft-mirsky-ippm-time-format-02.txt

From: Fioccola Giuseppe <[email-masked]>
Date: Wed, 3 Feb 2016 16:22:15 +0000

Hi Greg,
I think so, It would be great if the introduction section could explain the reason for this proposal in more detail.

Best Regards,

Giuseppe

-----Messaggio originale-----
Da: Gregory Mirsky [mailto:[email-masked]] 
Inviato: sabato 30 gennaio 2016 15:43
A: Fioccola Giuseppe; [email-masked]
Oggetto: RE: [ippm] FW: New Version Notification for draft-mirsky-ippm-time-format-02.txt

Hi Guiseppe,
greatly appreciate your thorough review and thoughtful comments. And my apologies for delayed response to you and the WG.
Indeed, difference in quality of clock synchronization between NTP and PTP is known and, in some part, may be attributed to lack of on-path support functionality in NTP (Boundary Clock and Transparent Clock). But NTP has advantages of its own and thus it would be beneficial for TWAMP to be able to use either time stamp format similar to capability been defined for MPLS networks in RFC 6374. 
Would adding text in the Introduction section to explain the motivation for the proposal and reference to RFC 6374 help?

	Regards,
		Greg

-----Original Message-----
From: Fioccola Giuseppe [mailto:[email-masked]] 
Sent: Wednesday, January 13, 2016 7:59 AM
To: Gregory Mirsky; [email-masked]
Subject: R: [ippm] FW: New Version Notification for draft-mirsky-ippm-time-format-02.txt

Hi Greg,
I have read the document and I think that it is based on an interesting consideration: NTP format has any limitations, especially for performance monitoring applications where the time precision is crucial and NTP accuracy could not be enough.
I'm agree with the solution proposed in draft-mirsky-ippm-time-format-02 and the use of a Timestamp flag is practical and stable. So I suggest to add a short section to explain the background for this proposal (e.g. if you need a measured accuracy in microseconds or nanoseconds, you prefer PTP; otherwise if milliseconds or seconds are sufficient, you use NTP).
What do you think about this statement?

Best Regards,

Giuseppe

-----Messaggio originale-----
Da: ippm [mailto:[email-masked]] Per conto di Gregory Mirsky
Inviato: lunedì 4 gennaio 2016 17:33
A: [email-masked]
Oggetto: [ippm] FW: New Version Notification for draft-mirsky-ippm-time-format-02.txt

Dear All,
the draft been refreshed. Authors greatly appreciate your reviews and comments. Below my earlier e-mail in response to our discussion of this work in Yokohama:
Dear All,
I wanted to thank Kostas, Al and Brian for their questions, comments at the presentation in Yokohama. The discussion suggests that this work is of interest to the IPPM WG. As Brian suggested, let’s continue the discussion on the mailing list.
I believe that we’ve discussed backward compatibility of the proposed TWAMP extension and Al and Brian asked for clarifications on scenario when TWAMP test cannot be conducted between supporting and non-supporting this extension NEs. Indeed, there’s such case. When Session-Reflector supports this extension and uses only 1588 timestamp format while Session-Sender does not support the extension Server will close the TCP connection with the Control-Client (as displayed on slide 5 of the presentation slide-deck). In case if a Session-Reflector does not support the extension and the Session-Sender does, the TWAMP session can proceed as Session-Sender would be able to interpret both timestamp formats as noted in the slide 3 (MUST be capable to INTERPRET NTP and PTPv2 time stamp formats).
Hope I’ve captured questions that have been asked in Yokohama.
Always welcome comments and questions. Looking forward to hear from Al and Brian whether I’ve answered their questions. Authors greatly appreciate your interest in this work and looking forward to bring it to WG adoption call soon.

                Regards,
                                Greg

-----Original Message-----
From: [email-masked] [mailto:[email-masked]]
Sent: Monday, January 04, 2016 8:12 AM
To: Gregory Mirsky; Ramanathan Lakshmikanthan; Israel Meilik; Suchit Bansal
Subject: New Version Notification for draft-mirsky-ippm-time-format-02.txt

A new version of I-D, draft-mirsky-ippm-time-format-02.txt
has been successfully submitted by Greg Mirsky and posted to the IETF repository.

Name:           draft-mirsky-ippm-time-format
Revision:       02
Title:          Support of IEEE-1588 time stamp format in Two-Way Active Measurement Protocol (TWAMP)
Document date:  2016-01-04
Group:          Individual Submission
Pages:          8
URL:            https://www.ietf.org/internet-drafts/draft-mirsky-ippm-time-format-02.txt
Status:         https://datatracker.ietf.org/doc/draft-mirsky-ippm-time-format/
Htmlized:       https://tools.ietf.org/html/draft-mirsky-ippm-time-format-02
Diff:           https://www.ietf.org/rfcdiff?url2=draft-mirsky-ippm-time-format-02

Abstract:
   This document describes an OPTIONAL feature for active performance
   measurement protocols allowing use of time stamp format defined in
   IEEE-1588v2-2008.

Please note that it may take a couple of minutes from the time of submission until the htmlized version and diff are available at tools.ietf.org.

The IETF Secretariat

_______________________________________________
ippm mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/ippm

Questo messaggio e i suoi allegati sono indirizzati esclusivamente alle persone indicate. La diffusione, copia o qualsiasi altra azione derivante dalla conoscenza di queste informazioni sono rigorosamente vietate. Qualora abbiate ricevuto questo documento per errore siete cortesemente pregati di darne immediata comunicazione al mittente e di provvedere alla sua distruzione, Grazie.

This e-mail and any attachments is confidential and may contain privileged information intended for the addressee(s) only. Dissemination, copying, printing or use by anybody else is unauthorised. If you are not the intended recipient, please delete this message and any attachments and advise the sender by return e-mail, Thanks.

---

From: Gregory Mirsky <[email-masked]>
Date: Thu, 4 Feb 2016 10:50:15 +0000

Hi Giuseppe,
thank you for your consideration and comments. Please check proposed update to the Introduction that reflects on advantages that option to use PTP time stamp format in TWAMP brings to measurements of performance metrics in IP network. Hope update addresses your comments.

Members of the IPPM WG community,
we welcome and greatly appreciate your comments of the draft.

	Regards,
		Greg

-----Original Message-----
From: Fioccola Giuseppe [mailto:[email-masked]] 
Sent: Wednesday, February 03, 2016 8:22 AM
To: Gregory Mirsky; [email-masked]
Subject: R: [ippm] FW: New Version Notification for draft-mirsky-ippm-time-format-02.txt

Hi Greg,

Best Regards,

Giuseppe

-----Messaggio originale-----
Da: Gregory Mirsky [mailto:[email-masked]] 
Inviato: sabato 30 gennaio 2016 15:43
A: Fioccola Giuseppe; [email-masked]
Oggetto: RE: [ippm] FW: New Version Notification for draft-mirsky-ippm-time-format-02.txt

Hi Guiseppe,

	Regards,
		Greg

-----Original Message-----
From: Fioccola Giuseppe [mailto:[email-masked]] 
Sent: Wednesday, January 13, 2016 7:59 AM
To: Gregory Mirsky; [email-masked]
Subject: R: [ippm] FW: New Version Notification for draft-mirsky-ippm-time-format-02.txt

Hi Greg,

Best Regards,

Giuseppe

-----Messaggio originale-----
Da: ippm [mailto:[email-masked]] Per conto di Gregory Mirsky
Inviato: lunedì 4 gennaio 2016 17:33
A: [email-masked]
Oggetto: [ippm] FW: New Version Notification for draft-mirsky-ippm-time-format-02.txt

Dear All,

                Regards,
                                Greg

-----Original Message-----
From: [email-masked] [mailto:[email-masked]]
Sent: Monday, January 04, 2016 8:12 AM
To: Gregory Mirsky; Ramanathan Lakshmikanthan; Israel Meilik; Suchit Bansal
Subject: New Version Notification for draft-mirsky-ippm-time-format-02.txt

Abstract:

The IETF Secretariat

---

From: Fioccola Giuseppe <[email-masked]>
Date: Fri, 5 Feb 2016 09:42:09 +0000

Hi Greg,
Thanks for your review to the introduction section. This is ok for me.

Best Regards,

Giuseppe

-----Messaggio originale-----
Da: Gregory Mirsky [mailto:[email-masked]] 
Inviato: giovedì 4 febbraio 2016 11:50
A: Fioccola Giuseppe; [email-masked]
Oggetto: RE: [ippm] FW: New Version Notification for draft-mirsky-ippm-time-format-02.txt

Hi Giuseppe,

	Regards,
		Greg

-----Original Message-----
From: Fioccola Giuseppe [mailto:[email-masked]] 
Sent: Wednesday, February 03, 2016 8:22 AM
To: Gregory Mirsky; [email-masked]
Subject: R: [ippm] FW: New Version Notification for draft-mirsky-ippm-time-format-02.txt

Hi Greg,

Best Regards,

Giuseppe

-----Messaggio originale-----
Da: Gregory Mirsky [mailto:[email-masked]] 
Inviato: sabato 30 gennaio 2016 15:43
A: Fioccola Giuseppe; [email-masked]
Oggetto: RE: [ippm] FW: New Version Notification for draft-mirsky-ippm-time-format-02.txt

Hi Guiseppe,

	Regards,
		Greg

-----Original Message-----
From: Fioccola Giuseppe [mailto:[email-masked]] 
Sent: Wednesday, January 13, 2016 7:59 AM
To: Gregory Mirsky; [email-masked]
Subject: R: [ippm] FW: New Version Notification for draft-mirsky-ippm-time-format-02.txt

Hi Greg,

Best Regards,

Giuseppe

-----Messaggio originale-----
Da: ippm [mailto:[email-masked]] Per conto di Gregory Mirsky
Inviato: lunedì 4 gennaio 2016 17:33
A: [email-masked]
Oggetto: [ippm] FW: New Version Notification for draft-mirsky-ippm-time-format-02.txt

Dear All,

                Regards,
                                Greg

-----Original Message-----
From: [email-masked] [mailto:[email-masked]]
Sent: Monday, January 04, 2016 8:12 AM
To: Gregory Mirsky; Ramanathan Lakshmikanthan; Israel Meilik; Suchit Bansal
Subject: New Version Notification for draft-mirsky-ippm-time-format-02.txt

Abstract:

The IETF Secretariat