Subject: [ippm] I-D Action: draft-ietf-ippm-twamp-yang-00.txt

From: [email-masked]
Date: Mon, 21 Mar 2016 08:33:03 -0700

A New Internet-Draft is available from the on-line Internet-Drafts directories.
This draft is a work item of the IP Performance Metrics of the IETF.

        Title           : Two-Way Active Measurement Protocol (TWAMP) Data Model
        Authors         : Ruth Civil
                          Al Morton
                          Lianshu Zheng
                          Reshad Rahman
                          Mahesh Jethanandani
                          Kostas Pentikousis
	Filename        : draft-ietf-ippm-twamp-yang-00.txt
	Pages           : 58
	Date            : 2016-03-21

Abstract:
   This document specifies a data model for client and server
   implementations of the Two-Way Active Measurement Protocol (TWAMP).
   We define the TWAMP data model through Unified Modeling Language
   (UML) class diagrams and formally specify it using YANG.

The IETF datatracker status page for this draft is:
https://datatracker.ietf.org/doc/draft-ietf-ippm-twamp-yang/

There's also a htmlized version available at:
https://tools.ietf.org/html/draft-ietf-ippm-twamp-yang-00

Please note that it may take a couple of minutes from the time of submission
until the htmlized version and diff are available at tools.ietf.org.

Internet-Drafts are also available by anonymous FTP at:
ftp://ftp.ietf.org/internet-drafts/

---

From: Steve Baillargeon <[email-masked]>
Date: Tue, 22 Mar 2016 12:39:23 +0000

Hi
I see the following paragraph:

reflector-udp-port
This parameter defines the UDP port number that will be used by the Session-Reflector for this TWAMP-Test session. The number is restricted to the dynamic port range (49152 ..65535). This value will be placed in the Receiver Port field of the Request-TW-Session message. If this value is not set, the device SHALL use the same port number as defined in the server-tcp-port parameter of this twamp-session-request's parent twamp-client-ctrl-connection.

There is a an exception to the rule when this range is already allocated by the reflector.
This is the case when the reflector is a 3GPP radio node.
More specially the WCDMA radio access technology uses the complete dynamic port range where each WCDMA bearer is allocated a dynamic UDP port.
To resolve this problem, it is best for the 3GPP radio node to completely avoid the dynamic port range and allocate one or a few available ports from the user port range(1024-49151).
Is it possible to change the reflector-udp-port from 1024 to 65535 and indicate a dynamic/private port is usually recommended?

Regards
Steve Baillargeon 

-----Original Message-----
From: ippm [mailto:[email-masked]] On Behalf Of [email-masked]
Sent: Monday, March 21, 2016 11:33 AM
To: [email-masked]
Cc: [email-masked]
Subject: [ippm] I-D Action: draft-ietf-ippm-twamp-yang-00.txt

Abstract:

Please note that it may take a couple of minutes from the time of submission until the htmlized version and diff are available at tools.ietf.org.

_______________________________________________
ippm mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/ippm