Subject: Re: [ippm] Call for adoption: milestone on coloring-based loss and delay methodologies

From: Qin Wu <[email-masked]>
Date: Tue, 19 Apr 2016 01:49:05 +0000

Agree with Mach and Greg.

-Qin

----------------

Dear Brian, Bill, and all who are interested in IPPM,

I support WG adoption of draft-tempia-ippm-p3m as foundation of our work on new active and hybrid performance measurement methods.

And I concur with Mach that the current version of draft-chen-ippm-coloring draft is demonstrating applicability of the method described in draft-tempia-ippm-p3m to IP networks in the same manner as draft-mirsky-bier-pmmm-oam demonstrates applicability of the marking method in BIER (Bit-Indexed Explicit Replication) domain.

        Regards,

               Greg

-----Original Message-----

From: ippm [mailto:ippm-bounces at ietf.org] On Behalf Of Mach Chen

Sent: Monday, April 18, 2016 2:10 AM

To: Brian Trammell; IETF IPPM WG

Subject: Re: [ippm] Call for adoption: milestone on coloring-based loss and delay methodologies

Hi Brian,

Firstly, I support the adoption of draft-tempia-ippm-p3m.

BTW, I would argue that draft-chen-ippm-coloring should be in the scope of the current charter.

> Additional methods will be defined for the composition and calibration

> of IPPM-defined metrics, as well as active, passive and hybrid

> measurement methods for these metrics. In addition, the WG encourages

> work which describes the applicability of metrics and measurement

> methods, especially to improve understanding of the tradeoffs involved

> among active, passive, and hybrid methods.

This is the charter text you quoted, IMHO, the second part is just what draft-chen-ippm-coloring is doing, which defines "the applicability of metrics and measurement methods". It applies the marking-based idea to P2P, P2MP, MP2P scenarios, it also defines how to correlate the metrics from ingress MAs and egress MAs, how to handle packet re-ordering, synchronization, etc., these are fundamental to the marking based loss and delay measurement.

As for the "operational collection and use of metrics produced by such methodologies", this actually has been separated to another draft(the IPFIX extension draft).

So, I think that daft-chen is in the charter and would hope that the WG would consider to adopt draft-chen as well. I remember that there were quite a lot supports on site during IETF 95th meeting.

Best regards,

Mach

> -----Original Message-----

> From: ippm [mailto:ippm-bounces at ietf.org] On Behalf Of Brian Trammell

> Sent: Friday, April 15, 2016 9:21 PM

> To: IETF IPPM WG

> Subject: [ippm] Call for adoption: milestone on coloring-based loss

> and delay methodologies

> Greetings, all,

> We're slowly working our way through the queue of things to do after

> the Buenos Aires meeting; we'll be making a few confirmations of calls

> for adoption in the coming days. One of the items for the chairs to

> consider following our face-to-face discussions is what, if anything,

> the working group wants to do about "coloring"-based hybrid measurement.

> On a review of our charter, we find that a milestone on measurement

> methodologies, largely as described by draft-tempia-ippm-p3m, is

> covered by Paragraph 4:

> > Additional methods will be defined for the composition and

> > calibration of IPPM-defined metrics, as well as active, passive and

> > hybrid measurement methods for these metrics. In addition, the WG

> > encourages work which describes the applicability of metrics and

> > measurement methods, especially to improve understanding of the

> > tradeoffs involved among active, passive, and hybrid methods.

> We would therefore like to make a call for adoption of the following milestone:

> (date TBD): Submit an Experimental draft on coloring-based hybrid

> measurement methodologies for loss and delay to the IESG

> and for the adoption of draft-tempia-ippm-p3m as the basis for a

> document meeting this milestone. Please indicate support for or

> concerns about adoption to the ippm at ietf.org mailing list by Friday 29 April 2016.

> Please note the IPR disclosure on draft-tempia-ippm-p3m

> (https://datatracker.ietf.org/ipr/2557/) when considering this adoption call.

> Larger frameworks for the operational collection and use of metrics

> produced by such methodologies, however, such as described by

> draft-chen-ippm-coloring-based-ipfpm-framework, do not appear to be

> covered under the present charter. Therefore, we can make no call for

> adoption for an appropriate milestone at this time.

> Thanks, cheers,

> Brian and Bill, as chairs

_______________________________________________

ippm mailing list

ippm at ietf.org

https://www.ietf.org/mailman/listinfo/ippm

---

From: Vinayak Hegde <[email-masked]>
Date: Tue, 19 Apr 2016 10:27:58 +0530

Support adoption.

Thanks
Vinayak

On Tue, Apr 19, 2016 at 7:19 AM, Qin Wu <[email-masked]> wrote:
> I support WG adoption of draft-tempia-ippm-p3m as foundation of our work on
> new active and hybrid performance measurement methods.
>
>
>
> And I concur with Mach that the current version of draft-chen-ippm-coloring
> draft is demonstrating applicability of the method described in
> draft-tempia-ippm-p3m to IP networks in the same manner as
> draft-mirsky-bier-pmmm-oam demonstrates applicability of the marking method
> in BIER (Bit-Indexed Explicit Replication) domain.
>
>
>
>         Regards,
>
>                Greg
>
>
>
> This is the charter text you quoted, IMHO, the second part is just what
> draft-chen-ippm-coloring is doing, which defines "the applicability of
> metrics and measurement methods". It applies the marking-based idea to P2P,
> P2MP, MP2P scenarios, it also defines how to correlate the metrics from
> ingress MAs and egress MAs, how to handle packet re-ordering,
> synchronization, etc., these are fundamental to the marking based loss and
> delay measurement.
>
>
>
> As for the "operational collection and use of metrics produced by such
> methodologies", this actually has been separated to another draft(the IPFIX
> extension draft).
>
>
>
> So, I think that daft-chen is in the charter and would hope that the WG
> would consider to adopt draft-chen as well. I remember that there were quite
> a lot supports on site during IETF 95th meeting.
>
>
>
> Best regards,
>
> Mach
>
>
>
> [email-masked]

---

From: Sudhin Jacob <[email-masked]>
Date: Tue, 19 Apr 2016 05:57:12 +0000

Support this adoption.

Regards,
Sudhin

-----Original Message-----
From: ippm [mailto:[email-masked]] On Behalf Of Vinayak Hegde
Sent: Tuesday, April 19, 2016 10:28 AM
To: Qin Wu <[email-masked]>
Cc: [email-masked]; Brian Trammell <[email-masked]>
Subject: Re: [ippm] Call for adoption: milestone on coloring-based loss and delay methodologies

Support adoption.

Thanks
Vinayak

On Tue, Apr 19, 2016 at 7:19 AM, Qin Wu <[email-masked]> wrote:
> I support WG adoption of draft-tempia-ippm-p3m as foundation of our 
> work on new active and hybrid performance measurement methods.
>
>
>
> And I concur with Mach that the current version of 
> draft-chen-ippm-coloring draft is demonstrating applicability of the 
> method described in draft-tempia-ippm-p3m to IP networks in the same 
> manner as draft-mirsky-bier-pmmm-oam demonstrates applicability of the 
> marking method in BIER (Bit-Indexed Explicit Replication) domain.
>
>
>
>         Regards,
>
>                Greg
>
>
>
>> calibration
> This is the charter text you quoted, IMHO, the second part is just 
> what draft-chen-ippm-coloring is doing, which defines "the 
> applicability of metrics and measurement methods". It applies the 
> marking-based idea to P2P, P2MP, MP2P scenarios, it also defines how 
> to correlate the metrics from ingress MAs and egress MAs, how to 
> handle packet re-ordering, synchronization, etc., these are 
> fundamental to the marking based loss and delay measurement.
>
>
>
> methodologies", this actually has been separated to another draft(the 
> IPFIX extension draft).
>
>
>
> So, I think that daft-chen is in the charter and would hope that the 
> WG would consider to adopt draft-chen as well. I remember that there 
> were quite a lot supports on site during IETF 95th meeting.
>
>
>
> Best regards,
>
> Mach
>
>
>