Subject: [ippm] Call for adoption: milestone on coloring-based loss and delay methodologies

From: Brian Trammell <[email-masked]>
Date: Fri, 15 Apr 2016 15:20:53 +0200

Greetings, all,

We're slowly working our way through the queue of things to do after the Buenos Aires meeting; we'll be making a few confirmations of calls for adoption in the coming days. One of the items for the chairs to consider following our face-to-face discussions is what, if anything, the working group wants to do about "coloring"-based hybrid measurement.

On a review of our charter, we find that a milestone on measurement methodologies, largely as described by draft-tempia-ippm-p3m, is covered by Paragraph 4:

> Additional methods will be defined for the composition and calibration of
> IPPM-defined metrics, as well as active, passive and hybrid measurement
> methods for these metrics. In addition, the WG encourages work which
> describes the applicability of metrics and measurement methods, especially
> to improve understanding of the tradeoffs involved among active, passive,
> and hybrid methods.

We would therefore like to make a call for adoption of the following milestone:

(date TBD): Submit an Experimental draft on coloring-based hybrid measurement methodologies for loss and delay to the IESG

and for the adoption of draft-tempia-ippm-p3m as the basis for a document meeting this milestone. Please indicate support for or concerns about adoption to the [email-masked] mailing list by Friday 29 April 2016.

Please note the IPR disclosure on draft-tempia-ippm-p3m (https://datatracker.ietf.org/ipr/2557/) when considering this adoption call.

Larger frameworks for the operational collection and use of metrics produced by such methodologies, however, such as described by draft-chen-ippm-coloring-based-ipfpm-framework, do not appear to be covered under the present charter. Therefore, we can make no call for adoption for an appropriate milestone at this time.

Thanks, cheers,

Brian and Bill, as chairs

---

From: "Alexander Clemm (alex)" <[email-masked]>
Date: Fri, 15 Apr 2016 18:50:02 +0000

Support

-----Original Message-----
From: ippm [mailto:[email-masked]] On Behalf Of Brian Trammell
Sent: Friday, April 15, 2016 6:21 AM
To: IETF IPPM WG <[email-masked]>
Subject: [ippm] Call for adoption: milestone on coloring-based loss and delay methodologies

Greetings, all,

On a review of our charter, we find that a milestone on measurement methodologies, largely as described by draft-tempia-ippm-p3m, is covered by Paragraph 4:

> Additional methods will be defined for the composition and calibration 
> of IPPM-defined metrics, as well as active, passive and hybrid 
> measurement methods for these metrics. In addition, the WG encourages 
> work which describes the applicability of metrics and measurement 
> methods, especially to improve understanding of the tradeoffs involved 
> among active, passive, and hybrid methods.

Thanks, cheers,

---

From: "J. Ignacio Alvarez-Hamelin" <[email-masked]>
Date: Fri, 15 Apr 2016 16:34:47 -0300 (ART)

Support.

---

From: Mach Chen <[email-masked]>
Date: Mon, 18 Apr 2016 09:10:09 +0000

Hi Brian,

Firstly, I support the adoption of draft-tempia-ippm-p3m. 

BTW, I would argue that draft-chen-ippm-coloring should be in the scope of the current charter. 

> among active, passive, and hybrid methods.

This is the charter text you quoted, IMHO, the second part is just what draft-chen-ippm-coloring is doing, which defines "the applicability of metrics and measurement methods". It applies the marking-based idea to P2P, P2MP, MP2P scenarios, it also defines how to correlate the metrics from ingress MAs and egress MAs, how to handle packet re-ordering, synchronization, etc., these are fundamental to the marking based loss and delay measurement. 

As for the "operational collection and use of metrics produced by such methodologies", this actually has been separated to another draft(the IPFIX extension draft).  

So, I think that daft-chen is in the charter and would hope that the WG would consider to adopt draft-chen as well. I remember that there were quite a lot supports on site during IETF 95th meeting.

Best regards,
Mach

> Sent: Friday, April 15, 2016 9:21 PM
> To: IETF IPPM WG
> We're slowly working our way through the queue of things to do after the
> Buenos Aires meeting; we'll be making a few confirmations of calls for adoption
> in the coming days. One of the items for the chairs to consider following our
> face-to-face discussions is what, if anything, the working group wants to do
> about "coloring"-based hybrid measurement.
> 
> On a review of our charter, we find that a milestone on measurement
> methodologies, largely as described by draft-tempia-ippm-p3m, is covered by
> Paragraph 4:
> 
> (date TBD): Submit an Experimental draft on coloring-based hybrid
> measurement methodologies for loss and delay to the IESG
> 
> and for the adoption of draft-tempia-ippm-p3m as the basis for a document
> meeting this milestone. Please indicate support for or concerns about adoption
> to the [email-masked] mailing list by Friday 29 April 2016.
> 
> Please note the IPR disclosure on draft-tempia-ippm-p3m
> (https://datatracker.ietf.org/ipr/2557/) when considering this adoption call.
> 
> Larger frameworks for the operational collection and use of metrics produced
> by such methodologies, however, such as described by
> draft-chen-ippm-coloring-based-ipfpm-framework, do not appear to be covered
> under the present charter. Therefore, we can make no call for adoption for an
> appropriate milestone at this time.
> 
> Thanks, cheers,
>

---

From: Gregory Mirsky <[email-masked]>
Date: Mon, 18 Apr 2016 20:17:10 +0000

Dear Brian, Bill, and all who are interested in IPPM,
I support WG adoption of draft-tempia-ippm-p3m as foundation of our work on new active and hybrid performance measurement methods.

And I concur with Mach that the current version of draft-chen-ippm-coloring draft is demonstrating applicability of the method described in draft-tempia-ippm-p3m to IP networks in the same manner as draft-mirsky-bier-pmmm-oam demonstrates applicability of the marking method in BIER (Bit-Indexed Explicit Replication) domain.

	Regards,
		Greg

-----Original Message-----
From: ippm [mailto:[email-masked]] On Behalf Of Mach Chen
Sent: Monday, April 18, 2016 2:10 AM
To: Brian Trammell; IETF IPPM WG
Subject: Re: [ippm] Call for adoption: milestone on coloring-based loss and delay methodologies

Hi Brian,

Best regards,
Mach

> We're slowly working our way through the queue of things to do after 
> the Buenos Aires meeting; we'll be making a few confirmations of calls 
> for adoption in the coming days. One of the items for the chairs to 
> consider following our face-to-face discussions is what, if anything, 
> the working group wants to do about "coloring"-based hybrid measurement.
> 
> methodologies, largely as described by draft-tempia-ippm-p3m, is 
> covered by Paragraph 4:
> 
> > Additional methods will be defined for the composition and 
> > calibration of IPPM-defined metrics, as well as active, passive and 
> > hybrid measurement methods for these metrics. In addition, the WG 
> > encourages work which describes the applicability of metrics and 
> > measurement methods, especially to improve understanding of the 
> > tradeoffs involved among active, passive, and hybrid methods.
> 
> and for the adoption of draft-tempia-ippm-p3m as the basis for a 
> document meeting this milestone. Please indicate support for or 
> concerns about adoption to the [email-masked] mailing list by Friday 29 April 2016.
> 
> Larger frameworks for the operational collection and use of metrics 
> produced by such methodologies, however, such as described by 
> draft-chen-ippm-coloring-based-ipfpm-framework, do not appear to be 
> covered under the present charter. Therefore, we can make no call for 
> adoption for an appropriate milestone at this time.
> 
> Thanks, cheers,
> 

_______________________________________________
ippm mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/ippm

---

From: Fioccola Giuseppe <[email-masked]>
Date: Tue, 19 Apr 2016 10:20:24 +0000

Support WG adoption of draft-tempia-ippm-p3m (as co-author).

I hope IPPM WG could consider as next step also the adoption of draft-chen-ippm-coloring-based-ipfpm-framework, because this is the framework for the applicability of the marking method, described in draft-tempia-ippm-p3m, to IP networks.

Best Regards,

Giuseppe

-----Messaggio originale-----
Da: ippm [mailto:[email-masked]] Per conto di Brian Trammell
Inviato: venerdì 15 aprile 2016 15:21
A: IETF IPPM WG
Oggetto: [ippm] Call for adoption: milestone on coloring-based loss and delay methodologies

Greetings, all,

Thanks, cheers,

Questo messaggio e i suoi allegati sono indirizzati esclusivamente alle persone indicate. La diffusione, copia o qualsiasi altra azione derivante dalla conoscenza di queste informazioni sono rigorosamente vietate. Qualora abbiate ricevuto questo documento per errore siete cortesemente pregati di darne immediata comunicazione al mittente e di provvedere alla sua distruzione, Grazie.

This e-mail and any attachments is confidential and may contain privileged information intended for the addressee(s) only. Dissemination, copying, printing or use by anybody else is unauthorised. If you are not the intended recipient, please delete this message and any attachments and advise the sender by return e-mail, Thanks.

---

From: Ionta Tiziano <[email-masked]>
Date: Tue, 19 Apr 2016 13:09:29 +0000

I support the adoption.
Best
Tiziano
> Da: ippm [mailto:[email-masked]<mailto:[email-masked]>] Per conto di Brian Trammell
> and for the adoption of draft-tempia-ippm-p3m as the basis for a document meeting this milestone. Please indicate support for or concerns about adoption to the [email-masked]<mailto:[email-masked]> mailing list by Friday 29 April 2016.
>
> [email-masked]<mailto:[email-masked]>

---

From: Brian Trammell <[email-masked]>
Date: Tue, 19 Apr 2016 15:49:03 +0200

hi Mach, all,

A few suggestions, as an individual contributor:

> On 18 Apr 2016, at 11:10, Mach Chen <[email-masked]> wrote:
> 
> Hi Brian,
> 
> This is the charter text you quoted, IMHO, the second part is just what draft-chen-ippm-coloring is doing, which defines "the applicability of metrics and measurement methods".

Parts of the document do indeed discuss measurement method applicability; however, draft-chen-ippm-coloring-based-ipfpm-framework goes much further than that. It prescribes an architecture of centralized coordination of a set of measurement agents (which may or may not be Measurement Agents in the LMAP sense; my understanding of the current state of the LMAP work indicates that the information model there might not be applicable to hybrid measurements as described in these documents at this point in time).

> It applies the marking-based idea to P2P, P2MP, MP2P scenarios, it also defines how to correlate the metrics from ingress MAs and egress MAs, how to handle packet re-ordering, synchronization, etc., these are fundamental to the marking based loss and delay measurement.

Agreed. It seems to me that these sections of the document could be merged into draft-tempia after its adoption as a working group item (should it be adopted, which looking at the mailing list at this point seems likely).

> As for the "operational collection and use of metrics produced by such methodologies", this actually has been separated to another draft(the IPFIX extension draft).

Perhaps the architectural bits of this draft belong in the separate draft as well? (Again, such a draft would  in my personal opinion need a new charter to be adoptable in IPPM)

Cheers,

Brian (as an individual)

---

From: Mach Chen <[email-masked]>
Date: Thu, 21 Apr 2016 08:02:58 +0000

Hi Brian,

Thanks for your suggestion, we did have some discussions among the authors of both drafts in the past, and thought it's a way to move forward. So, we will follow your suggestions and try to merge the two drafts once draft-tempia is adopted.  

Thanks,
Mach

> From: Brian Trammell [mailto:[email-masked]]
> Sent: Tuesday, April 19, 2016 9:49 PM
> To: Mach Chen
> Cc: IETF IPPM WG
> > This is the charter text you quoted, IMHO, the second part is just what
> draft-chen-ippm-coloring is doing, which defines "the applicability of metrics
> and measurement methods".
> 
> Parts of the document do indeed discuss measurement method applicability;
> however, draft-chen-ippm-coloring-based-ipfpm-framework goes much further
> than that. It prescribes an architecture of centralized coordination of a set of
> measurement agents (which may or may not be Measurement Agents in the
> LMAP sense; my understanding of the current state of the LMAP work indicates
> that the information model there might not be applicable to hybrid
> measurements as described in these documents at this point in time).
> 
> > It applies the marking-based idea to P2P, P2MP, MP2P scenarios, it also
> defines how to correlate the metrics from ingress MAs and egress MAs, how to
> handle packet re-ordering, synchronization, etc., these are fundamental to the
> marking based loss and delay measurement.
> 
> Agreed. It seems to me that these sections of the document could be merged
> into draft-tempia after its adoption as a working group item (should it be
> adopted, which looking at the mailing list at this point seems likely).
> 
> > As for the "operational collection and use of metrics produced by such
> methodologies", this actually has been separated to another draft(the IPFIX
> extension draft).
> 
> Perhaps the architectural bits of this draft belong in the separate draft as well?
> (Again, such a draft would  in my personal opinion need a new charter to be
> adoptable in IPPM)
> 
> Cheers,
> 
> Brian (as an individual)
> 
> >
> > So, I think that daft-chen is in the charter and would hope that the WG would
> consider to adopt draft-chen as well. I remember that there were quite a lot
> supports on site during IETF 95th meeting.
> >
> > Best regards,
> > Mach
> >
> >> the Buenos Aires meeting; we'll be making a few confirmations of
> >> calls for adoption in the coming days. One of the items for the
> >> chairs to consider following our face-to-face discussions is what, if
> >> anything, the working group wants to do about "coloring"-based hybrid
> measurement.
> >>

---

From: Cociglio Mauro <[email-masked]>
Date: Wed, 27 Apr 2016 07:52:07 +0000

Dear all,

I support WG adoption of draft-tempia-ippm-p3m (as co-author).
Regards.

Mauro

___________________
Mauro Cociglio
TIM-Telecom Italia
Via G. Reiss Romoli, 274
10148 - Torino (Italy)
Tel.: +390112285028
Mobile: +393357669751
___________________

-----Messaggio originale-----
Da: ippm [mailto:[email-masked]] Per conto di Brian Trammell
Inviato: venerdì 15 aprile 2016 15:21
A: IETF IPPM WG
Oggetto: [ippm] Call for adoption: milestone on coloring-based loss and delay methodologies

Greetings, all,

Thanks, cheers,