Subject: Re: [ippm] More info on https://tools.ietf.org/html/draft-ietf-ippm-twamp-time-format-00

From: Gregory Mirsky <[email-masked]>
Date: Mon, 27 Jun 2016 16:53:09 +0000

Hi Erik,
thank you for your interest in the proposal and your detailed questions. I’ve added IPPM WG to the discussion as it may be of interest to others.
Please find my answers in-line and tagged GIM>>.

                Regards,
                                Greg

From: Erik Alapää [mailto:[email-masked]]
Sent: Monday, June 27, 2016 6:53 AM
To: Gregory Mirsky
Subject: More info on https://tools.ietf.org/html/draft-ietf-ippm-twamp-time-format-00

Hi,

my name is Erik Alapää, I am a Linux developer working in Luleå, Sweden.

My question:

Do you have any more information fleshing out details not described in
https://tools.ietf.org/html/draft-ietf-ippm-twamp-time-format-00

For example, one question is this: How are the PTP timestamps inserted into the TWAMP packets? Is there any way of having a NIC hardstamping into the IP payload of the packet and possibly recalculating application layer checksums?
GIM>> The implementation I’m familiar with does rely on HW assistance to update packet on-the-fly and, as you’ve correctly pointed out, that affects the checksum. For IPv4 we can set checksum to 0 to avoid the re-calculation. Because IPv6 does not allow use of zero checksum one can use RFC7820 OWAMP and TWAMP Checksum Complement.

Or are you envisioning saving the hw timestamp of sent packets and sending those timestamps in payloads of subsequent TWAMP packets?
GIM>> I know of PTP using such technique in case of Transparent Clock. The follow-up timestamp being proposed in the draft-ietf-mpls-residence-time. But I think that we don’t need to use this technique in TWAMP as combination of HW assisted timestamping and RFC 7820 seems sufficient.

Best regards,

/Erik Alapää

--
Senior Specialist, C/C++, Linux and hard real-time. +46 70 54 81 999.

News: We're hiring - come work with us. See all job openings here<http://www.netrounds.com/join-us/>.

---

From: Erik Alapää <[email-masked]>
Date: Mon, 27 Jun 2016 21:46:09 +0200

Thank you very much for your prompt answer, looking forward to possibly
trying to implement some of this in real C/C++ code.

Best regards,

/Erik Alapää

On Mon, Jun 27, 2016 at 6:53 PM, Gregory Mirsky <[email-masked]
> wrote:

> Hi Erik,
>
> thank you for your interest in the proposal and your detailed questions.
> I’ve added IPPM WG to the discussion as it may be of interest to others.
>
> *From:* Erik Alapää [mailto:[email-masked]]
> *Sent:* Monday, June 27, 2016 6:53 AM
> *To:* Gregory Mirsky
> *Subject:* More info on
> For example, one question is this: How are the PTP timestamps inserted
> into the TWAMP packets? Is there any way of having a NIC hardstamping into
> the IP payload of the packet and possibly recalculating application layer
> checksums?
>
> GIM>> The implementation I’m familiar with does rely on HW assistance to
> update packet on-the-fly and, as you’ve correctly pointed out, that affects
> the checksum. For IPv4 we can set checksum to 0 to avoid the
> re-calculation. Because IPv6 does not allow use of zero checksum one can
> use RFC7820 OWAMP and TWAMP Checksum Complement.
>
>
>
> Or are you envisioning saving the hw timestamp of sent packets and sending
> those timestamps in payloads of subsequent TWAMP packets?
>
> GIM>> I know of PTP using such technique in case of Transparent Clock. The
> follow-up timestamp being proposed in the draft-ietf-mpls-residence-time.
> But I think that we don’t need to use this technique in TWAMP as
> combination of HW assisted timestamping and RFC 7820 seems sufficient.
>
>
>
> Best regards,
>
>
>
> /Erik Alapää
>
>
>
>
>
>
> --
>

News: We're hiring - come work with us. See all job openings here
<http://www.netrounds.com/join-us/>.

---

From: Erik Alapää <[email-masked]>
Date: Tue, 28 Jun 2016 09:17:16 +0200

Hi Gregory,

one more question: RFC7820 shows 'Figure 1' with a custom FPGA/ASIC doing
the hardstamping. Do you know of any standard NIC that could be used for
this, e.g. by hardstamping and updating UDP checksum on the fly? (I assume
checksum complement will not work with a standard NIC, since TWAMP packets
may possibly be too short to allow inserting the checksum complement, again
according to RFC7820, and a standard NIC obviously has no understanding of
TWAMP specifics.).

I am asking since you earlier referred to one HW-assisted implementation
you were familiar with.

/Erik