Subject: Re: [ippm] Draft Meeting Agenda for IPPM at IETF 96

From: Srivathsa Sarangapani <[email-masked]>
Date: Fri, 1 Jul 2016 08:11:12 +0000

Hi Greg,

Thanks for the reply.

Currently TWAMP is widely deployed by lot of operators to measure RTT. We want to EFFECTIVELY extend the use of TWAMP to achieve lot more functionality(by using the payload which is currently NOT used).
We are concentrating on two Metrics: Keepaliveless of a functionality/service and Service Latency introduced by a service.

When we say service it means a functionality. It is no way related to SFC ONLY. I could say that both Section 1 & 2 of draft-spv-ippm-monitor-implementation-services-kpi could be used in SFC also but this NOT FOR SFC only.
We are referring to a “specific functional module” as a service. So for example when we speak of keepaliveness of a service, DNS or HTTP COULD be referred as a service here.
Say if TWAMP is currently being used to calculate the rtt between a HTTP server and some Network Element, we want to overload/piggyback/extend TWAMP to check even the liveliness of the HTTP Service/Functionality on that server.
If the name service is confusing, then possibly we could replace the name service with some other name like “Application Functionality” or something like that. Please let us know.

I could see the even OAM tool RFC 7276 refers to TWAMP to calculate RTT. Similarly, OAM can refer to these extension drafts for calculating keepalive and service latency for a particular service.

Regarding RFC 7555, I could see that this is mostly dealing with MPLS networks and its operations. I could not see that this is used to calculate liveliness or latency of any other specific functionality.

—
Regards,
Vathsa

From: Gregory Mirsky <[email-masked]>
Date: Friday, July 1, 2016 at 3:39 AM
To: Srivathsa Sarangapani <[email-masked]>, Brian Trammell <[email-masked]>, IETF IPPM WG <[email-masked]>
Cc: Peyush Gupta <[email-masked]>, "[email-masked]" <[email-masked]>, "[email-masked]" <[email-masked]>
Subject: RE: [ippm] Draft Meeting Agenda for IPPM at IETF 96

Hi Srivathsa,

my understanding of your proposals is that you use TWAMP-Test not to perform any measurement but rather to carry opaque, for TWAMP-Sender and TWAMP-Reflector, data to be used by Service Function (SF) OAM. And TWAMP-Control is extended to negotiate the size and the  interpretation of that opaque payload on behalf of SF OAM. What you've proposed in Section 2 of draft-spv-ippm-monitor-implementation-services-kpi is very similar to idea in RFC 7555 Proxy MPLS Echo Request and been included in Overlay OAM Requirements<https://tools.ietf.org/html/draft-ooamdt-rtgwg-ooam-requirement-00> as:

   REQ#15: Overlay OAM MUST be able to trigger on-demand FM with

            responses being directed towards initiator of such proxy

            request.

                Regards,

                                Greg

-----Original Message-----
From: ippm [mailto:[email-masked]] On Behalf Of Srivathsa Sarangapani
Sent: Thursday, June 30, 2016 2:17 AM
To: Brian Trammell; IETF IPPM WG
Cc: Peyush Gupta; [email-masked]
Subject: Re: [ippm] Draft Meeting Agenda for IPPM at IETF 96

Hi Brain and Bill,

Thank you for sharing the agenda for the upcoming IETF event in Berlin.

We are interested in presenting our draft on TWAMP extension for monitoring services KPI :

[draft-spv-ippm-monitor-methodology-services-kpi & draft-spv-ippm-monitor-implementation-services-kpi]

We have got lot of comments in the last ietf meeting from the members in order to make these draft more focused and detailed.

We have had multiple discussion with most of the members/customers offline and after that we have modified the draft and addresses most of the concerns from them.

Please provide us a slot in the middle of the ippm WG this time, so that we can discuss the revised draft with all the attendees and address their concerns if any.

This will help us in taking our drafts forward.

Thank you for your attention.

—

Best Regards,

Srivathsa Sarangapani

-----Original Message-----

From: Brian Trammell <[email-masked]<mailto:[email-masked]>>

Date: Monday, June 27, 2016 at 2:58 PM

To: IETF IPPM WG <[email-masked]<mailto:[email-masked]>>

Cc: <[email-masked]<mailto:[email-masked]>>

Subject: [ippm] Draft Meeting Agenda for IPPM at IETF 96

Greetings, all,

We've posted a draft meeting agenda at https://www.ietf.org/proceedings/96/agenda/agenda-96-ippm (copied inline below) with presentations for working group items (five, including three newly adopted) and individual drafts discussed on list since Buenos Aires (none this time around).

We'd like to focus discussion on the initial registry draft this time around, since we really should complete this document in order to finish our chartered work on providing a basis for using IPPM metrics in wider measurement efforts. To that end, we'll also have an invited speaker, Ahmed Aldabbagh of OFCOM, speaking on QoS monitoring activity at BEREC (the European telecoms regulation coordination body); this represents a key audience and user community for this registry. We'll also reserve 25 minutes for initial registry discussion.

LMAP people (in CC) who haven't paid much attention of IPPM of late: if you have opinions about what should show up in the initial registry, please try to drop by the IPPM meeting in Berlin. The invited talk may also be of interest to you.

You'll note two (*) on the agenda: these are provisional slots pending submission of the drafts before the deadline. Otherwise, we'll remove these slots from the schedule.

Draft authors: please let us know if we've got the right speaker name next to each item.

Thanks, cheers,

Brian and Bill (chair hats)

IPPM Agenda - IETF 96 - Berlin, Germany

=======================================

Tue 19 July 2016 - 14:00 Central European Summer Time (UTC+2)

Main Agenda

-----------

Time  | Speaker      | Item

------+--------------+-------------------------------------------------------

14:00 | Chairs       | Note well, intro, status, agenda bash

14:10 | A. Aldabbagh | Invited Talk: QoS Monitoring Activity at BEREC

14:25 | A. Morton    | draft-ietf-ippm-initial-registry

14:50 | J. Fabini    | draft-ietf-ippm-2330-ipv6 (*)

15:05 | G. Mirsky    | draft-ietf-ippm-twamp-time-format

15:15 | G. Focciola  | draft-ietf-ippm-alt-mark

15:30 | A. Morton    | draft-ieft-ippm-model-based-metrics (*)

Lightning Talks

---------------

Five minutes per topic (strict), with available time at the end of the

main agenda.

Speaker      | Item

-------------+---------------------------------------------------------------

R. Geib      | draft-leipnitz-spring-pms-implementation-report-00

_______________________________________________

ippm mailing list

[email-masked]<mailto:[email-masked]>

https://www.ietf.org/mailman/listinfo/ippm

---

From: Gregory Mirsky <[email-masked]>
Date: Thu, 7 Jul 2016 05:03:50 +0000

Hi Brian,
thank you for having confidence in draft-ietf-ippm-twamp-time-format. Authors are ready for the WGLC and will work to address comments and progress the document.

We just submitted draft-muthu-ippm-twamp-nat-00 draft that brings to discussion issues of OWAMP/TWAMP control and test sessions traversing NAT. Would appreciate your consideration and hope you can add this draft to the waiting list of the Lightning Talk.

	Regards,
		Greg

-----Original Message-----
From: Brian Trammell [mailto:[email-masked]] 
Sent: Tuesday, June 28, 2016 3:12 AM
To: IETF IPPM WG <[email-masked]>
Cc: Gregory Mirsky <[email-masked]>
Subject: Re: [lmap] [ippm] Draft Meeting Agenda for IPPM at IETF 96

hi Greg,

> On 27 Jun 2016, at 19:48, Gregory Mirsky <[email-masked]> wrote:
> 
> Hi Brian,
> thank you for giving us the heads-up on IPPM WG meeting in Berlin. I'd like to ask for your consideration to:
> ·         add draft-mirsky-ippm-twamp-light-yang  to the main agenda. We’ve significantly re-worked the data model, added RPC, state and performance metric;

I haven't seen any discussion on this on the list since BA. I can add it to the lightning talk queue.

> ·         re-allocate 10 minutes slot from draft-ietf-ippm-twamp-time-format to draft-bailmir-ippm-twamp-dscp-ctrl-mon. I’ve presented it in BA during the Lightning part and would appreciate the opportunity to extend the discussion;

I haven't seen any discussion on this on the list since BA. I can add it to the lightning talk queue.

If there's nothing to discuss on time-format (indeed, I think it's close to done, myself), we can start the WGLC.

> ·         add draft-mirsky-ippm-twamp-refl-registered-port-00 presentation to the Lightning Talks section.

Done.

Updated agenda posted, and inline below.

Cheers,

Brian (chair hat)

Main Agenda
-----------

Time  | Speaker        | Item
------+----------------+------------------------------------------------
------+----------------+-----
14:00 | Chairs         | Note well, intro, status, agenda bash
14:10 | A. Aldabbagh   | Invited Talk: QoS Monitoring Activity at BEREC
14:25 | A. Morton      | draft-ietf-ippm-initial-registry
14:50 | J. Fabini      | draft-ietf-ippm-2330-ipv6 (*)
15:05 | G. Mirsky      | draft-ietf-ippm-twamp-time-format
15:10 | G. Focciola    | draft-ietf-ippm-alt-mark
15:25 | K. Pentikousis | draft-ietf-ippm-twamp-yang (*)
15:35 | A. Morton      | draft-ietf-ippm-model-based-metrics (*)

Agenda items with a (*) are pending new revisions by 4 July 2016

Lightning Talks
---------------

Five minutes per topic (strict), with available time at the end of the main agenda.

Speaker      | Item
-------------+----------------------------------------------------------
-------------+-----
R. Geib      | draft-leipnitz-spring-pms-implementation-report
G. Mirsky    | draft-mirsky-ippm-twamp-refl-registered-port
G. Mirsky    | draft-bailmir-ippm-twamp-dscp-ctrl-mon
G. Mirsky    | draft-mirsky-ippm-twamp-light-yang

> From: ippm [mailto:[email-masked]] On Behalf Of Brian Trammell
> Sent: Monday, June 27, 2016 2:29 AM
> To: IETF IPPM WG
> Cc: [email-masked]
> ------+--------------+------------------------------------------------
> ------+--------------+--
> ------+--------------+-----
> Five minutes per topic (strict), with available time at the end of the main agenda.
> 
> Speaker      | Item
> -------------+--------------------------------------------------------
> -------------+--
> -------------+-----
> lmap mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/lmap

Subject: New Version Notification for draft-muthu-ippm-twamp-nat-00.txt
From: "[email-masked]" <[email-masked]>
To: Gregory Mirsky <[email-masked]>, P Muthu Arul Mozhi <[email-masked]>
Date: Thu, 7 Jul 2016 04:55:38 +0000

A new version of I-D, draft-muthu-ippm-twamp-nat-00.txt
has been successfully submitted by Muthu Arul Mozhi Perumal and posted to the
IETF repository.

Name:		draft-muthu-ippm-twamp-nat
Revision:	00
Title:		Network Address Translator (NAT) Considerations for IP Performance Metrics (IPPM) Active Measurement Protocols
Document date:	2016-07-06
Group:		Individual Submission
Pages:		7
URL:            https://www.ietf.org/internet-drafts/draft-muthu-ippm-twamp-nat-00.txt
Status:         https://datatracker.ietf.org/doc/draft-muthu-ippm-twamp-nat/
Htmlized:       https://tools.ietf.org/html/draft-muthu-ippm-twamp-nat-00

Abstract:
   This document describes the problems in obtaining IP Performance
   Metrics (IPPM) one-way and two-way active measurements across
   Internet paths that traverse Network Address Translators (NATs).  It
   also documents the requirements, guidelines and best practices when
   such measurements are obtained across NATs.

Please note that it may take a couple of minutes from the time of submission
until the htmlized version and diff are available at tools.ietf.org.

The IETF Secretariat

---

From: Brian Trammell <[email-masked]>
Date: Thu, 7 Jul 2016 15:57:34 +0200

> On 07 Jul 2016, at 07:03, Gregory Mirsky <[email-masked]> wrote:
> 
> Hi Brian,

It's on the list as a new document. The chances we'll get to it are not great, but it's there if we can pick up some time earlier in the agenda.

Cheers,

Brian

> <Mail Attachment.eml>

---

From: Gregory Mirsky <[email-masked]>
Date: Sun, 10 Jul 2016 00:06:52 +0000

Hi Brian,
thank you for adding the draft-muthu-ippm-twamp-nat draft to the agenda. Minor change if that's not too late, Muthu Arul Mozhi Perumal will present it.

	Regards,
		Greg

-----Original Message-----
From: ippm [mailto:[email-masked]] On Behalf Of Gregory Mirsky
Sent: Wednesday, July 06, 2016 10:04 PM
To: Brian Trammell <[email-masked]>; IETF IPPM WG <[email-masked]>
Subject: Re: [ippm] [lmap] Draft Meeting Agenda for IPPM at IETF 96

Hi Brian,

	Regards,
		Greg

-----Original Message-----
From: Brian Trammell [mailto:[email-masked]]
Sent: Tuesday, June 28, 2016 3:12 AM
To: IETF IPPM WG <[email-masked]>
Cc: Gregory Mirsky <[email-masked]>
Subject: Re: [lmap] [ippm] Draft Meeting Agenda for IPPM at IETF 96

hi Greg,

Done.

Cheers,

Brian (chair hat)

Main Agenda
-----------

Time  | Speaker        | Item

Lightning Talks
---------------

Speaker      | Item

---

From: Srivathsa Sarangapani <[email-masked]>
Date: Thu, 14 Jul 2016 04:15:45 +0000

Hi Brian,

Thanks a lot for accommodating our request and giving us a slot in the lightening talks.
Qin is also co-authoring our drafts and this time in Berlin, he would present the draft. Hope it is fine.
We would join as remote participants. We will pass on the slides to you at the earliest.

— 
Regards,
Vathsa

-----Original Message-----
From: Brian Trammell <[email-masked]>
Date: Thursday, June 30, 2016 at 4:54 PM
To: Srivathsa Sarangapani <[email-masked]>
Cc: IETF IPPM WG <[email-masked]>, Peyush Gupta <[email-masked]>, "[email-masked]" <[email-masked]>
Subject: Re: [lmap] [ippm] Draft Meeting Agenda for IPPM at IETF 96

hi Srivastha,

We have seen no discussion of this draft on the list. Accordingly, I'll add this draft to the returning lightning talks queue, but in the current state of the agenda it doesn't look like we'll get that far.

Cheers,

Brian
> On 30 Jun 2016, at 11:17, Srivathsa Sarangapani <[email-masked]> wrote:
> 
> Hi Brain and Bill,
> 
> We have had multiple discussion with most of the members/customers offline and after that we have modified the draft and
> addresses most of the concerns from them.
> 
> From: Brian Trammell <[email-masked]>
> Cc: <[email-masked]>