Subject: Re: [ippm] optimize the IOAM YANG data model

From: "Reshad Rahman (rrahman)" <[email-masked]>
Date: Thu, 5 Apr 2018 18:05:36 +0000

Hi Tianran,

I agree that using feature makes more sense than schema mount in this model.

Regarding 6087bis, there are quite a few things. Every IETF YANG author should read the whole doc… But Appendix B gives a checklist and Appendix C has a checklist. Section 3.7 has the security considerations and 3.7.1 has the template for that.

Regards,
Reshad.

From: Tianran Zhou <[email-masked]>
Date: Sunday, March 25, 2018 at 10:04 PM
To: "Reshad Rahman (rrahman)" <[email-masked]>, "[email-masked]" <[email-masked]>
Cc: Lizhenbin <[email-masked]>, "[email-masked]" <[email-masked]>
Subject: RE: [ippm] optimize the IOAM YANG data model

Hi Reshad,

Thanks for your comments.
Please see in line.

Cheers,
Tianran

From: Reshad Rahman (rrahman) [mailto:[email-masked]]
Sent: Sunday, March 25, 2018 7:24 PM
To: Tianran Zhou; [email-masked]
Cc: Lizhenbin; [email-masked]
Subject: Re: [ippm] optimize the IOAM YANG data model

Hi Tianran and Greg,

While schema-mount would work, it is really intended for use-cases where there is a requirement to add a module in 2 or more locations (e.g. interfaces at top-level, in LNE and in NI).

[ztr]Yes, that’s what I thought. So I suggested to use “feature” so that the can only support part of the encapsulation types.

I’ve taken a quick look at the model:

  *   The “enabled” leaf node under ioam-profiles (via grouping ioam-admin-config) says "When true, IOAM configuration is enabled for the system.". I think it’d make more sense if that enabled flag was to enable/disable IOAM data-plane functionality.
[ztr]Yes, this is more clear. I will add the words to the document.

  *   Would be best to use yang-version 1.1 IMO.
  *   Please take a look at 6087bis.
[ztr]Could you please point out what part of the 6087bis I need to pay attention? And what is not yang 1.1?
I intended to follow yang 1.1 indeed. ☺

Regards,
Reshad.

From: ippm <[email-masked]<mailto:[email-masked]>> on behalf of Tianran Zhou <[email-masked]<mailto:[email-masked]>>
Date: Wednesday, March 21, 2018 at 3:03 PM
To: "[email-masked]<mailto:[email-masked]>" <[email-masked]<mailto:[email-masked]>>
Cc: Lizhenbin <[email-masked]<mailto:[email-masked]>>, "[email-masked]<mailto:[email-masked]>" <[email-masked]<mailto:[email-masked]>>
Subject: [ippm] optimize the IOAM YANG data model

Hi Folks,

Thanks Greg to point out the flexibility of sub-profiles on the meeting. Here I would like to discuss the way to optimize this point for the IOAM YANG as described in:
https://datatracker.ietf.org/doc/draft-zhou-ippm-ioam-yang/

Although, as suggested, schema mount could help to dynamically mount sub-profiles to the IOAM configuration, IMHO, it may lead to the fragmentation of the model, I.e., several modules. And I cannot see the possibility to reuse the sub-profiles, except to this model.

With the same requirement, I would suggest to use “feature” to enable the supported IOAM encapsulation types. And use the “enable” within each sub-profile to indicate the actual used sub-profile by the instance.

Now four encapsulation types are supported according to the latest IOAM data specification. We may augment the model with more sub-profiles.

Thoughts?

Thanks,
Tianran

---

From: Greg Mirsky <[email-masked]>
Date: Thu, 5 Apr 2018 14:53:00 -0700

Hi Tianran,
I concur with you and Reshad, using feature is more appropriate in this
model.

Regards,
Greg

On Thu, Apr 5, 2018 at 11:05 AM, Reshad Rahman (rrahman) <[email-masked]>
wrote:

> Regarding 6087bis, there are quite a few things. Every IETF YANG author
> should read the whole doc… But Appendix B gives a checklist and Appendix C
> has a checklist. Section 3.7 has the security considerations and 3.7.1 has
> the template for that.
>
>
>
> Regards,
>
> Reshad.
>
>
>
> *From: *Tianran Zhou <[email-masked]>
> *Date: *Sunday, March 25, 2018 at 10:04 PM
> *To: *"Reshad Rahman (rrahman)" <[email-masked]>, "[email-masked]" <
> [email-masked]>
> *Cc: *Lizhenbin <[email-masked]>, "draft-zhou-ippm-ioam-yang@
> ietf.org" <[email-masked]>
> *Subject: *RE: [ippm] optimize the IOAM YANG data model
>
>
>
> Hi Reshad,
>
>
>
> *From:* Reshad Rahman (rrahman) [mailto:[email-masked]]
> *Sent:* Sunday, March 25, 2018 7:24 PM
> *To:* Tianran Zhou; [email-masked]
> *Cc:* Lizhenbin; [email-masked]
> *Subject:* Re: [ippm] optimize the IOAM YANG data model
>
>
>
> Hi Tianran and Greg,
>
>
>
> While schema-mount would work, it is really intended for use-cases where
> there is a requirement to add a module in 2 or more locations (e.g.
> interfaces at top-level, in LNE and in NI).
>
>
>
> [ztr]Yes, that’s what I thought. So I suggested to use “feature” so that
> the can only support part of the encapsulation types.
>
>
>
>    - The “enabled” leaf node under ioam-profiles (via grouping ioam-admin-config)
>    says "When true, IOAM configuration is enabled for the system.". I think
>    it’d make more sense if that enabled flag was to enable/disable IOAM
>    data-plane functionality.
>
>    - Would be best to use yang-version 1.1 IMO.
>    - Please take a look at 6087bis.
>
> I intended to follow yang 1.1 indeed. J
>
>
>
> Regards,
>
> Reshad.
>
>
>
> *From: *ippm <[email-masked]> on behalf of Tianran Zhou <
> [email-masked]>
> *Date: *Wednesday, March 21, 2018 at 3:03 PM
> *To: *"[email-masked]" <[email-masked]>
> *Cc: *Lizhenbin <[email-masked]>, "draft-zhou-ippm-ioam-yang@
> ietf.org" <[email-masked]>
> *Subject: *[ippm] optimize the IOAM YANG data model
>
>
>
> Hi Folks,
>
>
>
> Thanks Greg to point out the flexibility of sub-profiles on the meeting.
> Here I would like to discuss the way to optimize this point for the IOAM
> YANG as described in:
>
> Although, as suggested, schema mount could help to dynamically mount
> sub-profiles to the IOAM configuration, IMHO, it may lead to the
> fragmentation of the model, I.e., several modules. And I cannot see the
> possibility to reuse the sub-profiles, except to this model.
>
>
>
> With the same requirement, I would suggest to use “feature” to enable the
> supported IOAM encapsulation types. And use the “enable” within each
> sub-profile to indicate the actual used sub-profile by the instance.
>
>
>
> Now four encapsulation types are supported according to the latest IOAM
> data specification. We may augment the model with more sub-profiles.
>
>
>
> Thoughts?
>
>
>
> Thanks,
>
> Tianran
>
> _______________________________________________
> ippm mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/ippm
>
>

---

From: "Reshad Rahman (rrahman)" <[email-masked]>
Date: Fri, 6 Apr 2018 13:57:25 +0000

Hi Tianran and authors,

Other comments:

- draft-brockners-proof-of-transit is an informative reference but it has the ietf-pot-profile module which is imported by ietf-oam. That reference should be normative. This begs the question whether the ietf-pot-profile module should be in draft-brockners-proof-of-transit or whether draft-zhou-ippm-oam-yang should have everything? If it stays in draft-brockners-proof-of-transit, is experimental the right intended status for that draft?

- There are errors reported for leaf acl-name.  Looks like path "/acl:access-lists/acl:acl/acl:name" should be changed to "/acl:acls/acl:acl/acl:name"? draft-ietf-netmod-acl-model should be added as normative reference.

Regards,

Reshad.

From: Greg Mirsky <[email-masked]>
Date: Thursday, April 5, 2018 at 5:53 PM
To: "Reshad Rahman (rrahman)" <[email-masked]>
Cc: Tianran Zhou <[email-masked]>, "[email-masked]" <[email-masked]>, Lizhenbin <[email-masked]>, "[email-masked]" <[email-masked]>
Subject: Re: [ippm] optimize the IOAM YANG data model

Hi Tianran,
I concur with you and Reshad, using feature is more appropriate in this model.

Regards,
Greg

On Thu, Apr 5, 2018 at 11:05 AM, Reshad Rahman (rrahman) <[email-masked]<mailto:[email-masked]>> wrote:
Hi Tianran,

Regards,
Reshad.

From: Tianran Zhou <[email-masked]<mailto:[email-masked]>>
Date: Sunday, March 25, 2018 at 10:04 PM
To: "Reshad Rahman (rrahman)" <[email-masked]<mailto:[email-masked]>>, "[email-masked]<mailto:[email-masked]>" <[email-masked]<mailto:[email-masked]>>
Cc: Lizhenbin <[email-masked]<mailto:[email-masked]>>, "[email-masked]<mailto:[email-masked]>" <[email-masked]<mailto:[email-masked]>>
Subject: RE: [ippm] optimize the IOAM YANG data model

Hi Reshad,

Cheers,
Tianran

From: Reshad Rahman (rrahman) [mailto:[email-masked]<mailto:[email-masked]>]
Sent: Sunday, March 25, 2018 7:24 PM
To: Tianran Zhou; [email-masked]<mailto:[email-masked]>
Cc: Lizhenbin; [email-masked]<mailto:[email-masked]>
Subject: Re: [ippm] optimize the IOAM YANG data model

Hi Tianran and Greg,

Regards,
Reshad.

Hi Folks,

Thoughts?

Thanks,
Tianran

_______________________________________________
ippm mailing list
[email-masked]<mailto:[email-masked]>
https://www.ietf.org/mailman/listinfo/ippm

---

From: Tianran Zhou <[email-masked]>
Date: Sun, 8 Apr 2018 01:53:44 +0000

Hi Greg,

Thank you very much for you initial comments.

Best,
Tianran

From: Greg Mirsky [mailto:[email-masked]]
Sent: Friday, April 06, 2018 5:53 AM
To: Reshad Rahman (rrahman) <[email-masked]>
Cc: Tianran Zhou <[email-masked]>; [email-masked]; Lizhenbin <[email-masked]>; [email-masked]
Subject: Re: [ippm] optimize the IOAM YANG data model

Hi Tianran,

Regards,
Greg

Regards,
Reshad.

Hi Reshad,

Cheers,
Tianran

Hi Tianran and Greg,

Regards,
Reshad.

Hi Folks,

Thoughts?

Thanks,
Tianran

---

From: Tianran Zhou <[email-masked]>
Date: Sun, 8 Apr 2018 01:55:18 +0000

Hi Reshad,

Thanks for the important information.
I will read the appendix. And follow the instructions.

Best,
Tianran

From: Reshad Rahman (rrahman) [mailto:[email-masked]]
Sent: Friday, April 06, 2018 2:06 AM
To: Tianran Zhou <[email-masked]>; [email-masked]
Cc: Lizhenbin <[email-masked]>; [email-masked]
Subject: Re: [ippm] optimize the IOAM YANG data model

Hi Tianran,

Regards,
Reshad.

Hi Reshad,

Cheers,
Tianran

Hi Tianran and Greg,

Regards,
Reshad.

Hi Folks,

Thoughts?

Thanks,
Tianran

---

From: Tianran Zhou <[email-masked]>
Date: Sun, 8 Apr 2018 02:07:39 +0000

Hi Reshad,

Thanks for keeping your eye on this work. Good catches for the both issues.
Please see in line.

Many thanks,
Tianran
From: Reshad Rahman (rrahman) [mailto:[email-masked]]
Sent: Friday, April 06, 2018 9:57 PM
To: Greg Mirsky <[email-masked]>
Cc: Tianran Zhou <[email-masked]>; [email-masked]; Lizhenbin <[email-masked]>; [email-masked]
Subject: Re: [ippm] optimize the IOAM YANG data model

Hi Tianran and authors,

Other comments:

[ztr] Yes, that’s a problem I would discuss with authors of the draft-brockners-proof-of-transit. Actually, I have raised this question during my presentation on IPPM. I would suggest to include the pot part into the IOAM module. So that IOAM related modules are not fragmented.

[ztr] Good catch. I noticed this because I received an alarm from the document system. The ACL module I referred has been updated several days after my post. Yes, the container name changed. I will update the IOAM module together with some other comments soon.

Regards,

Reshad.

From: Greg Mirsky <[email-masked]<mailto:[email-masked]>>
Date: Thursday, April 5, 2018 at 5:53 PM
To: "Reshad Rahman (rrahman)" <[email-masked]<mailto:[email-masked]>>
Cc: Tianran Zhou <[email-masked]<mailto:[email-masked]>>, "[email-masked]<mailto:[email-masked]>" <[email-masked]<mailto:[email-masked]>>, Lizhenbin <[email-masked]<mailto:[email-masked]>>, "[email-masked]<mailto:[email-masked]>" <[email-masked]<mailto:[email-masked]>>
Subject: Re: [ippm] optimize the IOAM YANG data model

Hi Tianran,

Regards,
Greg

Regards,
Reshad.

Hi Reshad,

Cheers,
Tianran

Hi Tianran and Greg,

Regards,
Reshad.

Hi Folks,

Thoughts?

Thanks,
Tianran

---

From: "t.petch" <[email-masked]>
Date: Wed, 11 Apr 2018 17:06:33 +0100

----- Original Message -----
From: "Reshad Rahman (rrahman)" <[email-masked]>
Sent: Thursday, April 05, 2018 7:05 PM

> Regarding 6087bis, there are quite a few things. Every IETF YANG
author should read the whole doc…

Yes, that is the theory but the practice is that it is too big; even
though I have followed its progress since the days of
draft-bierman-netmod-yang-usage-00.txt
I still struggle to find the text that I know is there when I want to
comment on a YANG I-D that does not conform; and when I do not include
the reference, I get a follow-up question as to where to look:-(

So I mull over how better to present the material but have no clear
conclusion as yet.

Tom Petch

>         But Appendix B gives a checklist and Appendix C has a
checklist. Section 3.7 has the security considerations and 3.7.1 has the
template for that.
> Cc: Lizhenbin <[email-masked]>,
"[email-masked]"
<[email-masked]>
> While schema-mount would work, it is really intended for use-cases
where there is a requirement to add a module in 2 or more locations
(e.g. interfaces at top-level, in LNE and in NI).
>
> [ztr]Yes, that’s what I thought. So I suggested to use “feature” so
that the can only support part of the encapsulation types.
>   *   The “enabled” leaf node under ioam-profiles (via grouping
ioam-admin-config) says "When true, IOAM configuration is enabled for
the system.". I think it’d make more sense if that enabled flag was to
enable/disable IOAM data-plane functionality.
> From: ippm <[email-masked]<mailto:[email-masked]>> on
behalf of Tianran Zhou
<[email-masked]<mailto:[email-masked]>>
> Cc: Lizhenbin <[email-masked]<mailto:[email-masked]>>,
"[email-masked]<mailto:draft-zhou-ippm-ioam-yang@iet
f.org>"
<[email-masked]<mailto:draft-zhou-ippm-ioam-yang@iet
f.org>>
> Thanks Greg to point out the flexibility of sub-profiles on the
meeting. Here I would like to discuss the way to optimize this point for
>
> With the same requirement, I would suggest to use “feature” to enable
the supported IOAM encapsulation types. And use the “enable” within each
sub-profile to indicate the actual used sub-profile by the instance.
>
> Now four encapsulation types are supported according to the latest
IOAM data specification. We may augment the model with more
sub-profiles.
> Tianran

------------------------------------------------------------------------
--------

---

From: "Reshad Rahman (rrahman)" <[email-masked]>
Date: Wed, 11 Apr 2018 17:40:43 +0000

Tom, I agree that it's big. I usually go to Appendix B and C first, but you are right that finding the section which says "thou shall...." is tedious.

Regards,
Reshad.

On 2018-04-11, 12:12 PM, "t.petch" <[email-masked]> wrote:

    ----- Original Message -----
    From: "Reshad Rahman (rrahman)" <[email-masked]>
    Sent: Thursday, April 05, 2018 7:05 PM

    
    
    Tom Petch

    behalf of Tianran Zhou