Subject: Re: [ippm] AD Evaluation for draft-ietf-ippm-2330-ipv6-03

From: "MORTON, ALFRED C (AL)" <[email-masked]>
Date: Tue, 3 Apr 2018 22:28:07 +0000

Inline for the one open issue:

From: Spencer Dawkins at IETF [mailto:[email-masked]]
Sent: Friday, March 30, 2018 5:55 PM
To: MORTON, ALFRED C (AL) <[email-masked]>
Cc: Brian Trammell <[email-masked]>; Nevil Brownlee <[email-masked]>; [email-masked]; [email-masked]; [email-masked]
Subject: Re: AD Evaluation for draft-ietf-ippm-2330-ipv6-03

Hi, Al,

On Fri, Mar 30, 2018 at 11:11 AM, MORTON, ALFRED C (AL) <[email-masked]<mailto:[email-masked]>> wrote:
Hi Spencer, please see replies in-line.

I have one item below that I'm still not clear on, but I think we are in sync everywhere else.

Thanks for your review!
Al
[acm] …

I wasn't quite sure what to make of this text:

  We further require that if a packet is described as having a "length
   of B octets", then 0 <= B <= 65535; and if B is the payload length in
   octets, then B <= (65535-IP header size in octets, including any
   Extension Headers).  The jumbograms defined in [RFC2675] are not
   covered by this length analysis.

Is the point that jumbograms aren't valid standard-form packets?
[acm]
No, that IPv6 Jumbograms in 2675 can be eve longer!
from 2675:
   A "jumbogram" is an IPv6 packet containing a payload longer than
   65,535 octets.
Practical MTUs keep all this from becoming a point
of contention, as we explain.

Right, but what I'm not lacing together is

- I have an IPv6 packet with 65,536 bytes
- Let's say that It would be a valid standard-form packet if it was one byte shorter
- am I understanding that it is not a valid standard-form packet?
- or is the point that we basically never see IPv6 jumbograms because they would take up at least 40 maximum-length Ethernet packets, so we don't care whether they would be valid standard-form packets if we ever did see one?

Thanks for clues,

Spencer

[acm]

So, I propose that we make the jumbogram sentence end like this:

... but if the IPv6 Jumbogram Payload Hop-by-Hop Option Header is present,
then a packet with corresponding length MUST be considered standard-formed.

Al

---

From: Spencer Dawkins at IETF <[email-masked]>
Date: Tue, 3 Apr 2018 17:36:24 -0500

Al,

On Tue, Apr 3, 2018 at 5:28 PM, MORTON, ALFRED C (AL) <[email-masked]>
wrote:

> *From:* Spencer Dawkins at IETF [mailto:[email-masked]]
> *Sent:* Friday, March 30, 2018 5:55 PM
> *To:* MORTON, ALFRED C (AL) <[email-masked]>
> *Cc:* Brian Trammell <[email-masked]>; Nevil Brownlee <
> [email-masked]>; [email-masked]; [email-masked];
> [email-masked]
> *Subject:* Re: AD Evaluation for draft-ietf-ippm-2330-ipv6-03
>
>
>
> Hi, Al,
>
>
>
> On Fri, Mar 30, 2018 at 11:11 AM, MORTON, ALFRED C (AL) <[email-masked]>
> wrote:
>
> *[acm] *…
> *[acm] *
> - or is the point that we basically never see IPv6 jumbograms because they
> would take up at least 40 maximum-length Ethernet packets, so we don't care
> whether they would be valid standard-form packets if we ever did see one?
>
>
>
> Thanks for clues,
>
>
>
> Spencer
>
>
>
> *[acm] *
>
>
>

That is perfectly clear, and I wouldn't have guessed it worked that way in
a million years with the previous text ;-)

Ship it (at the appropriate time, of course!)

Spencer