Subject: [ippm] Comments about draft-fioccola-ippm-multipoint-alt-mark-02

From: Tal Mizrahi <[email-masked]>
Date: Mon, 30 Apr 2018 10:25:29 +0300

Hi Giuseppe et al.,

I reviewed the draft, and I believe it is a valuable and timely draft that
should be pursued by the IPPM working group.

A few comments:

·         “by considering n measurement points and n monitored flows” – it
would be more general to consider a case where the number of MPs differs
from the number of flows.

·         “intermediate measurement points have only the task to split the
measurement.” – please clarify this point.

·         “PL = (PI1 + PI2 +...+ PIn) - (PO1 + PO2 +...+ POm)”
Please clarify that this equation is applied on a per-time-interval basis.

·         “Algorithm for Cluster partition”
I could not understand the algorithm. Perhaps it would be helpful to write
a few lines of pseudo-code to define the algorithm.

·         “Delay and delay variation measurements relative to a picked
packet (both single and double marked) cannot be performed in the
Multipoint scenario”
I believe this sentence is not accurate. I believe it would be more
accurate to say that: (1) Single marking based on the first packet of the
interval would not work, because it would not be possible to agree on the
first packet of the interval. (2) Double marking or multiplexed marking
would work, **but** each measurement would only give information about the
delay of a single path. However, by repeating the measurement multiple
times, you could get information about all the paths in the multipoint flow
(the mean delay approach of section 4.4.2. uses the same principle, i.e.,
by considering a large number of packets, we get information about the
different paths).

·         Section 4.4.3: please clarify why hash-based selection is
different than double marking in the multipoint context. It seems that the
basic hash is **logically** similar to the double marking method, right? In
both cases each measurement is applicable to a single path.
Indeed, the dynamic approach scales the number of measurements per
interval, but it would seem that double marking would also work well if we
reduced the interval length, right?

Cheers,
Tal.

---

From: Fioccola Giuseppe <[email-masked]>
Date: Mon, 30 Apr 2018 12:33:46 +0000

Hi Tal,
Thanks for your opinion of the document.
We will certainly address your comments in the next revision of the draft.
My answers inline tagged as [GF].

Best Regards,

Giuseppe

Da: Tal Mizrahi <[email-masked]>
Data: lunedì 30 aprile 2018 09:25
A: "[email-masked]" <[email-masked]>, "[email-masked]" <[email-masked]>
Oggetto: Comments about draft-fioccola-ippm-multipoint-alt-mark-02
Rinviato da: <[email-masked]>
Rinviato a: <[email-masked]>, <[email-masked]>, "Amedeo it>" <[email-masked]>, Riccardo Sisto <[email-masked]>
Data rinvio: lunedì 30 aprile 2018 09:25

Hi Giuseppe et al.,

I reviewed the draft, and I believe it is a valuable and timely draft that should be pursued by the IPPM working group.

A few comments:

•         “by considering n measurement points and n monitored flows” – it would be more general to consider a case where the number of MPs differs from the number of flows.

[GF]: Will fix it. It was just to highlight the order of magnitude of the packet counters as n squared.

•         “intermediate measurement points have only the task to split the measurement.” – please clarify this point.

[GF]: Will clarify this. This sentence is true only if no packet loss occurs.

•         “PL = (PI1 + PI2 +...+ PIn) - (PO1 + PO2 +...+ POm)”
Please clarify that this equation is applied on a per-time-interval basis.

[GF]: Agree.

•         “Algorithm for Cluster partition”
I could not understand the algorithm. Perhaps it would be helpful to write a few lines of pseudo-code to define the algorithm.

[GF]: Your suggestion makes sense. A step by step description of the algorithm is more explicative here and will be added. In the meanwhile I would point out a slide in the IPPM presentation prepared for the London meeting that can help.

•         “Delay and delay variation measurements relative to a picked packet (both single and double marked) cannot be performed in the Multipoint scenario”
I believe this sentence is not accurate. I believe it would be more accurate to say that: (1) Single marking based on the first packet of the interval would not work, because it would not be possible to agree on the first packet of the interval. (2) Double marking or multiplexed marking would work, *but* each measurement would only give information about the delay of a single path. However, by repeating the measurement multiple times, you could get information about all the paths in the multipoint flow (the mean delay approach of section 4.4.2. uses the same principle, i.e., by considering a large number of packets, we get information about the different paths).

[GF]: Yes, you are right and I think we should specify better the difference in the next revision. That sentence is valid if we would perform a delay measurement for more than one picked packet in the same marking period and, especially, if we want to get delay mesurements on multipoint-to-multipoint basis.

•         Section 4.4.3: please clarify why hash-based selection is different than double marking in the multipoint context. It seems that the basic hash is *logically* similar to the double marking method, right? In both cases each measurement is applicable to a single path.
Indeed, the dynamic approach scales the number of measurements per interval, but it would seem that double marking would also work well if we reduced the interval length, right?

[GF]: Will explain better in the new revision. In case of point-to-point path double marking and hash selection are equivalent. But if you want to get delay mesurements on multipoint-to-multipoint path basis and want to select more than one packet per period, you cannot use double marking because you  could not be able to couple the picked packets between input and output nodes. On the other hand you can do that by using hashing selection.

Cheers,
Tal.

Questo messaggio e i suoi allegati sono indirizzati esclusivamente alle persone indicate. La diffusione, copia o qualsiasi altra azione derivante dalla conoscenza di queste informazioni sono rigorosamente vietate. Qualora abbiate ricevuto questo documento per errore siete cortesemente pregati di darne immediata comunicazione al mittente e di provvedere alla sua distruzione, Grazie. 

This e-mail and any attachments is confidential and may contain privileged information intended for the addressee(s) only. Dissemination, copying, printing or use by anybody else is unauthorised. If you are not the intended recipient, please delete this message and any attachments and advise the sender by return e-mail, Thanks. 

Rispetta l'ambiente. Non stampare questa mail se non è necessario.