Subject: [ippm] Ben Campbell's No Objection on draft-ietf-ippm-twamp-yang-11: (with COMMENT)

From: Ben Campbell <[email-masked]>
Date: Tue, 19 Jun 2018 10:15:43 -0700

Ben Campbell has entered the following ballot position for
draft-ietf-ippm-twamp-yang-11: No Objection

When responding, please keep the subject line intact and reply to all
email addresses included in the To and CC lines. (Feel free to cut this
introductory paragraph, however.)

Please refer to https://www.ietf.org/iesg/statement/discuss-criteria.html
for more information about IESG DISCUSS and COMMENT positions.

The document, along with other ballot positions, can be found here:
https://datatracker.ietf.org/doc/draft-ietf-ippm-twamp-yang/

----------------------------------------------------------------------
COMMENT:
----------------------------------------------------------------------

Substantive:

§7:

The security consideration lists a couple of examples of writeable nodes that
might be vulnerable. I'd like to see an actual list of nodes thought to be
vulnerable, along with a sentence or two describing the risks for each.

Are there no nodes that are privacy (or otherwise) sensitive when just readable?

Editorial:

- Title/abstract: It seems like there's a bit more than a data model here;
there some normative behavior as well.

§3.3:
- first bullet: s/ "identical with " / "identical to "
- third bullet: "such as" and "for example" are redundant.

---

From: Mahesh Jethanandani <[email-masked]>
Date: Tue, 19 Jun 2018 22:05:41 -0700

Hi Ben,

Please see inline with [mj].

> On Jun 19, 2018, at 10:15 AM, Ben Campbell <[email-masked]> wrote:
> 

[mj] Readable nodes are sensitive. But as the section states, access to readonly nodes is protected by the security layer over which the data nodes are exchanged and by the use of access control (NACM). Just because the nodes are readonly does not mean that anyone can read them. In NACM, the ‘read-default’ can be set to ‘deny’, in which case unless a matching rule is found, read of any kind is denied.

As for a list of nodes thought to be vulnerable, I assume you want to know the impact w.r.t. TWAMP. We have singled out timeout values as vulnerable because we understand its operational impact w.r.t. TWAMP, i.e. untimely timeouts or sessions not timing out at all etc. For the remaining nodes, we have not been able to do the same, particularly as it relates to TWAMP.

> there some normative behavior as well.

[mj] I am not sure of the normative behavior that you refer to. Could you elaborate? 

> - third bullet: "such as" and "for example" are redundant.

[mj] Will fix both of the typos.

Mahesh Jethanandani
[email-masked]