Subject: [ippm] I-D Action: draft-ietf-ippm-twamp-yang-13.txt

From: [email-masked]
Date: Mon, 02 Jul 2018 14:03:52 -0700

A New Internet-Draft is available from the on-line Internet-Drafts directories.
This draft is a work item of the IP Performance Measurement WG of the IETF.

        Title           : Two-Way Active Measurement Protocol (TWAMP) Data Model
        Authors         : Ruth Civil
                          Al Morton
                          Reshad Rahman
                          Mahesh Jethanandani
                          Kostas Pentikousis
	Filename        : draft-ietf-ippm-twamp-yang-13.txt
	Pages           : 68
	Date            : 2018-07-02

Abstract:
   This document specifies a data model for client and server
   implementations of the Two-Way Active Measurement Protocol (TWAMP).
   The document defines the TWAMP data model through Unified Modeling
   Language (UML) class diagrams and formally specifies it using a NDMA-
   compliant YANG model.

The IETF datatracker status page for this draft is:
https://datatracker.ietf.org/doc/draft-ietf-ippm-twamp-yang/

There are also htmlized versions available at:
https://tools.ietf.org/html/draft-ietf-ippm-twamp-yang-13
https://datatracker.ietf.org/doc/html/draft-ietf-ippm-twamp-yang-13

A diff from the previous version is available at:
https://www.ietf.org/rfcdiff?url2=draft-ietf-ippm-twamp-yang-13

Please note that it may take a couple of minutes from the time of submission
until the htmlized version and diff are available at tools.ietf.org.

Internet-Drafts are also available by anonymous FTP at:
ftp://ftp.ietf.org/internet-drafts/

---

From: "t.petch" <[email-masked]>
Date: Tue, 3 Jul 2018 11:52:28 +0100

Looking at -13, it has
         bit unauth-test-encrpyt-control {
which AM thought should be
         bit unauth-test-encrypt-control {

And s.5.2 has
Advances Stream and Sampling Framework [RFC7312],
which I think should be
Advanced Stream and Sampling Framework [RFC7312],

Tom Petch

----- Original Message -----
From: <[email-masked]>
To: <[email-masked]>
Cc: <[email-masked]>
Sent: Monday, July 02, 2018 10:03 PM

> _______________________________________________
> ippm mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/ippm

---

From: Spencer Dawkins at IETF <[email-masked]>
Date: Tue, 10 Jul 2018 13:59:13 -0500

Dear Authors,

I think I'm within nanoseconds of sending an Approved note for this draft,
but then noticed a couple of things I wanted to ask about first.

I noted that Tom Petch had flagged

Looking at -13, it has

which he had previously flagged in -12.

He also mentioned

And s.5.2 has

Which seems to be new.

Are these proposed changes correct?

Is this citation

   [UML]      ISO/IEC, "Information technology - Open Distributed
                Processing - Unified Modeling Language", April 2005.

sufficient for the expected reader? I noted that Adam's question mentioned
"ISO/IEC 19501:2005", which seems like a helpful detail if someone were
chasing the reference.

Just let me know. I'm happy to do these as RFC Editor notes, if they're
correct.

Spencer

---

From: Mahesh Jethanandani <[email-masked]>
Date: Tue, 10 Jul 2018 13:15:57 -0700

Hi Spencer,

> On Jul 10, 2018, at 11:59 AM, Spencer Dawkins at IETF <[email-masked]> wrote:
> 
> Dear Authors,
> 
> I think I'm within nanoseconds of sending an Approved note for this draft, but then noticed a couple of things I wanted to ask about first.
> 

Thanks for catching this. Yes it should be 
bit unauth-test-encrypt-control {

> Advanced Stream and Sampling Framework [RFC7312],

Hmm. I seem to be missing his e-mail that catches that, but I can see it in the draft. So yes, it should be:

Advanced Stream and Sampling Framework[RFC7312],

> Are these proposed changes correct? 

Yes.

> sufficient for the expected reader? I noted that Adam's question mentioned "ISO/IEC 19501:2005", which seems like a helpful detail if someone were chasing the reference. 

Yes, I agree it would be helpful to have that reference.

> 
> Just let me know. I'm happy to do these as RFC Editor notes, if they're correct.

Thank you.

> 
> Spencer
> 
> On Mon, Jul 2, 2018 at 4:05 PM <[email-masked] <mailto:[email-masked]>> wrote:
> 
> https://datatracker.ietf.org/doc/draft-ietf-ippm-twamp-yang/ <https://datatracker.ietf.org/doc/draft-ietf-ippm-twamp-yang/>
> 
> https://tools.ietf.org/html/draft-ietf-ippm-twamp-yang-13 <https://tools.ietf.org/html/draft-ietf-ippm-twamp-yang-13>
> https://datatracker.ietf.org/doc/html/draft-ietf-ippm-twamp-yang-13 <https://datatracker.ietf.org/doc/html/draft-ietf-ippm-twamp-yang-13>
> 
> https://www.ietf.org/rfcdiff?url2=draft-ietf-ippm-twamp-yang-13 <https://www.ietf.org/rfcdiff?url2=draft-ietf-ippm-twamp-yang-13>
> 
> 
> until the htmlized version and diff are available at tools.ietf.org <http://tools.ietf.org/>.
> 
> ftp://ftp.ietf.org/internet-drafts/ <ftp://ftp.ietf.org/internet-drafts/>
> 
> [email-masked] <mailto:[email-masked]>
> https://www.ietf.org/mailman/listinfo/ippm <https://www.ietf.org/mailman/listinfo/ippm>

Mahesh Jethanandani
[email-masked]

---

From: "MORTON, ALFRED C (AL)" <[email-masked]>
Date: Tue, 10 Jul 2018 20:33:28 +0000

Hi Spencer,

Since I was investigating ion parallel, let me add:

From: Mahesh Jethanandani [mailto:[email-masked]]
Sent: Tuesday, July 10, 2018 4:16 PM
To: Spencer Dawkins at IETF <[email-masked]>
Cc: [email-masked]; Mirja Kuehlewind <[email-masked]>; [email-masked]
Subject: Re: [ippm] I-D Action: draft-ietf-ippm-twamp-yang-13.txt

Hi Spencer,

On Jul 10, 2018, at 11:59 AM, Spencer Dawkins at IETF <[email-masked]<mailto:[email-masked]>> wrote:

Dear Authors,

Looking at -13, it has

He also mentioned

And s.5.2 has

Which seems to be new.

Yes.
[acm]

Let's add these as OLD/NEW to the REF Editor, Tom said that was fine...

Is this citation

Yes, I agree it would be helpful to have that reference.
[acm]
It seems that the Title is not enough for a popular search engine
to find the right standard.  I also learned that there is a
related spec by searching with the title:

https://www.iso.org/standard/68641.html ISO/IEC 19793:2015

Only searching with the exact number did I get the right spec.
Note that the exact title is a little longer:

ISO/IEC 19501:2005 (OMG-UML VER 1.3)
Information technology -- Open Distributed Processing
-- Unified Modeling Language (UML) Version 1.4.2

We can handle this with an OLD/NEW as well, IMO.

Al

Thank you.

Spencer

On Mon, Jul 2, 2018 at 4:05 PM <[email-masked]<mailto:[email-masked]>> wrote:

Abstract:

The IETF datatracker status page for this draft is:
https://datatracker.ietf.org/doc/draft-ietf-ippm-twamp-yang/<https://urldefense.proofpoint.com/v2/url?u=https-3A__datatracker.ietf.org_doc_draft-2Dietf-2Dippm-2Dtwamp-2Dyang_&d=DwMFAg&c=LFYZ-o9_HUMeMTSQicvjIg&r=OfsSu8kTIltVyD1oL72cBw&m=osJAvla2Hb7POb-9zR1gPnpSuT_Lrq0e33EXq-luZ1k&s=NNUjX4MlWZeaYTKblVH7tZCN8aqT3JY5GfqFusVPUhM&e=>

There are also htmlized versions available at:
https://tools.ietf.org/html/draft-ietf-ippm-twamp-yang-13<https://urldefense.proofpoint.com/v2/url?u=https-3A__tools.ietf.org_html_draft-2Dietf-2Dippm-2Dtwamp-2Dyang-2D13&d=DwMFAg&c=LFYZ-o9_HUMeMTSQicvjIg&r=OfsSu8kTIltVyD1oL72cBw&m=osJAvla2Hb7POb-9zR1gPnpSuT_Lrq0e33EXq-luZ1k&s=BXr2MfMtD0xVQVVXfAsuV7nLMFxTUCMsVOFFIn0Xz78&e=>
https://datatracker.ietf.org/doc/html/draft-ietf-ippm-twamp-yang-13<https://urldefense.proofpoint.com/v2/url?u=https-3A__datatracker.ietf.org_doc_html_draft-2Dietf-2Dippm-2Dtwamp-2Dyang-2D13&d=DwMFAg&c=LFYZ-o9_HUMeMTSQicvjIg&r=OfsSu8kTIltVyD1oL72cBw&m=osJAvla2Hb7POb-9zR1gPnpSuT_Lrq0e33EXq-luZ1k&s=OWlEC1PmSdLk-H-OA9ar_1J9AurwYW9AWnijZFhMeHg&e=>

A diff from the previous version is available at:
https://www.ietf.org/rfcdiff?url2=draft-ietf-ippm-twamp-yang-13<https://urldefense.proofpoint.com/v2/url?u=https-3A__www.ietf.org_rfcdiff-3Furl2-3Ddraft-2Dietf-2Dippm-2Dtwamp-2Dyang-2D13&d=DwMFAg&c=LFYZ-o9_HUMeMTSQicvjIg&r=OfsSu8kTIltVyD1oL72cBw&m=osJAvla2Hb7POb-9zR1gPnpSuT_Lrq0e33EXq-luZ1k&s=e82DyFOGr_zEtGgRzzaLFGZ1fdHvexpg4fUeYUmNFxM&e=>

Please note that it may take a couple of minutes from the time of submission
until the htmlized version and diff are available at tools.ietf.org<https://urldefense.proofpoint.com/v2/url?u=http-3A__tools.ietf.org_&d=DwMFAg&c=LFYZ-o9_HUMeMTSQicvjIg&r=OfsSu8kTIltVyD1oL72cBw&m=osJAvla2Hb7POb-9zR1gPnpSuT_Lrq0e33EXq-luZ1k&s=CvHG8n26154tZWk6Akdk2YzgBSCpnrX2AVk2-ZVTbpE&e=>.

Internet-Drafts are also available by anonymous FTP at:
ftp://ftp.ietf.org/internet-drafts/<https://urldefense.proofpoint.com/v2/url?u=ftp-3A__ftp.ietf.org_internet-2Ddrafts_&d=DwMFAg&c=LFYZ-o9_HUMeMTSQicvjIg&r=OfsSu8kTIltVyD1oL72cBw&m=osJAvla2Hb7POb-9zR1gPnpSuT_Lrq0e33EXq-luZ1k&s=fPiEzM5rf6VoIvZd8BPALNOrRngwnizykMbawb9vwFo&e=>

_______________________________________________
ippm mailing list
[email-masked]<mailto:[email-masked]>
https://www.ietf.org/mailman/listinfo/ippm<https://urldefense.proofpoint.com/v2/url?u=https-3A__www.ietf.org_mailman_listinfo_ippm&d=DwMFAg&c=LFYZ-o9_HUMeMTSQicvjIg&r=OfsSu8kTIltVyD1oL72cBw&m=osJAvla2Hb7POb-9zR1gPnpSuT_Lrq0e33EXq-luZ1k&s=0uLcOxXzot5_PhW8Hsbluqy2lUhW7qPQTRKTBvEON7A&e=>

Mahesh Jethanandani
[email-masked]<mailto:[email-masked]>

---

From: "MORTON, ALFRED C (AL)" <[email-masked]>
Date: Tue, 10 Jul 2018 20:38:09 +0000

I'm re-sending, because the message came back from the
IETF alias system truncated, and info on the reference
was not included...

Hi Spencer,

Since I was investigating in parallel, let me add:

Hi Spencer,

Dear Authors,

Looking at -13, it has

He also mentioned

And s.5.2 has

Which seems to be new.

Yes.
[acm]

Is this citation

Al

Thank you.

Spencer

Abstract:

Mahesh Jethanandani

---

From: "MORTON, ALFRED C (AL)" <[email-masked]>
Date: Tue, 10 Jul 2018 22:19:13 +0000

The truncation happened at the same place, 
where I inserted some URLS & text.

At least it's deterministic.
I'll try again later...
Al

> -----Original Message-----
> From: MORTON, ALFRED C (AL)
> Sent: Tuesday, July 10, 2018 4:38 PM
> To: Mahesh Jethanandani <[email-masked]>; Spencer Dawkins at IETF
> <[email-masked]>
> Subject: RE: [ippm] I-D Action: draft-ietf-ippm-twamp-yang-13.txt
> 
> *** Security Advisory: This Message Originated Outside of AT&T ***.
> Reference http://cso.att.com/EmailSecurity/IDSP.html for more information.
> 
> On Jul 10, 2018, at 11:59 AM, Spencer Dawkins at IETF
> <[email-masked]<mailto:[email-masked]>>
> wrote:
> 
> Dear Authors,
> 
>                         Processing - Unified Modeling Language", April
> 2005

---

From: Spencer Dawkins at IETF <[email-masked]>
Date: Tue, 10 Jul 2018 22:28:11 -0500

Hi, Al,
On Tue, Jul 10, 2018 at 5:19 PM MORTON, ALFRED C (AL) <[email-masked]>

> At least it's deterministic.

Since you're sending this directly to me, I got untruncated copies, and was
able to add the RFC Editor Notes you and Manesh approved, and sent the
Approved note to the IESG Secretary.

I THINK you can see them at
https://datatracker.ietf.org/doc/draft-ietf-ippm-twamp-yang/writeup/ (but
I'm logged in as an AD), so please let me know if you can't see them, and
we'll work around that.

Thanks for all your hard work. You should see the announcement for this
draft tomorrow (unless the entire secretariat is flying to Montreal).

It is also the latest addition to the AD slides on completed work since
IETF 101 for TSVAREA ...

Spencer

---

From: "MORTON, ALFRED C (AL)" <[email-masked]>
Date: Wed, 11 Jul 2018 11:47:48 +0000

The write-up looks good to me, Spencer.

Thank you for your many good suggestions
and AD-level shepherding of this and many
other IPPM drafts!  It has been a pleasure
working with you in your AD-Advisor capacity.

Al

From: Spencer Dawkins at IETF [mailto:[email-masked]]
Sent: Tuesday, July 10, 2018 11:28 PM
To: MORTON, ALFRED C (AL) <[email-masked]>
Cc: Mahesh Jethanandani <[email-masked]>; [email-masked]; Mirja Kuehlewind <[email-masked]>; [email-masked]
Subject: Re: [ippm] I-D Action: draft-ietf-ippm-twamp-yang-13.txt

Hi, Al,
On Tue, Jul 10, 2018 at 5:19 PM MORTON, ALFRED C (AL) <[email-masked]<mailto:[email-masked]>> wrote:
The truncation happened at the same place,
where I inserted some URLS & text.

Since you're sending this directly to me, I got untruncated copies, and was able to add the RFC Editor Notes you and Manesh approved, and sent the Approved note to the IESG Secretary.

I THINK you can see them at https://datatracker.ietf.org/doc/draft-ietf-ippm-twamp-yang/writeup/<https://urldefense.proofpoint.com/v2/url?u=https-3A__datatracker.ietf.org_doc_draft-2Dietf-2Dippm-2Dtwamp-2Dyang_writeup_&d=DwMFaQ&c=LFYZ-o9_HUMeMTSQicvjIg&r=OfsSu8kTIltVyD1oL72cBw&m=KNiIfAgx7CsmkBBptISsHMdJQmH3bAXgXIGbfe-Qx1Y&s=m7m3XnOS3D4YxFiwwbV0rn8-S54mrOwNBgsHDJ-EjIs&e=> (but I'm logged in as an AD), so please let me know if you can't see them, and we'll work around that.

Thanks for all your hard work. You should see the announcement for this draft tomorrow (unless the entire secretariat is flying to Montreal).

It is also the latest addition to the AD slides on completed work since IETF 101 for TSVAREA ...

Spencer

---

From: Mahesh Jethanandani <[email-masked]>
Date: Wed, 11 Jul 2018 07:59:22 -0700

+1

> On Jul 11, 2018, at 4:47 AM, MORTON, ALFRED C (AL) <[email-masked]> wrote:
> 
>   <>
> On Tue, Jul 10, 2018 at 5:19 PM MORTON, ALFRED C (AL) <[email-masked] <mailto:[email-masked]>> wrote:
> I THINK you can see them at https://datatracker.ietf.org/doc/draft-ietf-ippm-twamp-yang/writeup/ <https://urldefense.proofpoint.com/v2/url?u=https-3A__datatracker.ietf.org_doc_draft-2Dietf-2Dippm-2Dtwamp-2Dyang_writeup_&d=DwMFaQ&c=LFYZ-o9_HUMeMTSQicvjIg&r=OfsSu8kTIltVyD1oL72cBw&m=KNiIfAgx7CsmkBBptISsHMdJQmH3bAXgXIGbfe-Qx1Y&s=m7m3XnOS3D4YxFiwwbV0rn8-S54mrOwNBgsHDJ-EjIs&e=> (but I'm logged in as an AD), so please let me know if you can't see them, and we'll work around that.
>  

Mahesh Jethanandani
[email-masked]