Subject: Re: [ippm] New Version Notification for draft-spiegel-ippm-ioam-rawexport-01.txt

From: Andrew Feren <[email-masked]>
Date: Thu, 25 Jul 2019 13:12:37 +0000

Hi Mikey,

I’m coming in way late on this, but somehow this flew under my radar until I saw you present in Montreal.  I haven’t given it a full read yet, but I do have one question.  Why do you need a new IE to include padding?  Why not use the existing ipHeaderPacketSection with the existing paddingOctets IE?

-Andrew

On Oct 22, 2018, at 8:26 PM, Mickey Spiegel <mspiegel=[email-masked]<mailto:mspiegel=[email-masked]>> wrote:

A new version of draft-spiegel-ippm-ioam-rawexport has been posted.

The new version updates references to the IOAM encap drafts, and adds a code point for IPv6.

New IPFIX information elements ipHeaderPacketSectionWithPadding and ethernetFrameSection are added. These address the issue of alignment with variable length packet sections such as the existing ipHeaderPacketSection and dataLinkFrameSection. In particular they allow for the insertion of up to 3 octets of padding in order to preserve alignment for subsequent information elements, and for additional records in the same set. The ethernetFrameSection also avoids the need to include the dataLinkFrameType and dataLinkFrameSize information elements.

Mickey

---------- Forwarded message ---------
From: <[email-masked]<mailto:[email-masked]>>
Date: Mon, Oct 22, 2018 at 4:33 PM
Subject: New Version Notification for draft-spiegel-ippm-ioam-rawexport-01.txt

A new version of I-D, draft-spiegel-ippm-ioam-rawexport-01.txt
has been successfully submitted by Mickey Spiegel and posted to the
IETF repository.

Name:           draft-spiegel-ippm-ioam-rawexport
Revision:       01
Title:          In-situ OAM raw data export with IPFIX
Document date:  2018-10-22
Group:          Individual Submission
Pages:          22
URL:            https://www.ietf.org/internet-drafts/draft-spiegel-ippm-ioam-rawexport-01.txt<https://linkprotect.cudasvc.com/url?a=https%3a%2f%2fwww.ietf.org%2finternet-drafts%2fdraft-spiegel-ippm-ioam-rawexport-01.txt&c=E,1,XLWC6KoyMbYRdm3X_R7ua7ysLxLB6W9wYAGQdFAieG8olfziOwoyjJvxKA_lINQ94LWjiFPgKLNm1T8hXhl9GZHeZA-CebmtDSM4DN4qVhxqmaX-qA,,&typo=1>
Status:         https://datatracker.ietf.org/doc/draft-spiegel-ippm-ioam-rawexport/<https://linkprotect.cudasvc.com/url?a=https%3a%2f%2fdatatracker.ietf.org%2fdoc%2fdraft-spiegel-ippm-ioam-rawexport%2f&c=E,1,AjAhXJCCP2-K3r_bhlY6tWekEre6khI9dAEE7K0D9rShsu0J7QOAMtOuOBjm9DoT_yTGSejvrvahlkrFy2WyWQ6TGBHqzhuJMVdY74ggJv2R&typo=1>
Htmlized:       https://tools.ietf.org/html/draft-spiegel-ippm-ioam-rawexport-01<https://linkprotect.cudasvc.com/url?a=https%3a%2f%2ftools.ietf.org%2fhtml%2fdraft-spiegel-ippm-ioam-rawexport-01&c=E,1,Q41YF2RIE308dAfPAbMtG0U2iC6VhaVmo8D95QwB80mZtGjDyyQIJF6RIA57yu4JSn2QZNEM6yP7i7NAufko5gfDAEF0pBQLjp-CJRiCMZ4X&typo=1>
Htmlized:       https://datatracker.ietf.org/doc/html/draft-spiegel-ippm-ioam-rawexport<https://linkprotect.cudasvc.com/url?a=https%3a%2f%2fdatatracker.ietf.org%2fdoc%2fhtml%2fdraft-spiegel-ippm-ioam-rawexport&c=E,1,AGhegdwBIgVcn3diXJnlYadHXr_-fEdJbEOrmzeEtcr8gZvfkEak4Cqm6FZoozAk3SLSRTre-2caaktlZFZkfic8MC95H3L3YwYJAEZ9RUhnPCWmKuMYoFaOcMY,&typo=1>
Diff:           https://www.ietf.org/rfcdiff?url2=draft-spiegel-ippm-ioam-rawexport-01<https://linkprotect.cudasvc.com/url?a=https%3a%2f%2fwww.ietf.org%2frfcdiff%3furl2%3ddraft-spiegel-ippm-ioam-rawexport-01&c=E,1,yIvtYp0d95tIWppvmYtExQYiB17viuvUMeOarRVq3mLCFumZMdEa5FNSV-PrxHo60Cn5tgBo9J2pEFgXG6iCnsGiyUjEP9OP11rvDxXTERDyuD8X8kKSVpKm&typo=1>

Abstract:
   In-situ Operations, Administration, and Maintenance (IOAM) records
   operational and telemetry information in the packet while the packet
   traverses a path between two points in the network.  This document
   discusses how In-situ Operations, Administration, and Maintenance
   (IOAM) information can be exported in raw, i.e. uninterpreted, format
   from network devices to systems, such as monitoring or analytics
   systems using IPFIX.

Please note that it may take a couple of minutes from the time of submission
until the htmlized version and diff are available at tools.ietf.org<https://linkprotect.cudasvc.com/url?a=http%3a%2f%2ftools.ietf.org&c=E,1,7SYpdkqDS7_x7bj-GITQVKdtWOkgNZ7ooqRju7NzGi99-CjcYTgrWr7CzMFQdsd3Pzg_NwNF4VHCyTHRMdFPllfvjKaP4QgrxGwCYHHW2xBPyih32YX2kgbp&typo=1>.

The IETF Secretariat

_______________________________________________
ippm mailing list
[email-masked]<mailto:[email-masked]>
https://linkprotect.cudasvc.com/url?a=https%3a%2f%2fwww.ietf.org%2fmailman%2flistinfo%2fippm&c=E,1,mKywgKF0-bE_26OpmLt0e76Y9C8HGIUciWfxiIQ2HrD8X3MqWAeLdOyc-fUtYkZ3S_dYN8M6LVbwLmCm9GsHbB4JGuDTOAjQvMvnM200VAbMIvbxVcg,&typo=1

This email message and any attachments are confidential. If you are not the intended recipient, please immediately reply to the sender and delete the message from your email system. Thank you.

---

From: Andrew Feren <[email-masked]>
Date: Thu, 25 Jul 2019 13:34:28 +0000

Oh.  I see what is going on.  You want varlen and padding without sectionExportedOctets.  I’ll finish my coffee and the draft before saying anything else.

-Andrew

On Jul 25, 2019, at 9:12 AM, Andrew Feren <andrew.feren=[email-masked]<mailto:andrew.feren=[email-masked]>> wrote:

Hi Mikey,

-Andrew

Mickey

---------- Forwarded message ---------
From: <[email-masked]<mailto:[email-masked]>>
Date: Mon, Oct 22, 2018 at 4:33 PM
Subject: New Version Notification for draft-spiegel-ippm-ioam-rawexport-01.txt

Abstract:

The IETF Secretariat

This email message and any attachments are confidential. If you are not the intended recipient, please immediately reply to the sender and delete the message from your email system. Thank you.
_______________________________________________
ippm mailing list
[email-masked]<mailto:[email-masked]>
https://www.ietf.org/mailman/listinfo/ippm

---

From: Mickey Spiegel <[email-masked]>
Date: Thu, 25 Jul 2019 08:25:27 -0700

On Thu, Jul 25, 2019 at 6:34 AM Andrew Feren <andrew.feren=
[email-masked]> wrote:

> Oh.  I see what is going on.  You want varlen and padding without sectionExportedOctets.
>  I’ll finish my coffee and the draft before saying anything else.
>

See slide 9 of the presentation at
https://datatracker.ietf.org/meeting/105/materials/slides-105-opsawg-draft-spiegel-ippm-ioam-rawexport-00
The primary point is the ability to add 0 to 3 octets of padding when using
variable length, in order to preserve 4 byte alignment. With the existing
ipHeaderPacketSection with variable length, no padding is allowed, so if
the packet length is not a multiple of 4 octets the next information
element or next record will not be 4 byte aligned.

Mickey

> -Andrew
>
> On Jul 25, 2019, at 9:12 AM, Andrew Feren <
> andrew.feren=[email-masked]> wrote:
>
> Hi Mikey,
>
> I’m coming in way late on this, but somehow this flew under my radar until
> I saw you present in Montreal.  I haven’t given it a full read yet, but I
> do have one question.  Why do you need a new IE to include padding?  Why
> not use the existing ipHeaderPacketSection with the existing paddingOctets
>  IE?
>
> -Andrew
>
> On Oct 22, 2018, at 8:26 PM, Mickey Spiegel <
> mspiegel=[email-masked]> wrote:
>
> New IPFIX information elements ipHeaderPacketSectionWithPadding and
> ethernetFrameSection are added. These address the issue of alignment with
> variable length packet sections such as the existing ipHeaderPacketSection
> and dataLinkFrameSection. In particular they allow for the insertion of up
> to 3 octets of padding in order to preserve alignment for subsequent
> information elements, and for additional records in the same set. The
> ethernetFrameSection also avoids the need to include the dataLinkFrameType
> and dataLinkFrameSize information elements.
>
> Mickey
>
> From: <[email-masked]>
> URL:
> https://www.ietf.org/internet-drafts/draft-spiegel-ippm-ioam-rawexport-01.txt
> <https://linkprotect.cudasvc.com/url?a=https%3a%2f%2fwww.ietf.org%2finternet-drafts%2fdraft-spiegel-ippm-ioam-rawexport-01.txt&c=E,1,XLWC6KoyMbYRdm3X_R7ua7ysLxLB6W9wYAGQdFAieG8olfziOwoyjJvxKA_lINQ94LWjiFPgKLNm1T8hXhl9GZHeZA-CebmtDSM4DN4qVhxqmaX-qA,,&typo=1>
> Status:
> https://datatracker.ietf.org/doc/draft-spiegel-ippm-ioam-rawexport/
> <https://linkprotect.cudasvc.com/url?a=https%3a%2f%2fdatatracker.ietf.org%2fdoc%2fdraft-spiegel-ippm-ioam-rawexport%2f&c=E,1,AjAhXJCCP2-K3r_bhlY6tWekEre6khI9dAEE7K0D9rShsu0J7QOAMtOuOBjm9DoT_yTGSejvrvahlkrFy2WyWQ6TGBHqzhuJMVdY74ggJv2R&typo=1>
> Htmlized:
> https://tools.ietf.org/html/draft-spiegel-ippm-ioam-rawexport-01
> <https://linkprotect.cudasvc.com/url?a=https%3a%2f%2ftools.ietf.org%2fhtml%2fdraft-spiegel-ippm-ioam-rawexport-01&c=E,1,Q41YF2RIE308dAfPAbMtG0U2iC6VhaVmo8D95QwB80mZtGjDyyQIJF6RIA57yu4JSn2QZNEM6yP7i7NAufko5gfDAEF0pBQLjp-CJRiCMZ4X&typo=1>
> Htmlized:
> https://datatracker.ietf.org/doc/html/draft-spiegel-ippm-ioam-rawexport
> <https://linkprotect.cudasvc.com/url?a=https%3a%2f%2fdatatracker.ietf.org%2fdoc%2fhtml%2fdraft-spiegel-ippm-ioam-rawexport&c=E,1,AGhegdwBIgVcn3diXJnlYadHXr_-fEdJbEOrmzeEtcr8gZvfkEak4Cqm6FZoozAk3SLSRTre-2caaktlZFZkfic8MC95H3L3YwYJAEZ9RUhnPCWmKuMYoFaOcMY,&typo=1>
> Diff:
> https://www.ietf.org/rfcdiff?url2=draft-spiegel-ippm-ioam-rawexport-01
> <https://linkprotect.cudasvc.com/url?a=https%3a%2f%2fwww.ietf.org%2frfcdiff%3furl2%3ddraft-spiegel-ippm-ioam-rawexport-01&c=E,1,yIvtYp0d95tIWppvmYtExQYiB17viuvUMeOarRVq3mLCFumZMdEa5FNSV-PrxHo60Cn5tgBo9J2pEFgXG6iCnsGiyUjEP9OP11rvDxXTERDyuD8X8kKSVpKm&typo=1>
>
> Abstract:
> until the htmlized version and diff are available at tools.ietf.org
> <https://linkprotect.cudasvc.com/url?a=http%3a%2f%2ftools.ietf.org&c=E,1,7SYpdkqDS7_x7bj-GITQVKdtWOkgNZ7ooqRju7NzGi99-CjcYTgrWr7CzMFQdsd3Pzg_NwNF4VHCyTHRMdFPllfvjKaP4QgrxGwCYHHW2xBPyih32YX2kgbp&typo=1>
> .
>
> The IETF Secretariat
>
> [email-masked]
> This email message and any attachments are confidential. If you are not
> the intended recipient, please immediately reply to the sender and delete
> the message from your email system. Thank you.
> [email-masked]
> [email-masked]