Subject: [ippm] FW: New Version Notification for draft-morton-ippm-capcity-metric-method-00.txt

From: "MORTON, ALFRED C (AL)" <[email-masked]>
Date: Sun, 14 Jul 2019 16:25:54 +0000

IPPM,

This new draft is a proposal for a metric and methods of
measurement for Maximum IP-layer Capacity, one of the many
possible metrics to characterize IP-layer performance.

We have a lightning 5-minutes on the IPPM agenda to discuss
this new draft, so the authors are providing this additional
background and welcome any comments on-list or side meetings 
we can arrange in Montreal to discuss.

Notes and Background:

This work will be a topic at a "measurements" table
at the Hackathon@105, and possibly presented later in the
week at MAPRG if time/other topics permit.

Liaisons received by IPPM provide additional info on testing
(with attachments containing test results in most cases):
https://datatracker.ietf.org/liaison/1645/
https://datatracker.ietf.org/liaison/1643/
https://datatracker.ietf.org/liaison/1634/
https://datatracker.ietf.org/liaison/1632/

Technical Committee ETSI STQ has approved ETSI TS 103 222-2 
"Part 2: Reference benchmarking and KPIs for High speed internet", 
containing the new material presently covered in clause 4.5, titled 
“IP/UDP Capacity“. The new clause contains a definition of 
Maximum IP Capacity that is equivalent to the definition 
proposed in the new draft. The TS text will be published shortly.

At ITU-T Study Group 12, Recommendation Y.1540, on
"IP packet transfer and availability performance parameters" 
(also containing an equivalent definition with requirements for methods 
of measurement) is proceeding through the (longer) approval process.

Thanks for considering this new proposal; it is one of the topics 
that IPPM was chartered over 20 years ago to complete.

Al, Rüdiger, and Len

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] 
Sent: Monday, July 8, 2019 12:43 PM
To: MORTON, ALFRED C (AL) <[email-masked]>; 
Subject: New Version Notification for draft-morton-ippm-capcity-metric-method-00.txt

A new version of I-D, draft-morton-ippm-capcity-metric-method-00.txt
has been successfully submitted by Al Morton and posted to the
IETF repository.

Name:		draft-morton-ippm-capcity-metric-method
Revision:	00
Title:		Metrics and Methods for IP Capacity
Document date:	2019-07-08
Group:		Individual Submission
Pages:		13
URL:            
https://tools.ietf.org/html/draft-morton-ippm-capcity-metric-method-00

Abstract:
   This memo revisits the problem of Network Capacity metrics first
   examined in RFC 5136.  The memo specifies a more practical Maximum
   IP-layer Capacity metric definition catering for measurement
   purposes, and outlines the corresponding methods of measurement.

---

From: "MORTON, ALFRED C (AL)" <[email-masked]>
Date: Tue, 23 Jul 2019 15:38:39 +0000

IPPM folks,

I'm willing to set-up one or more side meetings to discuss
this new draft and supporting material, including the most
recent testing and results from the Hackathon@105 [0].

Let me know if you can squeeze a few minutes for this in 
your busy week!

thanks,
Al

[0] https://github.com/IETF-Hackathon/ietf105-project-presentations/blob/master/105-acm-Hackathon-Measurements.pdf

> From: ippm [mailto:[email-masked]] On Behalf Of MORTON, ALFRED C
> (AL)
> Sent: Sunday, July 14, 2019 12:26 PM
> To: [email-masked]
> Cc: CIAVATTONE, LEN <[email-masked]>
> Subject: [ippm] FW: New Version Notification for draft-morton-ippm-
> capcity-metric-method-00.txt
> 
> 
> IPPM,
> 
> https://urldefense.proofpoint.com/v2/url?u=https-
> 3A__datatracker.ietf.org_liaison_1645_&d=DwIGaQ&c=LFYZ-
> o9_HUMeMTSQicvjIg&r=OfsSu8kTIltVyD1oL72cBw&m=IL8HkvaKvBB1lePcKTXpOgEWFU-
> b56ZFZsFV_SMnC_4&s=iHewHfAuU7oJMgGiiemtNsY5v2xhPZBaINvHGirKlZc&e=
> https://urldefense.proofpoint.com/v2/url?u=https-
> 3A__datatracker.ietf.org_liaison_1643_&d=DwIGaQ&c=LFYZ-
> o9_HUMeMTSQicvjIg&r=OfsSu8kTIltVyD1oL72cBw&m=IL8HkvaKvBB1lePcKTXpOgEWFU-
> b56ZFZsFV_SMnC_4&s=r-NJnMRfJcxNEbb0CtF6zE_YNfYXwSW6nYb6V6D3Hz4&e=
> https://urldefense.proofpoint.com/v2/url?u=https-
> 3A__datatracker.ietf.org_liaison_1634_&d=DwIGaQ&c=LFYZ-
> o9_HUMeMTSQicvjIg&r=OfsSu8kTIltVyD1oL72cBw&m=IL8HkvaKvBB1lePcKTXpOgEWFU-
> b56ZFZsFV_SMnC_4&s=OFl_Iqn1AhgTL4dkQjOp-MRS4-k33YHUrvRnPClsdaU&e=
> https://urldefense.proofpoint.com/v2/url?u=https-
> 3A__datatracker.ietf.org_liaison_1632_&d=DwIGaQ&c=LFYZ-
> o9_HUMeMTSQicvjIg&r=OfsSu8kTIltVyD1oL72cBw&m=IL8HkvaKvBB1lePcKTXpOgEWFU-
> b56ZFZsFV_SMnC_4&s=zrr92OnGzlO-nxGpIs0xfvIdcijhnqCkNf_dhTdcMC0&e=
> 
> https://urldefense.proofpoint.com/v2/url?u=https-
> 3A__tools.ietf.org_html_draft-2Dmorton-2Dippm-2Dcapcity-2Dmetric-2Dmethod-
> 2D00&d=DwIGaQ&c=LFYZ-
> o9_HUMeMTSQicvjIg&r=OfsSu8kTIltVyD1oL72cBw&m=IL8HkvaKvBB1lePcKTXpOgEWFU-
> b56ZFZsFV_SMnC_4&s=Kd6ckx4rIYt0nqpwi6gUSfasPgYZSn3sJVnqHF7phQg&e=
> 
> Abstract:
> _______________________________________________
> ippm mailing list
> [email-masked]
> https://urldefense.proofpoint.com/v2/url?u=https-
> 3A__www.ietf.org_mailman_listinfo_ippm&d=DwIGaQ&c=LFYZ-
> o9_HUMeMTSQicvjIg&r=OfsSu8kTIltVyD1oL72cBw&m=IL8HkvaKvBB1lePcKTXpOgEWFU-
> b56ZFZsFV_SMnC_4&s=uos7uP-jGxP5FZHY-azjA6Ip7zHpszskfXNMiZDO020&e=

---

From: "Ackermann, Michael" <[email-masked]>
Date: Tue, 23 Jul 2019 16:24:35 +0000

Thank you Al

I did read this draft and thought it was extremely well done and very informative.  

Please let me know if/when any related side meetings are set up and I will make every effort to attend!

Thanks again

Mike

-----Original Message-----
From: ippm <[email-masked]> On Behalf Of MORTON, ALFRED C (AL)
Sent: Tuesday, July 23, 2019 11:39 AM
To: [email-masked]
Cc: CIAVATTONE, LEN <[email-masked]>
Subject: Re: [ippm] New Version Notification for draft-morton-ippm-capcity-metric-method-00.txt

 ALERT This email was sent from a source external to BCBSM/BCN.
 DO NOT CLICK links or attachments unless you recognize the sender and trust the content.

IPPM folks,

I'm willing to set-up one or more side meetings to discuss this new draft and supporting material, including the most recent testing and results from the Hackathon@105 [0].

Let me know if you can squeeze a few minutes for this in your busy week!

thanks,
Al

> This new draft is a proposal for a metric and methods of measurement 
> for Maximum IP-layer Capacity, one of the many possible metrics to 
> characterize IP-layer performance.
>
> We have a lightning 5-minutes on the IPPM agenda to discuss this new 
> draft, so the authors are providing this additional background and 
> welcome any comments on-list or side meetings we can arrange in 
> Montreal to discuss.
>
> Notes and Background:
>
> This work will be a topic at a "measurements" table at the 
> Hackathon@105, and possibly presented later in the week at MAPRG if 
> time/other topics permit.
>
> Liaisons received by IPPM provide additional info on testing (with 
> attachments containing test results in most cases):
> o9_HUMeMTSQicvjIg&r=OfsSu8kTIltVyD1oL72cBw&m=IL8HkvaKvBB1lePcKTXpOgEWF
> U- b56ZFZsFV_SMnC_4&s=iHewHfAuU7oJMgGiiemtNsY5v2xhPZBaINvHGirKlZc&e=
> o9_HUMeMTSQicvjIg&r=OfsSu8kTIltVyD1oL72cBw&m=IL8HkvaKvBB1lePcKTXpOgEWF
> U- b56ZFZsFV_SMnC_4&s=r-NJnMRfJcxNEbb0CtF6zE_YNfYXwSW6nYb6V6D3Hz4&e=
> o9_HUMeMTSQicvjIg&r=OfsSu8kTIltVyD1oL72cBw&m=IL8HkvaKvBB1lePcKTXpOgEWF
> U- b56ZFZsFV_SMnC_4&s=OFl_Iqn1AhgTL4dkQjOp-MRS4-k33YHUrvRnPClsdaU&e=
> o9_HUMeMTSQicvjIg&r=OfsSu8kTIltVyD1oL72cBw&m=IL8HkvaKvBB1lePcKTXpOgEWF
> U- b56ZFZsFV_SMnC_4&s=zrr92OnGzlO-nxGpIs0xfvIdcijhnqCkNf_dhTdcMC0&e=
>
> Technical Committee ETSI STQ has approved ETSI TS 103 222-2 "Part 2: 
> Reference benchmarking and KPIs for High speed internet", containing 
> the new material presently covered in clause 4.5, titled “IP/UDP 
> Capacity“. The new clause contains a definition of Maximum IP Capacity 
> that is equivalent to the definition proposed in the new draft. The TS 
> text will be published shortly.
>
> At ITU-T Study Group 12, Recommendation Y.1540, on "IP packet transfer 
> and availability performance parameters"
> (also containing an equivalent definition with requirements for 
> methods of measurement) is proceeding through the (longer) approval process.
>
> Thanks for considering this new proposal; it is one of the topics that 
> IPPM was chartered over 20 years ago to complete.
>
> Al, Rüdiger, and Len
>
>
> Subject: New Version Notification for 
> draft-morton-ippm-capcity-metric- method-00.txt
>
>
> has been successfully submitted by Al Morton and posted to the IETF 
> repository.
>
> o9_HUMeMTSQicvjIg&r=OfsSu8kTIltVyD1oL72cBw&m=IL8HkvaKvBB1lePcKTXpOgEWF
> U- b56ZFZsFV_SMnC_4&s=Kd6ckx4rIYt0nqpwi6gUSfasPgYZSn3sJVnqHF7phQg&e=
>
> Abstract:
> o9_HUMeMTSQicvjIg&r=OfsSu8kTIltVyD1oL72cBw&m=IL8HkvaKvBB1lePcKTXpOgEWF
> U- b56ZFZsFV_SMnC_4&s=uos7uP-jGxP5FZHY-azjA6Ip7zHpszskfXNMiZDO020&e=
_______________________________________________
ippm mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/ippm

The information contained in this communication is highly confidential and is intended solely for the use of the individual(s) to whom this communication is directed. If you are not the intended recipient, you are hereby notified that any viewing, copying, disclosure or distribution of this information is prohibited. Please notify the sender, by electronic mail or telephone, of any unintended receipt and delete the original message without making any copies.
 
 Blue Cross Blue Shield of Michigan and Blue Care Network of Michigan are nonprofit corporations and independent licensees of the Blue Cross and Blue Shield Association.

---

From: "MORTON, ALFRED C (AL)" <[email-masked]>
Date: Wed, 24 Jul 2019 14:37:19 +0000

Thanks Mike and others who have indicated interest!

We'll meet on Thursday 1200 Lunch, 
at the Foyer in front of IETF Registration.

We grab something quick to eat,
and sit down to look at the background as necessary,
the draft, and a short Liaison reply to the "Harmonization" thread.

All are welcome, just show-up.
Al

PS: If you can't make this time, please contact me
to schedule an alternative opportunity.

> From: ippm [mailto:[email-masked]] On Behalf Of Ackermann, Michael
> Sent: Tuesday, July 23, 2019 12:25 PM
> To: MORTON, ALFRED C (AL) <[email-masked]>; [email-masked]
> I'm willing to set-up one or more side meetings to discuss this new draft
> and supporting material, including the most recent testing and results
> from the Hackathon@105 [0].
> 
> [0] https://urldefense.proofpoint.com/v2/url?u=https-3A__github.com_IETF-
> 2DHackathon_ietf105-2Dproject-2Dpresentations_blob_master_105-2Dacm-
> 2DHackathon-2DMeasurements.pdf&d=DwIGaQ&c=LFYZ-
> o9_HUMeMTSQicvjIg&r=OfsSu8kTIltVyD1oL72cBw&m=OWFIYwbnYUHx6EBa9258gGQmcVe5C
> YmKOu9Nvo8SHvU&s=9SWMfuct0UpMjBoHDjbWLthFSM1i3Tm1OpEgwYqEaRE&e=
> 
> 
> o9_HUMeMTSQicvjIg&r=OfsSu8kTIltVyD1oL72cBw&m=OWFIYwbnYUHx6EBa9258gGQmcVe5C
> YmKOu9Nvo8SHvU&s=J3GuOQ7UeJpe3NuaidU-fdcyEd0E7oeOzpMoe9KKEO8&e=
> 
> 
> The information contained in this communication is highly confidential and
> is intended solely for the use of the individual(s) to whom this
> communication is directed. If you are not the intended recipient, you are
> hereby notified that any viewing, copying, disclosure or distribution of
> this information is prohibited. Please notify the sender, by electronic
> mail or telephone, of any unintended receipt and delete the original
> message without making any copies.
> 
>  Blue Cross Blue Shield of Michigan and Blue Care Network of Michigan are
> nonprofit corporations and independent licensees of the Blue Cross and
> Blue Shield Association.
> o9_HUMeMTSQicvjIg&r=OfsSu8kTIltVyD1oL72cBw&m=OWFIYwbnYUHx6EBa9258gGQmcVe5C
> YmKOu9Nvo8SHvU&s=J3GuOQ7UeJpe3NuaidU-fdcyEd0E7oeOzpMoe9KKEO8&e=

---

From: J Ignacio Alvarez-Hamelin <[email-masked]>
Date: Wed, 24 Jul 2019 12:15:17 -0300

Hi Al., 

Unfortunately I am not there… but still this subject is very interesting for me. I see that the measurements methods are based on link saturation, is still some room to add another possibility without saturation? 

Many thanks an get a good time in Montreal!

	Ignacio

_______________________________________________________________

Dr. Ing. José Ignacio Alvarez-Hamelin
CONICET and Facultad de Ingeniería, Universidad de Buenos Aires
Av. Paseo Colón 850 - C1063ACV - Buenos Aires - Argentina
+54 (11) 5285 0716 / 5285 0705
e-mail: [email-masked]
web: http://cnet.fi.uba.ar/ignacio.alvarez-hamelin/
_______________________________________________________________

> On 24 Jul 2019, at 11:37, MORTON, ALFRED C (AL) <[email-masked]> wrote:
>

---

From: "MORTON, ALFRED C (AL)" <[email-masked]>
Date: Wed, 24 Jul 2019 15:28:06 +0000

Hi Ignacio,

Thanks for your interest - I think that there have
been many methods and different metrics tried and
tested. There's certainly room for more investigation
*as a parallel effort*.  The authors would prefer not
to expand this draft's coverage, unless another 
metric and method has been evaluated as extensively.

Tight scope is the key to more prompt delivery,
feel free to suggest how we can add limits to 
this scope and leave room for non-saturation methods
for IP-Capacity (not yet revealed).

see you soon on Meetecho,
Al

> From: J Ignacio Alvarez-Hamelin [mailto:[email-masked]]
> Sent: Wednesday, July 24, 2019 11:15 AM
> To: MORTON, ALFRED C (AL) <[email-masked]>
> Cc: Ackermann, Michael <[email-masked]>; [email-masked]; CIAVATTONE,
> LEN <[email-masked]>
> Unfortunately I am not there… but still this subject is very interesting
> for me. I see that the measurements methods are based on link saturation,
> is still some room to add another possibility without saturation?
> 
> web: https://urldefense.proofpoint.com/v2/url?u=http-
> 3A__cnet.fi.uba.ar_ignacio.alvarez-2Dhamelin_&d=DwIFaQ&c=LFYZ-
> o9_HUMeMTSQicvjIg&r=_6cen3Hn-e_hOm0BhY7aIpA58dd19Z9qGQsr8-
> 6zYMI&m=OprUpJKiIhcirgI04g0ZVVpKUXWtCK_-
> QKM_wv3SJGI&s=QSG7scjGmgLXuUmjZJLlpP0YMvvMPUyj788L8lS1wQg&e=
> >> Please let me know if/when any related side meetings are set up and I
> will
> >> make every effort to attend!
> >>
> >> Thanks again
> >>
> >> Mike
> >>
> >>
> 3A__www.ietf.org_mailman_listinfo_ippm&d=DwIFaQ&c=LFYZ-
> o9_HUMeMTSQicvjIg&r=_6cen3Hn-e_hOm0BhY7aIpA58dd19Z9qGQsr8-
> 6zYMI&m=OprUpJKiIhcirgI04g0ZVVpKUXWtCK_-
> QKM_wv3SJGI&s=LcM0qPrFdQLJOVVnhkCWERj8fJD_e4YiKd7E5S-0huU&e=

---

From: J Ignacio Alvarez-Hamelin <[email-masked]>
Date: Wed, 24 Jul 2019 15:09:26 -0300

Thats o.k., I will provide some ideas about that. Thanks!

> On 24 Jul 2019, at 12:28, MORTON, ALFRED C (AL) <[email-masked]> wrote:
> 
> Hi Ignacio,
>