Subject: [ippm] Regarding draft-mizrahi-ippm-ioam-flags

From: Greg Mirsky <[email-masked]>
Date: Thu, 25 Jul 2019 13:15:52 -0400

Dear Chairs, et al.,
I appreciate that editors of draft-ietf-ippm-ioam-data followed on the
decision of the WG reached at the meeting in Prague to extract material not
directly related to the definition of iOAM data elements from the document.
The new draft was presented earlier this week and generated many comments.
I feel that it would be right to discuss the draft and its relevance to the
charter of the IPPM WG before starting WG adoption poll.

Regards,
Greg

---

From: "Brian Trammell (IETF)" <[email-masked]>
Date: Thu, 25 Jul 2019 14:07:18 -0400

hi Greg,

Thanks for the feedback; absolutely, we can do this the normal way. Authors: let's do a normal two-week adoption call for this document before publishing the update.

This adoption call starts now.

IPPM, please respond to this message with an indication to the mailing list of your support for adopting draft-mizrahi-ippm-ioam-flags as a working group document, in partial fulfillment of our charter milestone "submit a Standards Track draft on inband OAM based measurement methodologies to the IESG" (obviously, depending on how many documents we end up sending to the IESG, we may have to change the plurality of this milestone). If you do not support this, please send a message to the list explaining why.

Thanks, cheers,

Brian (as IPPM co-chair)

> On 25 Jul 2019, at 13:15, Greg Mirsky <[email-masked]> wrote:
> 
> Dear Chairs, et al.,
> I appreciate that editors of draft-ietf-ippm-ioam-data followed on the decision of the WG reached at the meeting in Prague to extract material not directly related to the definition of iOAM data elements from the document. The new draft was presented earlier this week and generated many comments. I feel that it would be right to discuss the draft and its relevance to the charter of the IPPM WG before starting WG adoption poll.
> 
> Regards,
> Greg

---

From: "Frank Brockners (fbrockne)" <[email-masked]>
Date: Thu, 25 Jul 2019 18:45:13 +0000

Support (as co-author).

Frank

> -----Original Message-----
> From: ippm <[email-masked]> On Behalf Of Brian Trammell (IETF)
> Sent: Donnerstag, 25. Juli 2019 14:07
> To: Greg Mirsky <[email-masked]>
> Cc: IPPM Chairs <[email-masked]>; IETF IPPM WG <[email-masked]>
> Subject: [ippm] Adoption call for draft-mizrahi-ippm-ioam-flags Re: Regarding
> draft-mizrahi-ippm-ioam-flags
> 
> hi Greg,
> 
> Thanks for the feedback; absolutely, we can do this the normal way. Authors:
> let's do a normal two-week adoption call for this document before publishing
> the update.
> 
> IPPM, please respond to this message with an indication to the mailing list of
> your support for adopting draft-mizrahi-ippm-ioam-flags as a working group
> document, in partial fulfillment of our charter milestone "submit a Standards
> Track draft on inband OAM based measurement methodologies to the IESG"
> (obviously, depending on how many documents we end up sending to the IESG,
> we may have to change the plurality of this milestone). If you do not support
> this, please send a message to the list explaining why.
> 
> Thanks, cheers,
> 
> Brian (as IPPM co-chair)
> 
> 
> > I appreciate that editors of draft-ietf-ippm-ioam-data followed on the decision
> of the WG reached at the meeting in Prague to extract material not directly
> related to the definition of iOAM data elements from the document. The new
> draft was presented earlier this week and generated many comments. I feel that
> it would be right to discuss the draft and its relevance to the charter of the IPPM
> WG before starting WG adoption poll.
> >
> > Regards,
> > Greg
> 
> _______________________________________________
> ippm mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/ippm

---

From: Jai Kumar <[email-masked]>
Date: Thu, 25 Jul 2019 13:09:16 -0700

Hello Chairs,

What is the procedure for requesting edits.

Can it happen after the adoption call or requests need to be made before.

-Jai

On 7/25/19, 11:07 AM, "ippm on behalf of Brian Trammell (IETF)" <[email-masked] on behalf of [email-masked]> wrote:

    hi Greg,

    
    
    Thanks, cheers,
    
    Brian (as IPPM co-chair)

---

From: Tommy Pauly <[email-masked]>
Date: Fri, 26 Jul 2019 10:11:37 -0400

Any document adopted by the working group can and will receive edits from the group as a whole. Feel free to send reviews now, but the primary question at hand here is if IPPM as a group believes that the mechanism that this document aims to add is something the group should work on, and that this document is a good starting place for the work.

Thanks!
Tommy

> On Jul 25, 2019, at 4:09 PM, Jai Kumar <[email-masked]> wrote:
> 
> Hello Chairs,
>

---

From: Barak Gafni <[email-masked]>
Date: Fri, 26 Jul 2019 14:17:20 +0000

Support (as co-author)

Thanks,
Barak

-----Original Message-----
From: ippm <[email-masked]> On Behalf Of Frank Brockners (fbrockne)
Sent: Thursday, July 25, 2019 2:45 PM
To: Brian Trammell (IETF) <[email-masked]>; Greg Mirsky <[email-masked]>
Cc: IPPM Chairs <[email-masked]>; IETF IPPM WG <[email-masked]>
Subject: Re: [ippm] Adoption call for draft-mizrahi-ippm-ioam-flags Re: Regarding draft-mizrahi-ippm-ioam-flags

Support (as co-author).

Frank

> Subject: [ippm] Adoption call for draft-mizrahi-ippm-ioam-flags Re: 
> Regarding draft-mizrahi-ippm-ioam-flags
> 
> hi Greg,
> 
> let's do a normal two-week adoption call for this document before 
> publishing the update.
> 
> IPPM, please respond to this message with an indication to the mailing 
> list of your support for adopting draft-mizrahi-ippm-ioam-flags as a 
> working group document, in partial fulfillment of our charter 
> milestone "submit a Standards Track draft on inband OAM based measurement methodologies to the IESG"
> (obviously, depending on how many documents we end up sending to the 
> IESG, we may have to change the plurality of this milestone). If you 
> do not support this, please send a message to the list explaining why.
> 
> Thanks, cheers,
> 
> Brian (as IPPM co-chair)
> 
> 
> of the WG reached at the meeting in Prague to extract material not 
> directly related to the definition of iOAM data elements from the 
> document. The new draft was presented earlier this week and generated 
> many comments. I feel that it would be right to discuss the draft and 
> its relevance to the charter of the IPPM WG before starting WG adoption poll.
> >
> > Regards,
> > Greg
> 
> https://eur03.safelinks.protection.outlook.com/?url=https%3A%2F%2Fwww.
> ietf.org%2Fmailman%2Flistinfo%2Fippm&amp;data=02%7C01%7Cgbarak%40mella
> nox.com%7Ce9e9ff4937cf4eb44b2e08d711304c20%7Ca652971c7d2e4d9ba6a4d1492
> 56f461b%7C0%7C0%7C636996771443958186&amp;sdata=BSaO76OoQZ7zW9Ltu5X4gB0
> QSdVTspF9wxtLwO8gd2w%3D&amp;reserved=0

_______________________________________________
ippm mailing list
[email-masked]
https://eur03.safelinks.protection.outlook.com/?url=https%3A%2F%2Fwww.ietf.org%2Fmailman%2Flistinfo%2Fippm&amp;data=02%7C01%7Cgbarak%40mellanox.com%7Ce9e9ff4937cf4eb44b2e08d711304c20%7Ca652971c7d2e4d9ba6a4d149256f461b%7C0%7C0%7C636996771443958186&amp;sdata=BSaO76OoQZ7zW9Ltu5X4gB0QSdVTspF9wxtLwO8gd2w%3D&amp;reserved=0

---

From: Jai Kumar <[email-masked]>
Date: Fri, 26 Jul 2019 08:08:07 -0700

Thanks Tommy.

Support [as a reviewer]

> On Jul 26, 2019, at 7:11 AM, Tommy Pauly <[email-masked]> wrote:
>

---

From: John Lemon <[email-masked]>
Date: Fri, 26 Jul 2019 08:20:35 -0700

I support WG adoption of draft-mizrahi-ippm-ioam-flags.

John (co-author)

On Thu, Jul 25, 2019 at 11:07 AM Brian Trammell (IETF) <[email-masked]>
wrote:

> hi Greg,
>
> Thanks for the feedback; absolutely, we can do this the normal way.
> Authors: let's do a normal two-week adoption call for this document before
> publishing the update.
>
> working group document, in partial fulfillment of our charter milestone
> "submit a Standards Track draft on inband OAM based measurement
> methodologies to the IESG" (obviously, depending on how many documents we
> end up sending to the IESG, we may have to change the plurality of this
> milestone). If you do not support this, please send a message to the list
> explaining why.
>
> Thanks, cheers,
>
> Brian (as IPPM co-chair)
>
>

---

From: "Carlos Pignataro (cpignata)" <[email-masked]>
Date: Mon, 29 Jul 2019 04:09:33 +0000

Hi, Brian,

I support adoption of draft-mizrahi-ippm-ioam-flags. This is an important set of definition of flags for real uses based on experience. It fulfills part of the charter milestone below complementing the base ioam-data, realizing specific use cases, as an offspring document from ioam-data.

I’m a co-author.

Thanks,

Carlos.

> On Jul 25, 2019, at 2:07 PM, Brian Trammell (IETF) <[email-masked]> wrote:
> 
> hi Greg,
>

---

From: Tianran Zhou <[email-masked]>
Date: Wed, 31 Jul 2019 02:57:28 +0000

I support wg adoption of draft-mizrahi-ippm-ioam-flags.

Cheers,
Tianran

> From: ippm [mailto:[email-masked]] On Behalf Of Carlos Pignataro
> (cpignata)
> Sent: Monday, July 29, 2019 12:10 PM
> To: Brian Trammell (IETF) <[email-masked]>
> I support adoption of draft-mizrahi-ippm-ioam-flags. This is an important
> set of definition of flags for real uses based on experience. It fulfills
> part of the charter milestone below complementing the base ioam-data,
> realizing specific use cases, as an offspring document from ioam-data.
> 
> I’m a co-author.
> 
> Thanks,
> 
> Carlos.
> 
> > IPPM, please respond to this message with an indication to the mailing list
> of your support for adopting draft-mizrahi-ippm-ioam-flags as a working group

---

From: Parviz Yegani <[email-masked]>
Date: Tue, 30 Jul 2019 20:22:43 -0700

I support adoption of draft-mizrahi-ippm-ioam-flags.

Thanks,
Parviz

On Tue, Jul 30, 2019 at 7:57 PM Tianran Zhou <[email-masked]> wrote:

> Authors:
> publishing
> list
> IESG,
> document.

-- 

-------------
Dr. Parviz Yegani
(408) 759-1973 mobile
[email-masked]

---

From: Giuseppe Fioccola <[email-masked]>
Date: Wed, 31 Jul 2019 13:42:37 +0000

Yes, I support WG adoption.
Best Regards,

Giuseppe

-----Original Message-----
From: ippm [mailto:[email-masked]] On Behalf Of Brian Trammell (IETF)
Sent: Thursday, July 25, 2019 8:07 PM
To: Greg Mirsky <[email-masked]>
Cc: IPPM Chairs <[email-masked]>; IETF IPPM WG <[email-masked]>
Subject: [ippm] Adoption call for draft-mizrahi-ippm-ioam-flags Re: Regarding draft-mizrahi-ippm-ioam-flags

hi Greg,

Thanks, cheers,

Brian (as IPPM co-chair)

---

From: Greg Mirsky <[email-masked]>
Date: Wed, 31 Jul 2019 14:53:36 -0400

Dear Authors,
thank you for bringing this proposal for the discussion. When considering
WG AP, I use the following criteria:

   - is the document reasonably well-written;
   - does it addresses a practical problem;
   - is the proposed solution viable?

On the first point, I commend you - the draft is easy to read.
On the second point, I have several questions:

   - What is the benefit of using Loopback flag in the Trace mode?
   - Why is it important to limit the applicability of Loopback to only
   Trace mode?
   - What is the benefit of collecting the same, as I understand the
   description, data on the return path to the source?
   - What is the benefit of using Active flag comparing to existing active
   OAM protocols?
   - What is the benefit of using Immediate flag comparing to Postcard-Based
   Telemetry
   <https://tools.ietf.org/html/draft-song-ippm-postcard-based-telemetry-04>
   (PBT) proposal?

On the third point, I'd appreciate your clarification on these points:

   - In which transports (I find that iOAM encapsulation has been proposed
   for all known transports) you've envisioned to use Loopback flag?
   - The third bullet in Section 5 refers to a replica of the data packet
   that follows the same path as the original packet. What controls that
   replication?
   - The last paragraph in the Security Consideration section relies on
   "restricted administrative domain" to mitigate the threat of malicious
   attacks using a combination of iOAM extensions. That might be the case when
   operating in a PNF environment, but it is much more challenging to maintain
   such a trusted domain in VNF environment. How can these new security risks
   be mitigated in a VNF environment?

Appreciate your consideration and clarifications to my questions.

Regards,
Greg

---

From: Tom Herbert <[email-masked]>
Date: Wed, 31 Jul 2019 15:40:30 -0700

On Wed, Jul 31, 2019 at 11:53 AM Greg Mirsky <[email-masked]> wrote:
>
> Dear Authors,
> thank you for bringing this proposal for the discussion. When considering WG AP, I use the following criteria:
>
> is the document reasonably well-written;
> does it addresses a practical problem;
> is the proposed solution viable?
>
> What is the benefit of using Loopback flag in the Trace mode?

This is unclear to me also. Additionally, I am concerned that protocol
blindly reflects the packet back to the source without any regard to
what else the packet contains. For instance, if a TCP packet is
reflected by ten intermediate nodes this is nonsensical. The
possibility of an amplification attack is obvious and in fact
mentioned in the security section, however I'm skeptical that the
proposed mitigation of rate limiting is sufficient.

Minimally, it seems like the reflected packets should be wrapped in
ICMP to mitigate spoofing attacks. Also, I wonder if traceroute
methodology could be used for tracing, i.e. one sent packet results in
at most one return packet (ICMP), to mitigate the amplification
problem.

Tom

> Why is it important to limit the applicability of Loopback to only Trace mode?
> What is the benefit of collecting the same, as I understand the description, data on the return path to the source?
> What is the benefit of using Active flag comparing to existing active OAM protocols?
> What is the benefit of using Immediate flag comparing to Postcard-Based Telemetry (PBT) proposal?
>
> In which transports (I find that iOAM encapsulation has been proposed for all known transports) you've envisioned to use Loopback flag?
> The third bullet in Section 5 refers to a replica of the data packet that follows the same path as the original packet. What controls that replication?
> The last paragraph in the Security Consideration section relies on "restricted administrative domain" to mitigate the threat of malicious attacks using a combination of iOAM extensions. That might be the case when operating in a PNF environment, but it is much more challenging to maintain such a trusted domain in VNF environment. How can these new security risks be mitigated in a VNF environment?
>
> On Thu, Jul 25, 2019 at 2:07 PM Brian Trammell (IETF) <[email-masked]> wrote:
>>
>> hi Greg,
>>