Subject: [ippm] Side Meeting: IOAM Immediate Export Draft

From: Tal Mizrahi <[email-masked]>
Date: Wed, 24 Jul 2019 23:23:50 +0300

Hi,

Time: Friday, 8:30-9:45.
Room: Coller
https://trac.ietf.org/trac/ietf/meeting/wiki/105sidemeetings

Details:
We are going to hold a side meeting on Friday morning to discuss the
outline of the new draft that will describe the immediate export IOAM
option.

The meeting is open to all, and specifically intended for authors and
contributors of the related IOAM drafts.

Minutes will be sent to the list after the meeting.

Cheers,
Tal.

---

From: "Ramesh Sivakolundu (sramesh)" <[email-masked]>
Date: Wed, 24 Jul 2019 20:26:32 +0000

Any way to get a Webex  for this meeting. I can set up the Webex, if you can call in from the conference room.

-Ramesh

From: ippm <[email-masked]<mailto:[email-masked]>> on behalf of Tal Mizrahi <[email-masked]<mailto:[email-masked]>>
Date: Wednesday, July 24, 2019 at 4:23 PM
To: IETF IPPM WG <[email-masked]<mailto:[email-masked]>>
Cc: IPPM Chairs <[email-masked]<mailto:[email-masked]>>
Subject: [ippm] Side Meeting: IOAM Immediate Export Draft

Hi,

Time: Friday, 8:30-9:45.
Room: Coller

Details:
We are going to hold a side meeting on Friday morning to discuss the outline of the new draft that will describe the immediate export IOAM option.

The meeting is open to all, and specifically intended for authors and contributors of the related IOAM drafts.

Cheers,
Tal.

---

From: Tal Mizrahi <[email-masked]>
Date: Thu, 25 Jul 2019 14:18:07 +0300

Hi Ramesh,

If you can set up a Webex meeting that would be great.
We will try to set it up, depending on the equipment in the room.

Cheers,
Tal.

On Wed, Jul 24, 2019 at 11:27 PM Ramesh Sivakolundu (sramesh) <
[email-masked]> wrote:

> From: ippm <[email-masked]> on behalf of Tal Mizrahi <
> [email-masked]>
> To: IETF IPPM WG <[email-masked]>
> Cc: IPPM Chairs <[email-masked]>

---

From: Tal Mizrahi <[email-masked]>
Date: Fri, 26 Jul 2019 15:28:54 +0300

We are meeting in Notre Dame.

Apologies for the late change, but the previous room was double booked.

Cheers,
Tal.

---

From: Jai Kumar <[email-masked]>
Date: Fri, 26 Jul 2019 08:05:11 -0700

Tal,

Sorry, have to miss this meeting as I am back in San Jose and it was way too early in the morning for me.

Please send the meeting minutes and I will provide my comments there.

-Jai

> On Jul 26, 2019, at 5:28 AM, Tal Mizrahi <[email-masked]> wrote:
> 
>> On Wed, Jul 24, 2019 at 11:23 PM Tal Mizrahi <[email-masked]> wrote:
>> Hi,
>> 
>> Time: Friday, 8:30-9:45.
>> Room: Coller
> _______________________________________________
> ippm mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/ippm

---

From: Barak Gafni <[email-masked]>
Date: Fri, 26 Jul 2019 15:49:54 +0000

Hi,

Please find below side meeting notes: Friday 26th July 8:30 am Notredam

Summary:

  *   Group suggestion: for 00 draft we should define the new IOAM option and keep single flag which tells “immediate export”. Additional capabilities will be discussed towards 01 and beyond
  *   The group is asking the chairs to approve the need for a public IETF mailing list for a “design” team and a public webex to allow the group to progress on a weekly or bi-weekly cadence

More details:

  *   The option is added / removed by the encap/decap nodes, read by the intermediate nodes

  *   Tianran presented option defined a modified form from draft-song-ippm-postcard-based-telemetry-04:

       0             0 0             1 1             2 2             3
       0             7 8             5 6             3 4             1
      +-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+
      |        Namespace ID           | Flags | action|  Hop Count    |
      +-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+
      |         IOAM-Trace-Type                       |  Reserved     |
      +-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+
      |                         Flow ID (optional)                    |
      +-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+
      |                     Sequence Number  (Optional)               |
      +-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+

Below comments came from discussion of the above and the content of immediate export to answer:

  1.  What to export
  2.  Where to export
  3.  When to export

  *   Discussed potential fields in the option header, beyond 00 draft:
     *   Discussed the option to add “actions”, although may change the name
     *   The original flags from the flags draft may be reconsidered
        *   Overflow may become redundant
        *   Active is still relevant
        *   Loopback should be considered
        *   Immediate export – whether it is implicit or should be explicit
     *   IOAM trace type should stay as is to help collector and trace implementation to maintain consistent node data parsing.
     *   Consider whether to have the sequence number and flow id. The interpretation is through the higher layer length. Will be included as optional at the 00 draft
        *   Sequence number – suggestion is to use the e2e sequence number
        *   Anyway, agreement is that the sequence number and the flow id go as a pair.
     *   Flags should reside in a similar place as at the ioam tracing options
  *   Suggest to use the raw export draft to export the data
     *   Need to follow up on the raw export
     *   Need to clarify the behavior, so the node 0 will follow the captured immediate export option
  *   Suggest not to add hop count at this stage, as it adds more complexity to the processing, in addition for example to reducing TTL
  *   As for the suggestion on the “actions” presented in the meeting
     *   Two types – actions need to get executed by the node vs conditions for any execution
        *   Conditions – there are too many, discussion inclined towards not using specific condition. Going forward the group intend to consider export on exception/alarm without defining what exception/alarm are
        *   Log – needs further discussion. We believe we shouldn’t define what is the protocol and where should the logging reside. The indication to export is what we are using. Need further discussion on export to some preconfigured collector, export to the source of the packet or record the data locally.
  *   Side note regarding rawexport – consider export reason – how and if is it related to the IOAM protocol. Should consider remove it from rawexport?
  *   Tal Mizrahi volunteered to write and publish the 00 draft in collaboration with people who join the design team.

Thanks,
Barak

From: ippm <[email-masked]> On Behalf Of Tal Mizrahi
Sent: Wednesday, July 24, 2019 4:24 PM
To: IETF IPPM WG <[email-masked]>
Cc: IPPM Chairs <[email-masked]>
Subject: [ippm] Side Meeting: IOAM Immediate Export Draft

Hi,

Time: Friday, 8:30-9:45.
Room: Coller
https://trac.ietf.org/trac/ietf/meeting/wiki/105sidemeetings<https://eur03.safelinks.protection.outlook.com/?url=https%3A%2F%2Ftrac.ietf.org%2Ftrac%2Fietf%2Fmeeting%2Fwiki%2F105sidemeetings&data=02%7C01%7Cgbarak%40mellanox.com%7C7b0e46c15e5f4cd01d5e08d71074e672%7Ca652971c7d2e4d9ba6a4d149256f461b%7C0%7C0%7C636995966577906606&sdata=7Qgkw9dlo2wEANwsxk%2B4ndyu%2BYag3OUKRZa0yHm5shQ%3D&reserved=0>

Details:

Cheers,
Tal.

---

From: Jai Kumar <[email-masked]>
Date: Wed, 31 Jul 2019 17:02:06 -0700

Barak,

Please include John, Surendra and myself from Broadcom in the design team.

We will shortly get back to you with some thoughts on 00 draft.

If the alias is active, we can send it there. Let us know.

-Jai

From: ippm <[email-masked]> on behalf of Barak Gafni <[email-masked]>
Date: Friday, July 26, 2019 at 8:50 AM
To: Tal Mizrahi <[email-masked]>, IETF IPPM WG <[email-masked]>
Cc: IPPM Chairs <[email-masked]>
Subject: Re: [ippm] Side Meeting: IOAM Immediate Export Draft

Hi,

Summary:
Group suggestion: for 00 draft we should define the new IOAM option and keep single flag which tells “immediate export”. Additional capabilities will be discussed towards 01 and beyond
The group is asking the chairs to approve the need for a public IETF mailing list for a “design” team and a public webex to allow the group to progress on a weekly or bi-weekly cadence

More details:
The option is added / removed by the encap/decap nodes, read by the intermediate nodes
Tianran presented option defined a modified form from draft-song-ippm-postcard-based-telemetry-04:

      0             0 0             1 1             2 2             3

       0             7 8             5 6             3 4             1

      |                         Flow ID (optional)                    |

What to export
Where to export
When to export
 
Discussed potential fields in the option header, beyond 00 draft:
Discussed the option to add “actions”, although may change the name
The original flags from the flags draft may be reconsidered
Overflow may become redundant
Active is still relevant 
Loopback should be considered
Immediate export – whether it is implicit or should be explicit
IOAM trace type should stay as is to help collector and trace implementation to maintain consistent node data parsing.
Consider whether to have the sequence number and flow id. The interpretation is through the higher layer length. Will be included as optional at the 00 draft
Sequence number – suggestion is to use the e2e sequence number
Anyway, agreement is that the sequence number and the flow id go as a pair.
Flags should reside in a similar place as at the ioam tracing options
Suggest to use the raw export draft to export the data
Need to follow up on the raw export
Need to clarify the behavior, so the node 0 will follow the captured immediate export option
Suggest not to add hop count at this stage, as it adds more complexity to the processing, in addition for example to reducing TTL
As for the suggestion on the “actions” presented in the meeting
Two types – actions need to get executed by the node vs conditions for any execution
Conditions – there are too many, discussion inclined towards not using specific condition. Going forward the group intend to consider export on exception/alarm without defining what exception/alarm are
Log – needs further discussion. We believe we shouldn’t define what is the protocol and where should the logging reside. The indication to export is what we are using. Need further discussion on export to some preconfigured collector, export to the source of the packet or record the data locally.
Side note regarding rawexport – consider export reason – how and if is it related to the IOAM protocol. Should consider remove it from rawexport?
Tal Mizrahi volunteered to write and publish the 00 draft in collaboration with people who join the design team.

Thanks,

Barak

Hi,

Time: Friday, 8:30-9:45.

Room: Coller

Details:

Cheers,

Tal.

 

_______________________________________________ ippm mailing list [email-masked] https://www.ietf.org/mailman/listinfo/ippm

---

From: Tianran Zhou <[email-masked]>
Date: Thu, 1 Aug 2019 01:52:56 +0000

Hi Jai,

Welcome to join us. Hopefully, we can get a list shortly.
Looking forward to your comments.

Cheers,
Tianran

From: ippm [mailto:[email-masked]] On Behalf Of Jai Kumar
Sent: Thursday, August 01, 2019 8:02 AM
To: Barak Gafni <[email-masked]>; Tal Mizrahi <[email-masked]>; IETF IPPM WG <[email-masked]>
Cc: Surendra Anubolu <[email-masked]>; IPPM Chairs <[email-masked]>
Subject: Re: [ippm] Side Meeting: IOAM Immediate Export Draft

Barak,

-Jai

From: ippm <[email-masked]<mailto:[email-masked]>> on behalf of Barak Gafni <[email-masked]<mailto:[email-masked]>>
Date: Friday, July 26, 2019 at 8:50 AM
To: Tal Mizrahi <[email-masked]<mailto:[email-masked]>>, IETF IPPM WG <[email-masked]<mailto:[email-masked]>>
Cc: IPPM Chairs <[email-masked]<mailto:[email-masked]>>
Subject: Re: [ippm] Side Meeting: IOAM Immediate Export Draft

Hi,

Summary:

More details:

       0             0 0             1 1             2 2             3
       0             7 8             5 6             3 4             1

  1.  What to export
  2.  Where to export
  3.  When to export

Thanks,
Barak

From: ippm <[email-masked]<mailto:[email-masked]>> On Behalf Of Tal Mizrahi

Hi,

Time: Friday, 8:30-9:45.
Room: Coller

Details:

Cheers,
Tal.

_______________________________________________ ippm mailing list [email-masked]<mailto:[email-masked]> https://www.ietf.org/mailman/listinfo/ippm