Subject: [ippm] IPPM slides for IOAM data fields and IOAM flags updates

From: "Frank Brockners (fbrockne)" <[email-masked]>
Date: Mon, 22 Jul 2019 10:44:24 +0000

Hi IOAM enthusiasts,

I've started to craft slides for the IOAM update in the IPPM WG meeting on Wednesday. Here is what I've assembled for covering draft-ietf-ippm-ioam-data-06 and draft-mizrahi-ippm-ioam-flags-00: https://docs.google.com/presentation/d/1nSbwvwWlexQ9Ns5VbtWavY9BQMpKT1RgjvCPGpwQFAw/

Appreciate your thoughts and comments.

Thanks, Frank

---

From: Tianran Zhou <[email-masked]>
Date: Mon, 22 Jul 2019 18:15:51 +0000

Hi Frank,

I think according to the side meeting in Prague, most of us believed an independent postcard option is better than the using of immediate export flag.
And draft-song-ippm-postcard-based-telemetry-04 has closed the discussion on flow id and sequence number by setting them optional.

Here are some of my thoughts:
- IOAM already has incremental tracing option and pre-allocated tracing option based on the way to operate metadata. Both have clear Semantics on operating metadata. It reasonable to use another option for PBT.
- Hardware is easy to realize the next step process by parsing the option type, without further flag matching.
- A new option will enable the extensibility for PBT related data fields. E.g., actions as proposed in the mailing list

What's your thoughts?

Thanks,
Tianran

________________________________
发件人: ippm [[email-masked]] 代表 Frank Brockners (fbrockne) [[email-masked]]
发送时间: 2019年7月22日 18:44
收件人: [email-masked]
主题: [ippm] IPPM slides for IOAM data fields and IOAM flags updates

Hi IOAM enthusiasts,

I’ve started to craft slides for the IOAM update in the IPPM WG meeting on Wednesday. Here is what I’ve assembled for covering draft-ietf-ippm-ioam-data-06 and draft-mizrahi-ippm-ioam-flags-00: https://docs.google.com/presentation/d/1nSbwvwWlexQ9Ns5VbtWavY9BQMpKT1RgjvCPGpwQFAw/

Thanks, Frank

---

From: "Frank Brockners (fbrockne)" <[email-masked]>
Date: Mon, 22 Jul 2019 21:41:24 +0000

Hi Tianran,

IMHO this sounds like a workable path forward, i.e. we’d consolidate things into a new IOAM option for Immediate-Export/PBT, avoid the “I-Flag” and describe actions (e.g. log/forward-a-copy/count/..) per the earlier discussion. We can discuss this in the IPPM WG meeting as part of the IOAM update slot.

Where would we best specify this new option? We could either write a new dedicated document for this new IOAM option (borrowing pieces from draft-song-ippm-postcard-based-telemetry-04), or fold it into the existing IOAM data fields draft. Does the WG have a preference?

Thanks, Frank

From: Tianran Zhou <[email-masked]>
Sent: Montag, 22. Juli 2019 14:16
To: Frank Brockners (fbrockne) <[email-masked]>; [email-masked]
Subject: Re: IPPM slides for IOAM data fields and IOAM flags updates

Hi Frank,

What's your thoughts?

Thanks,
Tianran

________________________________
发件人: ippm [[email-masked]] 代表 Frank Brockners (fbrockne) [[email-masked]]
发送时间: 2019年7月22日 18:44
收件人: [email-masked]<mailto:[email-masked]>
主题: [ippm] IPPM slides for IOAM data fields and IOAM flags updates
Hi IOAM enthusiasts,

Thanks, Frank

---

From: Tianran Zhou <[email-masked]>
Date: Tue, 23 Jul 2019 14:47:17 +0000

Hi Frank,

Thanks. I think we are now aligned on the new option now.

With regard to the place, I think we can just evolve the existing PBT draft.

Cheers,
Tianran

________________________________
发件人: Frank Brockners (fbrockne) [[email-masked]]
发送时间: 2019年7月23日 5:41
收件人: Tianran Zhou; [email-masked]
主题: RE: IPPM slides for IOAM data fields and IOAM flags updates

Hi Tianran,

Thanks, Frank

Hi Frank,

What's your thoughts?

Thanks,
Tianran

Thanks, Frank

---

From: "Frank Brockners (fbrockne)" <[email-masked]>
Date: Tue, 23 Jul 2019 15:24:38 +0000

Hi Tianran,

Thanks. IMHO we need an IOAM-focused small and concise spec for Immediate-Export – this can either be done within draft-ietf-ippm-ioam-data or in a dedicated document which would extend draft-ietf-ippm-ioam-data, much like draft-mizrahi-ippm-ioam-flags for flags. A dedicated document might allow us to finish up draft-ietf-ippm-ioam-data faster – which might be a reason why we’d want a dedicated document.
If you refer to draft-song-ippm-postcard-based-telemetry-04  as “PBT draft” below: This document isn’t focused on IOAM and thus is not a good fit. This doc is rather a bit all over the map, it discusses challenges for INT, which isn’t an IETF protocol, it proposed new headers unrelated to IOAM, etc.

Cheers, Frank

From: Tianran Zhou <[email-masked]>
Sent: Dienstag, 23. Juli 2019 10:47
To: Frank Brockners (fbrockne) <[email-masked]>; [email-masked]
Subject: RE: IPPM slides for IOAM data fields and IOAM flags updates

Hi Frank,

Cheers,
Tianran

________________________________
发件人: Frank Brockners (fbrockne) [[email-masked]]
发送时间: 2019年7月23日 5:41
收件人: Tianran Zhou; [email-masked]<mailto:[email-masked]>
主题: RE: IPPM slides for IOAM data fields and IOAM flags updates
Hi Tianran,

Thanks, Frank

From: Tianran Zhou <[email-masked]<mailto:[email-masked]>>
Sent: Montag, 22. Juli 2019 14:16
To: Frank Brockners (fbrockne) <[email-masked]<mailto:[email-masked]>>; [email-masked]<mailto:[email-masked]>
Subject: Re: IPPM slides for IOAM data fields and IOAM flags updates

Hi Frank,

What's your thoughts?

Thanks,
Tianran

Thanks, Frank

---

From: Tianran Zhou <[email-masked]>
Date: Tue, 23 Jul 2019 19:27:47 +0000

Hi Frank,

A new dedicated document makes sense. We can spin out the new IOAM option specification from draft-song-ippm-postcard-based-telemetry.
Then draft-song-ippm-postcard-based-telemetry could be general, informative to describe the PBT method.

Cheers,
Tianran

发送时间: 2019年7月23日 23:24

Hi Tianran,

Cheers, Frank

Hi Frank,

Cheers,
Tianran

Thanks, Frank

Hi Frank,

What's your thoughts?

Thanks,
Tianran

Thanks, Frank