Subject: [ippm] AD review of draft-ietf-ippm-metric-registry-19

From: Mirja Kuehlewind <[email-masked]>
Date: Tue, 27 Aug 2019 15:43:30 +0200

Hi all,

I just reviewed draft-ietf-ippm-metric-registry-19. Thanks for the well-written document! I have one process question on the following part before we can move ahead:

Sec 8.1:
  "Submission to IANA MAY be the result of IETF Standards Action, where
   an approved Internet Draft proposes one or more Registered
   Performance Metrics to be added to the Performance Metrics Registry,
   including the text of the proposed Registered Performance Metric(s).”

Maybe I’m confused but I would think that as soon as a document is approved by the IESG, it’s too late for an Expert review because an approved RFC that contains instruction for IANA will usually be implemented by IANA as approved. I believe what we usually do is to request the new entry before IESG evaluation and simply document in the RFC that an registration was performed, or in case of e.g. the port registry (where however the policy is IETF Review for system ports) we ask the experts for review during the IESG evaluation process and take this as input for the IESG to make a decision on approval (rather than as input for IANA). I’m cc’ing Michelle, as I understood that she was already involved in reviewing this document, and she might have further insights/considerations.

Also on experts: Did the group/chairs/authors already consider possible candidates? If not, is anybody of the author team willing to serve? I assume having 2 experts should be sufficient, right?

Thanks!
Mirja

P.S.: Two nits:
- sec 7.3.2: "The packet generation stream may require parameters such as the the average packet rate …” -> two “the”
- sec 8.2: "why the existing entry shuold be revised” -> s/shuold/should/

---

From: Mirja Kuehlewind <[email-masked]>
Date: Tue, 27 Aug 2019 16:02:03 +0200

Hi again,

Sorry one more thing on references: There are two normative reference to obsoleted RFC (RFC2141 and RFC4148). I think it would be more appropriate to make these references informational instead. Also there is a new Downref to RFC6248, however, I think that could also be an informational reference instead.

@Bill: as the document shepherd it would be could to point out these things in the shepherd write-up. If the authors/group decides to move these references to informational, there is no additional action require from you. However, if not, the write-up should be updated accordingly.

Thanks!
Mirja

> On 27. Aug 2019, at 15:43, Mirja Kuehlewind <[email-masked]> wrote:
> 
> Hi all,
>