Subject: [ippm] about draft-zhou-ippm-enhanced-alternate-marking-03.txt

From: Haoyu Song <[email-masked]>
Date: Thu, 17 Oct 2019 19:24:04 +0000

(resent cause the original email didn't go through)

Hi Tianran and authors，

This draft provides a light-weighted solution to support both alternate marking and PBT-M at the same time. Given the use cases of alternate marking have been well established, I believe this enhanced proposal will support more interesting and powerful use cases and address a different set of in-band measurement problems from IOAM.

However, even the proposed data fields are short, the encapsulation requirement is the same as that for IOAM (note that the original PBT-M only needs to borrow a single existing header bit). Any thoughts on this?

The collisions of flow ID, even if the probability is low, can cause measurement errors. How can you avoid it?

Thanks!
Haoyu

---

From: Tianran Zhou <[email-masked]>
Date: Fri, 18 Oct 2019 02:27:14 +0000

Hi Haoyu,

Thank you very much for your interest and comments.
Please see in line.

Tianran

-----邮件原件-----
发件人: Haoyu Song [mailto:[email-masked]] 
发送时间: 2019年10月18日 3:24
收件人: [email-masked]' <[email-masked]>; [email-masked]' <[email-masked]>
主题: about draft-zhou-ippm-enhanced-alternate-marking-03.txt

Hi Tianran and authors，

ZTR> Yes, you are right. There is no free lunch. While a structure can take more information, we need to consider how to carry it in the encapsulation protocol. In IPv6, we consider the way to mitigate the compatibility with non-capable devices. It could be encapsulated in the DOH or SRH. So that the intermediate node will not drop packets.

ZTR> As mentioned in the draft, there are two ways to assign the flow ID. 
One is to be assigned by the central controller. So it's easy to avoid the collision.
The other way is to assign the flow ID by the ingress node locally. In our implementation, an extended flow ID is used. That is to say, the flow ID in this structure is for the basic need. It's used for a local/private part. An extended flow ID with global part information could be carried in other way in the encapsulation protocol.

Thanks!
Haoyu