Subject: [ippm] TR: New Liaison Statement, "LS on 3GPP CT WG4 feedback on QUIC network level troubleshooting capabilities"

From: <[email-masked]>
Date: Wed, 16 Oct 2019 10:58:21 +0000

Hi,

Below the text of a LS from  3GPP CT WG4 on QUIC network level troubleshooting capabilities.
TL,NR: the 3GPP CT WG 4 (CT4) is currently studying the introduction of QUIC as transport protocol instead of HTTP/2 in the 5G core network.
It has some questions regarding the troubleshooting capabilities supported by QUIC compared to the ones available with TCP.
It focuses on the lack of  support for on-path packet loss measurements.

Regards

Emile

-----Message d'origine-----
De : QUIC [mailto:[email-masked]] De la part de Liaison Statement Management Tool
Envoyé : lundi 14 octobre 2019 19:08
À : Lars Eggert; Mark Nottingham
Cc : Magnus Westerlund; [email-masked]; [email-masked]; Mark Nottingham; Mirja Kühlewind; Lars Eggert; QUIC Discussion List
Objet : New Liaison Statement, "LS on 3GPP CT WG4 feedback on QUIC network level troubleshooting capabilities"

Title: LS on 3GPP CT WG4 feedback on QUIC network level troubleshooting capabilities

Submission Date: 2019-10-14

URL of the IETF Web page: https://datatracker.ietf.org/liaison/1655/

Please reply by 2020-02-14

From: Susanna Kooistra <[email-masked]>

To: Lars Eggert <[email-masked]>,Mark Nottingham <[email-masked]>

Cc: Mirja Kühlewind <[email-masked]>,QUIC Discussion List <[email-masked]>,Lars Eggert <[email-masked]>,Magnus Westerlund <[email-masked]>,Mark Nottingham <[email-masked]>

Response Contacts: [email-masked],[email-masked]

Technical Contacts:

Purpose: For action

Body: 1. Overall Description:

3GPP CT WG4 is performing a feasibility study on the potential usage of QUIC protocol for the 3GPP 5G Core Network in 3GPP°TR°29.893 (last version available via the following link: https://www.3gpp.org/ftp/Specs/archive/29_series/29.893/29893-120.zip ). 3GPP CT WG4 is currently waiting for the release of the first official version of QUIC RFC in order to resume and conclude this study.

3GPP CT4 WG hence reviewed the IETF draft-ietf-quic-transport-19 and would like to provide the following feedback on network level troubleshooting capabilities of QUIC as compared to TCP (cf. clause°9.6.3 of 3GPP TR°29.893 for more details):

-           QUIC replaces both TLS and TCP. One of the main differences indeed is that QUIC encrypts the transport headers in addition to the payload, which is highly relevant for the network level troubleshooting matters. The existing Network OAM (Operation And Maintenance) solutions which are designed to make use and act on TCP headers would hence not be able to troubleshoot QUIC traffic and even less be easily adaptable to perform this task.

-           QUIC includes an optional measurement bit, named spinbit, which allows in-path probes to measure both the round trip delay and the decomposition of the delay on both sides of symmetrical path.

-           As of version 19, QUIC specifications do not support packet loss measurements.

-           To enable an in depth analysis of the performance (e.g. flow control, etc.) between a consumer 3GPP 5G core Network Function (NF) and a producer NF, the decryption of the entire QUIC message is often required in order to read the transport parameters of the QUIC packet header. Contrary to HTTP/2 over TLS, this has the side effect of decrypting and revealing application layer information to network probes.

2. Actions:

To IETF QUIC group

ACTION:           3GPP CT WG4 kindly asks IETF QUIC WG to take the above feedback into consideration in QUIC version 1 specification and provide a feedback (especially on the highlighted points).

3. Date of Next CT4 Meetings:

3GPP TSG CT4#95       11th – 15th November 2019       Reno, US

3GPP TSG CT4#96       24th – 28th February 2020         Sophia Antipolis, FR

Attachments:

    Liaison Statement on QUIC network level troubleshooting capabilities

    https://www.ietf.org/lib/dt/documents/LIAISON/liaison-2019-10-14-3gpp-tsgct-ct4-quic-ls-on-3gpp-ct-wg4-feedback-on-quic-network-level-troubleshooting-capabilities-attachment-1.docx

_________________________________________________________________________________________________________________________

Ce message et ses pieces jointes peuvent contenir des informations confidentielles ou privilegiees et ne doivent donc
pas etre diffuses, exploites ou copies sans autorisation. Si vous avez recu ce message par erreur, veuillez le signaler
a l'expediteur et le detruire ainsi que les pieces jointes. Les messages electroniques etant susceptibles d'alteration,
Orange decline toute responsabilite si ce message a ete altere, deforme ou falsifie. Merci.

This message and its attachments may contain confidential or privileged information that may be protected by law;
they should not be distributed, used or copied without authorisation.
If you have received this email in error, please notify the sender and delete this message and its attachments.
As emails may be altered, Orange is not liable for messages that have been modified, changed or falsified.
Thank you.

---

From: Giuseppe Fioccola <[email-masked]>
Date: Fri, 18 Oct 2019 10:35:41 +0000

Hi Emile, All,
Thank you for forwarding.
I would point out draft-cfb-ippm-spinbit-new-measurements, that describes a spinbit related methodology for on-path packet loss in addition to delay measurement for QUIC and in general for transport protocols.

Regards,

Giuseppe

From: ippm [mailto:[email-masked]] On Behalf Of [email-masked]
Sent: Wednesday, October 16, 2019 12:58 PM
To: [email-masked]; IETF IPPM WG ([email-masked]) <[email-masked]>; [email-masked]
Subject: [ippm] TR: New Liaison Statement, "LS on 3GPP CT WG4 feedback on QUIC network level troubleshooting capabilities"

Hi,

Regards

Emile

-----Message d'origine-----
De : QUIC [mailto:[email-masked]] De la part de Liaison Statement Management Tool
Envoyé : lundi 14 octobre 2019 19:08
À : Lars Eggert; Mark Nottingham
Cc : Magnus Westerlund; [email-masked]<mailto:[email-masked]>; [email-masked]<mailto:[email-masked]>; Mark Nottingham; Mirja Kühlewind; Lars Eggert; QUIC Discussion List
Objet : New Liaison Statement, "LS on 3GPP CT WG4 feedback on QUIC network level troubleshooting capabilities"

From: Susanna Kooistra <[email-masked]<mailto:[email-masked]>>

To: Lars Eggert <[email-masked]<mailto:[email-masked]>>,Mark Nottingham <[email-masked]<mailto:[email-masked]>>

Cc: Mirja Kühlewind <[email-masked]<mailto:[email-masked]>>,QUIC Discussion List <[email-masked]<mailto:[email-masked]>>,Lars Eggert <[email-masked]<mailto:[email-masked]>>,Magnus Westerlund <[email-masked]<mailto:[email-masked]>>,Mark Nottingham <[email-masked]<mailto:[email-masked]>>

Response Contacts: [email-masked],[email-masked]<mailto:[email-masked],[email-masked]>

Technical Contacts:

Purpose: For action

2. Actions:

To IETF QUIC group

Attachments:

Thank you.