Subject: [ippm] Fwd: New Version Notification for draft-mirsky-ippm-hybrid-two-step-04.txt

From: Greg Mirsky <[email-masked]>
Date: Tue, 8 Oct 2019 10:09:03 -0700

Dear All,
the new version of the Hybrid Two-Step draft includes the new section on
the use of HTS in a multicast network. The goal is to avoid unnecessary
replication of telemetry information collected on-path while multicast data
packets traverse a multicast distribution tree. At the same time, a
centralized controller should have sufficient information associated with
collected telemetry information to reconstruct the state of the traversed
multicast path based on HTS packets.
 Much appreciate your comments, questions, and suggestions.

Regards,
Greg

---------- Forwarded message ---------
From: <[email-masked]>
Date: Tue, Oct 8, 2019 at 10:00 AM
Subject: New Version Notification for
draft-mirsky-ippm-hybrid-two-step-04.txt
To: Gregory Mirsky <[email-masked]>, Wang Lingqiang <
[email-masked]>, Guo Zhui <[email-masked]>

A new version of I-D, draft-mirsky-ippm-hybrid-two-step-04.txt
has been successfully submitted by Greg Mirsky and posted to the
IETF repository.

Name:           draft-mirsky-ippm-hybrid-two-step
Revision:       04
Title:          Hybrid Two-Step Performance Measurement Method
Document date:  2019-10-08
Group:          Individual Submission
Pages:          11
URL:
https://www.ietf.org/internet-drafts/draft-mirsky-ippm-hybrid-two-step-04.txt
Status:
https://datatracker.ietf.org/doc/draft-mirsky-ippm-hybrid-two-step/
Htmlized:
https://tools.ietf.org/html/draft-mirsky-ippm-hybrid-two-step-04
Htmlized:
https://datatracker.ietf.org/doc/html/draft-mirsky-ippm-hybrid-two-step
Diff:
https://www.ietf.org/rfcdiff?url2=draft-mirsky-ippm-hybrid-two-step-04

Abstract:
   Development of, and advancements in, automation of network operations
   brought new requirements for measurement methodology.  Among them is
   the ability to collect instant network state as the packet being
   processed by the networking elements along its path through the
   domain.  This document introduces a new hybrid measurement method,
   referred to as hybrid two-step, as it separates the act of measuring
   and/or calculating the performance metric from the act of collecting
   and transporting network state.

Please note that it may take a couple of minutes from the time of submission
until the htmlized version and diff are available at tools.ietf.org.

The IETF Secretariat

---

From: Haoyu Song <[email-masked]>
Date: Tue, 8 Oct 2019 23:50:10 +0000

Hi Greg,

I agree that multicast is an important use case to cover for any telemetry technique.
In our draft, https://tools.ietf.org/html/draft-song-multicast-telemetry-00, we also discussed the on-path multicast telemetry techniques that combine both IOAM and PBT for efficient multicast support.

Regards,
Haoyu

From: ippm <[email-masked]> On Behalf Of Greg Mirsky
Sent: Tuesday, October 08, 2019 10:09 AM
To: IETF IPPM WG <[email-masked]>
Subject: [ippm] Fwd: New Version Notification for draft-mirsky-ippm-hybrid-two-step-04.txt

Dear All,
the new version of the Hybrid Two-Step draft includes the new section on the use of HTS in a multicast network. The goal is to avoid unnecessary replication of telemetry information collected on-path while multicast data packets traverse a multicast distribution tree. At the same time, a centralized controller should have sufficient information associated with collected telemetry information to reconstruct the state of the traversed multicast path based on HTS packets.
 Much appreciate your comments, questions, and suggestions.

Regards,
Greg
---------- Forwarded message ---------
From: <[email-masked]<mailto:[email-masked]>>
Date: Tue, Oct 8, 2019 at 10:00 AM
Subject: New Version Notification for draft-mirsky-ippm-hybrid-two-step-04.txt
To: Gregory Mirsky <[email-masked]<mailto:[email-masked]>>, Wang Lingqiang <[email-masked]<mailto:[email-masked]>>, Guo Zhui <[email-masked]<mailto:[email-masked]>>

Name:           draft-mirsky-ippm-hybrid-two-step
Revision:       04
Title:          Hybrid Two-Step Performance Measurement Method
Document date:  2019-10-08
Group:          Individual Submission
Pages:          11
URL:            https://www.ietf.org/internet-drafts/draft-mirsky-ippm-hybrid-two-step-04.txt<https://nam03.safelinks.protection.outlook.com/?url=https%3A%2F%2Fwww.ietf.org%2Finternet-drafts%2Fdraft-mirsky-ippm-hybrid-two-step-04.txt&data=02%7C01%7Chaoyu.song%40futurewei.com%7C8bb3a78d03c2465bf11708d74c126511%7C0fee8ff2a3b240189c753a1d5591fedc%7C1%7C1%7C637061514211735388&sdata=VK5DdXwWKpWfcjx9No6l%2B1564W7SFYcXK3FOTvDpcmI%3D&reserved=0>
Status:         https://datatracker.ietf.org/doc/draft-mirsky-ippm-hybrid-two-step/<https://nam03.safelinks.protection.outlook.com/?url=https%3A%2F%2Fdatatracker.ietf.org%2Fdoc%2Fdraft-mirsky-ippm-hybrid-two-step%2F&data=02%7C01%7Chaoyu.song%40futurewei.com%7C8bb3a78d03c2465bf11708d74c126511%7C0fee8ff2a3b240189c753a1d5591fedc%7C1%7C1%7C637061514211745374&sdata=Jsz53OwTWAQ13C2OFaY54sSvtvtR26bVaJQ9F7T7BkA%3D&reserved=0>
Htmlized:       https://tools.ietf.org/html/draft-mirsky-ippm-hybrid-two-step-04<https://nam03.safelinks.protection.outlook.com/?url=https%3A%2F%2Ftools.ietf.org%2Fhtml%2Fdraft-mirsky-ippm-hybrid-two-step-04&data=02%7C01%7Chaoyu.song%40futurewei.com%7C8bb3a78d03c2465bf11708d74c126511%7C0fee8ff2a3b240189c753a1d5591fedc%7C1%7C1%7C637061514211745374&sdata=oUEuJ4DWh9bjGgaNaJBh7Yyxla190NNjOnERDjakXcQ%3D&reserved=0>
Htmlized:       https://datatracker.ietf.org/doc/html/draft-mirsky-ippm-hybrid-two-step<https://nam03.safelinks.protection.outlook.com/?url=https%3A%2F%2Fdatatracker.ietf.org%2Fdoc%2Fhtml%2Fdraft-mirsky-ippm-hybrid-two-step&data=02%7C01%7Chaoyu.song%40futurewei.com%7C8bb3a78d03c2465bf11708d74c126511%7C0fee8ff2a3b240189c753a1d5591fedc%7C1%7C1%7C637061514211755371&sdata=FEalLkhr6w6Lgqo1lc3HuduuBug7OUhfvzXOhH8PBy4%3D&reserved=0>
Diff:           https://www.ietf.org/rfcdiff?url2=draft-mirsky-ippm-hybrid-two-step-04<https://nam03.safelinks.protection.outlook.com/?url=https%3A%2F%2Fwww.ietf.org%2Frfcdiff%3Furl2%3Ddraft-mirsky-ippm-hybrid-two-step-04&data=02%7C01%7Chaoyu.song%40futurewei.com%7C8bb3a78d03c2465bf11708d74c126511%7C0fee8ff2a3b240189c753a1d5591fedc%7C1%7C1%7C637061514211755371&sdata=mQUZJjS70Oy7EbPHuAO8O%2FxpC4oaz2duYg5trtMlSrU%3D&reserved=0>

Abstract:

Please note that it may take a couple of minutes from the time of submission
until the htmlized version and diff are available at tools.ietf.org<https://nam03.safelinks.protection.outlook.com/?url=http%3A%2F%2Ftools.ietf.org&data=02%7C01%7Chaoyu.song%40futurewei.com%7C8bb3a78d03c2465bf11708d74c126511%7C0fee8ff2a3b240189c753a1d5591fedc%7C1%7C1%7C637061514211755371&sdata=BDJo1loEJXAvHrsrtDaAM7lyMzfnDHybM26mgM7hDXM%3D&reserved=0>.

The IETF Secretariat

---

From: Greg Mirsky <[email-masked]>
Date: Thu, 10 Oct 2019 13:19:42 -0700

Hi Haoyu,
thank you for your interest in the HTS proposal. I've read the draft you've
mentioned and am glad that we have independently arrived to the same
conclusion - it is time to discuss specifics of collecting telemetry
information in multicast networks. While we discuss various telemetry
protocols we implicitly talk about only unicast flows. As a result,
deploying these telemetry protocols in multicast network may cause some
unexpected results.
I think it would be great to discuss telemetry collection in multicast
networks in detail at the meeting.

Regards,
Greg

On Tue, Oct 8, 2019 at 4:50 PM Haoyu Song <[email-masked]> wrote:

> In our draft,
> https://tools.ietf.org/html/draft-song-multicast-telemetry-00, we also
> discussed the on-path multicast telemetry techniques that combine both IOAM
> and PBT for efficient multicast support.
>
>
>
> Regards,
>
> Haoyu
>
>
>
> *From:* ippm <[email-masked]> *On Behalf Of * Greg Mirsky
> *Sent:* Tuesday, October 08, 2019 10:09 AM
> *To:* IETF IPPM WG <[email-masked]>
> *Subject:* [ippm] Fwd: New Version Notification for
> <https://nam03.safelinks.protection.outlook.com/?url=https%3A%2F%2Fwww.ietf.org%2Finternet-drafts%2Fdraft-mirsky-ippm-hybrid-two-step-04.txt&data=02%7C01%7Chaoyu.song%40futurewei.com%7C8bb3a78d03c2465bf11708d74c126511%7C0fee8ff2a3b240189c753a1d5591fedc%7C1%7C1%7C637061514211735388&sdata=VK5DdXwWKpWfcjx9No6l%2B1564W7SFYcXK3FOTvDpcmI%3D&reserved=0>
> Status:
> <https://nam03.safelinks.protection.outlook.com/?url=https%3A%2F%2Fdatatracker.ietf.org%2Fdoc%2Fdraft-mirsky-ippm-hybrid-two-step%2F&data=02%7C01%7Chaoyu.song%40futurewei.com%7C8bb3a78d03c2465bf11708d74c126511%7C0fee8ff2a3b240189c753a1d5591fedc%7C1%7C1%7C637061514211745374&sdata=Jsz53OwTWAQ13C2OFaY54sSvtvtR26bVaJQ9F7T7BkA%3D&reserved=0>
> Htmlized:
> <https://nam03.safelinks.protection.outlook.com/?url=https%3A%2F%2Ftools.ietf.org%2Fhtml%2Fdraft-mirsky-ippm-hybrid-two-step-04&data=02%7C01%7Chaoyu.song%40futurewei.com%7C8bb3a78d03c2465bf11708d74c126511%7C0fee8ff2a3b240189c753a1d5591fedc%7C1%7C1%7C637061514211745374&sdata=oUEuJ4DWh9bjGgaNaJBh7Yyxla190NNjOnERDjakXcQ%3D&reserved=0>
> Htmlized:
> <https://nam03.safelinks.protection.outlook.com/?url=https%3A%2F%2Fdatatracker.ietf.org%2Fdoc%2Fhtml%2Fdraft-mirsky-ippm-hybrid-two-step&data=02%7C01%7Chaoyu.song%40futurewei.com%7C8bb3a78d03c2465bf11708d74c126511%7C0fee8ff2a3b240189c753a1d5591fedc%7C1%7C1%7C637061514211755371&sdata=FEalLkhr6w6Lgqo1lc3HuduuBug7OUhfvzXOhH8PBy4%3D&reserved=0>
> Diff:
> <https://nam03.safelinks.protection.outlook.com/?url=https%3A%2F%2Fwww.ietf.org%2Frfcdiff%3Furl2%3Ddraft-mirsky-ippm-hybrid-two-step-04&data=02%7C01%7Chaoyu.song%40futurewei.com%7C8bb3a78d03c2465bf11708d74c126511%7C0fee8ff2a3b240189c753a1d5591fedc%7C1%7C1%7C637061514211755371&sdata=mQUZJjS70Oy7EbPHuAO8O%2FxpC4oaz2duYg5trtMlSrU%3D&reserved=0>
>
> Abstract:
> until the htmlized version and diff are available at tools.ietf.org
> <https://nam03.safelinks.protection.outlook.com/?url=http%3A%2F%2Ftools.ietf.org&data=02%7C01%7Chaoyu.song%40futurewei.com%7C8bb3a78d03c2465bf11708d74c126511%7C0fee8ff2a3b240189c753a1d5591fedc%7C1%7C1%7C637061514211755371&sdata=BDJo1loEJXAvHrsrtDaAM7lyMzfnDHybM26mgM7hDXM%3D&reserved=0>
> .
>
> The IETF Secretariat
>